Jump to content

Bootloader stalls at [PCI configuration begin]


13 posts in this topic

Recommended Posts

Equipment: asus p9x79 pro, core i73930k, 4G RAM, 840 pro ssd, quadro 4000, wifi card, firewire card, usb mouse and keyboard


I've tried two separate approaches to this. The first was rockin_ron's tutorial here on insanely mac using MLion. My first attempt got me to the apple logo where it stalls. One hour later no movement. Tried verbose mode and got this block of text:


MAC Framework successfuly initialized using 16384 buffer headers and 10240 cluster IO buffer headers

IOAPIC: Version 0x20 Vectors 64:87

IOAPIC: Version 0x20 Vectors 88:111

ACPI: System State [s0 s3 s4 s5]

PFM64 (44 cpu) 0xfff10000000, 0xf0000000

[PCI configuration begin]


And that's where the show stops.


My next approach was using the myHack app, this time using Lion. Saw a note on his instructions that Sandy Bridge E processors are only compatible with Lion, so I used Lion.


Exact same problem, exact same block of text.


Shall I assume this is hardware related, like one of the PCI boards for instance?


Thanks for any advice you all can offer.

OK, it wasn't those little pci boards. The graphics card then? Something else altogether?

Link to comment
Share on other sites

Sandy Bridge works with Mountain Lion.


You should use ML.


Anyways, this is a known problem.

As the poster said above me, try npci=0x2000 at the Darwin prompt. If that does not work then try npci=0x3000

Link to comment
Share on other sites

thanks guys. sorry for the late response.


so, i'll redo the bootloader in ML and then, correct me if i'm wrong, at the prompt where i entered -v, yadda yadda, i then enter either:








don't know why i'm asking. not too many other options. just want to make sure i'm not missing a magic button somewhere.


(by they way, there's always a magic button. hate the magic button. takes me forever to find it.)


i'll report back.



Link to comment
Share on other sites

ok, used myHack to make the ML installer. loaded it up. when the boot: prompt came up, i typed npci=0x2000 and pressed enter. gray apple logo screen came up, then the pinwheel, then the screen promptly went to black, the monitor shut down, and then the computer went into something like a standby mode as evidenced by the slowing of all the fan speeds.


powered off, restart, boot: prompt with npci=0x3000, same response.


powered off, restart, boot: prompt with npci=0x2000 -v and the log showed it moving past the previous hang up point but ended with something along the lines of


Not able to open the file /var/db/bootcache.playlist   2 file not found


that's not exact, but it's what i was able to catch before it printed a few more lines after which the monitor blinked out. i tried again with the 0x3000 -v, same thing, still couldn't catch the last few lines.


question about npci: is that a command telling the whatever to look at a particular pci lane for the graphics card? mostly just curious.


anyway, it seems like that command gets it past that previous fail point, but something else is hanging it up.


if you need me to, i'll try to get a screenshot of that last verbose mode language with me phone camera, but that camera is really crappy, because i have such a crappy phone.



Link to comment
Share on other sites

Alright npci=0x2000 gets past the first problem. I've tried GraphicsEnabler=Yes:No, but neither works. PciRoot=1 doesn't work either. Until I can get some video of the log the best I'm able to see before the screen blinks out is that last that reads Nvidia controller... somethingsomethingsomething.


It looks like I might need something a bit more specific to my graphics card, correct?

Link to comment
Share on other sites

alright, after much ado over getting this damn pic, here she blows (please note that I used -v npci=0x2000 at the boot prompt):




about a blink after that last line the monitor and computer effectively go to sleep, or so it seems. this pic is the first time i've been able to read those last 4 lines at all.


and @joe_black: i have not loaded any video drivers. should I? where and how? would i have to reinstall the bootloader to do this?



Link to comment
Share on other sites

@rampage dev, i'm writing this to you on a windows system and do not have access to a mac os with much ease these days. is removing an nvidia driver from the installer a simple matter of plugging my installer drive into a mac machine and opening the correct folder to do this? or is this something that involves a tweak to the actual initial installation procedure? i'm fairly sure it's the former, as there were no video card installation options during the installation. but, you know, i really don't know about these things.


so, maybe to prevent you all from having to repeat already recorded instructions, if i'm seriously remiss in some info here, please just direct me to it. i really do hate making people repeat things said so many times that they've become tutorials. i simply haven't found those tutorials, or actually they're just enough off from what i'm doing that i'm not quite sure how to make them work.


anyway, i've read of added graphics kexts somewhere, but i'm not sure of which ones, where, kind of thing. i'll go hunt around and see what i get.



Link to comment
Share on other sites

  • 2 weeks later...

  • Create New...