Jump to content

Redoing Multiboot AHCI problem

4 posts in this topic

Recommended Posts

Recently install perfectly OSX 10.8 using myHack 3.2.

Install went with no problems and on the first boot I got the boot0:error. Following the guide on this forum I used the boot1h fix on the bs to equal 4096 then it booted fine and perfect.


Been running perfectly ever since but now I really need to get it dual booting with Windows 7 that's where the problem started.



I split the osx install in half to make a 2nd partition to install Windows.

As always I put the Windows install onto a USB stick for faster installing and booted from it but now it just stops at (Starting Windows) before it even gets to the installing part.


Tried other OS's to see if boots; Ubuntu wont load at all.


The bios settings for the motherboard have been set right for both osx and windows with main on being AHCI enabled (was my old board and worked perfectly then installing Windows via usb with AHCI enabled)



Did a test and used the same drive with AHCI disabled and them the usb install worked :(

Tried a old spare drive with AHCI enabled again and this time the install worked.



Does anyone have an idea if or how the OSX install could have somehow stopped AHCI installs working on this HDD?




Intel ii3-2120

Asus P8P67 Pro Rev 3.1

8GB Patriot 1600mhz DDR3

Geforce GTS 250


Link to comment
Share on other sites

Are you booting the USB install from bios selection or using chameleon(chimera) bootloader?


not sure where is the problem, but you could try install win on the second drive (make sure windows use the same partition for boot information) and then clone the partition to your mac os drive. Kinda tricky i know but you can save time with investigation. 

Link to comment
Share on other sites

Yeah booting the Windows 7 install USB via bios selection.


Used Darik's Boot and Nuke on the drive to give it a full wipe to start a fresh. Tried the Win7 install as usual in AHCI and still hangs before starting to install.

Will now try an OSX install to see if that even starts as I don't know how a HDD that used to install in AHCI mode now has just stopped doing it.

Link to comment
Share on other sites


  • Create New...