Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
joe_black

[GUIDE] Installing OS X on Asus X501A (Kexts Included)

39 posts in this topic

Recommended Posts

My Asus X501a model has an Intel B930 CPU (2x2.4 GHz), 2 GB RAM, and 320 GB HDD, video is Intel HD (without number).

 

Managed to install using Niresh 10.8, and installed ALL the kexts found here (10.6 and 10.8 zip for asusx501).

 

Sorry I don't know how to burn chameleon+iatkos on the SAME USB stick, because the dual stick method described above always gives me "Can't find mach_kernel" errors when I tried to boot the installer.
 
Anyway, after install (selecting Graphics Enabler and UUID only under custom options) + all kexts droppend into kext wizard + fix permissions and a reboot I got the following results:
 
Weird thing - during niresh install the laptop's keyboard and touchpad worked OOB - after install no keyboard+ touchpad!

I downloaded ElanTouchpad_ML_V1.7_Final_V3_Only.zip kext! However it enabled the keyboard only.
 
What does not work: touchpad, wifi, bluetooth, built in memory card reader (a Realtek PCIE one).

Graphics works using: "Graphics Mode"="1366x768x32", screensaver works, menus are slightly transparent, I can move the chess figures but Safari new tab flickers like hell.

 

BIOS settings: After playing with the amount of RAM separated for the Intel HD Graphics I stick to the lowest setting 32 MB. There is no difference in video performance if I give it the highest, 512 MB RAM. 

 

Microphone not tested, sound is ok.

 

I will experiment more, maybe a reinstall next week.

 

Wifi tethering through USB works with an Android phone, just install HoRNDISrel4.pkg and plug in your phone with an USB cable.

 

86991213231653479639_thumb.png

Share this post


Link to post
Share on other sites

My Asus X501a model has an Intel B930 CPU (2x2.4 GHz), 2 GB RAM, and 320 GB HDD, video is Intel HD (without number).

 

Managed to install using Niresh 10.8, and installed ALL the kexts found here (10.6 and 10.8 zip for asusx501).

 

Sorry I don't know how to burn chameleon+iatkos on the SAME USB stick, because the dual stick method described above always gives me "Can't find mach_kernel" errors when I tried to boot the installer.

 

Anyway, after install (selecting Graphics Enabler and UUID only under custom options) + all kexts droppend into kext wizard + fix permissions and a reboot I got the following results:

 

Weird thing - during niresh install the laptop's keyboard and touchpad worked OOB - after install no keyboard+ touchpad!

I downloaded ElanTouchpad_ML_V1.7_Final_V3_Only.zip kext! However it enabled the keyboard only.

 

What does not work: touchpad, wifi, bluetooth, built in memory card reader (a Realtek PCIE one).

Graphics works using: "Graphics Mode"="1366x768x32", screensaver works, menus are slightly transparent, I can move the chess figures but Safari new tab flickers like hell.

 

BIOS settings: After playing with the amount of RAM separated for the Intel HD Graphics I stick to the lowest setting 32 MB. There is no difference in video performance if I give it the highest, 512 MB RAM. 

 

Microphone not tested, sound is ok.

 

I will experiment more, maybe a reinstall next week.

 

Wifi tethering through USB works with an Android phone, just install HoRNDISrel4.pkg and plug in your phone with an USB cable.

 

86991213231653479639_thumb.png

Ok man, both of us are on the same point! 

 

I think this is the maximum you can do with this laptop.. The intel Graphics is the HD2000, that isn't supported by Mac Os..

Share this post


Link to post
Share on other sites

Ok man, both of us are on the same point! 

 

I think this is the maximum you can do with this laptop.. The intel Graphics is the HD2000, that isn't supported by Mac Os..

It is the sixth gen Intel HD I have, Sandy Bridge architecture: http://en.wikipedia.org/wiki/Comparison_of_Intel_graphics_processing_units#Sixth_generation

 

My Pentium B9x0 CPU's builtin vga is called ->  Intel HD Graphics...

 

... without the number 2000 at the end!

 

According to the wiki Core i3 or betterCPU's have the HD 2000 or HD 3000.

 

Asus X501 comes with many variations (different CPU, RAM and HDD). In case an X501 has Ivy Bridge Core i3 or better then tha vga will be Intel HD4000.

Share this post


Link to post
Share on other sites

Ok man, both of us are on the same point! 

 

I think this is the maximum you can do with this laptop.. The intel Graphics is the HD2000, that isn't supported by Mac Os..

"Graphics works using: "Graphics Mode"="1366x768x32", screensaver works, menus are slightly transparent, I can move the chess figures but Safari new tab flickers like hell."

 

Well I checked it again after reading a lot. Menus are around 4% transparent, but the top bar is not transparent! I've checked the flipup and floating screensavers (not the flurry) I got black screen. And finally Pixelmator throws and error during startup and quits (it uses CI extensively).

 

These are all signs that no QE/CI are active in case of a B930 CPU with HD Graphics.

 

Actually fullscreen youtube or pretty much any video are lagging and flickering here. 480p videos in a window are playing nicely, altought not as smoothly like under linux or win.

 

I would keep my 10.8 if power saving options (screen brightness), wifi and bluetooth would be ok. Actually for everyday use it is pretty cool even without QE/CI!!!! It is snappy and the OS has many-many nice features I am addicted to after a few days!

Share this post


Link to post
Share on other sites

 

*** Successful 10.8 ML Installation ***

* Boot installer using Chameleon v2.2svn r2254! *

X501A ML ZIP Kext Archive (Tested 10.8.2) : https://app.box.com/s/nzu6kihpparuzsjrunao

 

Successful Mountain Lion (10.8.2) installation on Asus X501A.

Was much more complicated than Snow Leopard...

 

Patched Kernel: "mach_intel" kernel from ML ZIP Kext Archive (Niresh "intel" kernel)

FakeSMC.kext: (Placed in both /Extra and /S/L/E)

System Definitions: MacBookPro 8,1 (SMBios.plist)

USB: Might need a rollback but first try without it.

PCI Configuration Fix may be required (search for kext/guide)

 

If you get AppleSMC hangs go to:

/System/Library/Extensions/IOPlatformPluginFamily.kext > Inside go to ACPI_SMC_PlatformPlugin.kext in Plugins > MacBookPro8,1.plist

Edit the file and remove this block:

 <key>FanThrottledRPM</key>
      <integer>3500</integer>
      <key>FanMax</key>
      <array>
        <integer>6200</integer>
      </array>

EDIT: Another possible solution to solve SMC hangs is to use a Macmini definition but I recommend using the patched MacbookPro definitions for this machine.

 

And now! We now have this!

  http://s15.postimg.org/y7vunqrtn/about.png

 

 

 
Hello, 
potrsti Briefly explain the steps you used to arrive at this installation? 
I would be very grateful ... excuse my English. 
I own an ASUS F502 (much like how the notebook).

Share this post


Link to post
Share on other sites

Hi All,

 

First tons of thanks for this wonderful guide. It was really helpful for me upto some point...have some things to work upon(despite i tried your suggestions already posted...may be i didn't follow correctly..don't know trying to install mavericks)

 

Specs for my ASUS

http://www.snapdeal.com/product/asus-x550caxx258d-laptop-intel-celeron/2025582099

 

What's left to do:

Bootloader - tried everything to get the Bootloader working (chameleon, chimera, clover....just doesn't work at all) - desperately need it

unknown cpu fakesmc plugin issue comes changed make to macbookpro 8,1 edited .plist file boot again booting only in safe mode.

Able to boot into safe mode -x after installation and adding your kexts sometimes able to boot into normal mode

 

Please help...if any further output required from any application or script..so that you can actually guide me. it'll be really great.

 

i mean i tried more than 100 times...it's celeron 1000 M cpu with 2 gigs of ram, just bought...i don't need all or everything..

 

Thanks in advance :-)

Share this post


Link to post
Share on other sites

could someone please help..

ASUS X501A just don't take any bootloader...i have to have installer disc in dvd-rom to select bootable partition.

and, only safe mode works -x -v shows unknown cpu 0xa blahblahblah..

 

please help


could someone please help..

ASUS X501A just don't take any bootloader...i have to have installer disc in dvd-rom to select bootable partition.

and, only safe mode works -x -v shows unknown cpu 0xa blahblahblah..

 

please help

Share this post


Link to post
Share on other sites

i have Asus X502CA
CPU - Intel Pentium 2117U
Chipset - Intel HM76, Intel Ivy Bridge
RAM - 4GB DDR3 1600 MHz
Video -Intel HD Graphics 2500
HDD - 500GB WD WDC WD5000LPVX-80V0TT0
WIFI - Ralink RT3290
LAN - Atheros AR8161
Sound - Realtek ALC269

 

trying to boot iAtkos ML2 from usb (Chameleon bootloader) with yours kexts (i didnt replace those with already was on usb stick)

and get this

54612b2852a1t.jpg

when boot with npci=0x2000 have same result

 

help me to install it

Share this post


Link to post
Share on other sites

Which is the best option in the distros to install in my hardware..? I tried Niresh 10.8.2, and iATKOS L2, and can't even install, tried with several bootflags and no results
It allways get stuck in apple logo screen, Im installing from a dvd I burned with transmac, actually I don't have USB, but if it's the best way to install ill try, hardware on my X501A is:

 

CPU: Pentium B980

GPU: Intel HD Graphics Family, Vendor ID: 8086, Device ID: 0106

Ram: M471B5273DH0-CK0 Samsung 4GB

SSD: MKNSSDCL120GB-DX

LAN: RTL8168

WLAN: AR9485

Thanks in advance

Share this post


Link to post
Share on other sites

When I put iATKOS_S3_version2 on my usb via TransMac and restart my laptop, it says '' Reboot and Select proper Boot device or Insert Boot Media in selected Boot device and press a key '' Please help me.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×