Jump to content

5 posts in this topic

Recommended Posts

Hi everybody, i have installed iAtKOS L2 ( lion 10.7.2 11c74 ) on my HP Pavilion a6230in.


 


Issue > GPU not detected and display resolution only 1024x720 ( mine is a HPw1907 1440x900 )


 


My Specs:


 


Intel Pentium ® Dual CPU E2140 @ 1.60 GHZ.


 


ASUS P5LP-LE


 


2.5 GB RAM


 


Network Card - Intel Pro 100 VE 


 


GPU - ASUS GTS450 1 GB DDR5


 


The issue is that my mackintosh doesn't recognize my GPU.


 


 


When i go to > About this mac > System Report > Graphics and Display 


 


I get this >>


 


Display:


 


  Type: GPU


  Bus: PCIe


  PCIe Lane Width: x16


  VRAM (Total): 3 MB


  Vendor: NVIDIA (0x10de)


  Device ID: 0x1245


  Revision ID: 0x00a1


  Displays:


Display:


  Resolution: 1024 x 768


  Pixel Depth: 32-Bit Color (ARGB8888)


  Main Display: Yes


  Mirror: Off


  Online: Yes


 


The options i ticked during install are :


 


Boot loader > Chameleon 2.1


 


Boot loader Options > Graphics Enabler


                                        Built in Ethernet 


Patches >   FakeSMC


                   Disabler


                   RTC>RTC


                   Ev0Reboot


                   IOPCIFamily


 


Drivers > Main hardware > SATA/IDE > ACHI SATA


                 Sound > VoodooHDA > 2.7.2


 


USB > USB


 


Hardware Sensors > CPU


                                  Motherboard


                                  nVIDIA VGA Cards


 


PS/2


 


VGA > nVidia > GF100


 


Network > I didn't select anything, after installation i added AppleIntel8255x.kext to S/L/E ( with modified value in info.Plist ) using kext wizard.


 


So anybody who have installed GTS450 or any fermi cards, kindly have a look and suggest me to figure this out.


 


 


 


 


 


Share this post


Link to post
Share on other sites
Advertisement

Thank you artur, i followed ur steps, added my DevID and Ven ID in NVDAResman.kext and NVDAGF100Hal.kext.

 

My GPU is detected and i am now running full resolution.

 

Again a small issue, 

 

Earlier i got audio working by using VoodooHDA.kext (2.7.2),the onboard ICH7 HD Audio was woking.

 

But now no Audio, i have got the Dev ID and Ven ID of my Geforce HD Audio, but i don't know where to add those values.

Share this post


Link to post
Share on other sites

Once again thanks for the reply artur.

 

I made a nooby mistake, i didn't select the output in sound options now i have done it, and everything is fine. 

 

Thank you so much for your kind reply.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By rxfx
      So I’ve been working at trying to get the wifey’s [HP Envy Recline 23-k310 All-in-One]’s display to properly wake from sleep for months now. I’m kinda at my wits end; It’s probably something so simple and I’m overthinking it.
       
      The computer sleeps properly, but when it wakes, I get no display (no backlight either). The keyboard and peripherals seem to work after wake; able to key in the passcode/password and sound works when I use the volume up/down buttons. But I get absolutely no display. I’ve done 3 other successful hackintoshes (though, none had any dGPUs/eGPUs). But I’m somewhat confident that I’ve disabled the Nvidia Optimus (NVIDIA GeForce 830A)/N15S-GM) I couldn’t find any _ini when I poll the SSDT’s and no signs of Nvidia In System Report, Hackintosh, or IOReg. It’s disabled via the Frame Buffer patch in clover (I use 0x0D220003 for platform ID. I definitely have the Lilu and Whatevergreen kexts in L/E. I’ve tried a plethora of Clover settings, changing SMBIOS’s, darkwake bootflags, and AppleBacklightfixup.kext in both Clover/Kexts and L/E to no avail. Power management has been set using the Pike R. Alpha ssdtPRGen implementation. I’ve gone through and setup the proper SSDTs for the USB patching. Besides adding the HDMI audio output patch (which I don’t use/or have anything plugged into since its an AIO), everything else works on point. But…
       
      “Help me Obi-Wan[’s], you’re my only hope!!”
       
      I’ve attached an “Error Report.zip” including an IOReg report, config.plist, and a generated report form black.dragon74’s tool. I would love any recommendations or possible fixes/files/patches to these files to resolve this issue that has been stumping me for months.
       
      HP Envy Recline 23-k310 AIO
      Intel i3-4330T
      Intel HD Graphics 4400
      8GB 1600 MHz RAM
      Intel H87 Chipset [HP/Quanta Laurel2-1G mainboard]
      macOS Catalina 10.15.3 (with iMac 14,3 SMBIOS)
      Error Report.zip
    • By JTSaysWhat
      My rig is working great driving a single display from Vega 64 via DisplayPort, but I'm having a devil of a time getting a TV monitor working via HDMI on the same card.
       
      My TV lights up an input icon when I plug it to the Vega (see attached--notice the next port w/ nothing plugged in is grayed out). So I know some electrons are flowing (maybe EDID?), but it never gets a signal. I've tried several HDMI 2.0 cables.
       
      I'm running a vanilla install of 10.14.6, as iMac19,1, with just Lilu (1.3.8) + Whatevergreen (1.3.1). System recognizes the Vega and seems to be correctly using the UHD630 headlessly. I just can't get HDMI out of the dGPU...
       
      I've tried the "-raddvi" and "agdpmod=vit9696" boot args, no dice. I've tried the kext patch workaround for disabling board verification, also no go (not surprising as I think that method is now obsolete for my setup).
       
      I hit the same wall running 10.14.2 as iMac18,3 with a different platform-id before updating.
       
      Here's my whole EFI.
       
      Any assistance at all is hugely appreciated!! Thanks y'all.


    • By philippd
      Hey there
       
      So I managed to do a vanilla install of 10.14 on my new machine.
      I have 2 exact same displays hooked up to my ASUS STRIX RX470 8G.
      Display 1: connected via HDMI
      Display 2: connected via DVI to HDMI cable
       
      Display #1 works perfectly fine, but display #2 has a really ugly pink/ magenta tint to it.
       
      In Clover (in fact even in the first half of booting) the second display has the colors just right.
      Then, my screen glitches/ flashes for a second
      The display #1 continues to work properly, #2 turns pink.
       
      Any help would be very much appreciated!
×