Jump to content
ameris cyning

[Success] Gigabyte Z87-D3HP -- first Haswell hackintosh?

345 posts in this topic

Recommended Posts

My bad. I am so {censored} high right now that I misread you. You have no idea how blazed I am. Sorry.

 

If they aint causing you trouble then its ok to keep them

 

And don't worry about permissions. The installer will take care of that

Oh wait, so what you're saying is I must create a whole new USB installer with MavericksPreview2 on it and reinstall? Or can I download it from App store and update it?

 

If I update via app store, must I run myfix via myhack installer afterwards?

 

Thanks, just wanting to get clarification.

 

d-1

Share this post


Link to post
Share on other sites
Advertisement

No

 

Do it through the App store and you should be fine. When you reboot, you don't have to boot with -x as you don't have to remove the kexts

Share this post


Link to post
Share on other sites

No

 

Do it through the App store and you should be fine. When you reboot, you don't have to boot with -x as you don't have to remove the kexts

Just ran it and updated, took about 11 minutes if not less and I'm back to desktop.

 

Did you notice anything different about the update, performance wise?

 

d-1

Share this post


Link to post
Share on other sites

Nope, nothing. In fact in some instances it was snappier than before.

 

On another note, I had to reinstall today because I {censored}ed up my graphic drivers and I knew that I would never be able to fix it. That was my bad because I can be an idiot at this.

Share this post


Link to post
Share on other sites

Nope, nothing. In fact in some instances it was snappier than before.

 

On another note, I had to reinstall today because I {censored}ed up my graphic drivers and I knew that I would never be able to fix it. That was my bad because I can be an idiot at this.

Yeah noticed that too and now, at least for now, when it wakes up out of sleep, the screen opens up right away.

 

ScreenShot2013-06-30at123449PM.png

 

d-1

Share this post


Link to post
Share on other sites

Found the reasoning for the problem of not being able to obtain DHCP addys on boot with the ethernet kext:

 

Its an NVRAM issue. Open terminal and type "sudo nvram -c" and reboot

Share this post


Link to post
Share on other sites

%25E0%25B8%2588%25E0%25B8%25B1%25E0%25B8It is almost like a lack of a HD 4600 + Sound alc 898 + DSDT
Now use Voodoohda before
Kext waiting for you to do first
thank
%E0%B8%88%E0%B8%B1%E0%B8%9A%E0%B8%A0%E0%

Share this post


Link to post
Share on other sites

Hey guys, I was wondering what your boot times were on your machines. Mine's well over a minute and a half and restart takes even longer. It seems to be progressively getting worse. I also noticed that sometimes my video works properly, other times it doesn't. Sometimes the menu bar loads translucent and all video is smooth, other times, the menu bar is opaque and everything is choppy. I'm not sure what to attribute this to. I am running DP2. 

Share this post


Link to post
Share on other sites

Thats an easy fix

 

You have to always boot with -f

 

I figured that out very quickly

-f just ignores caches... my kernel cache was updated as soon as I installed the kext. It worked fine for 10 or 20 reboots (Rebooting a lot to test DSDTs) then randomly bugged out one time. It's been fine for another dozen or so reboots since. I very rarely use -f, pretty much only if I can't boot and have to boot from usb to install a kext in S/L/E.

Share this post


Link to post
Share on other sites

Hello Gigabyte Z87 owners :)

 

I bought a Z87-UD3H and my build is running 10.8.5 12F9

 

Easier board than Asus ; it's been a while since i owned a Gigabyte (EX58-UD5 at the same time that d00d) ; anyway.

 

Here is my main concern,

 

For those with 10.9 and 10.8.5 (and Chameleon r2251 bootloader), do you have the speedstep, CPU throttle, etc,. fully functional?

 

I believe Gigabyte UEFI BIOS are not locked but it needs to patch the AICPUPM.kext?

 

And maybe to generate a SSDT as my previous builds, SB and IB generations? My 4670K got only x2.0, x4.0 and x8.0 multipliers (reported by HWMonitor) ; geekbench score is around 11 000 with 4 Gb RAM @ 1333 ; (it seems decent, but?)

 

 

EDIT : just done a fresh install of 10.9 DP2, AICPUM + AICPUPMClient are loaded, seems good :)

Share this post


Link to post
Share on other sites

Hello Gigabyte Z87 owners :)

 

I bought a Z87-UD3H and my build is running 10.8.5 12F9

 

Easier board than Asus ; it's been a while since i owned a Gigabyte (EX58-UD5 at the same time that d00d) ; anyway.

 

Here is my main concern,

 

For those with 10.9 and 10.8.5 (and Chameleon r2251 bootloader), do you have the speedstep, CPU throttle, etc,. fully functional?

 

I believe Gigabyte UEFI BIOS are not locked but it needs to patch the AICPUPM.kext?

 

And maybe to generate a SSDT as my previous builds, SB and IB generations? My 4670K got only x2.0, x4.0 and x8.0 multipliers (reported by HWMonitor) ; geekbench score is around 11 000 with 4 Gb RAM @ 1333 ; (it seems decent, but?)

 

 

EDIT : just done a fresh install of 10.9 DP2, AICPUM + AICPUPMClient are loaded, seems good :)

 

Would you mind posting a walkthrough of what you did to fully enable power management?

Share this post


Link to post
Share on other sites

Anyone have an AppleHDA solution yet?

 

Voodoo is working great, but I'd rather be as vanilla as possible.

Share this post


Link to post
Share on other sites

Would you mind posting a walkthrough of what you did to fully enable power management?

 

I'm not sure about the PM under 10.8.5, or maybe HWMonitor reports false values, AICPUMPM and Client are not loaded. LPC and HPET are. And my Geekbench score seems decent. It's kinda blurry to me.

 

Under 10.9 DP2 AICPUPM and Client are loaded, this is great.

 

No DSDT at the moment, no patched BIOS, nor kexts.

 

No clear CMOS (no need to patch RTC, or a modded DSDT) ; sleep, shutdown, restart seems OK ; Ethernet (153b) OK, app store, etc,. sound OK, it looks to be definitely a great board. I am seriously waiting the official release of Mavericks and to use the iGPU and get rid of the discrete card.

Share this post


Link to post
Share on other sites

I'm not sure about the PM under 10.8.5, or maybe HWMonitor reports false values, AICPUMPM and Client are not loaded. LPC and HPET are. And my Geekbench score seems decent. It's kinda blurry to me.

 

Under 10.9 DP2 AICPUPM and Client are loaded, this is great.

 

No DSDT at the moment, no patched BIOS, nor kexts.

 

No clear CMOS (no need to patch RTC, or a modded DSDT) ; sleep, shutdown, restart seems OK ; Ethernet (153b) OK, app store, etc,. sound OK, it looks to be definitely a great board. I am seriously waiting the official release of Mavericks and to use the iGPU and get rid of the discrete card.

 

Did you need anything special in your Chameleon boot plist to get AICPUPM loaded, like any generate c states / p states stuff?

Share this post


Link to post
Share on other sites

Anyone have an AppleHDA solution yet?

 

Voodoo is working great, but I'd rather be as vanilla as possible.

 

i haven't tried that but have you noticed any difference between the mavericks apple hda and the mountain lion one?

if there is any, there might be a whole new method to patch it ( not to mention the kext-signature )

Share this post


Link to post
Share on other sites

Has anyone installed Pro-SnapZ on this install, will it work...? Or will SnagIt is $50 work? , comes with a dual license for both the Mac and Windows versions. Or how bout Voila costs $30? Or Skitchm, will it work?  it's is free. Pro-Snapz is not available on the Mac App Store.

 

Anyone tried any of these on Mavericks?

 

Thanks...

 

d-1

Share this post


Link to post
Share on other sites

~gaspimp: can you please recompile your ethernet kext to work with 10.8.5? 

Sorry I didn't see that you published the source, and I did it so now I compiled it against my system and it works perfectly.  

 

Thank you for your work.

AppleIntelE1000e.kext.zip

Share this post


Link to post
Share on other sites

Anyone have an AppleHDA solution yet?

 

Voodoo is working great, but I'd rather be as vanilla as possible.

Not my work but here it is... If use DSDT method do not use HdaEnabler.kext

ALC898Solution.zip

Share this post


Link to post
Share on other sites

Not my work but here it is... If use DSDT method do not use HdaEnabler.kext

Testing this now. I will be so grateful if it works - I have a bunch of issues with VoodooHDA - none major on their own but as a whole it is quite annoying.

Share this post


Link to post
Share on other sites

Testing this now. I will be so grateful if it works - I have a bunch of issues with VoodooHDA - none major on their own but as a whole it is quite annoying.

VoodooHDA did not get the job done for me either. Volume was there, but WAY to soft. It did however allow me to dump the codec and pin configuration. But before I I finished the patches I found this.....

Share this post


Link to post
Share on other sites

Testing this now. I will be so grateful if it works - I have a bunch of issues with VoodooHDA - none major on their own but as a whole it is quite annoying.

I miss the sound of it already

http://www.insanelymac.com/forum/topic/289812-applehda-patching-in-109-mavericks/page-5?do=findComment&comment=1930410

not work with 10.8.x this is only for 10.9

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×