Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
ameris cyning

[Success] Gigabyte Z87-D3HP -- first Haswell hackintosh?

345 posts in this topic

Recommended Posts

there's an instruction as to generate your device own efi string ( saw it on revoboot thread) you might want to try it yourself 

since i am not at home right now 

Share this post


Link to post
Share on other sites

congrats mate! good to hear that 

 

is there any other issue left? 

 

None at all

 

VoodooHDA works like a charm for my audio. That was the last thing I needed.

Share this post


Link to post
Share on other sites

I thought the timer still looked off so I pulled out my iPhone and use the clock app. Either I am high as {censored} or the timer seems to skip a second every minute.

Share this post


Link to post
Share on other sites

Hey Guys I got my Mavericks 10.9 installed on this Gigabyte Z87-D3HP Haswell I-7 MOBO. Its shows 16GB 1333Mhz DDR3, 4.3 GHZ Quad-Core Intel Xeon.

 

Can you guys tell me what Kexts I need for Internet and graphics and Audio sound for this motherboard?

 

All I had to do was enter -x to get in.

 

Thanks for your help.

 

d-1

Share this post


Link to post
Share on other sites

My DVD does not mount and USB ports are not working, with the exception of the EFI USB installer. Maverick see's that, but when I plug in a regular storage USB, its does not see it.

 

My clock runs real fast.

 

d-1

Share this post


Link to post
Share on other sites

My DVD does not mount and USB ports are not working, with the exception of the EFI USB installer. Maverick see's that, but when I plug in a regular storage USB, its does not see it.

 

My clock runs real fast.

 

d-1

 

You need to switch to RevoBoot instead of Chameleon. Look up my previous post in this this thread with a boot.zip attachment.

Share this post


Link to post
Share on other sites

I am pretty sure that this is related to AppleIntelHD5000Graphics.kext and friends. Had the same problem when I tried to boot with the iGPU only. No longer an issue since my HD 46000 works (full resolution using AAPL,ig-platform-id 0x0c26000). No discrete GPU installed here.

So the 4600 is supported by Mavericks out of the box? Would a Thunderbolt Display theoretically work if you have a motherboard with Thunderbolt?

Share this post


Link to post
Share on other sites

I'm really enjoying Mavericks and Haswell, but I have encountered one minor annoyance. Occasionally when I boot up (let's say, 40% of the time), both of my network interfaces remain in the "Not connected" state. I have to mark them as inactive and then active to bring them up, regardless of whether using DHCP or Static IP. The other 60% of the time, they work just fine and require no manual intervention. Has anyone encountered anything similar? One of the cards is a DLink PCIe 1x card with a Marvell 88E8053 chipset and the other is a Myricom PCIe 4x 10G Fiber card. Both have natively supported OS X drivers, and neither exhibited this issue in Mountain Lion. 

Share this post


Link to post
Share on other sites

You need to switch to RevoBoot instead of Chameleon. Look up my previous post in this this thread with a boot.zip attachment.

I'll give it a closer look. Reason why I could not mount DVD or USB is because I was running it in -x (safe mode).

 

How did you connect to internet?

 

d-1

Share this post


Link to post
Share on other sites

Putting my ethernet device ID in the Apple kext had no effect. I may be doing it incorrectly, but I tried two different methods that I found others using online. I may resort to a pci card for the time being.

 

I still think I have graphics issues, boot hangs on pci configuration begin for almost a minute before my system finally boots. I've tried all the flags... npci, graphics enabler (won't boot at all if I enable it)... etc. I also tried the efi string method which seems to have no effect, though I'm not sure what to put in the rom-revision field. I'm looking into modifying my DSDT now, only so much time in the day...

 

One last Issue I've found is that if I insert a usb stick, remove it (safely) then reinsert it my box goes down. Seems to do it with both 3.0 and 2.0 ports.

Share this post


Link to post
Share on other sites

How hard can it be to credit someone? I mean I reported this months ago:

 

memcpy(fakeEfiPages->unsupportedret_instructions, UNSUPPORTEDRET_INSTRUCTIONS_64, sizeof(UNSUPPORTEDRET_INSTRUCTIONS_64));

 

Not to mention that looking at other peoples code makes writing patches a lot easier. People should know that this kind of lame stuff makes people stop helping other people.

Share this post


Link to post
Share on other sites

How hard can it be to credit someone? I mean I reported this months ago:

 

memcpy(fakeEfiPages->unsupportedret_instructions, UNSUPPORTEDRET_INSTRUCTIONS_64, sizeof(UNSUPPORTEDRET_INSTRUCTIONS_64));

 

Not to mention that looking at other peoples code makes writing patches a lot easier.

 

...?

Share this post


Link to post
Share on other sites

Chameleon was changed but lack proper credits!

 

Oh FFS that is completely unacceptable

Share this post


Link to post
Share on other sites

Though i agree with proper accreditation, always, no exceptions, wouldn't be better if you, Pike, spoke to the team Chameleon via private message (better solution) or at least in a topic it's sure read by them (the Chameleon general discussion) instead of here?

 

That said, amazing work. I cannot help and say it's a pity you decided to keep RevoBoot as a personal boot loader instead of pushing more adoption. Keep up the good work.

 

All the best!

Share this post


Link to post
Share on other sites

Though i agree with proper accreditation, always, no exceptions, wouldn't be better if you, Pike, spoke to the team Chameleon via private message (better solution) or at least in a topic it's sure read by them (the Chameleon general discussion) instead of here?

 

That said, amazing work. I cannot help and say it's a pity you decided to keep RevoBoot as a personal boot loader instead of pushing more adoption. Keep up the good work.

 

All the best!

That would of course be more convenient, for the Chameleon developers and this forum, but what I want is that people here know what is going on.

 

Listen. I work long hours to get stuff going, at night even – knowing that I only have one week left – so when something like this happens, then I wonder why I should continue to help other people when I return from my honeymoon trip.

 

p.s. I simply don't have time for RevoBoot to make it a public boot loader.

Share this post


Link to post
Share on other sites

First of all, this forum's not at stake: Chameleon's not "Insanelymac's official software" and they answer alone for their own acts, and the same goes for you, by the way.

 

That's why I suggested you guys treated these matters privately. It was good advice and please take it as it. If you want to voice your concerns publicly, that's also fine - as long as there's no trolling or flaming, Insanelymac is for free speech as well. Although, is forum etiquette that posts keep on-topic, and this falls at our concern (we, mods). So I'll ask Lejenk to move all off-topic posts to where they belong. Don't worry, none will be deleted.

 

All the best!

 

P.s.: I believe how hard would be to provide support for a large user base by yourself - look at XPC and how they want to keep low profile exactly because of that. But you could always push for other devs to help you, just like Slice did. Anyway, it's up to you and you know your reasons better than anyone else. Your blog by itself is quite useful for the community.

P.p.s.: hate to post here using the iPhone...

Share this post


Link to post
Share on other sites

Hey Guys, what is the best way to install VoodooHDA, is it better to use Kext Wizard or Kext Utility? If I use Kext Wizard, what folders do I install it to.

 

Thanks,

 

d-1

Share this post


Link to post
Share on other sites

Hey Guys, what is the best way to install VoodooHDA, is it better to use Kext Wizard or Kext Utility? If I use Kext Wizard, what folders do I install it to.

 

Thanks,

 

d-1

Kext Wizard is perfect. That is what I recommend. I would also recommend Chameleon Wizard. Janek is one hell of a good programmer.

 

As for the folders it would be in /system/library

 

BTW did you get your graphics card working :P ?

Share this post


Link to post
Share on other sites

Kext Wizard is perfect. That is what I recommend. I would also recommend Chameleon Wizard. Janek is one hell of a good programmer.

 

As for the folders it would be in /system/library

 

BTW did you get your graphics card working :P ?

What folders do I check for voodooHDA Kexts in order to install?

 

As for Chameleon Wizard - is it pretty easy to follow to build boot-loader?

 

On my MSI GeForce GTX650 Nvidia, I could not get the card to load on the previous install. I am currently do a reinstall of Mavericks and I typed the boot-flags -f GraphicsEnabler=No and I could tell the graphics install page look 1000X better and are high res. But I am on the beginning phase of installing the whole OS allover.

 

Will keep you posted....

 

d-1

@ q6eceo - on reboot, I get the grey apple logo page , but no spinning cursor wheel shows, after about 1 min or so, it goes to a solid grey page with no apple logo and sits there even longer. On this reboot I did not enter any boot flags on reboot.

 

Must I reenter those boot flags for MSI GeForce GTX 650 card? (-f GraphicsEnabler=No) to finalize the installation?

 

On 2nd rebbot I entered (-f GraphicsEnable=No) and I was able to finalize the install. (resolution is great) beautiful Ken Burns screensaver.

 

Now to install Chameleon Wizard and Kext Wizard. (I have to find links.)

 

d-1

Can someone provide the Links for Chameleon Wizard to go with and Kexts wizard?

 

Thanks...

 

d-1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×