Jump to content

87 posts in this topic

Recommended Posts

has anybody tested clover kernelCpu=true for atom cpus in mavs thx

 

I have tried. Without success Mavericks 10.9 and 10.9.1 (both using the same kernel) and 10.9.2.  :blush:

Share this post


Link to post
Share on other sites
Advertisement

Try this kernel, my build (10.9.2),  Atom 330 work. Sorry for my English, I'm from Russia.

 

This Kernel works for me I'm running 10.9.3.

 

Atom D525, Ion2.

Share this post


Link to post
Share on other sites

This Kernel works for me I'm running 10.9.3.

 

Atom D525, Ion2.

Awesome !! can you give the steps you followed when installing OS X. I have not tried this Kernel yet, but all my previous attempts with different Kernels failed with boot loops. Can you point me to any guide that you followed to get the install done ? I have the same CPU and ION combination as you on a Asus board (Asus AT5IONT).

Share this post


Link to post
Share on other sites

Finally, thanks to an user called TimeWalker75a, we can run the vanilla 10.9.x kernel with our Atom machines, just like we did with Mountain Lion, when the kernel patcher module still worked. With the vanilla kernel, we can use all the iCloud services like iMessages FaceTime and so on. In fact, it's the same principle of on-the-fly kernel patching, only the kernel patcher runs with Clover, not Chameleon. Even better, these new patcher will run also with Yosemite and perhaps other future iterations of OS X.

 

Here's the link: http://www.insanelymac.com/forum/topic/264740-asus-1201n-installation-and-support/page-49?do=findComment&comment=2032837

 

Enjoy!

 

P.S.: of course, just to make it clear, this new patcher is only meant to run the vanilla kernel on Atom hardware, and won't be of any help for accelerating the unsupported integrated GPUs that usually come with it, like the GMA3150, the x3100 or the GMA950: these won't get hardware acceleration - the infamous QE/CI - and will never do. If you have these cards, I recommend you don't use your computer as a hackintosh, or use it only for learning purposes, since OSX without graphics acceleration is really awful.

Share this post


Link to post
Share on other sites

Good to know! If you have spare time, I'd also ask you to create a Yosemite installer and see if it works. I'll do the same as soon as I get home. Otherwise, enjoy Mavericks on your 1201PN.

 

All the best!


P.S.: and thank TimeWalker74a: I'm just spreading the news. :)

Share this post


Link to post
Share on other sites

Great news!

 

I've been trying to run Mavericks on my 1201n since it was seeded as a preview, with no success: the kernel patcher module from Chameleon clearly needs to be updated, and since it's not developed by the Chameleon team itself, but by a third party development company (meklort's xZenue LCC), we haven't yet any ETA for this update. I tried the old kernel patcher from meklort, but also met with no success (which was expected, since it shares the same code with the kernel patcher module). So we've been stuck with Mountain Lion for quite a while.

 

As some of you might know, i'm deeply involved with AMD kernel development - and I'm currently the AMD Development forum moderator - and we managed to boot some AMD machines with a couple of beta kernels. These kernels are quite AMD-specific, and in fact i tried them with my 1201n, but they didn't work. However, one of our leading developers, Andy Vandjick, doesn't have an AMD machine, so he has been trying to make his patches as much CPU-agnostic as possible, and indeed his old AMD kernels for Mountain Lion and  Snow Leopard also included support for legacy Intel hardware. Last week, he adapted his patch set for Mavericks, and since he didn't install the necessary new Xcode, i have to build the binaries for him. The resultant kernel didn't work, but brought relevant insights for the current beta kernels for AMD.

 

Well, knowing Andy's history of enabling legacy Intel support for his kernels, and also knowing he has been using essentially the same base patch set across OSX iterations, i decided to experiment with his kernel, even a little skeptical - since it didn't met its goals, that is, boot on AMD. Then, today, for my greatest surprise, after a few attempts, it worked, and i manage to install mavericks on my 1201n!

 

I didn't do many things with my Mavericks partition since then, and i expect all iCloud-based services not to be working, since that's the rule with kernels compiled from the XNU sources, but hey!, that's a real deal! Hope you all try it! Here's our kernel: atom_kernel.zip

 

Excellent information!

 

I have an ASUS AT3IONT-I Deluxe motherboard (Atom 330) that uses Nvidia ION.... I am hopeful... how would one add this atom kernel to install and potentially get OSX working in my situation? 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By zeg66
      Please help me with this 10.9.5 system. Motherboard: Gigabyte 965p-s3 rev3.3, gpu: Ati Radeon HD6450 (dvi/hdmi/vga). 
      Using any of the 3 ports on the 6450 (dvi, hdmi, vga), I see all the white letters on black background during boot but when they complete and it's time for the graphics to start I get a black screen and sometimes a restart after that. Using Clover 4411. Is there any way to get past this?
    • By zeg66
      Could you please help me enable the VGA port on the GT710 in 10.9.5 13F34 ? 
      It is currently booting fine through its HDMI port, web driver 334.0103f01 and config.plist arguments checked: Verbose (-v), npci=0x2000, dart=0, nvda_drv=1
      The nvidia GT710 works fine through its VGA port and web drivers on a friend's Mac Pro 3,1
      I must soon return this borrowed HDMI monitor, mine only has a VGA port so I'd appreciate your input.
    • By zeg66
      Have managed to boot into Finder without a usb but cannot see the outside world. Could you please help me to enable Marvell 80E8056 ethernet access on 10.9.5 13F34 ?
    • By Nemorosus
      Note: This computer works with every version of OS X since (virtually) Snow Leopard, to High Sierra (and newer I presume, except if Apple makes drastic changes). Depending on your hardware configuration, you may need to change some settings and experiment more.
      My configuration:
      CPU: Intel Core i5 3570 3.4GHz RAM: 8GB DDR3 GPU: NVIDIA Geforce GT210 1GB (connected via HDMI) What works, what doesn't?
      Works: Native power management with TB, USB 3.0*, Ethernet*, parallel ports (natively)... Doesn't work: Intel HD2500. If you have i7 or another CPU with HD4000, you may get it to work. The options in BIOS are there, it's just I hadn't had any luck with the HD2500 and couldn't enable it (tried various ways). Note: I don't know if native audio works, as I own an USB audio interface and I use it without any problems. I presume you'll be able to get audio with AppleHDA patches or in last resort VoodooHDA. Let me just say that this is a relatively compatible computer. The motherboard is very good, with the exception of the PSU - you are limited to set of GPUs. Before I had the GT210, I had GTX1050 which worked wonderfully with High Sierra (latest version). But for my purposes, I needed Mavericks and hence the GPU downgrade.
      BIOS settings
      SATA mode to AHCI Disable VT-d Disable integrated GPU (if you have HD2500) Enable Execute Disable Bit Installation Guide
      Create an USB with DiskMakerX Install Clover on it (no special settings needed) Insert FakeSMC.kext into kexts/Other folder When booting, select all the CPU patches (including XCPM) If you have NVIDIA GT210, you'll need to disable the integrated GPU and only select 'Inject NVIDIA' in Graphics settings in Clover Viola Additional Kexts
      Ethernet - AppleIntelE1000e.kext USB 3.0 - GenericUSBXHCI.kext Some more screenshots:




    • By zeg66
      Trying to install Mavericks on an Asus H170M-E D3 motherboard, Skylake I3-6100 cpu, Intel 530 graphics.
      Last message I see is "root device uud is" and a series of "+++" but then it just stops.
      Have prepared usb with createinstallmedia, added Clover 4413 and changed a few settings with Configurator.
      Any help is welcome.
×