Jump to content
rockinron_1

10.9 Mavericks Simple Vanilla Hackintosh Install Guide

167 posts in this topic

Recommended Posts

Success on Asus K53e with I3 Processor.

Followed the instructions and copied my extra folder from my ML install. 

Just sound, keyboard and trackpad not yet working but hopefully [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] will have a solution for those.

Share this post


Link to post
Share on other sites
Advertisement

I can't seem to copy the kexts over to the System/Library/Extensions folder, as it is locked. Using a MacBook Pro running OS X 10.9 Mavericks to prepare everything. Pacifist can't copy it, same goes for Finder. The machine to be Hackintoshed is running an Intel Core i5 unlocked Haswell. My first time doing a Hackintosh, so please don't jump all over my newbieness!

Share this post


Link to post
Share on other sites
The installation I managed to do it with -v -x. After I followed the steps to copy FakeSMC and NullCPUPowerManagement, but when trying to boot from the hdd appears ''MISSING BLUETOOTH CONTROLLER TRANSPORT'' and then ''RESETING IOCATALOG''

 

What can be happening?

 

My PC:

Gigabyte Z77M-D3H

Intel Core i5 3330

Gigabyte GTX 650

8 gb ram

 

Sorry for my English :blush:

Share this post


Link to post
Share on other sites

I have the 7970 installed and working with Mavericks.  The only thing it requires for a successful boot is use of "GraphicsEnabler=No".  System info still shows 7xxx 3072 MB

For me it is not working. Fine with 10.9 DP (any version) but now finally i have not full QE/CI, but my card shows as 7xxx and 3096 MB RAM. I can't fix this.

Share this post


Link to post
Share on other sites

So I installed Mountain Lion on vmware workstation 10 on my Dell Inpsiron 7720.
Downloaded Mavericks
Setup bootable USB
Created a new Virtual machine
Installed Mavericks
All went well
Only thing I cannot get working is iMessage?

I have tried the fixes but dont think they work in a virtual machine?

I suspect that under "About this Mac" I need to see hardware specs like at the moment it says Mac and thats it!

Share this post


Link to post
Share on other sites

just finished installing Mavericks 13A603 GM , added five kexts a well sorted extras folder and chameleon 2265 job done gotta love this mobo Asus p5k-vm worked flawlessly since 10.5.6

It works good here, except constant and random freezes, no kernel panic, but I have to reset from button when freezes. I tried everything, including ApplePCIIDE.kext (the freezes are more rare, but they still happen randomly). I am totally illiterate in editing dsdt (I don't understand anything in these lines).

I attach my dsdt here, can you see it and help me?

dsdt.aml.zip

Share this post


Link to post
Share on other sites

Does your installation work well without a dsdt if so ill post my dsdt I've used it on my hack and my wife's both working 100%

Share this post


Link to post
Share on other sites

My installation works without the dsdt, but in this case, I have no audio (AppleHDA.kext not loaded even the original one), the internal drives appear orange and the freezes occur more frequent. I mention the freezes occur especially when something load the CPU to 80-100% for 10-30 seconds, even some seconds after the CPU loading peak is gone. I put a new and bigger CPU heat sink over the CPU and even a cooler over the north bridge radiator, touching the CPU radiator it is not very hot, but the north bridge was really hot after 30 minutes of working Mavericks. I still not suspect a hardware malfunction, because it happens the same with the 2nd p5k-vm I have. I suspect something wrong in my dsdt or in my dsdt/kexts combination. I attach a screenshot with my kexts in Extra/Extensions.

post-1427-0-69889200-1382935930_thumb.png

Share this post


Link to post
Share on other sites

Hi everyone, i get a error on bootloader.

Not boot to OS X or WIndows if USB not stick usb drive.

Boot0: done

And PC not reponse, i have to press the reset button.

While have USB PC boot dual with WIndows 8.1 and OS X Mavericks ( Windows and OS X install on same HDD, two partition ).

 

Help me with error.

Thanks.

Share this post


Link to post
Share on other sites

Installed Mavericks AppStore version yesterday. I used MyHack to crate USB installer. Everything except sound worked OOB. Installed Voodoo for sound and now I have perfect Mavericks system :)

Share this post


Link to post
Share on other sites

1. Last release of Chameleon doesn't support  kexts are in the extra/extension. You need to copy essential kexts (FakeSMC, NullCPUPowerManagement) to /System/Library/Extensions on your USB stick

essential software & kexts + org.chameleon.Boot.plist + dsdt + smbios are in /Extra

Chameleon-2.2svn-r2246 who is in the attachment of the guide

 

How do you mean it doesn't support kexts in Extra\Extensions folder? I've just installed Mavericks and FakeSMC version 5.2.655 straight from the source (HWmonitor works) and associated plugins are in that folder (chameleon installed in system drive) I also have AHCI_3rdParty_eSATA and IOAHCIBlockStorageInjector there with Chameleon version: 2.2-r2266

 

I've got everything working  in my system (GA X58-UD4P_ATI5450) except shutdown sleep and restart, all kexts load fine (IntelCPU, AppleLPC) patched AppleRTC as well, but to no avail.

Share this post


Link to post
Share on other sites

I am also running 2.2r2266 and using Extra/Extensions folder for some fixes... no problem with that.

 

still trying to get resolution and acceleration w/8800 GT.

Share this post


Link to post
Share on other sites

Thanks , great guide ... But i have a big problem .

During the installation from the usb stick , everything works great until the welcome screen comes ... Then i have no mouse , no keyboard ! , i see the welcome screen scrolling with different languages ... But there is no input device working to continue the installation ,

I'm using hp dv6 i7 laptop ... Was working fine with ml 10.8.2

Can i use a fix for kb/mouse ?

How ?

Thanks

Share this post


Link to post
Share on other sites

Hi XanthraX your kexts are different to mine your issue my be related to that nullcpu management kext I don't know what that is I don't use it

I have attached the files that I use  kexts to use my DSDT, which is patched a bit plz try them get back to me

P5K VM pack.zip

Share this post


Link to post
Share on other sites

Hi. I have a Dell computer without ahci mode in the bios (only RAID And ATA). My usb stick with Mavericks installation does not see my hard drive where I want to install Mavericks in both raid and ata modes.

Now I have Lion installed, and I have added from it ACHIPORTIJECTOR.KEXT in the s/l/e folder of the pendrive in order to make it recognize the drive. But infortunatly I cannot repair permission of the s/l/e folder of the usb drive.. If I use disk utility the option il disabled, And with the terminal even by superuser the permission remain set as "unknown".

 

How can I modifie usb permissions or how can I Made my usb drive recognize my drive?

Share this post


Link to post
Share on other sites

I still had 2 freezes, but more rare than before. I suppose they are fermi freezes due to my nVidia GeForce 9400 GT. I ordered another videocard based on AMD HD 5670 and I am sure the freezes will be gone.

If you want sleep you have to have a proper patched AppleIntelCPUPowerManagement.kext (AICPM) and to get rid of NullCPUPowerManagement.kext (NCPM). I have no idea what to edit at AICPM and it is very risky, because you should install it back in /System/Library/Extensions after every system update. Or put away NCPM and install it in /Extra/Extensions before every system update, then replace AICPM with the patched one in /System/Library/Extensions and remove NCPM from/E/E.

Share this post


Link to post
Share on other sites

Updated via Software Update - "Software  OS X 10.9 (13A497d)" now. Lost trim support and audio. I could fix trim. No way with 889 yet. Everything else works. It seems a little slower.

yeah, it's a LOT slower for me.

Share this post


Link to post
Share on other sites

Any idea why i am getting this in installation:
 

 

 

Mac OS X can't be installed on this computer.

OS X Mavericks cannot be installed on this computer.

If you want to restore your system from Machine backup, clisk "Restore from Backup"

 

Share this post


Link to post
Share on other sites

Hi gsxb. I seem to find the source of the random freezes. It was the wrong RAM modules pairing. I changed the modules and now it seems to work fine. It was not because the graphic card. I still testing because it wasn't anything specific to generate those freezes, but I use now the computer from more than 4 hours and no freeze occurred. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By cydia2020
      G'day guys,
      I recently bought a Surface Book i5 256GB with dGPU, and I found that there's no tutorial about Hackintosh since it's released, so i am here to be the first (maybe) to try this out
       
      This guide is not being recommended by its author, as the final performance is usually janky and unstable, most fundamental functions of your Surface will not work in Hackintosh, please always consider the consequence of proceeding, you also risk losing your data, again, please proceed with caution
       
      ******謝絕轉載謝謝配合******
      ******Please do not repost, thanks******
      ******転載禁止です。ご協力をお願いします。*******
      This project is deprecated (and it was only meant for 10.11 - 10.12.3) due to hardware availability on my side, no support for future OSes will be provided by me personally and support on current OSes will be limited. Your contributions, testing and guides will be appreciated by the community.
       
      video is up at
       

      Disclaimer: everything is on yourself, please proceed with caution and care
      Works
      Keyboard & Trackpad (No Gestures)(Buggy, when you hold a key, pointer won't move),
      SD card reader,
      USB 3.0 ports,
      Sound
      PCIe SSD
      Intel HD 520 Graphics works perfect on 10.11.4
      DP Video output now works(don't close the lid, it lead to big problems)(after closing the lead with external monitor, when plug in the external monitor, it no longer recognize the internal display, you must unplug the monitor and reboot)
      Long press power key brings up the power menu
      Brightness
      Lid

      Doesn't work
      NVidia dGPU
      Touch Screen (Alex's driver won't work since it's now on HID Camplg ports, which is not open source)
      Wireless (Wi-Fi & Bluetooth)
      Volume rocker
      Battery status

      What Works for 10.12
      Everything for 10.11 :-)

      Bugs For 10.12.3 and below
      Graphics is janky and unstable. and does not work natively, driver patch is needed
       
      Graphics will not work on 10.12.4 as reported for the built-in display, please take notice and do not upgrade
      First Step: Installing a Virtual Machine
      You will need a VM in order to get the thumb drive ready, please install a VM or you can use a real Mac to do this, the installation is not very hard, but do need some times for downloads and other stuff.
      Download VMWare Workstation Pro 12.0 Trial Version Download VMWare Unlocker Download Python Runtime Modify Unlocker Bat file -- In the unlocker installer, there's a win-install.bat file that you can open by CMD, but don't open yet, we need to modify a path in the file, open the file using your favorite text editor, find unlocker.exe in the file, change it to unlocker.py The previous step is redundant  Follow the instruction on unlocker readme file Go to a Apple Store, get a Install App from their computer and convert the BaseSytem.dmg to CDR, or you can just skip those steps to the making USB step Use the converted CDR as install media in VMware Installing OS X as normal Second Step: Prepare to install
      You need an actual Mac to make the install USB or using a VM, both methods are fine, I wouldn't say more about installing a VM on your devices, you can Google that yourself
      You'll need to download the 10.11.x installing App from this link For macOS 10.12 please go to this link to get the preview version You need to open Disk Utility. Select the USB Drive and format it as Mac OS X Extended (Journal-ed), Name it whatever you want, as long as you can remember the name. Now, open the terminal, enter the following text, this will cost you around 4 minutes on a USB 3.0 device and 30 minutes on a USB 2.0 device, go get yourself some drinks For 10.11 sudo /Applications/Install\ OS\ X\ El\ Capitan.app/Contents/Resources/createinstallmedia --volume /Volumes/PARTITION NAME --applicationpath "/Applicatons/Install OS X El Capitan.app" --nointeraction The previous method won't work on 10.12 anymore, you will get a USB that is not booting, use the guide below Download Clover from Clover Official Download Page Install Clover by choosing "Install UEFI Version only, install to EFI partition, Install Themes, Driver64UEFI(unselect CsmVideoDxe-64) After installing, you should see a Partition called EFI mounted, and it's your thumb drive (Copy the EFI folder from Installing OS X to the EFI Partition) only do this if it didn't do atomically DownloadSurfaceDriver.zip and follow the instruction in the ReadMe.txt to paste the files into your CLOVER folder ++++++++++Notice for 10.12 USB Creation++++++++++
      The pervious way of making the 10.11 drive won't work anymore in 10.12, instead, after downloading the 10.12 install app, you'll need to follow the following steps
      Show hidden files by executing this command defaults write com.apple.finder AppleShowAllFiles YES Navigate to /Application/Install macOS Sierra/Contents/SharedSupport and mount InstallESD.dmg
      Open "Disk Utility", restore the USB drive with Basesystem.dmg (hidden) in the mounted DMG file.
      Copy /Packages in the mounted DMG file to the restored USB's /System/Installation. Delete the old link before proceeding to the copy.
      Copy basesystem.dmg and basesystem.chunklist to the root directory of your USB drive
      Third Step: Installing OS X 10.11

      Now, we can start installing 10.11, you should plug in an external keyboard, mouse, and your thumb drive, after you finish the booting process, you should see the welcome page, choose the language you prefer and proceed the installation
      Go to Windows First, partition your drive for at least 50 GB if you want to keep using, because as I tried before, remapping disk after installing macOS or OS X is extremely HARD, don't try that unless it's necessary, you will risk the integrity of your data by doing that
      Choose Disk Utility, choose your installing partition and click erase, format as OS X Extended (Journal-ed), then, exit Disk Utility and proceed the installation process, you might need to proceed the same process twice to get the full install, so if you didn't saw your OS X drive, please choose install again. (The installation will automatically continue.)

      Or: Installing macOS 10.12
      Please change ig-platform-id to 12345678 before installing the framebuffer kext.
      Things getting a little bit tricky when you're trying to install 10.12 on Surface Book. Since there's still a little bit of problems with the NVMe driver, you will likely get a error message says: unable to unmount volume for repair
      I am not sure if the error spreads largely, but, I experienced it every time I install the 10.12
      The temporary workaround is that to use an external USB hard drive or a SD card, I don't recommend a USB thumb drive unless it's superfast.
       
      Install 10.12 as normal to the external hard drive apply all the combo updates to the external hard drive system Use the recovery environment comes with the Installer (not the hard drive) Open Disk Utilities and restore the whole USB hard drive to the macOS install drive You can apply combo or delta updates as normal, but do not apply big updates that requires a standalone app download, backup and reinstall instead Problems regarding 10.12 installing has been solved, please proceed as normal
       
       
      The Final Process: Make your experience better
      You don't have to patch the keyboard drivers for 10.12.1 and/or above
      For 10.12, please install the kexts in 10.12 "install" folder located in the driver pack
      Make the keyboard works (10.11 only)
      Navigate to InstallHD/System/Library/Extension Copy the IOUSBFamily Kext to your desktop or wherever you like Right click on it and choose show package content, go to /Contents/PlugIns Right click on IOUSBHIDDriver and choose show package content, go to /Contents Open Info.plist using software like: PlistEditor Pro, and xCode Navigate to IOKitPersonalities Copy Generic Keyboard and right click on IOKitPersonalities Select "Paste as a child" Expand Generic Keyboard 2 change the value of bInterfaceProtocol to 0 change the value of bInterfaceSubclass to 3 change USBCompatibilityMatch to YES (doesn't have this on 10.11) save the file and open Kext Utilities Drag and Drop the kext in to it, enter password and after it finished reboot, then you should have a working keyboard Install Clover to SSD
       
       
      To install clover to ssd, you need the CLOVER PKG installer and remeber to update as a new version releases, it might contains bug fixes.
       
       
      Install clover as normal, install to your HACKINTOSH INSTALL DRIVE Use UEFI Boot Version, Install theme, and Driver, unselect CsmVideoDxe PUT THE SURFACE BOOT DRIVER INTO THE DIRECTORY Use BOOTICE x64 Version under windows, mount EFI under windows, Select UEFI tab, add a new boot entry navigate to EFI:\EFI\CLOVER\CLOVERX64.efi, name it clover bootloader (or whatever you like). Go to Surface UEFI, unselect Windows Boot Manager under Boot tab, select and drag CLOVER to the first position of the UEFI boot sequence,  
      NOTICE: DO NOT DELETE "INTERNAL" selection in UEFI setup, or your Surface WILL NOT BOOT (won't happen on newer BIOS)
       
       
      By the way, according to the feedback, there has been some problems with the AppleHDA patch, please install AppleHDA298.kext to S/L/E directly using your kext installer instead of placing it under /CLOVER/kexts, also, please use sRGB as color profile to avoid any grahpics glitch in 10.11.
       
       
      _____________________________________________________________________
       
      You'll need a Wi-Fi dongle to get online or you can use USB Sharing on Android and iOS, don't know whether network sharing on Ubuntu Touch, Windows Phone and Blackberry will work
      You'll also need a Bluetooth dongle to get BT working


       
      __________________________________________________________________________________________________________________________________________
      Thanks to
      LonelyTV
      MeuPRodrigo
      maj1es2tic
      Pike

      and all of you
    • By zcmckenna
      I have been having a pretty major issue with my new Hackintosh lately. It has been displaying broken link images in safari (See image 1). It has also had certain areas of artifacting such as the storyboard in Xcode (See image 2). and finally PDFs have been showing up completely blacked out (See image 3). This has been a big issue for me and I was wondering if any of you have had the same problem and have had any luck fixing it. I have already tried display calibration and switching to integrated graphics. Thanks in advance!
      (See attached for config.plist)
      Specs:
      CPU: i5-8600k
      MB: Gigabyte Z370XP SLI
      GPU: ASUS 1070 Dual
      RAM: 16GB Ballistix (8GB x 2)
      HDD: WD Blue 1TB



      config.plist
    • By ITzTravelInTime
      Hi guys, this thread is to show you a new and open source app, created by me, that I called TINU:
       
      The name means: TINU Is Not #####, the U refers to a popular software that is used to create Mac OS hackintosh installers (that for good reasons is banned on this forum), but the aim of the name is to explain that this app is a totally different thing from that software and works in a totally different way.
       
      This app basically is a graphical interface for the createinstallmedia executable that is inside the Mac OS installer apps, it is capable to create a Mac OS installer on a drive completely vanilla like what you do using the command line method, and also this method is recommended by apple itself.
       
      Allows you to create easily a macOS install media without messing around with command line stuff and without using disk utility, all you need to do is use the app and then install clover on the usb drive once TINU has finished or leave it as is you want to use it on a Mac.
       
      Features:
        - Simple to use UI that allows you to easily start the macOS install media creation process   - It can work with every Mac OS installer app that has the createinstallmedia executable inside of it's resources folder (including also beta and newly released installers)   - You can use any drive or partition you want that can be erased and is at least 7 GB of size   - Works on Mac OS recovery, so you can create a macOS install media from a bootable macOS installer or from the macOs recovery   - All vanilla, the macOS install medias created with this tool are 100% vanilla, just like you created them using the command line "createinstallmedia" method   - Open source, you will know what this program does on your computer and also you can create your own version by downloading and playing with the source code   - Does not requires to do anything of special first, just open the program   - No need to go in disk utility first, TINU can format your drive for you   - Uses recent and more modern APIs and SDKs and Swift 3 language   - Transparent graphics style available (use alt + s on the keyboard or View->Use transparent style)   - Works using the latest versions of macOS and will also support newer Mac installers out of the box without needing for an update    Features that I'd like to add in the future:    - Advanced section, to customize your macOS install media   - Installer customization: Kernelcache/prelinkedknerel and boot files replacement (a feature that can be handy while dealing with old Macs or with beta installers when you need to mod or change the boot files some times)   - Install clover and configure clover   - Install kexts inside the kexts folder of clover   - Clover drivers customization   - Use custom dsdt in clover   - integrated pre-made clover config templates database from a remote and open repository   - Support for other languages, at least Italian   Rquirements:  - A computer that runs Mac OS X Yosemite or a more recent version (Mac OS X El Capitan is required to use TINU in a macOS recovery or installer)  - A drive or a free partition of at least 7 GB that you want to turn into a macOS/Mac OS X installer  - A copy of a macOS/Mac OS X installer app (Maveriks or newer versions are supported) in the /Applications folder or in the root of any storage drive in your machine (excepted the drive or volume you want to turn into your macOS install media)   Note that this app is under the GNU GPL v3 license so any reuse of the source code must follow the license's terms   TINU 1.1 Stable release:    - Download available here:    https://github.com/ITzTravelInTime/TINU/releases    - Source code:     https://github.com/ITzTravelInTime/TINU   TINU 2.0 pre-release:    - Source code:    https://github.com/ITzTravelInTime/TINU/tree/development    - Download available here:    https://dl.dropboxusercontent.com/s/nvzss51qcieynve/TINU.zip     Frequently asked questions about TINU: https://github.com/ITzTravelInTime/TINU/wiki/FAQs     NOTE: if you have problems with your USB installer of 10.13.4 or newer version not being detected by clover you have to use the latest clover and if it still does not detectets your usb installer you have to remove the invivible file called .IAPhysicalMedia located into the root of the usb installer. This issue is caused by a changement in the apple's createinstallmedia, don't blame TINU for that, tinu does only uses the installer creation method from apple, which has been changed, causing this problem for hackintosh users, this issue should be resolved in the latest versions of clover which will no longer require that you do changements to let your usb dive to be detected, a setting to do this fix automatically in tinu is also comeing in a new pre-release of TINU 2 I leave also some screenshots as well








    • By JDizz
      #UPDATE AS OF APRIL 27, 2018 Thursday, 3:53 PM EST

      SIMPLE INSTRUCTIONS
      After you figure out how to get High Sierra 10.13 or 10.13.4 installed to a USB with Clover Bootloader, and you're loaded onto MacOS High Sierra:

      Download Clover Configurator and MOUNT your partition and OPEN it to reveal your EFI folder. Delete it.
      Simply download the attached ZIP and unzip it by double clicking it. Then copy and paste the EFI folder you unzipped to the location of your mounted partition.

      Done. Enjoy. Special thanks to Jake Lo !


      WORKING [Dell M6800 - High Sierra 10.13.4]
      Sleep/Wake WHILE THE POWER CORD IS PLUGGED IN (Not from closing the screen down, but from clicking the Apple logo and sleep or by timer).
      Wi-Fi (AirPort Extreme) via Broadcom BCM43xx.
      2 USB ports on the LEFT side as USB 2.0/3.0 and the 1 USB 2.0/eSATA on the back.
      KeyBoard.
      TouchPad (With MultiTouch - Fully functional)
      iMessage, iCloud, FaceTime, AppStore work perfectly.
      NVIDIA Graphics work perfectly thanks to the Lilu and NvidiaGraphicsFixUp kext. THIS FIXES THE BLACK OR BLANK SCREEN PROBLEM.
      DVD-Drive/Burning if you even care to use CD, DVD disk.
      Bluetooth (Works even with Apple HomePod =] )
      Ethernet/RJ-45
      2 USBs on right side as USB 2.0/3.0
      Native Sound (On board Speakers and can adjust sound with buttons)
      SD Card Readers
      Adjusting Brightness (Download an app from the AppStore called Brightness Slider -OR- use Night Shift [will not adjust brightness, but will be bearable]).


      NOT WORKING [Dell M6800 - High Sierra 10.13.4]
      Headphone Jack (Excessive Static)
×