Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
rockinron_1

10.9 Mavericks Simple Vanilla Hackintosh Install Guide

167 posts in this topic

Recommended Posts

no problems here you go this is were you need to be  http://www.osx86.net/files/file/148-boot-usb-os-x-mavericks-postinstal-v2-pkg/

just remember to add pc or laptop support for all those who are interested this is were iBooks put your books

~/Library/Containers/com.apple.BKAgentService/Data/Documents/iBooks/Books, make your library visible first.

Share this post


Link to post
Share on other sites

Hi,

I'm having this problem since forever : "Still waiting for something (root device :P )"

I read on his forum that I need some AHCIinjector (or something like that), tried it and the problem persists, and sometimes I get a kernel panic with the applepowermanagement kext, so I thought that the smbios file isn't correct (tried all kinds of macs from 2009 till now), still have this problem.

I used -f -v.

But, I already tried to install Mac OS (ML) using Clover and it worked (even if I had to plug the usb where Clover is installed each boot), and I tried the same procedure and it didn't work (same kernel panic above). Should I delete this kext or download a patched one?

-x flag gives me directly a kernel panic!

For Information: The usb led goes off during the boot (that's why it is looking for a root device) , and I tried the USB 3 kext (a generic one) and it gives me the kernel panic above but the usb led is still on!

 

My computer :

Sony VAIO S (SVS 2012) SVS13A290X

CPU: Intel i7 3520M 2.9 (3.4 Turbo)

Memory:12 Gb

HD: WD 1TB (GPT partitioned since I have Win 8 preinstalled using UEFI)

GCs: Intel HD4000 + discrete card Nvidia GT640M LE

USBs: 2x3.0 + 1x2.0 (I used all of them and the problem persisits)

Share this post


Link to post
Share on other sites

After a while of loading I just get a "spinning beachball" and a grey screen. I am using Clover bootloader. I tried booting with Chameleon but it just instantly restarts my laptop. I am running OSX10.8.5 just fine, so it's (probably) not hardware. Any suggestions?

 

Edit: nevermind, I fixed it with Chameleon

Share this post


Link to post
Share on other sites

Hi rockinron,

Thank you for the excellent guide.

On Page 1, you indicate

"My main guide will be updated to give a full explanation of how to install Mavericks around GM time"

Maverick GM time has arrived.

I am holding on to the installation awaiting your main guide.

Will appreciate letting us know when it will be available?

Thank You and Have a nice day. 

Share this post


Link to post
Share on other sites

Hi,

 

I've just installed Mavericks GM following this guide on page 1.

Use same dsdt and smbios as used on SL.

Instal works perfect , my GPU 9500GT is recognized with GraphicEnabler=Yes

Missing Network, Sound and USB3, I will looking for extra kext shortly.

 

Enjoy  :)

Share this post


Link to post
Share on other sites

Hi,

 

I've just installed Mavericks GM following this guide on page 1.

Use same dsdt and smbios as used on SL.

Instal works perfect , my GPU 9500GT is recognized with GraphicEnabler=Yes

Missing Network, Sound and USB3, I will looking for extra kext shortly.

 

Enjoy  :)

Congratulations on your perfect install.

I tried to follow the guide on page 1 but not clear on some instructions.

Hope you can clarify for me.

1." 7. Copy essential kexts to /System/Library/Extensions on your USB stick" For ML, all essential kexts are in the extra/extension  folder, why put in /S/L/E for Marvericks?

2."10. Copy your folder of essential software & kexts to your USB stick" Is it to  the extra folder of the USB stick or root of the  USB stick?

3."8. Install chameleon to the USB drive" Which revision of chameleon did u used or recommend?

 

Thank You & Have a nice day.

Share this post


Link to post
Share on other sites

I run the following code to create Install USB, then boot from existing Clover UEFI bootloader (with kexts in Clover\kexts\10.9):

 

sudo /Applications/Install\ OS\ X\ Mavericks.app/Contents/Resources/createinstallmedia --volume /Volumes/Untitled --applicationpath /Applications/Install\ OS\ X\ Mavericks.app --nointeraction

Share this post


Link to post
Share on other sites

Congratulations on your perfect install.

I tried to follow the guide on page 1 but not clear on some instructions.

Hope you can clarify for me.

1." 7. Copy essential kexts to /System/Library/Extensions on your USB stick" For ML, all essential kexts are in the extra/extension  folder, why put in /S/L/E for Marvericks?

2."10. Copy your folder of essential software & kexts to your USB stick" Is it to  the extra folder of the USB stick or root of the  USB stick?

3."8. Install chameleon to the USB drive" Which revision of chameleon did u used or recommend?

 

Thank You & Have a nice day.

1. Last release of Chameleon doesn't support  kexts are in the extra/extension. You need to copy essential kexts (FakeSMC, NullCPUPowerManagement) to /System/Library/Extensions on your USB stick

essential software & kexts + org.chameleon.Boot.plist + dsdt + smbios are in /Extra

Chameleon-2.2svn-r2246 who is in the attachment of the guide

Share this post


Link to post
Share on other sites

Use the link I posted and let it create your usb installer it will add chameleon to the usb as part of the usb setup don't forget to select pc or laptop S/L/E/E I've not used since lion. Have your extra extentions / chameleon 2246 / kext wizard/dsdt on another stick follow the install then reboot from the usb installer selecting your hdd once on the desktop use your preferred kext utility to add extra extentions add your extra folder to the root of your boot hdd( your extra should have your chameleon . Org . Boot plist , dsdt ,smbios and themes ) reboot should be good to go hope this helps

Share this post


Link to post
Share on other sites

1. Last release of Chameleon doesn't support  kexts are in the extra/extension. You need to copy essential kexts (FakeSMC, NullCPUPowerManagement) to /System/Library/Extensions on your USB stick

essential software & kexts + org.chameleon.Boot.plist + dsdt + smbios are in /Extra

Chameleon-2.2svn-r2246 who is in the attachment of the guide

Thank you for your response and help.

Since last release of Chameleon ( I presume this include Chameleon-2.2svn-r2246), so there is no need for extra/extensions folder as all kexts have to be in /System/Library/Extensions/. Is this correct?

What if you have the same kexts in both extra/extensions & /System/Library/Extensions/. Does this cause problem?

Share this post


Link to post
Share on other sites

No need for an extra extentions folder as the kexts you add will replace the original ones which will be put in a backup folder on the main boot disc which you can then delete if not required hope this helps

Share this post


Link to post
Share on other sites

Thanks for the clarification.

I managed to install Mavericks GM on my system successfully except 2 minor problem.

1. Internal HDD shown as External orange HDD.

2. CMOS reset after sleep/restart.

Any help will be much appreciated.

Share this post


Link to post
Share on other sites

1.You need IOAHCIBlockstorageInjector.kext

2.You need updated AppleRTC.kext (on Gigabyte MOBO's)

 

 

Succes

Thank You. Work like a charm.

Share this post


Link to post
Share on other sites

Please help my system specs are:

CPU: Intel Core i5 3470 CPU 
Motherboard: MSI Z77A-G43 
Memory: Corsair XMS3 CMX16GX3M2A1600C11 16GB 2X8GB DDR3-1600 
Video card: Gigabyte Radeon HD 7950 Windforce 3GB 

 

I can only boot into safe mode (-x) - please help

Share this post


Link to post
Share on other sites

I have a problem. My USB pen won't get recognized on boot. I tried with other computers and even with PLOP Boot Manager and still nothing, so I tought the problem could be with myHack. Any solutions? I do the procedure exactly as stated in 1st post and nothing.

 

Thanks in advance :)

Share this post


Link to post
Share on other sites

just finished installing Mavericks 13A603 GM , added five kexts a well sorted extras folder and chameleon 2265 job done gotta love this mobo Asus p5k-vm worked flawlessly since 10.5.6

Share this post


Link to post
Share on other sites

Ok, so if anyone was wondering at all, don't install Mavericks using the AppStore Native Method. It won't work lol. You can download the final from there, but don't do the installation directly lol.

 

I tried it earlier just because it was a thing I can do. It caused me to lose graphics and it still hasn't actually updated. Gonna try this USB method when I get home.

Share this post


Link to post
Share on other sites

I used myHack and put Mavericks on it, booted to the USB and deleted my existing HDD data to setup new partitions on GUID (was on mbr) but upon attempting to install Mavericks I get this error: OS X could not be installed on your computer. The Installer encountered an error that caused the installation to fail.

 

I've attached a screenshot.

 

It could be my smbios, mbr or something else. I really don't know.. and how would I even fix the issue now that I've already deleted Mountain Lion from my HDD? I have a Ubuntu USB but that's it.

 

The error doesn't come up till a few minutes into the install (starts at 24 minutes remaining, error appears at 18 minutes remaining) as well, if that's of any help.

post-843009-0-99225000-1382539013_thumb.jpg

Share this post


Link to post
Share on other sites

Would it work if someone made me the smbios and sent it to me so I could replace the one in /Extras within the Installer USB? If so, could someone do that for me that's the closest to my system?

 

System specs -

 

Processor: Intel® Core2 Duo CPU E8400 @ 3.00GHz (2 CPUs), ~3.0GHz

Memory: 3070MB RAM

Card name: NVIDIA GeForce GT 240

Motherboard: Asus IPIBL-LB

Share this post


Link to post
Share on other sites

I had a custom /Extras folder in my External HDD, so I made 2 partitions (one for the mac install the other for cham) and installed Chameleon to the 2nd partition, installed the /Extras folder, made the 2nd partition flag as boot using a Ubuntu Live CD and rebooted. Chameleon worked on the 2nd partition and from what I could tell the SMBios.plist loaded fine, but same error occured.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×