Jump to content
fantomas1

OS X 10.9 DP's builds

642 posts in this topic

Recommended Posts

I investigated the file and I found out that the patched applesmc kext has the mountain lion applesmc kext's binary file with this modification:

4B 8F 00 BB 1B A5 39 0A A1 35 A5 83 EF 55 3E 77 replaced with AB 9D A4 4C 06 32 35 D7 94 FE 6D 18 C4 C7 AB FA
 

We now know that this patched applesmc kext is basically some kind of rollback with some modified code.

 

Good work man...also ask, which Mountain Lion version did you compare?

 

Share this post


Link to post
Share on other sites
Advertisement

I think Mountain Lion's DP also had this log "issue" (I'm not sure though, my memory is fuzzy) but it disappeared in the final revision. So it may be a no-issue in the end.

Share this post


Link to post
Share on other sites

I think Mountain Lion's DP also had this log "issue" (I'm not sure though, my memory is fuzzy) but it disappeared in the final revision. So it may be a no-issue in the end.

I'm also hoping that ...

Share this post


Link to post
Share on other sites

One thing i found odd in all DPs: despite a huge improved performance in benchmarks, it appears that the system performance actually worsens overall - graphics lag sometimes, apps, preferences and windows take longer to open etc., and i guess the latter has everything to do with HDD access. Despite my supported-out-of-the-box intel 7 series chipset, i'm geting the orange icon for all HDDs but the startup disk with Mavericks from day one.

 

All the best!

Share this post


Link to post
Share on other sites

One thing i found odd in all DPs: despite a huge improved performance in benchmarks, it appears that the system performance actually worsens overall - graphics lag sometimes, apps, preferences and windows take longer to open etc., and i guess the latter has everything to do with HDD access. Despite my supported-out-of-the-box intel 7 series chipset, i'm geting the orange icon for all HDDs but the startup disk with Mavericks from day one.

 

All the best!

I think you're right, I noticed it too...

 

Edit: I also tested an SSD and there are not big differences in access, except at boot ... the differences in benchmarks between an SSD and a  normal hard drive  are identical...but we are still in version dp3 ...

Best regards

Share this post


Link to post
Share on other sites

Which ML version did you compare to?

 

I compared with 10.8.4 and it's exactly the same binary.

I compared it to 10.8.4 too... Did you compared all the hex code with a hex editor, or just by size?

Share this post


Link to post
Share on other sites

One thing i found odd in all DPs: despite a huge improved performance in benchmarks, it appears that the system performance actually worsens overall - graphics lag sometimes, apps, preferences and windows take longer to open etc., and i guess the latter has everything to do with HDD access. Despite my supported-out-of-the-box intel 7 series chipset, i'm geting the orange icon for all HDDs but the startup disk with Mavericks from day one.

 

All the best!

 

For me it feels faster in just about any task except for the authentication dialog that takes about a second to appear.

Share this post


Link to post
Share on other sites

I compared it to 10.8.4 too... Did you compared all the hex code with a hex editor, or just by size?

I just ran a diff and it did not return anything.

 

diff Downloads/AppleSMC.kext/Contents/MacOS/AppleSMC /System/Library/Extensions/AppleSMC.kext/Contents/MacOS/AppleSMC

 

returns nothing, it should say "Binary files X and Y differ" if there was any difference.

 

Anyway I just compared hex dumps just to be sure and they are identical.

 

xxd Downloads/AppleSMC.kext/Contents/MacOS/AppleSMC > a

xxd /System/Library/Extensions/AppleSMC.kext/Contents/MacOS/AppleSMC > b

diff a b

 

returns nothing.

Share this post


Link to post
Share on other sites

I tried diff command and it says they differs... So wtf? I didn't modified my AppleSMC kext in ML ever... (didn't used any helper app, I always do everything manually, with terminal) I have 10.8.4. And for me, they different...

 

How the hell is this possible?

 

edit: I'll download the 10.8.4 combo update and check the file from the pkg.

 

edit2: I checked, and somehow my applesmc in my 10.8.4 was modified... but I searched on the net and didn't even found any binary patch for it...so i don't know what the hell was changed in it for me...

I edited my post (stroked out the modified code)

Share this post


Link to post
Share on other sites

The diffs you mentioned are at 0x488 and the code begins at 0xE90 so I guess they are not relevant.

 

otool -tV -arch x86_64 /System/Library/Extensions/AppleSMC.kext/Contents/MacOS/AppleSMC > a

otool -tV -arch x86_64 AppleSMCpatched > b

diff a b
1c1
---
> AppleSMCpatched:
 
AppleSMCpatched being my original with the patched bytes you posted.
 
xxd /System/Library/Extensions/AppleSMC.kext/Contents/MacOS/AppleSMC > a
xxd AppleSMCpatched > b
diff a b
73,74c73,74
4b8f 00bb 1ba5 390a  ........K.....9.
a135 a583 ef55 3e77 2a00 0000 1000 0000  .5...U>w*.......
---
> 0000480: 1b00 0000 1800 0000 ab9d a44c 0632 35d7  ...........L.25.
> 0000490: 94fe 6d18 c4c7 abfa 2a00 0000 1000 0000  ..m.....*.......

Share this post


Link to post
Share on other sites

I tested diff on my installed applesmc in my 10.8.4 with the applesmc from the 10.8.4 combo update pkg, and they are different. So there is something modified for me... But I just don't know what and why.... :D

 

So ontopic: the thing is that there is no patched applesmc for mavericks... because that "patched" applesmc is only a rollback.

Share this post


Link to post
Share on other sites

the thing is that there is no patched applesmc for mavericks... because that "patched" applesmc is only a rollback.

That's it.

Share this post


Link to post
Share on other sites

I just had a Graphics Update 1.0 showing up at the App Store. Just installed and restarted, and it indeed seems to have solved the graphics glitches (i'm on DP3).

 

I should've taken a screenshot, my bad!

 

All the best!

Share this post


Link to post
Share on other sites

@Boombeng,

 

Can you tell me what graphics options are you using in Clover to get your HD5850 working properly?

 

Cheers.

Well i only use the classical GraphicsEnabler=Yes

The 1st instal with dp1 i had to delete the ati* and amd* kexts to boot the "OSX base system" installer

Share this post


Link to post
Share on other sites

Wow, just had to share, and apologies if in the wrong place or someone has already said it...  

 

I decided I had to try the Steam game Civilization 5 with its latest upgrade Brave New World on DP3, and wow, it really rocks!!  No more wait while the screen redraws, even in 1080p with reasonably high settings.  Haven't tried maxxed settings yet.  See signature for rig info.

 

With maxxed out settings, no worries!!

Edited by Graebags

Share this post


Link to post
Share on other sites

OS X Mavericks Developer Preview 4  1.0 is released. 

 

1.27 GB updating now . . .

 

installed all fine so far.

Installed. Runs perfectly fine!

 

Restore 10.8.4 patched AppleHDA!

Share this post


Link to post
Share on other sites

Installed DP 4 - had to apply RTC and TRIM fixes again as they disappeared.

Everything seems to be working fine.

 

It appears that it is significantly faster startup in DP4 than in any other previous DP version and faster than in ML. By this I mean the time from the moment the Apple sign appears to the moment you are presented with login screen is significantly shorter.

 

Installed GenericUSBXHCI in DP3 and USB3 is working fine. Sleep is not affected - functional.

 

p.s. After trying all sorts of tricks I could possibly find regarding enabling Face Time and iMessages, iMessages not working. I managed to get them working in DP1 then it stopped when I installed DP2. I got it working again after I signed off iMessages from my genuine MBP. Later, when I changed network configuration it stopped working again. Since then no success! I reinstalled from scratch and changed serial number using the Champlist application - rejected! Then installed DP3 on MBP using an external USB SSD, moved to Hackintosh installed Chameleon, FakeSMC. Got recovery partition, and all the bells and whistles, including FaceTime working but iMessage rejects every option on this MB  (GA-X58-UD7)!?

 

Independently tried to install 10.9 on RAID 0 (two SATA 3 SSDs) by copying an existing working disk image to RAID 0, then installing Chameleon on both drives, and pointing Chameleon to RAID ID. No success to pass even boot - OSX "panic attack". 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

×