Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
xpamamadeus

[Guide] Gigabyte Z77X UD5H Clover UEFI Install/Tweak guide

472 posts in this topic

Recommended Posts

have found a new better way of fixing this problem.

using mmtool we need to delete Via1394Ctrl and Via1394CtrlSmm.

BrEnPPo.jpg

 

problem solved.

Firewire works in windows and OSX without any problem.

Enjoy!

 

 

Just had a go at this and the message is back spamming the Console again...

31/08/2013 23:28:26.000 kernel[0]: FireWire GUID 0000000000000000 is invalid!
31/08/2013 23:28:31.000 kernel[0]: FireWire GUID 0000000000000000 is invalid!
31/08/2013 23:28:36.000 kernel[0]: FireWire GUID 0000000000000000 is invalid!
31/08/2013 23:28:41.000 kernel[0]: FireWire GUID 0000000000000000 is invalid!

post-499606-0-00247800-1377988615_thumb.png

Share this post


Link to post
Share on other sites

ozmosis v5

 

changes from v3

 

that one have dsdt in bios soo no need to load it from acpi folder.

injector its changed for our board soo it inject information for our marvel controller.

only kext needed for this one are network kext.

enjoy.

 

https://www.dropbox.com/s/sjcglvp6ianj27n/ozmosisv5.rom.zip

 

https://www.dropbox.com/s/3fcn00eoz79ns6k/network.zip

Share this post


Link to post
Share on other sites

Ozmosis v6

 

Changes:

Added latest fakesmc from kozlek (Hw Sensors work now)

CPUSensors

LPCSensors

AppleIntel1000e

ALXEthernet

 

All integrated into bios.

 

No more need for any non Applekext in S/L/E or any other folder now all run from bios.

 

We now have more brainless hack than Quo board!!

 

Enjoy!

Share this post


Link to post
Share on other sites

Great great ....I'm happy for your work, I hope in the future for asus

maybe if we get new ozmosis i try again for your board but dont hope too much that this will work on asus x79.

Share this post


Link to post
Share on other sites

maybe if we get new ozmosis i try again for your board but dont hope too much that this will work on asus x79.

ok ... let's try ... maybe the new bios asus 4310 it is a the best of old 4206 .

 

Ps: if you want , and have time ..tomorrow , or a few more days

Share this post


Link to post
Share on other sites

Ozmosis v6

 

Changes:

Added latest fakesmc from kozlek (Hw Sensors work now)

CPUSensors

LPCSensors

AppleIntel1000e

ALXEthernet

 

All integrated into bios.

 

No more need for any non Applekext in S/L/E or any other folder now all run from bios.

 

We now have more brainless hack than Quo board!!

 

Enjoy!

Great work XP. however does ozmosis v6 still compatible with Windows?

Share this post


Link to post
Share on other sites

Ozmosis v6 seems to be working fine with Windows 7 64 bit, with one exception: although disabled in bios setup, the VIA 1394 firewire controller is still detected by Windows.

I always disable: firewire, Atheros ethernet, Marvell SATA, and Intel GPU, so that those normally aren't even detected by Windows Device Manager.

Also: a previously working install of OSX 10.8.5 Mountain Lion fails to complete the boot-up, hanging at the initial boot screen. Worked fine with the official F16 bios, but not with the Ozmosis v6 modded version.

Share this post


Link to post
Share on other sites

Ozmosis v6 seems to be working fine with Windows 7 64 bit, with one exception: although disabled in bios setup, the VIA 1394 firewire controller is still detected by Windows.

I always disable: firewire, Atheros ethernet, Marvell SATA, and Intel GPU, so that those normally aren't even detected by Windows Device Manager.

Also: a previously working install of OSX 10.8.5 Mountain Lion fails to complete the boot-up, hanging at the initial boot screen. Worked fine with the official F16 bios, but not with the Ozmosis v6 modded version.

Do u have disabled CSM in bios ?

Can u boot verbose and report why ML fails for u ?

Share this post


Link to post
Share on other sites

CSM=??

What's on screen is only: the Apple logo with white background. No opportunity visible to enter boot parameters.

The system clock then needs correction after booting back into Windows.

The installation was done via the Niresh 10.8.2 installer, then updated to 10.8.5 (beta version). 

All other install methods weren't workable.

Share this post


Link to post
Share on other sites

CSM=??

What's on screen is only: the Apple logo with white background. No opportunity visible to enter boot parameters.

The system clock then needs correction after booting back into Windows.

The installation was done via the Niresh 10.8.2 installer, then updated to 10.8.5 (beta version). 

All other install methods weren't workable.

go to first page plz and read.

Thx.

 

Will post soon new ozmosis thats based on f14 bios  that work with windows and that can install vanilla installesd.dmg

problem that we cannot install osx using ozmosis its releated to nvram issues that appear in new bioses like some of f15 and f16+

only windows can write to nvram in new bioses.

 

need some time to finish this mod.

only think lest  that need do with this mod its to inject applehda from bios.

all other work without modified dsdt and all modules are in place nothing deleted.

stay in touch.

Share this post


Link to post
Share on other sites

CSM is not listed anywhere, as such, in bios.

The only mention of CSM on the first page of this thread is:

.....................................

http://www.insanelymac.com/forum/topic/288829-guide-gigabyte-z77x-ud5h-clover-uefi-installtweak-guide/?do=findComment&comment=1919030

 

"Fix for firewire bug when CSM disabled.
When we disable CSM we get alot of this error in Console"

.....................................

 

What exactly, in plain English, are you talking about: "CSM"?

 

Suggestion: make a new thread about your Ozmosis bios, because most of what you're saying in the first page of this current thread would be totally irrelevant to an Ozmosis bios system. Correct?

Share this post


Link to post
Share on other sites

CSM is not listed anywhere, as such, in bios.

The only mention of CSM on the first page of this thread is:

.....................................

http://www.insanelymac.com/forum/topic/288829-guide-gigabyte-z77x-ud5h-clover-uefi-installtweak-guide/?do=findComment&comment=1919030

 

"Fix for firewire bug when CSM disabled.

When we disable CSM we get alot of this error in Console"

.....................................

 

What exactly, in plain English, are you talking about?

 

Suggestion: make a new thread about your Ozmosis bios, because most of what you're saying in the first page of this current thread would be totally irrelevant to an Ozmosis bios system. Correct?

Its most important thing when we use UEFI.

Soo plz again check first post.

And look at pictures.

Compatibility Support Module
The Compatibility Support Module (CSM) is a component of the firmware that emulates a BIOSenvironment; allowing legacy operating systems and some option ROMs that do not support UEFI to still be used.

we dont want bios when we use osmosis and clover.

I dont want to make new thread since this its only for this board from me soo no new thread sry.

Here we go.

Again new Ozmosis mods.

This one its based on F14 bios version becouse with this bios OSX can write to nvram and we can use ozmosis to install OSX,we cannot do that on mods based on f16 for now because of nvram issues.

 

UEFI GOP driver updated to latest version from f16 mod2 by stasio.

 

This version works for installing OSX mountain lion 10.8.4 from original apple store .app

U need to  restore installesd.dmg to usb stick or hdd and boot it like on real MAC.

 

After flashing load bios defaults.

There are 2 important bios settings that we need to set.

 

Set CPU PLL Overvoltage to disabled.

CSM Support to never.

 

 

There are 2 version of mods.

 

First one have HDAEnablerkext and its intended for using with patched applehda without DSDT.

Second its without HDAEnablerkext and this one needs DSDT edits to enable audio.

 

 

https://www.dropbox.com/s/iv6bqcrj8c5hae7/Z77XUD5HF14%28hda%20enabler%20included%29.rom.zip

 

https://www.dropbox.com/s/olvwycp2dm7lg1p/Z77XUD5HF14%28no%20hda%20enabler%29.rom.zip

 

After installing OSX u need to make DSDT and install modded applehda.kext

Or if u use version with HDAEnabler then just install moded applehda.kext.

 

All other kext are in bios soo no need for anything else.

 

This version works with windows without any problem since nothing has changed,only added.

 

 

Share this post


Link to post
Share on other sites

Its most important thing when we use UEFI.

Soo plz again check first post.

And look at pictures.

Compatibility Support Module
The Compatibility Support Module (CSM) is a component of the firmware that emulates a BIOSenvironment; allowing legacy operating systems and some option ROMs that do not support UEFI to still be used.

we dont want bios when we use osmosis and clover.

I dont want to make new thread since this its only for this board from me soo no new thread sry.

Here we go.

Again new Ozmosis mods.

This one its based on F14 bios version becouse with this bios OSX can write to nvram and we can use ozmosis to install OSX,we cannot do that on mods based on f16 for now because of nvram issues.

 

UEFI GOP driver updated to latest version from f16 mod2 by stasio.

 

This version works for installing OSX mountain lion 10.8.4 from original apple store .app

U need to  restore installesd.dmg to usb stick or hdd and boot it like on real MAC.

 

After flashing load bios defaults.

There are 2 important bios settings that we need to set.

 

Set CPU PLL Overvoltage to disabled.

CSM Support to never.

 

 

There are 2 version of mods.

 

First one have HDAEnablerkext and its intended for using with patched applehda without DSDT.

Second its without HDAEnablerkext and this one needs DSDT edits to enable audio.

 

 

https://www.dropbox.com/s/iv6bqcrj8c5hae7/Z77XUD5HF14%28hda%20enabler%20included%29.rom.zip

 

https://www.dropbox.com/s/olvwycp2dm7lg1p/Z77XUD5HF14%28no%20hda%20enabler%29.rom.zip

 

After installing OSX u need to make DSDT and install modded applehda.kext

Or if u use version with HDAEnabler then just install moded applehda.kext.

 

All other kext are in bios soo no need for anything else.

 

This version works with windows without any problem since nothing has changed,only added.

have been watching and xp thanks for all your hard work on z77x-ud5h board. I just ordered new samsung evo ssd and does this version work with discrete graphics or igpu only. looked back on posts and did not notice if works with peg or igpu?

Share this post


Link to post
Share on other sites

have been watching and xp thanks for all your hard work on z77x-ud5h board. I just ordered new samsung evo ssd and does this version work with discrete graphics or igpu only. looked back on posts and did not notice if works with peg or igpu?

work with both

work with only igpu

and only dgpu.

work with all.

Share this post


Link to post
Share on other sites

Awesome work xpam! Been watching the progress and patiently awaiting a final version. However, it worries me that you are reverting to F14 for the BIOS. I would like to point something out; For my system, any BIOS other than F15q, F15r, and F16 will result in the loss of sleep when dual GPUs are enabled for BOTH Windows 7/8 and OS X! I currently have 2x 7950HD in crossfire (with HD4000 enabled for Chameleon boot). I used to have GTX 660 Ti with HD4000, then 2x GTX 660 Ti SLI (with and without HD4000), then sidegraded to 7950HD (with HD4000), and now my current. It does not matter the combination, if 2 GPUs are enabled, no sleep/auto-sleep in Windows or OS X. And yes, I was using F14 when I was trying out Clover hoping that perhaps sleep would work. No go. So I reverted to F16 and sleep worked as it should (Clover/Chameleon).

 

If any other users out there with 2 or more GPUs can confirm this, that would be great.  :2cents:

Share this post


Link to post
Share on other sites

Awesome work xpam! Been watching the progress and patiently awaiting a final version. However, it worries me that you are reverting to F14 for the BIOS. I would like to point something out; For my system, any BIOS other than F15q, F15r, and F16 will result in the loss of sleep when dual GPUs are enabled for BOTH Windows 7/8 and OS X! I currently have 2x 7950HD in crossfire (with HD4000 enabled for Chameleon boot). I used to have GTX 660 Ti with HD4000, then 2x GTX 660 Ti SLI (with and without HD4000), then sidegraded to 7950HD (with HD4000), and now my current. It does not matter the combination, if 2 GPUs are enabled, no sleep/auto-sleep in Windows or OS X. And yes, I was using F14 when I was trying out Clover hoping that perhaps sleep would work. No go. So I reverted to F16 and sleep worked as it should (Clover/Chameleon).

 

If any other users out there with 2 or more GPUs can confirm this, that would be great.  :2cents:

I know that original f14 have that problem and problem wass in intelgop driver.

I have pointed that out in "[bug] Sleep And Wake Issue With Uefi Boot, Sleep and wake now working with Clover UEFI boot" about 7 months ago soo its a old news if u read that thread.

 

In my version of f14 there are updated driver from f16 mod2 soo its latest and sleep work for me.

Must point out that u need disable CSM for this since legacy vga bios(i didnt update this one) for hd 4000 will not sleep in UEFI boot only UEFI one that i updated to latest version.

also be sure that u have flashed 7950HD with UEFI GOP compatible bios

Try it out and report plz.

thx.

Share this post


Link to post
Share on other sites

 

In my version of f14 there are updated driver from f16 mod2 soo its latest and sleep work for me.

Must point out that u need disable CSM for this since legacy vga bios(i didnt update this one) for hd 4000 will not sleep in UEFI boot only UEFI one that i updated to latest version.

also be sure that u have flashed 7950HD with UEFI GOP compatible bios

Try it out and report plz.

thx.

 

Thanks for the advice. Will give it a go.

Share this post


Link to post
Share on other sites

Its most important thing when we use UEFI.

Soo plz again check first post.

And look at pictures.

Compatibility Support Module
The Compatibility Support Module (CSM) is a component of the firmware that emulates a BIOSenvironment; allowing legacy operating systems and some option ROMs that do not support UEFI to still be used.

we dont want bios when we use osmosis and clover.

I dont want to make new thread since this its only for this board from me soo no new thread sry.

Here we go.

Again new Ozmosis mods.

This one its based on F14 bios version becouse with this bios OSX can write to nvram and we can use ozmosis to install OSX,we cannot do that on mods based on f16 for now because of nvram issues.

 

UEFI GOP driver updated to latest version from f16 mod2 by stasio.

 

This version works for installing OSX mountain lion 10.8.4 from original apple store .app

U need to  restore installesd.dmg to usb stick or hdd and boot it like on real MAC.

 

After flashing load bios defaults.

There are 2 important bios settings that we need to set.

 

Set CPU PLL Overvoltage to disabled.

CSM Support to never.

 

 

There are 2 version of mods.

 

First one have HDAEnablerkext and its intended for using with patched applehda without DSDT.

Second its without HDAEnablerkext and this one needs DSDT edits to enable audio.

 

 

https://www.dropbox.com/s/iv6bqcrj8c5hae7/Z77XUD5HF14%28hda%20enabler%20included%29.rom.zip

 

https://www.dropbox.com/s/olvwycp2dm7lg1p/Z77XUD5HF14%28no%20hda%20enabler%29.rom.zip

 

After installing OSX u need to make DSDT and install modded applehda.kext

Or if u use version with HDAEnabler then just install moded applehda.kext.

 

All other kext are in bios soo no need for anything else.

 

This version works with windows without any problem since nothing has changed,only added.

Awesome work XPA!!  Does this have the fix for Firewire integrated that you described in a post in the previous page?

Share this post


Link to post
Share on other sites

have been watching and xp thanks for all your hard work on z77x-ud5h board. I just ordered new samsung evo ssd and does this version work with discrete graphics or igpu only. looked back on posts and did not notice if works with peg or igpu?

Hi XP.

 

is it possible for you to provide all the different drivers you have put in to you'r modded bios? I will try to inject all of that into my X77XUP5 F13a bios

Share this post


Link to post
Share on other sites

Cheers mate!

 

Another question. XP was deleting Legacy OPROM-s to get more space. Where can I find this in bios? I'm out of space in bios so I need to compress or delete something. Any wise input or tips about this? 

Lastly is there a risk to compress extracted files when inserting (replacing) with MMTool?

 

joe75

sorry for this silly question but I presume I should inject all those ffs kext in bios or?

I ask because I can't find (see) them in XP:s last v.6 version of his modded bios!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.



×