Jump to content
Slice

Clover Themes

1,521 posts in this topic

Recommended Posts

Advertisement

@blackosx A bit late but, thank you for fixing the issue. I had alignment issues before committing those changes, there were random hardcoded numbers, like that 8, which you mentioned in one of your previous posts. Even though all that fixed the alignment issues for themes that use default sizes, it broke themes that are using custom sizes for icons, my bad I didn't check. Anyway, it's fixed now.

My apologies to everyone for breaking the custom themes, they differ in behaviour from default, which I didn't take into account.

Share this post


Link to post
Share on other sites

@Badruzeus Fixed the TileYSpace issue with bootcampstyle. Used the attached theme to test it. 

It will break any theme that used hacks to adapt to the wrong logic. 

@@ -4068,7 +4068,7 @@ VOID MainMenuStyle(IN REFIT_MENU_SCREEN 
       row1PosX = (UGAWidth + 8 - (row1TileSize + (INTN)(8.0f * GlobalConfig.Scale)) * row1Count) >> 1;
 
       if (GlobalConfig.BootCampStyle && !(GlobalConfig.HideUIFlags & HIDEUI_FLAG_LABEL)) {
-        row1PosY = row0PosY + EntriesHeight + (BCSMargin * 2) + TextHeight +
+        row1PosY = row0PosY + row0TileSize + (BCSMargin * 2) + TextHeight +
             (INTN)(INDICATOR_SIZE * GlobalConfig.Scale) +
             (INTN)((LayoutButtonOffset + GlobalConfig.TileYSpace) * GlobalConfig.Scale);
       } else {

Also attached is the full diff file.

Aero256.zip

layoutYfix.diff

 

CLOVERX64.efi

Edited by Needy
Wrong binary

Share this post


Link to post
Share on other sites
45 minutes ago, Needy said:

@Badruzeus Fixed the TileYSpace issue with bootcampstyle. Used the attached theme to test it. 

It will break any theme that used hacks to adapt to the wrong logic. 

 

Thanks, working fine with BootCampStyle=true

Spoiler

Last login: Sun Jan 13 22:23:25 on ttys000
MacBook-Pro:~ badruzeus$ cd ~/src/edk2/Clover/rEFIt_UEFI/refit
MacBook-Pro:refit badruzeus$ patch -i ~/Desktop/Needy/layoutYfix.diff
patching file menu.c
MacBook-Pro:refit badruzeus$ 

 

 

Screenshot 29.png

r4844-Test.zip

 

#EDIT: I did patch ../menu.c before you edited the post with attached "CLOVERX64.efi", if I know this before; I won't patch && compile it my self but using yours LoL...

Edited by Badruzeus

Share this post


Link to post
Share on other sites
18 hours ago, Needy said:

@blackosx A bit late but, thank you for fixing the issue. I had alignment issues before committing those changes, there were random hardcoded numbers, like that 8, which you mentioned in one of your previous posts. Even though all that fixed the alignment issues for themes that use default sizes, it broke themes that are using custom sizes for icons, my bad I didn't check. Anyway, it's fixed now.

My apologies to everyone for breaking the custom themes, they differ in behaviour from default, which I didn't take into account.

 

No problem. Thank you for implementing bootcamp style :)

Share this post


Link to post
Share on other sites
On 2/16/2016 at 1:41 PM, kosakgroove said:

I am having problems with the icns support in Clover.. Should all my custom icons be PNG for more compatibility?

Also, what resolution and what file type can I use for GUI background?

I changed the icns extention to png and managed to open and edit it in Photoshop. Then, after editing it, I saved it and changed the extention back to png. Anyway, I just did this to grab it's size! Now that I know, if I remember correctly is 80x80, I just create an png document with the logo I want to use (without background/I mean an empty bg), save it  as png and then change it's extention to icns. I hope it works for you! :-)

 

Share this post


Link to post
Share on other sites

Hey guys. Here goes one simple BootCamp theme from me. I was pixel peeping with my mac and tried make all the elements as close as possible to the original - therefore no badges :) Tools menu below the main menu. Test it please ;) 

 

Screenshots taken at 2560x1440.

screenshot1.thumb.png.886c396473f500a63f0c4af4043a13d8.pngscreenshot2.thumb.png.79841b51c2497fe86f620bcf0218abaa.png

bcc.zip

Share this post


Link to post
Share on other sites

@Slice  the recent change 4867 puts the messaging text in bad location (too high) overlapping with other icons with Clovy. can you adjust it to move it down a bit?

the messages: Boot macOS or Start UEFI is right next to the icons and overlaps them a bit. \

and with other themes seems like the same thing message is pretty jammed up with icons?

 

screenshot0.thumb.png.5f7e042c1796e3fa35d13744281384ce.png

Edited by tluck

Share this post


Link to post
Share on other sites
1 minute ago, tluck said:

@Slice  the recent change 4867 puts the messaging text in bad location (too high) overlapping with other icons with Clovy. can you adjust it to move it down a bit?

Yeah, I've reported similar issue so.. it also occurs on Vector theme as well hmmb..

Share this post


Link to post
Share on other sites

Hi, I'm having an issue with the Clovy Theme when I'm using my Intel UHD 630 graphics.

 

When my GTX 1070 is set as the primary GPU, the Clovy theme shows up as expected on startup after booting into Clover (with a keypress, as timeout=0)

 

However, when my Intel iGPU is set to primary, I just get a black screen when I try and use the Clovy theme at startup. Other themes like Mojave work fine with my Intel GPU.

 

I'm using a 1440p monitor, with an ASUS Prime Z390-A motherboard. My Hackintosh is running Mojave 10.14.3, and Clover is version 4862.

 

I'm also using device-id 3e9b my for Intel GPU, so I can get working GPU acceleration in macOS.

 

Any help appreciated. Thanks.

Share this post


Link to post
Share on other sites
On 1/29/2019 at 8:35 PM, bidero said:

Hey guys. Here goes one simple BootCamp theme from me. I was pixel peeping with my mac and tried make all the elements as close as possible to the original - therefore no badges :) Tools menu below the main menu. Test it please ;) 

 

Screenshots taken at 2560x1440.


Work with @2x valid for Resolution 4k?

Edited by WeBeRiO

Share this post


Link to post
Share on other sites

OSS update to v2.1.0

 

Haven't touch Hackintosh for a while until recently got a dell desktop for cheap. So I decide to update my OSS theme a bit :)

 

Changelog:

- Use Clover bult-in Bootcampstyle instead of self-building arrow under driver icon

- Add Mac Chime sound to work with latest Clover. Current I have to set PlayAsync as false otherwise Clover hangs for some reason. Not sure if it is theme bug or Clover bug. To be safe just leave it as false.

- Rename and remove some files to be more organized.

 

Other thoughts in the future:

I read something about svg theme supported by Clover but didn't find any tutorial how to build one yet. Maybe I will transport this theme to svg based for better hidpi support.

 

 

 

screenshot.thumb.png.c9f363d9f776733c2195122f92423eba.png

OSS v2.1.0.zip

Share this post


Link to post
Share on other sites
3 hours ago, lisai9093 said:

OSS update to v2.1.0

 

Haven't touch Hackintosh for a while until recently got a dell desktop for cheap. So I decide to update my OSS theme a bit :)

 

Changelog:

- Use Clover bult-in Bootcampstyle instead of self-building arrow under driver icon

- Add Mac Chime sound to work with latest Clover. Current I have to set PlayAsync as false otherwise Clover hangs for some reason. Not sure if it is theme bug or Clover bug. To be safe just leave it as false.

- Rename and remove some files to be more organized.

 

Other thoughts in the future:

I read something about svg theme supported by Clover but didn't find any tutorial how to build one yet. Maybe I will transport this theme to svg based for better hidpi support.

 

OSS v2.1.0.zip

1. PlayAsync is resolved in Clover 4870. It should work now.

2. There is "Vector Theme" topic and

Clover SVG Theme Builder

I don't think full tutorial is possible because it is a year to learn what is vector graphics and 100 pages on SVG specification.

You may read through google translate russian topic "how to..."

Как сделать векторную тему в Adobe Illustrator

Share this post


Link to post
Share on other sites
6 hours ago, Slice said:

1. PlayAsync is resolved in Clover 4870. It should work now.

2. There is "Vector Theme" topic and

Clover SVG Theme Builder

I don't think full tutorial is possible because it is a year to learn what is vector graphics and 100 pages on SVG specification.

You may read through google translate russian topic "how to..."

Как сделать векторную тему в Adobe Illustrator

Thanks a lot! I still remembered the days checking Russian forum to solve my WiFi problemsB)

Share this post


Link to post
Share on other sites

@Badruzeus 

I wanted to thank you for the absolutely stunning DarkBoot theme.  It is stylish while remaining elegant, something we don't see often.

 

I have it almost perfectly tuned but have 2 outstanding issues I cannot find info on.

 

1)  I would like to change the MAcOS icon for another one in your library.  How do I enter the info in Clover Configurator, GUI, Custom entries?

 

2)  Lastly, do you happen to have 2560 X 1080 image of background.png without the fade?

 

Thanks!

Share this post


Link to post
Share on other sites
On 3/18/2019 at 11:11 AM, Modmike said:

@Badruzeus 

I wanted to thank you for the absolutely stunning DarkBoot theme.  It is stylish while remaining elegant, something we don't see often.

 

I have it almost perfectly tuned but have 2 outstanding issues I cannot find info on.

 

1)  I would like to change the MAcOS icon for another one in your library.  How do I enter the info in Clover Configurator, GUI, Custom entries?

 

2)  Lastly, do you happen to have 2560 X 1080 image of background.png without the fade?

 

Thanks!

U r welcome.

1) There's option to use Custom Icon for Specific Entry on config.plist (GUI - Custom - Entry).. but I no longer remember how to. Alternatively, change it' s icon name.

2) Yes. But I just moved my daily OS from old 10.11.6 to 10.13.6 while my designs are archived on ext. backup disk (which I forgot where was placing it for last time). Hopefully on next few days I'll take a look into it.

Thanks.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Reel
      All work except camera
      You need SwitchResX that the screen does not freeze
         


    • By RougeOne
      Budget Workstation MacOS 10.14.1 build: z370 AORUS Gaming 5 - i5-8600K - RX 580 - UHD 630
      flawless iGPU/dGPU integration, fast FCPX editing/rendering, great overall performance for ~$1200 / ~£1000
       
      Update: updated WhateverGreen and Lilu, then updated OS to 10.14.3 and everything is fine! Even iMessage, which previously I hadn't been able to make work, is now working - possibly the update flushed the NVRAM?
       
      I'm gonna come straight out and admit it - I used newb tools which are considered taboo on InsanelyMac, and so this isn't so much an installation guide as it is a green flag to anyone considering the same hardware. My first and previous Hackintosh project was just over ten years ago and this site was massively helpful, so this is my (very small) way of giving back.
       
      EFI DIRECTORY
      http://s000.tinyupload.com/index.php?file_id=97606131925137056003
       
      HARDWARE
      CPU: Intel i5-8600K 3.6GHz hexacore (contains UHD 630 iGPU)
      CPU Cooler: be quiet! Pure Rock Slim (no paste needed, and fan facing front)
      Mobo: GIGABYTE z370 AORUS Gaming 5 (WIFI)
      RAM: 1x 8GB CORSAIR Vengeance LPX C16 2666MHz (in first slot)
      GFX Card: Sapphire RX 580 NITRO+ SE
      SATA: used ports 0, 1, 3, 5 (HDD problems when connected to port 4)
      HDD: generic
      DVD Drive: generic
      PSU: EVGA 500W Semi Modular (but you should get 650W!)
      Case: CoolerMaster CM590 III
      Fans: 2x stock case fans (one sucky on front, one blowy on back), 3x be quiet! BL046 120mm fans (two blowy on top, one sucky on front). Airflow near-perfectly balanced.
       
      ADVICE
      With the Clover configuration, you want to pay close attention to all things relating to graphics. There are some specific settings for ACPI, Boot, Devices and Graphics which should be copied exactly in order to get the iGPU and dGPU to work in perfect harmony. For instance, make sure you use ig-platform-id 59120003 rather than 59120000 if you want FCPX to be usable. With the right settings, FCPX will not only run, but run flawlessly.
       
      I was not able to figure out how to make NVRAM/PRAM behave itself, and I got errors when I tried to issue relevant commands. As a result, I could not at first get iMessage to work properly. It worked once on my first installation attempt but not from subsequent attempts. This Clover configuration therefore has no consideration whatsoever toward iMessage reliability - however, iMessage ended up working somehow, anyway - I noticed it after I'd updated to 10.14.3 but this may just have been coincidence.
       
      Onboard WiFi does not work. There is no driver for it. I'm using wired ethernet to a bridge router as it was cheaper than getting a compatible PCI card.
       
      Audio is working well after I installed the z370 audio patch, then the ALC1220 codecs, then AppleALC.
       
      With kexts for generic 3rd party SATA and generic 3rd party eSATA, my HDDs and DVD drive work perfectly well.
       
      Sleep/Wake functions run perfectly. iCloud functions run perfectly. Shutdown leaves the mobo LEDs on, annoyingly.
       
      My USB 3 ports seem to suffer from low power output, and I don't know why.
       
      Overall, this system appears to run about as well under MacOS 10.14 Mojave as it does under Windows 7. I would solidly recommend this build to anyone looking to build a computer for workstation purposes, on a budget.
    • By JhonneR
      Good morning, everyone, I'm sorry if I was wrong in choosing the topic but I need help.
      I have found it extremely difficult to mount a Hackintosh in my acer.
      Setup;
      I5 2430m 2.4 6GB RAM
      Mobo P5we0 - Intel intel Graphics 3000
      At the moment I have not found out what my audio codecs are.
      but I'll leave the link on the motherboard.
      however, my real problem is several.
      I have already used the itakos image, I have already used several images that could be installed normally and that after installing the image I do not have internet via cable or wireless.
      And another, I already looked in other forums and I know that I will be called a donkey in the logical question but I have not been able to install the [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] or clover to start from the Hard Disk, so I do not know what to do.At the moment I still do not know if there has already been someone who has already installed the High Sierra or just the Sierra in this notebook model and obtained permanent success.
      If anyone can help me, I'll be grateful.
      Installations without success, but with the system already installed in ACER;
      SIERRA
      HIGH SIERRA
      MOJAVE
      All with the same symptom. Starting only by the bootable USB stick and without internet connection via cable and wireless.
      Appreciate ! Acer 5750 Official Page
    • By Slice
      Since rev 4844 Vector Themes are supported and there are ready-to-use Clovy by Clovy, cesium by Slice and BGM_SVG by Blackosx.
      You may see it's structure to create own theme
      -------------------------------------------------------------------------------------------------------------------------------------------------------
       
       
      Now I want to add vector graphics support in Clover. See rev 4560 and later.
      It is not working yet but designers may begin to create Vector Themes.
      It supposed to consist of SVG elements and has design size. It will be rendered to any screen size scaled from design size.
       
      What application in macOS can create SVG graphics?
      Inkscape is not working in macOS 10.11+. Pity.
      LibreOffice Draw works with SVG but buggy.
      Boxy SVG cost 10$ but looks good enough. It creates the best in simplicity files and have more then enough features.
      Illustrator is good but expensive.
       
      How to improve SVG file?
      Clover has restricted support for SVG. It is your job to make compatible file and as small as possible to speedup rendering.
      Some helps:
      Help:Inkscape – From invalid to valid SVG Inkscape files
      From invalid to valid SVG Adobe Illustrator files
      From invalid to valid SVG files of other editors: BKchem, ChemDraw and CorelDRAW
      Help:Illustrator – Assistance with creating and saving SVG images in Adobe Illustrator that will pass W3C validation
      User:Quibik/Cleaning up SVG files manually
      Later I will write own instructions specific to Clover abilities.
       
      How to create SVG fonts?
      You can google to find ready-to-use SVG fonts.  I found some problems with too beaty fonts: slow rendering and overflow crash. Be careful.
      You can get ttf or otf fonts and convert them into svg by using online WEB services. Not a problem to google.
      But then I want to find a way to simplify the font to reduce a size and speedup rendering.
      You can create own font by FontForge It is opensource and available for Windows, Mac and GNU+Linux. It creates otf font which you can convert to svg font.
       
      Pictures from Badruzeus
      https://www.insanelymac.com/forum/applications/core/interface/file/attachment.php?id=301597
×