Jump to content
Slice

Clover Themes

1,520 posts in this topic

Recommended Posts

20 hours ago, Badruzeus said:

Which one are you using?

Mojave theme uses 160px os_icons by default.

Mojave4k comes with 384px icons size for Main Entries.

I'm using Mojave, my resolution 1920x1080 24"

Maybe you could make a size of 128px os_icons.

Edited by luky35

Share this post


Link to post
Share on other sites
Advertisement
1 hour ago, luky35 said:

I'm using Mojave, my resolution 1920x1080

Maybe you could make a size of 128px os_icons.

Ok, got it. I'll probably do it when I have free time, will be uploaded here instead of Clover repo.

 

Previously no one reported that 160px was too big, in my humble opinion.. 128px is small, while 256px is too big. Then I choose a size between them. So, all of my non-256 themes on repo use this one for os_icons. Thanks anyway.

Edited by Badruzeus

Share this post


Link to post
Share on other sites
1 hour ago, Badruzeus said:

Ok, got it. I'll probably do it when I have free time, will be uploaded here instead of Clover repo.

 

Previously no one reported that 160px was too big, in my humble opinion.. 128px is small, while 256px is too big. Then I choose a size between them. So, all of my non-256 themes on repo use this one for os_icons. Thanks anyway.

 

Sorry someone report: I've tell you twice 160px was too big for 1920*1080 24" monitor, in my modest opinion. Maybe 160px is suitable for 1920*1080 with larger monitor size (28 ", 32", etc).

 

I congratulate you for the super theme that you realize. They are great. :)

Share this post


Link to post
Share on other sites
1 hour ago, Badruzeus said:

Well, you could rename all os_icons *.icns >> *.png then resize them using Photoshop. Good luck. :angel:

 

#EDIT: Anyway, my monitor size is 13" and I'm happy with bigger icons.. not a big deal.

 

For rename and resize, I use only Preview and apply Clover standard dimension :)

 

EDIT: good news if you're happy with big icons, on 13" monitor

Edited by Matgen84

Share this post


Link to post
Share on other sites

Sorry, bit late uploading this (already finished few weeks ago, actually);

You could use "MojaveX" theme (with 128px for MainEntries) from link below (among other themes). Thanks.

https://github.com/badruzeus/MyCloverThemes/tree/master/Deprecated

 

Screenshot.png

Edited by Badruzeus

Share this post


Link to post
Share on other sites
6 hours ago, Badruzeus said:

Sorry, bit late uploading this (already finished few weeks ago, actually);

You could use "MojaveX" theme (with 128px for MainEntries) from link below (among other themes). Thanks.

https://github.com/badruzeus/MyCloverThemes/tree/master/Deprecated

 

Screenshot.png

@Badruzeus hi,

 

Thanx 100x, super icons 128px my monitor.

Share this post


Link to post
Share on other sites
On 9/27/2018 at 1:47 AM, Badruzeus said:

All right, "Mojave" theme for Clover v2.4k is now available on official repository. Use CloverThemeManager.app to download & install. "Mojave4k" for 3840x2160 display resolution (4K) is also there, enjoy! B)

 

x5doq4m.png

 

Mojave4k

  Hide contents

Q8Uyk0h.png

 

Where can I get the 1080P resolution of this theme?Thx!!

Share this post


Link to post
Share on other sites
On 7/15/2018 at 12:02 AM, DK-RendeR said:

Is it possible to hide all "Components" in theme.plist?? Setting "Tools" and "Functions" to false still leaves "Options" and "About Clover" below the device selection...

 

Hi, I would like to know about this too. Is this how is it now or is it a bug?

 

Previous versions hid ALL the "functions", including "Options" and "About Clover", making a much cleaner look.

Share this post


Link to post
Share on other sites
4 hours ago, audio01 said:

 

Hi, I would like to know about this too. Is this how is it now or is it a bug?

 

Previous versions hid ALL the "functions", including "Options" and "About Clover", making a much cleaner look.

It looks to be absent feature.

Share this post


Link to post
Share on other sites

Hello @Slice,

Is there any change on Clover r4725 upto r4728 related to "icons transparency"..?

It seems, I lost "transparency" using a same theme with r4728 (Right image) compared to r4724 (Left). Thanks.

CloverGUI-Trans.png

Edited by Badruzeus

Share this post


Link to post
Share on other sites
1 hour ago, Slice said:

Yes, there are changes also for PNG transparency.

How can I know what is more correct left or right?

Previously, was the Left Side (r4630)

Now I'm bit confuse; is transparency gone or just it's level has been changed?

If it changed, it looks better.. but I need to adapt some of my affected themes becaused of this change.

 

#EDIT: I just need a confirmation it was not a bug, so.. I'll make refinements to some of my themes.

#EDIT2: On previous revs, tranparent gray outer shadow became "black". Now it looks properly (r4728 on my case).

 

CloverGUI-Trans-r4630.png

Edited by Badruzeus

Share this post


Link to post
Share on other sites

I confirm somethings wrong Clover 4728 for animation Logo

See difference

 

screenshot.thumb.png.dacde885e5457f6e36fabb258a1a8d5e.png

 

screenshot1.thumb.png.f1d04c9497c2bab399d17f0607f2583f.png

Edited by chris1111

Share this post


Link to post
Share on other sites

Wait @chris1111,

But I think r4728 change is better compared to prev. revs. The transparent GUI now seems close to original design has (no longer becomes "black" on VESA mode, take a look for Lens Flare Selection fx on r4630 vs r4728 from screenshots below). So, I just need to make some refinements to my themes and I suggest leave the current codes).

 

#EDIT: I hope we aren't confusing @Slice on this case LoL

 

VirtualBox_Clover GUI_02_11_2018_22_10_31.pngVirtualBox_Clover GUI_02_11_2018_22_07_03.png

Edited by Badruzeus

Share this post


Link to post
Share on other sites
1 minute ago, Badruzeus said:

Wait @chris1111,

But I think r4728 change is better compared to prev. revs. The transparent GUI now seems close to original design has (no longer becomes "black" on VESA mode, take a look for Lens Flare Selection fx on r4630 vs r4728 from screenshots below). So, I just need to make some refinements to my themes and I suggest leave the current codes). 

 

 

 

Please don't compare your screen of mine, I am talk about animation on Logo

Share this post


Link to post
Share on other sites
1 minute ago, chris1111 said:

Please don't compare your screen of mine, I am talk about animation on Logo

OK, got it. Yeah, I just realized that both of ur screenshots (Banner animation) have diff. black stroke / outline (I need to raise my disp brightness to see them lol).

Share this post


Link to post
Share on other sites

Hi

 

Another issue here with commit r4729: strange fonts in Clover GUI, menu etc makes Clover unusable. Sorry for my bad english.

 

EDIT: same issue with commit r4731. Can we continue to use PNG / Icns instead of SVG themes, Please

 

screenshot1.png

Edited by Matgen84

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Reel
      All work except camera
      You need SwitchResX that the screen does not freeze
         


    • By RougeOne
      Budget Workstation MacOS 10.14.1 build: z370 AORUS Gaming 5 - i5-8600K - RX 580 - UHD 630
      flawless iGPU/dGPU integration, fast FCPX editing/rendering, great overall performance for ~$1200 / ~£1000
       
      Update: updated WhateverGreen and Lilu, then updated OS to 10.14.3 and everything is fine! Even iMessage, which previously I hadn't been able to make work, is now working - possibly the update flushed the NVRAM?
       
      I'm gonna come straight out and admit it - I used newb tools which are considered taboo on InsanelyMac, and so this isn't so much an installation guide as it is a green flag to anyone considering the same hardware. My first and previous Hackintosh project was just over ten years ago and this site was massively helpful, so this is my (very small) way of giving back.
       
      EFI DIRECTORY
      http://s000.tinyupload.com/index.php?file_id=97606131925137056003
       
      HARDWARE
      CPU: Intel i5-8600K 3.6GHz hexacore (contains UHD 630 iGPU)
      CPU Cooler: be quiet! Pure Rock Slim (no paste needed, and fan facing front)
      Mobo: GIGABYTE z370 AORUS Gaming 5 (WIFI)
      RAM: 1x 8GB CORSAIR Vengeance LPX C16 2666MHz (in first slot)
      GFX Card: Sapphire RX 580 NITRO+ SE
      SATA: used ports 0, 1, 3, 5 (HDD problems when connected to port 4)
      HDD: generic
      DVD Drive: generic
      PSU: EVGA 500W Semi Modular (but you should get 650W!)
      Case: CoolerMaster CM590 III
      Fans: 2x stock case fans (one sucky on front, one blowy on back), 3x be quiet! BL046 120mm fans (two blowy on top, one sucky on front). Airflow near-perfectly balanced.
       
      ADVICE
      With the Clover configuration, you want to pay close attention to all things relating to graphics. There are some specific settings for ACPI, Boot, Devices and Graphics which should be copied exactly in order to get the iGPU and dGPU to work in perfect harmony. For instance, make sure you use ig-platform-id 59120003 rather than 59120000 if you want FCPX to be usable. With the right settings, FCPX will not only run, but run flawlessly.
       
      I was not able to figure out how to make NVRAM/PRAM behave itself, and I got errors when I tried to issue relevant commands. As a result, I could not at first get iMessage to work properly. It worked once on my first installation attempt but not from subsequent attempts. This Clover configuration therefore has no consideration whatsoever toward iMessage reliability - however, iMessage ended up working somehow, anyway - I noticed it after I'd updated to 10.14.3 but this may just have been coincidence.
       
      Onboard WiFi does not work. There is no driver for it. I'm using wired ethernet to a bridge router as it was cheaper than getting a compatible PCI card.
       
      Audio is working well after I installed the z370 audio patch, then the ALC1220 codecs, then AppleALC.
       
      With kexts for generic 3rd party SATA and generic 3rd party eSATA, my HDDs and DVD drive work perfectly well.
       
      Sleep/Wake functions run perfectly. iCloud functions run perfectly. Shutdown leaves the mobo LEDs on, annoyingly.
       
      My USB 3 ports seem to suffer from low power output, and I don't know why.
       
      Overall, this system appears to run about as well under MacOS 10.14 Mojave as it does under Windows 7. I would solidly recommend this build to anyone looking to build a computer for workstation purposes, on a budget.
    • By JhonneR
      Good morning, everyone, I'm sorry if I was wrong in choosing the topic but I need help.
      I have found it extremely difficult to mount a Hackintosh in my acer.
      Setup;
      I5 2430m 2.4 6GB RAM
      Mobo P5we0 - Intel intel Graphics 3000
      At the moment I have not found out what my audio codecs are.
      but I'll leave the link on the motherboard.
      however, my real problem is several.
      I have already used the itakos image, I have already used several images that could be installed normally and that after installing the image I do not have internet via cable or wireless.
      And another, I already looked in other forums and I know that I will be called a donkey in the logical question but I have not been able to install the [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] or clover to start from the Hard Disk, so I do not know what to do.At the moment I still do not know if there has already been someone who has already installed the High Sierra or just the Sierra in this notebook model and obtained permanent success.
      If anyone can help me, I'll be grateful.
      Installations without success, but with the system already installed in ACER;
      SIERRA
      HIGH SIERRA
      MOJAVE
      All with the same symptom. Starting only by the bootable USB stick and without internet connection via cable and wireless.
      Appreciate ! Acer 5750 Official Page
    • By Slice
      Since rev 4844 Vector Themes are supported and there are ready-to-use Clovy by Clovy, cesium by Slice and BGM_SVG by Blackosx.
      You may see it's structure to create own theme
      -------------------------------------------------------------------------------------------------------------------------------------------------------
       
       
      Now I want to add vector graphics support in Clover. See rev 4560 and later.
      It is not working yet but designers may begin to create Vector Themes.
      It supposed to consist of SVG elements and has design size. It will be rendered to any screen size scaled from design size.
       
      What application in macOS can create SVG graphics?
      Inkscape is not working in macOS 10.11+. Pity.
      LibreOffice Draw works with SVG but buggy.
      Boxy SVG cost 10$ but looks good enough. It creates the best in simplicity files and have more then enough features.
      Illustrator is good but expensive.
       
      How to improve SVG file?
      Clover has restricted support for SVG. It is your job to make compatible file and as small as possible to speedup rendering.
      Some helps:
      Help:Inkscape – From invalid to valid SVG Inkscape files
      From invalid to valid SVG Adobe Illustrator files
      From invalid to valid SVG files of other editors: BKchem, ChemDraw and CorelDRAW
      Help:Illustrator – Assistance with creating and saving SVG images in Adobe Illustrator that will pass W3C validation
      User:Quibik/Cleaning up SVG files manually
      Later I will write own instructions specific to Clover abilities.
       
      How to create SVG fonts?
      You can google to find ready-to-use SVG fonts.  I found some problems with too beaty fonts: slow rendering and overflow crash. Be careful.
      You can get ttf or otf fonts and convert them into svg by using online WEB services. Not a problem to google.
      But then I want to find a way to simplify the font to reduce a size and speedup rendering.
      You can create own font by FontForge It is opensource and available for Windows, Mac and GNU+Linux. It creates otf font which you can convert to svg font.
       
      Pictures from Badruzeus
      https://www.insanelymac.com/forum/applications/core/interface/file/attachment.php?id=301597
×