Jump to content
Slice

Clover Themes

1,656 posts in this topic

Recommended Posts

Please ignore current snippets, its a part of my prev propose which is unimplemented (wont affect to Clover).

 

I did test your theme. No doubt, its a gorgeous theme indeed!

But I found 'darker' background while selected. Idk if you do this in purpose or not.

Most important here, Im not currently complaining for anyone works here and keep up good work!

What an eagle eye!  :rolleyes: thanks. About 'darker' background; I don't realize it when previewing with my Display; I think it caused of irregular "Tile" pattern. I'm considering to use a solid backgound color instead.

Share this post


Link to post
Share on other sites
Advertisement

vMOPH7k.png

Maybe anyone have this theme, or it was lost on the Internet? name - softgrey

Its not on Clover repos

who is the author ?

Share this post


Link to post
Share on other sites

Hello,

Enjoy two new Clover themes; "Smooth" and "SmoothDark".

Happy hackintosh!  :) (No SourceForge release yet #atm)

 

#EDIT: Released on SF, but not indexed with CloverThemeManager.app

 

1. Smooth (Light version):

BNuEYJE.png

 

2. SmoothDark (as it's name):
wcYFfmF.png

Smooth-Theme-v1.0.zip

SmoothDark-Theme-v1.0.zip

Share this post


Link to post
Share on other sites

Great work with these themes Badruzeus  :D
 
With regard to the theme repo since the Sourceforge server migration, it's functioning okay as far as cloning/committing stuff but the backend hooks are not working properly and that's affecting the CloverThemeManager.

 

When the post-update hook fires after a commit and push we're seeing the following error.
 
remote: fatal: Unable to create '/git/p/cloverefiboot/themes.git/./index.lock': File exists.
 
I created a ticket for this which they resolved but the problem has returned. I cannot ssh in to the server to take a look as I currently get the same issue as this ticket. So at the moment, waiting on SF to fix.
 
In the mean time, if anyone wants to download themes from the repo then the command line option is working.

git archive --remote=git://git.code.sf.net/p/cloverefiboot/themes HEAD themes/xxxxxx | tar -x

Share this post


Link to post
Share on other sites

Hello,

Enjoy two new Clover themes; "Smooth" and "SmoothDark".

Happy hackintosh!  :) (No SourceForge release yet #atm)

 

#EDIT: Released on SF, but not indexed with CloverThemeManager.app

 

1. Smooth (Light version):

BNuEYJE.png

 

2. SmoothDark (as it's name):

wcYFfmF.png

 

Congrats for another awesome theme! I love the dark one!

 

Question: are the fonts part of the theme itself? Can I have the same font with other themes?

 

I've used the LightUp theme (congrats to the author) for years now. And I still love it. Probably my favorite theme ever. But the fonts are not as sharp, for some reason. I was wondering if there's any way to have these fonts with that theme... Looks like the font itself might be also different... But I might be wrong. Looks incredibly well in my opinion.

Share this post


Link to post
Share on other sites

Congrats for another awesome theme! I love the dark one!

 

Question: are the fonts part of the theme itself? Can I have the same font with other themes?

 

I've used the LightUp theme (congrats to the author) for years now. And I still love it. Probably my favorite theme ever. But the fonts are not as sharp, for some reason. I was wondering if there's any way to have these fonts with that theme... Looks like the font itself might be also different... But I might be wrong. Looks incredibly well in my opinion.

Try using this. Thanks.  :)

Font_KawkabMono_16pt_White.png.zip

Share this post


Link to post
Share on other sites

Oops, really sorry for double committing this and this; I previously added "Neon" theme to the repo but strange was; on first succeeded "push" I got no commit msg on SF. I then did "git status" and saw that my local vs remore were divorced for unknown reason. "git pull" suggested me to merge, but after pushing it I get two same commits on SF (And yes, I did "git commit -m" twice with a same msg, I think caused of this. So, it was my mistake).

 

#EDIT: I remember; when did 1st "push" I by mistake pressing Ctrl+C instead of Cmd+C to copy some messages from Terminal window; my bad..

 

 

 

MacBookPro:cloverefiboot-themes badruzeus$ git push origin master
Password: 
Counting objects: 83, done.
Delta compression using up to 4 threads.
Compressing objects: 100% (83/83), done.
Writing objects: 100% (83/83), 334.27 KiB | 6.96 MiB/s, done.
Total 83 (delta 2), reused 0 (delta 0)
remote: You have permission to modify themes/*
remote: Checking permission to change themes/Neon/theme.plist
^CKilled by signal 2. 

 

 

Share this post


Link to post
Share on other sites

Try using this. Thanks.  :)

 

Thank you! That worked perfectly!

 

Also, the font is an image?! I never knew... I wonder how does that even work...

 

Anyway, now I've got another question, if you don't mind: if I want the original color of the font, I need to edit the png itself and color the letters in that image with the original color?

 

I'm only curious. As I said, I've never done this before.

 

Also also...it looks like this theme is using some sort of color transition for the font. From green to blue. Which makes it very interesting to me. I wonder how that has been done.

 

post-1303722-0-34337300-1519549565.png

Share this post


Link to post
Share on other sites

Hello,

Enjoy two new Clover themes; "Smooth" and "SmoothDark".

Happy hackintosh!  :) (No SourceForge release yet #atm)

 

#EDIT: Released on SF, but not indexed with CloverThemeManager.app

 

1. Smooth (Light version):

 

 

2. SmoothDark (as it's name):

Very impressive themes. Thanks man :)

Another new simple Clover dark theme; "Neon". Enjoy!  :)

 

 

 

#EDIT: v1.0 is uploaded to the repo. Thanks.

Share this post


Link to post
Share on other sites

...

Also, the font is an image?! I never knew... I wonder how does that even work...

 

Anyway, now I've got another question, if you don't mind: if I want the original color of the font, I need to edit the png itself and color the letters in that image with the original color?

 

...

Also also...it looks like this theme is using some sort of color transition for the font. From green to blue. Which makes it very interesting to me. I wonder how that has been done.

FYi, @blackosx has simplified the way for designing a font with his "createFont" script here.

But I use image editor method to produces it with manual allignment and more available effects.

Attached file below is *.psd document with KawkabMono-Font (*.ttf and rasterized version are included as well).

 

For font's background color; it depends on theme's background color (dark or light).

After U've done with designing; (on this case using Photoshop):

 

File > Export > Save for Web (Legacy) > PNG-8 (Perceptual, Diffusion, Transparency unchecked)

Use Colors: 256 if font contains gradient (so U don't lost color transition effect) << ofc, a little bit bigger in size.

Use Colors: 16 if font only contains one solid color << for a smaller size.

Image Size in pixels is: 176x288. Then compress *.png with pngquant (IMHO ImageOptim.app GUI is good enough) for even smaller size.

Good luck. :)

 

#EDIT: I think for gradient effect it's better with per-line on font and not whole font; that's why I rasterized it and made them separated to different layers on the psd. Apply Styles for one of them, Copy-Paste it to another layers.. that is.

Clover-Font-Design.zip

Share this post


Link to post
Share on other sites

FYi, @blackosx has simplified the way for designing a font with his "createFont" script here.

But I use image editor method to produces it with manual allignment and more available effects.

Attached file below is *.psd document with KawkabMono-Font (*.ttf and rasterized version are included as well).

 

For font's background color; it depends on theme's background color (dark or light).

After U've done with designing; (on this case using Photoshop):

 

File > Export > Save for Web (Legacy) > PNG-8 (Perceptual, Diffusion, Transparency unchecked)

Use Colors: 256 if font contains gradient (so U don't lost color transition effect) << ofc, a little bit bigger in size.

Use Colors: 16 if font only contains one solid color << for a smaller size.

Image Size in pixels is: 176x288. Then compress *.png with pngquant (IMHO ImageOptim.app GUI is good enough) for even smaller size.

Good luck. :)

 

#EDIT: I think for gradient effect it's better with per-line on font and not whole font; that's why I rasterized it and made them separated to different layers on the psd. Apply Styles for one of them, Copy-Paste it to another layers.. that is.

 

Well, I guess that worked out beautifully.

 

post-1303722-0-10237800-1519567274_thumb.png

 

Many, many thanks. :)

 

 

post-1303722-0-36375100-1519567388.png

Share this post


Link to post
Share on other sites

Such festive little clovers, for a moment I thought you were gonna use that as the main animation :D

They are too inofencive to be in Clover  :lol:  :P

Share this post


Link to post
Share on other sites

Another new simple Clover dark theme; "Neon". Enjoy! :)

 

oJCfqk7.png

 

#EDIT: v1.0 is uploaded to the repo. Thanks.

Can you add DeepinOS icon too .I can add manual icons for different os by setting custom entries for each os but does clover support auto load different os icons and entries ,it currently support for Ubuntu only for me.if you know how to add different icons to different os ,and made clover recognise other os too ,pls elaborate .thanks for awesome theme

Share this post


Link to post
Share on other sites

Can you add DeepinOS icon too .I can add manual icons for different is by setting custom entries for each os but does clover support auto load different os icons and entries ,it currently support for Ubuntu only for me.if you know how to add different icons to different os ,and made clover recognise other os too ,pls elaborate .thanks for awesome theme

Hello,

here's "os_deepin.icns" as ur request.

To make it appears on Clover GUI (w/o Custom Entry), try providing us with ur EFI structure of deepin bootloader here (screenshot, etc). Thanks.  :)

os_deepin.icns.zip

Share this post


Link to post
Share on other sites

Hello,

here's "os_deepin.icns" as ur request.

To make it appears on Clover GUI, try giving ur EFI structure of deepin bootloader here (screenshot, etc). Thanks. :)

Cool will try ,out of curiosity ,how you make neon icons .

 

Sent from my Redmi Note 3 using Tapatalk

Hello,

here's "os_deepin.icns" as ur request.

To make it appears on Clover GUI (w/o Custom Entry), try providing us with ur EFI structure of deepin bootloader here (screenshot, etc). Thanks. :)

There is nothing different than Ubuntu or any other Linux distro ,it's pseudo grub.cfg config redirect config to its installed partition /boot/grub/grub.cfg ,there is a 'deepin' named folder created by it in efi folder beside 'ubuntu' which contains grubx64.efi and pseudo grub.cfg file.clover just has to detect 'deepin' folder like 'ubuntu' folder in efi folder of efi partition (esp).

Note:- folder name is case-sensitive ,BTW ,I am currently boot phoenix is with systemd.efi method to add custom entry .Any better suggestion for phoenix ?

 

Sent from my Redmi Note 3 using Tapatalk

Share this post


Link to post
Share on other sites

Cool will try ,out of curiosity ,how you make neon icons .

 

Simple glowing effect with PS or GiMP did the trick; but since the OuterGlow has color gradient; we make them separated to different Layers. Just apply Styles to layer, Select pixels, rasterize it, cut selected pixels, then re-apply gradient for OuterGlow. That is.  ^_^

 

 

iUdaTe5.jpg

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

Announcements

  • Similar Content

    • By le332313
      Can someone share the dell 5593/5493 EFI ? I try to fit the graphics driver, but it not working please help me thanks
       
    • By MaLd0n
      -OpenCore Vanilla TUTORIAL-
       
       
      -USB Port Mapping TUTORIAL-
       
        1 -Create a USB bootable
       
      Create your usb installer, use this tool and download Catalina or Big Sur from Apple servers
       
      Catalina
      installScript_allfullapp.zip
       
      Big Sur
      installScript_1016fullapp.zip
       
      Credits: crazybirdy
       
      Copy Catalina / Big Sur installer to Applications folder, open terminal and run
       
      Catalina
       
       
      Big Sur
       
       
      If you want check one step by step, check here
       
      -Opencore Vanilla Tutorial
      https://tinyurl.com/ycvcnp8h
       
      2- EFI folder USB installation
       
      -EFI OpenCore Folder Desktop 10th Intel Processors
      Paste this EFI folder in EFI partition in your USB STICK
      https://tinyurl.com/ybwr9kq3
       
      -EFI Clover Folder Desktop 10th Intel Processors
      Paste this EFI folder in EFI partition in your USB STICK
      https://tinyurl.com/yxsw7d3t
       
      3- EFI folder SSD
       
      -EFI OpenCore Folder Desktop 10th Intel Processors
      Paste this EFI folder in EFI partition SSD 
      https://tinyurl.com/ybwr9kq3
       
      -EFI Clover Folder Desktop 10th Intel Processors
      Paste this EFI folder in EFI partition SSD
      https://tinyurl.com/yxsw7d3t
       
      4- Start Fine Tune
       
      Run this app and post full dump here for full ACPI solution
       
      RunMe.app
      https://tinyurl.com/y9562hz7
       
       
      If you like a SSDT way, here we go
      SSDT-OLARILA.aml.zip
       
      5- USB Solution
       
      Use these kexts, enable XHCI port limit patch
       
      USB INTEL SERIE 400.zip
       
      and follow this tutorial for remap USB ports
       
       
      --DSDT PATCHES--
       
      -FIX ERRORS AND WARNINGS -FIX ACPI ERRORS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA SERIE ID -DMAC -REMOVE LINES, PROBLEMATIC and UNUSED -FIX K.P in REBOOT -NVRAM -REAL TIME CLOCK -SLPB -DARWIN / WINDOWS -XHCI -PLUGIN TYPE -HDEF -ARTC -IPIC -TIMR -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -UAR1 -LAN -FWHD -USBX -PMCR -PPMC -XSPI -kUSBCompanionIndex -io-device-location -IMEI -EC -PNLF -ARPT -GFX0 -NVME -ACPI-WAKE-GPE -DTGP -HDMI / HDAU  
      --SCREENSHOTS--































      -If you want to buy me a beer - Donations with PayPal
      https://tinyurl.com/r2bvzm7
       
      Big Thanks to XLR and your Badass Motherboard, Ultrafast CPU, Coolest Heatsink, Huge Graphics Card, Tonnes of RAM,
      Gigantic Hard Drive, Lightspeed Disk Burner, Professional Sound Card, Massive LCD Display.
       
       
      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!

      We're all here to have fun and learn from each other!
    • By Nomade
      Hello All,
       
      It's been a while that I am trying to update my system to 10.15.16.
      The install seem to start, then at reboot time I only see the Normal boot and the Recovery option from the Clover boot menu.
      None of those 2 allow to complete the update.
       
      Is there any ways to force it to install and/or show the "Update" option on the Clover boot screen?
       
      PS: I'm using Z97-Gaming-3
    • By Damx
      The specs CPU: Intel® Core™ i3 Processor 8130U, 2.20 GHz (Kaby Lake Refresh) Chipset: Intel® 300 Series Graphics: Intel® UHD Graphics 620 Display: 21.5'' 1920x1200 RAM: DDR4 PC2400 4GB SSD1: M.2 PLEXTOR (with original Windows 10) SSD2: SATA SAMSUNG 850 EVO (for macOS) Sound: Realtek ALC269 WiFi / BT: Intel 3168 NGW Realtek Card-reader  
       
      Not working
      WiFi: Intel 3168 NGW Realtek Card-reader  
       
      Pre-Installation
       
      I will not go through the basics since it is explained in details here on this site. Briefly, the process is to:
      Get Clover Get Catalina macOS installer Create USB with 2 MBR partitions (FAT32 for Clover and HFS+J for the installer)  
       
      Required kexts
      AppleALC.kext Lilu.kext RealtekRTL8111.kext VirtualSMC.kext WhateverGreen.kext  
       
      Config.plist
      I used the one provided by RehabMan called config_HD615_620_630_640_650.plist. Download it from GitHub. It has almost everything you will need with only few edits for audio.
      Edits:
      [CPU] Make sure there is lilcpu=9 setting in boot arguments needed for Kaby Lake R CPU to be recognised correctly. [GPU] Make sure there is a patch GFX0 to IGPU under ACPI->DSDT [GPU] Under Devices->Properties->PciRoot(0)/Pci(0x02,0) make sure that the AAPL,ig-platform-id value is 00001B59, and the device-id value is 16590000 [AUDIO] Under Devices->Properties->PciRoot(0)/Pci(0x1f,3) set the layout-id to 40 and the device-id to 70A10000 [SMBIOS] Set Mac model ID is iMac19,2  

       

       
      Notes
      For some reason with latest version of Clover the install partition was not visible. If you run into the same issue you can downgrade Clover to r5103, which worked perfectly. WiFi / BT Intel 3168 NGW needs to be replaced if one needs WiFi. Someone mentioned that to get HDMI work properly you may need to change AAPL,ig-platform-id value to 00001659 for PciRoot(0)/Pci(0x02,0) - not my case but may be considered if you get this issue. Don't forget to generate your serial and other SMBUS values before signing in with iCloud services.  
       
    • By MaLd0n
      A very custom DSDT for best experience under macOS. Removed all unused devices, injected all Apple devices, essentials, cosmetics, real improvements. 
       
      -OpenCore Vanilla TUTORIAL-
       
       
      -USB Port Mapping TUTORIAL-
       
          -Original DSDT have 167,880 lines and 762kb
       
      DSDT ORIGINAL.aml.zip138.01 kB · 8 downloads
       
      -Patched DSDT have 30,912 lines and 111kb
       
      DSDT PATCHED.aml.zip27.01 kB · 17 downloads
       
      --Hardware--
      Asus ROG RAMPAGE VI EXTREME OMEGA

      Processor  Intel i9-10980XE

      GPU Radeon RX 5700 XT

      --DSDT Patches--
      -FIX ERRORS AND WARNINGS -FIX ACPI ERRORS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA SERIE ID -DMAC -REMOVE LINES, PROBLEMATIC and UNUSED -REAL TIME CLOCK -SLPB -DARWIN / WINDOWS -XHCI -PLUGIN TYPE -HDEF -ARTC -IPIC -TIMR -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -UAR1 -LAN -FWHD -USBX -XSPI -EC -PNLF -ARPT -GFX0 -NVME  
      --Screenshots-



















       
      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!

      We're all here to have fun and learn from each other!
×