Jump to content
Slice

Clover Themes

1,517 posts in this topic

Recommended Posts

Hello Clover Lovers; "Luxury" theme v1.0 is now available on the Repo!  :thumbsup_anim: Have a nice day and don't let ur kernel becomes 'panic' LoL...

 

 

Great I like this  :thumbsup_anim:

Thank you  :D

 

@blackosx

Should have added volumes to the Preboot for HS?

Share this post


Link to post
Share on other sites
Advertisement

@Badruzeus

New theme Luxury is great but os_opensuse.icns should be os_suse.icns to be inline with all other themes.

With change.

attachicon.gifscreenshot0.png

Oh my bad, about "~suse.icns" it was typo.. LoL, I would correct it after finishing my new theme. Thanks  :D

 

#EDIT: Has been fixed on Luxury v1.1

Share this post


Link to post
Share on other sites

"Simplicity is the ultimate sophistication." (Leonardo da Vinci)

Here is, our new elegant clean looks theme with a bright solid background named; "Beauty".

Version 1.0 is now available on the Repo; have a lovely day..!  :rolleyes:

 

q16yhSa.png

post-826765-0-95488400-1503496967_thumb.png

post-826765-0-60353500-1503497021_thumb.png

post-826765-0-01605400-1503497080_thumb.png

Share this post


Link to post
Share on other sites

"Simplicity is the ultimate sophistication." (Leonardo da Vinci)

Here is, our new elegant clean looks theme with a bright solid background named; "Beauty".

Version 1.0 is now available on the Repo; have a lovely day..!  :rolleyes:

 

 

Super Fantastic  :thumbsup_anim:  :D

Share this post


Link to post
Share on other sites

"Simplicity is the ultimate sophistication." (Leonardo da Vinci)

Here is, our new elegant clean looks theme with a bright solid background named; "Beauty".

Version 1.0 is now available on the Repo; have a lovely day..!  :rolleyes:

 

 

Neat! very very gorgeous  :)

Share this post


Link to post
Share on other sites

What a beauty  :yes:

attachicon.gifscreenshot0.png

Wow thanks so much, also an awesome screenshot.. just a little bit glitchy font though, and yeah... I think need to learn about Font design, scrollbar etc.. fortunately there're some good guides on this thread.  :rolleyes:

Share this post


Link to post
Share on other sites

6 new ready to use Scrollbars design for theming..  :angel: Enjoy..!

 

440zYb8.png

 

Download via | Drive

MD5: fa6ebc778b381c8e7b93f2a32160f252

 

#EDIT: has been successfully applied to all of my themes:

~ Beauty v1.2

~ Carbon v1.3

~ Crystal v1.2

~ Gothic v2.4

~ Luxury v1.3, and

~ Material v1.4.

 

Keep up to date && happy hackintosh.  :thumbsup_anim:

post-826765-0-28291900-1503655304_thumb.jpg

Share this post


Link to post
Share on other sites

"Simplicity is the ultimate sophistication." (Leonardo da Vinci)

Here is, our new elegant clean looks theme with a bright solid background named; "Beauty".

Version 1.0 is now available on the Repo; have a lovely day..!  :rolleyes:

 

Looks super.

How can one download JUST THIS theme from sourceforge WITHOUT downloading ALL the other themes or using the theme manager ??

Share this post


Link to post
Share on other sites

Great work again Baruzeus.

You are a machine! ;)


How can one download JUST THIS theme from sourceforge WITHOUT downloading ALL the other themes or using the theme manager ??

 

Sure. The command to do that is listed at the foot of the Clover Theme Manager thread

Here it is for you for the Beauty theme.

git archive --remote=git://git.code.sf.net/p/cloverefiboot/themes HEAD themes/Beauty | tar -x

Note: You will need git installed.

Share this post


Link to post
Share on other sites

6 new ready to use Scrollbars design for theming..  :angel: Enjoy..!

 

Download via | Drive

MD5: fa6ebc778b381c8e7b93f2a32160f252

 

#EDIT: has been successfully applied to all of my themes:

~ Beauty v1.2

~ Carbon v1.3

~ Crystal v1.2

~ Gothic v2.4

~ Luxury v1.3, and

~ Material v1.4.

 

Keep up to date && happy hackintosh.  :thumbsup_anim:

You're the master of Perfection :)

Thanks man ;)

Share this post


Link to post
Share on other sites

LoL... I'm still far to become perfect and have nothing w/o @chris1111 helps (and all of You for sure)  :P

Ah, forget it.. To be honest; I still don't event know how to "Create font files for Bootloader GUI's", followed this thread though.. uhmmb, rendered but.. just gotta irregular character spacing and little bit glitchy using this command:

Badruzeus-MBP:createFont_v0.88 badruzeus$ ./createFont.sh -t2 -s14 -f/Users/badruzeus/Projects/createFont_v0.88/Fonts/Lato-Regular.ttf -c 238,242,245 -b 16,16,16
Scanning font character metrics
===============================
................................................................................................................................................................................................................................................................
Widest Char is at index 137 | ‰ at 17 pixels
Canvas size will be 304x304 using cell size 19x19
Building ImageMagick code sequence
Running ImageMagick to create image
Optimising /Users/badruzeus/Projects/createFont_v0.88/type2_Lato-Regular_14pt_Cell_19x19_l0.png
Opening /Users/badruzeus/Projects/createFont_v0.88/type2_Lato-Regular_14pt_Cell_19x19_l0.png
Badruzeus-MBP:createFont_v0.88 badruzeus$

 

 

 

What's wrong, my bad command or font file itself? Thanks.

 

Lato-Regular.ttf.zip

post-826765-0-76727300-1503669783_thumb.png

Share this post


Link to post
Share on other sites

Good to see you trying to create new typeface images. I've not played with different fonts on Clover for a while but it used to work just fine though some fonts worked better than others. 

 

What font width setting have you entered in to the theme config? and can you show an image of what you see in Clover GUI?

I also notice that font image uses a proportional typeface so have you enabled the proportional fonts setting in Clover?

 

Share this post


Link to post
Share on other sites

Good to see you trying to create new typeface images. I've not played with different fonts on Clover for a while but it used to work just fine though some fonts worked better than others. 

 

What font width setting have you entered in to the theme config? and can you show an image of what you see in Clover GUI?

I also notice that font image uses a proportional typeface so have you enabled the proportional fonts setting in Clover?

Nah, I think Font setting is missing from my theme.plist:

 

 

		<key>Banner</key>
		<string>Logo.png</string>
		<key>Font</key>
		<dict/>
		<key>Selection</key>
		<dict>
			<key>Big</key>
			<string>selection_big.png</string>
			<key>Color</key>
			<string>0xFFFFFF7F</string>
			<key>Small</key>
			<string>selection_small.png</string>
		</dict> 

 

 

post-826765-0-16036700-1503672278.png

Share this post


Link to post
Share on other sites

Great work again Baruzeus.

You are a machine! ;)

 

Since the take off, it is no longer Stopable  :thumbsup_anim:  :w00t:  :D

it is a theme creator machine    :P 

it is refreshing to see new things  :angel:

Share this post


Link to post
Share on other sites

Great work again Baruzeus.

You are a machine! ;)

 

Sure. The command to do that is listed at the foot of the Clover Theme Manager thread

Here it is for you for the Beauty theme.

git archive --remote=git://git.code.sf.net/p/cloverefiboot/themes HEAD themes/Beauty | tar -x

Note: You will need git installed.

 

Got it. Thanks.

Share this post


Link to post
Share on other sites

@blackosx,

Using 'Proportional Font' setting on theme.plist:

 

 

<key>Font</key>
	<dict>
		<key>CharWidth</key>
		<integer>10</integer>
		<key>Path</key>
		<string>White_SanFrancisco-Regular_16pt.png</string>
		<key>Proportional</key>
		<true/>
		<key>Type</key>
		<string>Load</string>
	</dict> 

 

 

 

.. on some parts it looks better, but another parts it doesn't:

 

f6i6gHv.png

 

 

Fyi, I'm running Legacy Clover r4187 with Nvidia vesa 1360x768 display mode, 16pt SanFrancisco *.png rendered with 'createFont_v0.88' script.

 

 

Badruzeus-MBP:createFont_v0.88 badruzeus$ ./createFont.sh -t2 -s16 -f/Users/badruzeus/Projects/createFont_v0.88/Fonts/SanFrancisco-Regular.ttf -c 255,255,255 -b 0,0,0
Scanning font character metrics
===============================
................................................................................................................................................................................................................................................................
Widest Char is at index 140 | Πat 18 pixels
Canvas size will be 320x336 using cell size 20x21
Building ImageMagick code sequence
Running ImageMagick to create image
Optimising /Users/badruzeus/Projects/createFont_v0.88/type2_SanFrancisco-Regular_16pt_Cell_20x21_l0.png
Opening /Users/badruzeus/Projects/createFont_v0.88/type2_SanFrancisco-Regular_16pt_Cell_20x21_l0.png 

 

 

Share this post


Link to post
Share on other sites

hmmm.. yes I see.

 

Testing here with font:

type2_SanFranciscoDisplay-Regular_16pt_Cell_19x21_l0.png

 

using:

<key>Font</key><dict>
<key>CharWidth</key>
<integer>19</integer>
<key>Path</key>
<string>type2_SanFranciscoDisplay-Regular_16pt_Cell_19x21_l0.png</string>
<key>Type</key>
<string>Load</string>
<key>Proportional</key>
<true/>
</dict>

It works great on Clover's about page

VcMKHHz.jpg

 

But borked elsewhere

A9jTFBv.jpg

 

Looks like there's been a change made to the source to disable the proportional on some pages???

 

EDIT: Yep. Here it is

http://www.insanelymac.com/forum/topic/304530-clover-change-explanations/?p=2238877

 

EDIT2:

I'm gonna be busy today but if I get a chance later, I'll compile a version of Clover with those changes removed and see what it looks like.

Edited by blackosx

Share this post


Link to post
Share on other sites

hmmm.. yes I see.

 

Testing here with font:

type2_SanFranciscoDisplay-Regular_16pt_Cell_19x21_l0.png

....

Looks like there's been a change made to the source to disable the proportional on some pages???

 

EDIT: Yep. Here it is

http://www.insanelymac.com/forum/topic/304530-clover-change-explanations/?p=2238877

Hmmb, never mind.. I could still use createFont.sh with -s72 'Mono' Font (or bigger) with solid color & transparent background, then manually edit it with graphical image editor to reduce the space manually, also applying some effects (color gradient, shadow, outline etc). These options w/o using 'Proportional" to be "True" for sure, or only use 'Load' on Font setting within 'theme.plist'. Thanks for the script anyway..  :rolleyes:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By RougeOne
      Budget Workstation MacOS 10.14.1 build: z370 AORUS Gaming 5 - i5-8600K - RX 580 - UHD 630
      flawless iGPU/dGPU integration, fast FCPX editing/rendering, great overall performance for ~$1200 / ~£1000
       
      Update: updated WhateverGreen and Lilu, then updated OS to 10.14.3 and everything is fine! Even iMessage, which previously I hadn't been able to make work, is now working - possibly the update flushed the NVRAM?
       
      I'm gonna come straight out and admit it - I used newb tools which are considered taboo on InsanelyMac, and so this isn't so much an installation guide as it is a green flag to anyone considering the same hardware. My first and previous Hackintosh project was just over ten years ago and this site was massively helpful, so this is my (very small) way of giving back.
       
      EFI DIRECTORY
      http://s000.tinyupload.com/index.php?file_id=97606131925137056003
       
      HARDWARE
      CPU: Intel i5-8600K 3.6GHz hexacore (contains UHD 630 iGPU)
      CPU Cooler: be quiet! Pure Rock Slim (no paste needed, and fan facing front)
      Mobo: GIGABYTE z370 AORUS Gaming 5 (WIFI)
      RAM: 1x 8GB CORSAIR Vengeance LPX C16 2666MHz (in first slot)
      GFX Card: Sapphire RX 580 NITRO+ SE
      SATA: used ports 0, 1, 3, 5 (HDD problems when connected to port 4)
      HDD: generic
      DVD Drive: generic
      PSU: EVGA 500W Semi Modular (but you should get 650W!)
      Case: CoolerMaster CM590 III
      Fans: 2x stock case fans (one sucky on front, one blowy on back), 3x be quiet! BL046 120mm fans (two blowy on top, one sucky on front). Airflow near-perfectly balanced.
       
      ADVICE
      With the Clover configuration, you want to pay close attention to all things relating to graphics. There are some specific settings for ACPI, Boot, Devices and Graphics which should be copied exactly in order to get the iGPU and dGPU to work in perfect harmony. For instance, make sure you use ig-platform-id 59120003 rather than 59120000 if you want FCPX to be usable. With the right settings, FCPX will not only run, but run flawlessly.
       
      I was not able to figure out how to make NVRAM/PRAM behave itself, and I got errors when I tried to issue relevant commands. As a result, I could not at first get iMessage to work properly. It worked once on my first installation attempt but not from subsequent attempts. This Clover configuration therefore has no consideration whatsoever toward iMessage reliability - however, iMessage ended up working somehow, anyway - I noticed it after I'd updated to 10.14.3 but this may just have been coincidence.
       
      Onboard WiFi does not work. There is no driver for it. I'm using wired ethernet to a bridge router as it was cheaper than getting a compatible PCI card.
       
      Audio is working well after I installed the z370 audio patch, then the ALC1220 codecs, then AppleALC.
       
      With kexts for generic 3rd party SATA and generic 3rd party eSATA, my HDDs and DVD drive work perfectly well.
       
      Sleep/Wake functions run perfectly. iCloud functions run perfectly. Shutdown leaves the mobo LEDs on, annoyingly.
       
      My USB 3 ports seem to suffer from low power output, and I don't know why.
       
      Overall, this system appears to run about as well under MacOS 10.14 Mojave as it does under Windows 7. I would solidly recommend this build to anyone looking to build a computer for workstation purposes, on a budget.
    • By JhonneR
      Good morning, everyone, I'm sorry if I was wrong in choosing the topic but I need help.
      I have found it extremely difficult to mount a Hackintosh in my acer.
      Setup;
      I5 2430m 2.4 6GB RAM
      Mobo P5we0 - Intel intel Graphics 3000
      At the moment I have not found out what my audio codecs are.
      but I'll leave the link on the motherboard.
      however, my real problem is several.
      I have already used the itakos image, I have already used several images that could be installed normally and that after installing the image I do not have internet via cable or wireless.
      And another, I already looked in other forums and I know that I will be called a donkey in the logical question but I have not been able to install the [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] or clover to start from the Hard Disk, so I do not know what to do.At the moment I still do not know if there has already been someone who has already installed the High Sierra or just the Sierra in this notebook model and obtained permanent success.
      If anyone can help me, I'll be grateful.
      Installations without success, but with the system already installed in ACER;
      SIERRA
      HIGH SIERRA
      MOJAVE
      All with the same symptom. Starting only by the bootable USB stick and without internet connection via cable and wireless.
      Appreciate ! Acer 5750 Official Page
    • By Slice
      Since rev 4844 Vector Themes are supported and there are ready-to-use Clovy by Clovy, cesium by Slice and BGM_SVG by Blackosx.
      You may see it's structure to create own theme
      -------------------------------------------------------------------------------------------------------------------------------------------------------
       
       
      Now I want to add vector graphics support in Clover. See rev 4560 and later.
      It is not working yet but designers may begin to create Vector Themes.
      It supposed to consist of SVG elements and has design size. It will be rendered to any screen size scaled from design size.
       
      What application in macOS can create SVG graphics?
      Inkscape is not working in macOS 10.11+. Pity.
      LibreOffice Draw works with SVG but buggy.
      Boxy SVG cost 10$ but looks good enough. It creates the best in simplicity files and have more then enough features.
      Illustrator is good but expensive.
       
      How to improve SVG file?
      Clover has restricted support for SVG. It is your job to make compatible file and as small as possible to speedup rendering.
      Some helps:
      Help:Inkscape – From invalid to valid SVG Inkscape files
      From invalid to valid SVG Adobe Illustrator files
      From invalid to valid SVG files of other editors: BKchem, ChemDraw and CorelDRAW
      Help:Illustrator – Assistance with creating and saving SVG images in Adobe Illustrator that will pass W3C validation
      User:Quibik/Cleaning up SVG files manually
      Later I will write own instructions specific to Clover abilities.
       
      How to create SVG fonts?
      You can google to find ready-to-use SVG fonts.  I found some problems with too beaty fonts: slow rendering and overflow crash. Be careful.
      You can get ttf or otf fonts and convert them into svg by using online WEB services. Not a problem to google.
      But then I want to find a way to simplify the font to reduce a size and speedup rendering.
      You can create own font by FontForge It is opensource and available for Windows, Mac and GNU+Linux. It creates otf font which you can convert to svg font.
       
      Pictures from Badruzeus
      https://www.insanelymac.com/forum/applications/core/interface/file/attachment.php?id=301597
×