Jump to content
  1. Rocky12

    Rocky12

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Tristana
      Hello, and thank you for your help!
       
      Ever since installing my new Sapphire Radeon Pulse RX580, I've been having issues with audio freezing up for the whole system- seemingly the coreaudiod process crashing / my USB audio interface not working. It feels random but seems to correlate with playing youtube videos, streaming audio in Finder, playing sound files from chat clients like Telegram/Discord and such. The system otherwise works as normal, with only audio related functions breaking. Sometimes instead of a full freeze / crash, the sample rate of audio will just drop significantly, causing a lot of aliasing.
      I followed this guide here, though it is outdated and some KEXTs have been merged with WhateverGreen. The shikigva=4 & -rad4200 boot arguments weren't available in WhateverGreen so I didn't add any boot arguments.
      https://hackintosher.com/guides/fix-rendering-issues-fcpx-high-sierra/
       
      My issue was not fixed by this. I also learned that USBInjectAll hadn't been given a custom SSDT and so I made one, which I have included at the end of this post. I also disabled the 15 port patch which had been left on. My USB ports now show up properly (though I've excluded my mobo's type-c port to meet the 15 port limit). My audio issues still have not been fixed, though.

      On High Sierra, the crash was irrecoverable- opening sound in system prefs just froze up, and I have to reset the system to get audio back. In Catalina, I seem to be able to choose a different audio device then go back to my external interface to reset the driver and get sound back.

      Thank you for any help / ideas you can offer!

      UPDATE: Issue still persists. I'm now using a USBPorts.kext created by Hackintool and have updated my list of current kexts below.

      System:

      Kexts:


       
       
    • By heiza
      Ryzen 7 2700X
      ASUS Prime X470 Pro
      32GB G.Skill Ripjaws V DDR4-3200
      ASRock Phantom Gaming Vega 56
       
      My motherboard doesn’t have an option for 4G encoding. And boot modes are listed as ”Windows UEFI Mode” and “Other OS”.
       
    • By netseeder1008
      I tried to patch my DSDT.dsl. for Catalina 10.15.4
      i am searching alink where all the error have solution(if know then please share)
      Solved few errors but stuck in those---

      3107, Reserved method must return a value (Integer/String/Buffer/Package/Reference required for _DSM)
      3124, Switch expression is not a static Integer/Buffer/String data type, defaulting to Integer
      3130, Result is not used, possible operator timeout will be missed

      Can anyone tell me how to resolve this problem and any help should be apritiatable.


      Here is my working DSDT
      DSDT.aml
      DSDT.dsl
    • By Cimmerian_Iter
      Hello everyone i have a sony vaio svd1321Z9E intel i7-4500U/4400HD and 8G of ram and using opencore 5.6
      I made a battery patch following rehabman tutorials and i think the patch looks good, but when i try to load it with the kext my pc won't boot to the home menu.

      Like i it does the verbose boot then show me a grey glitchy screen with scattered apple logo.

      Normally it should give this screen then immediately turn into a black apple loading screen (still glitchy) and then return back to normal once it boot into the desktop menu of mac os. (my gpu problem that i never managed to fix but doesn't bother me)

      I would like to know how i could debug and solve this problem. Any help is appreciated.
      Here are my DSDT, config and my battery patch

       
      config.plist
      DSDT.dsl
      SSDT-BATT-3.aml
    • By Gunzar
      Hello there!
       
      TL:DR; I built a Hackintosh system using the OpenCore Vanilla Desktop Guide (running Catalina 10.15.4) and I use an AMD Ryzen 1600 CPU and Radeon RX 5700 XT GPU. All works well except my displays are very blurry and it feels like I’ll get a headache if I try to look at the screen for very long. The picture quality is noticeably worse than Windows or Linux. What can I do to fix it?
       
      --
       
      Let me start off by saying that this is my first hackintosh build. I based my build on the Opencore Vanilla Desktop Guide at https://khronokernel-2.gitbook.io/opencore-vanilla-desktop-guide/. I’m running macOS Catalina 10.15.4.
       
      So I finished installing macOS after slowly and carefully taking about 8-10 hours to go through the guide yesterday and make sure I did everything properly. It paid off - it has been solid as a rock. However, there is one problem that is currently bugging me to no end - my displays are very blurry. This seems to be independent of any application or display resolution. My dock icons are blurry, the system text is blurry, app text is blurry (like in Slack, Safari, Notes, etc). This does not occur in Linux or Windows when using the same screens. 
       
      Also, as a test, I hooked up my girlfriend’s MacBook Pro to the same two screens, and the monitors are crystal clear again, just like they usually are in Windows. This leads me to think that my EFI may be configured improperly or my system may be missing some software or a kext that enables the displays to show a sharp image. I attached my EFI folder and my config.plist file for reference. 
       
      EFI setup:
      ACPI: SSDT-EC-USBX-AMD.aml Drivers: ApfsDriverLoader.efi OpenRuntime.efi VBoxHfs.efi Kexts: AppleALC.kext AppleMCEReporterDisabler.kext Lilu.kext RealtekRTL8111.kext VirtualSMC.kext WhateverGreen.kext (version 1.3.8) My boot args are: "npci=0x2000 agdpmod=pikera keepsyms=1 debug=0x100 alcid=1"  
      System specs:
      Ryzen 5 1600, no overclock or anything special Corsair Vengeance Pro RGB RAM, 32GB total (2x16GB DDR4 dimms running at 2400MHz) XFX Radeon RX 5700 XT RAW II 8GB GPU (this is listed as a PCIe 4.0 GPU, could that cause issues since my motherboard is PCIe 3.0 only? Works great in Windows/Linux) ASUS Prime B350M-A motherboard Samsung PM961 256GB NVMe SSD  
      My monitors:
      Samsung U32J59x (32” @ 3840x2160) ASUS MX279 (27” @ 1920x1080) The blurry issue also occurs when I plug directly into my 58" Samsung 4K TV.  
      I’ve already tried these steps:
      Adjusting monitor “sharpness” settings, totally unbearable at “0” but still looks pretty bad even at “100” Trying a bunch of different resolutions in the “Display” preferences. On the 4k monitor, the only one that looks any better is the 1920x1080p option, but then I have far too little screen space left. Using SwitchResX, no different than using different resolutions in the regular Display preferences Using subpixel antialiasing in the terminal with no noticeable difference, even through reboots Turning on/off AMD FreeSync on my 4K monitor — if I turn on FreeSync, the display lags and stutters, and quality is not any better. Also tried turning on/off “game mode” but that had no difference. Tried switching DisplayPort version between 1.1 and 1.2 in monitor settings (on 4K monitor) Checking my BIOS settings, such as making sure CSM is off, against the OpenCore guide that I used to make sure everything was correct  
      Does anyone else have some other ideas that could help to correct this issue? Any ideas would be greatly appreciated. Thanks in advance!!
      -Gunzar
      EFI.zip
      config.plist
×