Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
hando

Gigabyte GA-Z77X-D3H please help.

5 posts in this topic

Recommended Posts

Hiya - I've done a fresh vanilla install using rockinron's guide. It's my first Hackintosh attempt.

 

I have problems with this steup though and despite googling for hours :wallbash: and trying many things, I have to ask for help - sorry :help:

 

rockinron's vanilla guide gives a link to DSDT editor which I can't use because it asks for Java 6 SE. I installed Java 7 (the latest) and it will not work. (Apple's Java 6 update will not install because it is for OS 10.6..... i think...)

 

I have installed DSDTSE but I have to say I'm really unsure how to use this tool. I've gone as far as extracting the DSDT, but that's it.

 

My Hackintosh has the following problems:

  • no Audio
  • graphics are not filling the screen (1920 x 1080). System pref. appears to be stuck at 1024 x 768 - no other options
  • no ethernet

Would someone mind letting me know where to start please? :worried_anim:

Share this post


Link to post
Share on other sites

hello

 

sorry to say to u , but DSDT is not GOD...

 

it help for running mac os x .. but not for u troubles..

 

nvidia see how to enable the kext in system for u graphics

 

ethernet what is u dev id and vendor id ?

 

sound

 

in mac os x 2 options

 

voodoohda / applehda

 

must be patched for u alc (codec)

 

good hack

Share this post


Link to post
Share on other sites

SOUND

OK I see what you said, and I've done some more work on the DSDT...

I tried to copy what some others have done with the appleHDA.kext - I kept on getting errors which I don't know how to fix (google didn't help). But then even if I get rid of the errors I don't know if the new DSDT will work anyway - I'm hopeful.

 

RESOLUTION

I tried plugging the monitor in with all 3 cables (HDMI, DVI, VGA). Only one working is the DVI. It appears I have some NV kexts already. What am I looking for here?

 

NETWORK

The ethernet plug is a foxconn and it has a MAC address nunmber on it but I couldn't find the device ID. I think the Vendor ID is 0x105B. But I can't be sure of that, that is just what google said. What do I do with that info if I get it anyway?

Share this post


Link to post
Share on other sites

Hey artur,

Thanks for help with the links provided so far.

I've been working at it with all my spare time and I'm pleased to say I have ethernet working!!!

 

I'm currently using the osx86 tools app to give me EFI string for the boot.plist for my graphics card and here is the system profile:

 

 

575]
Unknown nVidia card:

 

575] Chipset Model: Unknown nVidia card

575] Type: GPU

575] Bus: PCIe

575] PCIe Lane Width: x16

575] VRAM (Total): 1024 MB

575] Vendor: NVIDIA (0x10de)

575] Device ID: 0x0a65

575] Revision ID: 0x00a2

575] ROM Revision: nVidia GeForce 210 OpenGL Engine [EFI]

575] Displays:

65]
Display:

65] Resolution: 1280 x 1024

65] Pixel Depth: 32-Bit Color (ARGB8888)

65] Main Display: Yes

65] Mirror: Off

65] Online: Yes

 

According to that, I have no problem with the card but the display is the issue - it still gets the graphics resolution incorrect. My screen is an Asus VS247H (1920 x 1080). Should I be trying DSDT with the graphic card? I have looked at putting my vendor/device ID into kexts however, I do not have info.plist files in NVDAResman.kext or in NVDANV50Hal.kext Is that normal?? Should I be doing both EFI string in boot.plist and also v/d ID's into kexts? or is one method enough?

 

Also when using safari browser any adobe flash component is causing screen to flicker and seem to be constantly reloading causing delay on the mouse etc. Do you think that is related to graphics card problem?

 

Sound: still no progress.

 

Sorry if this is gone off DSDT topic.....

 

 

 

EDIT:

 

Fixed my sound.

http://www.insanelymac.com/forum/topic/279133-voodoohda-for-gigabyte-ga-z77x-ud3h-via-vt2020vt2021/page__hl__+ga#8208z77x&%238208d3h%23entry1839092

 

Fixed the resolution.

http://www.insanelymac.com/forum/topic/288582-new-nvidia-retail-driver-install-solution/

 

I still don't know why those kexts don't have .plist files inside.

I still don't know exactly what fixed the ethernet...

But right now I'm pretty happy.... and I haven't used DSDT yet either. which makes this completely

:offtopic:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×