Jump to content

17 posts in this topic

Recommended Posts

Hi all,

After several attempts and tests I've got flawlessly working Dell Precision 670 workstation under Snow Leopard 10.6.8.

 

I used Nawcomm ModCD 0.3.2, Nawcomm's legacy kernel 10.6.8, ##### SL 3.10.1 with my own generated DSDT (without patches). Everything works fine except NIC.

 

I could not bring to life onboard NIC so I started to test various PCI NIC cards. After some research I decided to buy refurbished PCI-X Intel PRO/1000MT DUAL (Intel 82546EB chip). I assumed the card will work because I found it was sold by Mac accesory producers: Sonnet (Presto Dual Gigabit NIC) and SmallTree. Therefore I think I'm very close to get it to work.

 

Remark 1: Precision 670 mobo has following PCI ports:

1x PCIe 16X (graphics),

1x PCIe 8x (works as 4x)

1x PCI (32 bit)

3x PCI-X (64 bit)

 

Short PCI slot is reserved for my Audigy soundcard (btw working great with kx driver) and PCIe is reserved for the Revodrive 3 which I'm going to buy in near future. So, available slots for NIC are PCI-X slots.

 

Remark 2: I also buy refurbished Realtek 8169 PCI-X card, which works OOB in Snow, but - and this is somewhat funny - I could not find working Windows 7 driver and my 670 has to be dual OS'ed. I also noticed poor network performance using this card.

 

OK, let's back to Intel NIC. Card is properly recognised by OSX:

 

nic_sys.png

Now:

  1. I've modified AppleIntel8254XEthernet (in IONetworkingFamily) setting valid device ID: 0x10108086 (default was 0x10008086).
     
  2. Plugin ethernet cable causes kernel panic, when configuration in Network system preferences either is set to DHCP or manually:

kp.jpg

 

 

And, of course I found the SmallTree drivers which someone in this forum reported working, but I could not manage it to work, trying 3.2.22 and newest 3.4.24 version. SmallTree kext is installed but it is not loaded on startup.

 

So, dear community, I appreciate any help or hints to work this s..t out ;]

Share this post


Link to post
Share on other sites
Advertisement

I've been on this one for ages on my Precision 670 too. Nothing worked.

My built-in Intel Pro/1000MT PCI dev id differs from that of your add-on model: mine is reported with device id 0x1026. It's the single-port built-in version on the workstation (chip 82545ep according to PCI Database site). It gets detected properly by AppleIntel8254XEthernet plugin of IONetworkingFamily kext and will display proper MAC address but keeps reporting that it's not connected, no matter what.

I don't believe you require to patch your AppleIntel8254XEthernet kext plist: your card device id should be covered by the built-in wildcard mask: 0x10008086&0x0000ffff. I would change that back.

Share this post


Link to post
Share on other sites

Well, I also spent hours (days) on this with no success so nothing's left but give up. Intel PRO/1000 is reported to work with 10.5 here, so this might be OS version related issue.

 

I'm very curious whether SmallTree PCIX NIC will work on SL but this card is no longer available and buying it used is almost impossible. If I find it someday, I'll report results here.

 

Now, I just have bought Netgear GA311 which is reported as working in HCL 10.6.8.

 

Many thanks for your support!

 

Cheers

Share this post


Link to post
Share on other sites

Hi, yes, I know this SF project and I used this kext trying to get to work onboard NIC. I have install it now to S/L/E. There is progress - no KP, but Network in System Preferences shows it's cable is unplugged.

You are still waking my hopes hahaha ;]

Share this post


Link to post
Share on other sites

Well, finally got it!!! Success at long last!!! Better late than never I hear you say...

 

The attached old AppleIntel8254XEthernet v1.1.2 (from Tiger 10.4?) brings life to my Precision 670's built-in Intel Pro 1000/MT under Snow Leopard. Note that it only supports PPC & Intel i386 mode, i.e. it's 32bit-only, not 64bit.

AppleIntel8254XEthernet.kext.zip 

03:0e.0 Ethernet controller [0200]: Intel Corporation 82545GM Gigabit Ethernet Controller [8086:1026] (rev 04)

I verified this under SL 10.6.8 (browsed another Hack attached to the Ethernet, transferred some files both ways, etc.). Ethernet interfaces were configured in automatic mode (i.e. autonegotiation) on each side and settled at 100Mb/full-duplex (as expected since laptop connected to Precision 670 had 10/100Mb Ethernet interface). Doing various files transfers gave me about 60-80Mbps throughput, which I found excellent on a 100Mb/FD connection. This older kext v1.1.2 should therefore be used instead of v2.1.3b1 which is provided as Plugin of IONetworkingFamily kext in /S/L/E.

 

In the case of my particular myHack SL installation, I simply placed the older kext in /E/E, then ran myfix (quick) to supersede the vanilla kext whilst leaving /S/L/E unmodified.

post-851564-0-47804500-1388369011_thumb.jpg post-851564-0-99984300-1388370414_thumb.jpg post-851564-0-56753500-1388370126_thumb.jpg

 
 

Share this post


Link to post
Share on other sites

Well, my hopes raised up to the skies but apparently unnecessarily...

 

After install system info shows it "does not contain any ethernet devices"

 

I even replaced AppleIntel8254XEthernet to 1.1.2 version in the IONetworkingFamily kext in /S/L/E.

 

I generated my DSDT with onboard NIC turned off - do you think it matters?

I've also noticed you're using different kernel and install method. Mine is 10.6.8 Legacy kernel and the Nawcom ModCD (please refer to this topic).

 

:(

Share this post


Link to post
Share on other sites

I'm not sure the DSDT bears any relevance in your case (kernel will not for sure), but use IORegistryExplorer to see if you have an "Ethernet" entry under PCI5 within PCI3. I assume you have re-enabled the NIC in BIOS Setup… If not, you know what to do. You can also boot with Chameleon option DSDT=No to bypass your DSDT.

 

You say you replaced the AppleIntel8254XEthernet next in the PlugIns folder of /S/L/E/IONetworkingFamily; however, did you repair permissions and rebuild kextcache afterwards? If not, your changes are ineffective until these steps are done.

Share this post


Link to post
Share on other sites

I do have "Ethernet" entry under PCI3@0,2 (albeit I can't see any PCI5 there) and of course NIC is enabled in the BIOS :)

 

All permissions and kextcaches are rebuilt after every modification.

When I install 1.1.2 kext to /E/E (I use Kext Wizard app) System Profile shows Ethernet Card still uses version 2.1.3b1...

 

I also installed it to /S/L/E using Kext Wizard and still the same: NIC is present with 2.1.3b1 kext and cable unplugged

Share this post


Link to post
Share on other sites

That won't work: OS X will always use the kext with higher version in the presence of multiple kexts of a same name. You need to remove the original kext to use the old one. This is where myHack comes really handy as it bumps version of kexts placed in /E/E to 1111 so that they supersede any vanilla kext in /S/L/E.

Delete the original kext and replace it with older version and you should be sorted.

Share this post


Link to post
Share on other sites

Well i did it but obviously it does not want to work :)

I'll try to install fresh copy of the system using your DSDT. We'll see!

 

Thank you for your help and have a great 2014!

Share this post


Link to post
Share on other sites

Was the older kext loaded? Was the card reported in System Report->Ethernet with that kext or the older kext reported loaded in SystemReport->Extensions? Remember: it's an old kext and only works in PPC and Intel i386 (32bit) modes. It won't load in 64bit mode.

 

You don't need to re-install to use my DSDT, you can simply copy it to your / or /Extra folder under a different name and call it through Chameleon boot option DSDT=<path>/<filename> (eg: DSDT=/Extra/dsdt2.aml). In fact you should also try with no DSDT at all (Chameleon boot option: DSDT=No).

 

Bear in mind that we have different hardware (CPU and NIC to name at least those two), so my DSDT might not work/work well on your own workstation...

Share this post


Link to post
Share on other sites

Hi,
forgive me long time lack of response but I had really hard time last monts and had to break my hackintosh developement...

 

I can confirm the kext you shared works on my Dell 670 but only in 32bit mode. Anyway I can't use this due to my 64bit architecture.

 

I wish I had skills to mod it to 64bit... Maybe someone has?

 

Cheers!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By BrianWong11031
      Hi,
      Please help me to enable and use hd 3000 with Mojave.
      I know that I can install some .bundle or .kext files to make it can be enable.
      But it always show an err msg up. "IOConsoleUsers gIOScreenLockState 3 ......"
      I have tried to reinstall the refi drivers and kexts.
      but still not solved this issue.
      I will upload my EFI partition as a zip file below (Google Drive, Because It's bigger than 10 mb).
      Thanks for helping.
      For the details about my hardwares, please see my "About Me" page->Brian's Budget Hackintosh.
      https://drive.google.com/file/d/1E2aFpweYwKzcJj98zRroWSwFLVf5gz62/view?usp=sharing
      Cheers,
      Brian
    • By itsjamielike
      Hello, I am wondering if somebody could help me, I am new to the whole "Hackintosh" system having been a windows fan boy since the day I remember. I have worked In IT the last 9 years but had very limited interaction with OSX and Hackintosh (Managing to Hackintosh a Fuji laptop back in 2011 but not sure how I managed). 
      I am running a Dell E6420. 
      Intel I5 - 2520M 
      10GB ram 
      250GB Samsung SSD
      Nvidia 4200M 
      Alps touchpad 
      Intel Wifi  ( I am aware I will need to change this) 
      Intel Ethernet 82579
      Unsure on Sound device (But it was working I believe with Voodoo)
      I have tried to download a pre made distro that I got to boot up, and install on to my laptop. I found a similar Dell post online (Maybe for a E8420?) and downloaded their EFI files, I then just copied this to my usb stick and deleted the existing EFI folder. This got me to the set up my account screen when i realised my touchpad didnt work (Would scroll and click but not move) and then using a USB one I then realised that my keyboard (that was working on the install screen now doesnt work). 
      I then reinstalled it but this time choosing customise and selecting some options for installed KEXTS and this then got my laptop to boot and get to the create account screen but this time I didnt have any network connection. 
      Third time lucky.... Well I then installed again but selected the above and network adaptors (I tried the Nvidia options too but this didnt work) and then I was able to create an account, browse the internet and start playing about seeing what I could get to work. 
      I then downloaded some Clover tool and I was trying to download some KEXTs for the touchpad and I was using a KEXT installer.. This then was my downfall after this I then (as I had flashbacks to years ago) when I realised I had then broken it... 
      Eventually tried to reinstall but this time I was getting errors on install, I recreated the boot usb and still got errors, I then tried multiple boots and then I would just get a hang screen after loading "voodoobootps2?" or just kernal panic. 
      When I was trying all this I had my laptop set to UEFI (I believe this was incorrect), and I could only boot my laptop when I had the USB still installed, I would boot and then select "run OSX" this would boot fine, but I could never get it to work fine. I then on multiple times tried to boot using non UEFI and Legacy but I would always get KP and never work, Only booting with UEFI was my best chance.  BIOS Settings had been coppied from dare I say.. a youtube video.. So they could be incorrect. 
      I don't have access to a MAC, I do have a copy ready of HighSierra clean and my "tainted" pre edited version. I was installed the imaging to USB using Transmac. I was using CLOVER. 

       
    • By ITzTravelInTime
      So apple has presented a new and updated mac mini a few days ago, and the great news seems to be the use of desktop processors in it, in fact, all the specs seems to match a typical desktop socket 1151 v2 coffeelake system without a dedicated gpu, so i am wondering if the smbios of this machine could be our new smbios of preference for coffeelake desktop machines. So i have created this new topic to discuss about it. Of course we will have to wait to do tests using the first public version of mac os which integrates this smbios, because when every new mac is released it's smbios is available initialy just in a purpose made mac os build and then it's added for all the os builds in the following releases.
       
      So what do you think about the possibility of using this new smbios for desktop coffeelake machines instead of the imac 18.3/18.2 ones?
       
       
      https://www.apple.com/mac-mini/specs/
       
       

    • By angelo_ios
      Hello! 
       
      My Intel HD 630 isn’t functioning on MacOS Mojave (or High Sierra)
      It only shows 5MB of VRAM. 
       
      Things i tried:
      Whatevergreen&Lilu
      Clover IntelGFX (Fake ID)
      Clover IG-Platform-ID (Need to use the one now or my Mac won’t boot)
      Clover Patches
      Boot args
      Setting the NVRAM myself (Clover)
      AppleIntelKBLFramebuffer.kext (Forced load by clover)
      FakeCPUID (tried many different ones)
       
      Other Clover settings:
      SMBIOS: iMac18,2 (Native HD 630 Support, can’t get it to work)
       
       
      My processor is a Intel Pentium G4620 
       
      Other Hardware:
      NVidia 1050 GTX (Not supported on Mojave, Workaround is not my favorite)
       
      If someone has any other idea whatsoever anything is welcome as I ran out of ideas and places for a answer (I’m the only one with the 5MB issue, others have 4 or 7MB)
    • By doixanh
      This follows my previous guide for macOS Sierra.
       
      0. What works and does not
      Works
      - CPU power management
      - QE/CI on Integrated Intel HD 4000
      - Keyboard/Trackpad
      - HDMI and LVDS output
      - Audio: Headphone, speaker, HDMI (?).
      - Ethernet
      - Camera
      - Battery info
      - Bluetooth
      - USB
       
      Does NOT work
      - Internal Wifi. Workaround: USB wifi or replace your internal wifi with a supported mPCI-e card.
      - Sleep: does not work with an USB wifi. Workaround: Replace your internal wifi with a supported card.
      - VGA out. Workaround: Use an « active » HDMI to VGA adapter. I use this way to connecting my laptop to projectors.
      - Discrete AMD GPU
      - Card reader. Workaround: Use an external USB card reader.
       
       
      1. Specs
      My Dell Inspiron 15R SE still has the following specs (I haven't upgraded it since Yosemite) :
      - Intel Core i7 3632QM with Intel HD Graphic 4000
      - 8GB + 4GB RAM (12GB total)
      - 128GB Samsung EVO SSD + 1TB HDD
      - AMD Radeon 7730M, won't be used by any Hackintosh build
      - Full HD 15.4" screen
       
      2. Requirements
      - A Dell 7520, of course
      - An USB Stick, minimum 16GB. Any 16GB should work.
      - A pair of USB Mouse / Keyboard during the installation and fixes (you can use your built in keyboard and touchpad later)
      - An existing Hackintosh (or a real Mac, if you have any )
      - Downloaded «Install macOS Mojave Beta» from App Store.
      - A GPT-partitioned hard drive
      - A 20GB (minimum) partition as the target.
      - Dosdude1's macOS Mojave Patcher
       
      3. Create USB Install. For full guide please see here
      - Boot your existing Hackintosh or real Mac.
      - First you need to be sure that you have downloaded the app «Install macOS Mojave» from App Store
      - Use Disk Utilities to partition your USB stick with 1 partition in GPT mode, and choose «OS X Extended (Journaled)» as partition type. Note: don't use any space in label of your disk.
      - Run Dosdude1's macOS Mojave Patcher, select the installer app, select usb disk as target.
      - Be patient. It's quite slow.
      - Download and install Clover Bootloader v4658 to the usb disk, note to install using EFI boot only
      - Copy attached config.plist to /Volumes/ESP/EFI/CLOVER/
      - Copy attached kexts to /Volumes/ESP/EFI/CLOVER/Other/
      - Download NullCPUPowerManagement.kext and put it in /Volumes/ESP/EFI/CLOVER/Other/
      - Reboot after finishing creating your USB for installation.
       
      4. Install
      - During boot, press F12 to have boot list. Choose your USB to start. Set ig-platform-id to 0x01660004 to boot the installation.
      - It should boot directly to the installation UI
      - Select Utilities and Disk Utility.
      - Format your target partition as OS X Extended (Journaled). APFS can be used but it's your own risks
      - Exit Disk utility.
      - Begin the install procedure - it should be there already. Choose your newly formatted partition. Follow the instruction. Wait for a while (in my case I waited around 10 minutes).
      - It will restart your computer as soon as it finishes the file copy.
      - You still need to boot from USB. Hit F12 during boot to show boot list. Choose your USB to start. Set ig-platform-id to 0x01660004, select your installed partition and press Enter.
      - You will be able to see user creation. Follow the instructions on screen. When you get to your desktop, rebuild kernel cache:
      sudo touch /System/Library/Extensions sudo kextcache -u / - Reboot, you should be able to use both LVDS and HDMI outputs (with default ig-platform-id 01660003, already patched using this guide) with proper kext and config.plist attached.
       
       
      Welcome to macOS Mojave!

       
      5. Device fixes
      Most of the fixes are included in the attached kext zip.
      5.1. CPU Power Management
      Works fine with macOS Mojave (official version) as long as you use ssdtPRGen.sh as instructed here. Don't forget to delete NullCPUPowerManagement.kext afterward.
      5.2. Wifi
      The integrated wifi doesn't work. At all. I used an external wifi dongle TP Link WN725N (v2) for Internet access. After that I replaced the internal wifi with a Atheros AR5B29 and it works natively
      If you use this AR5B29, copy the attached AirPortAtheros40.kext into /System/Library/Extensions
      config.plist.zip
      kexts.zip
      AirPortAtheros40.kext.zip
×