Jump to content
TonyHailway

AMD APU mountain lion support

312 posts in this topic

Recommended Posts

it has no use ... it hangs on error reading blabla with -v .... with different kernels.... it sucks big time .. i'm out of luck ...

 

hopefully someone gets a solution for this problem .. HP is not responding to any e-mails ( i asked about bios unlocked and i'm not happy )... free time given too much ...

at the the moment i don't have any girlfriend so ... i have a lot of time ... IT school starts nexts week...

Share this post


Link to post
Share on other sites
Advertisement

 

 

EDIT: oh well sorry mate..i cant now ..my gf actually came to my house so..i cant :P but i will tomorow as soon as i drop her on university ;D

Tomorrow sounds great, thanks man :)

Share this post


Link to post
Share on other sites

it has no use ... it hangs on error reading blabla with -v .... with different kernels.... it sucks big time .. i'm out of luck ...

 

hopefully someone gets a solution for this problem .. HP is not responding to any e-mails ( i asked about bios unlocked and i'm not happy )... free time given too much ...

at the the moment i don't have any girlfriend so ... i have a lot of time ... IT school starts nexts week...

 

i called hp and they said there isnt any unlock bios.. you have to actually confront them mate :P and..there isnt.--

Share this post


Link to post
Share on other sites

There is an unlocked bios .. HP just don't want to give you more options ... HP sucks big time .. the also say the HP Pavilion G6 series supports up to 8GB of RAM .. but the chipset supports up to 16GB RAM 1600-Mhz ... the don't want to give as an unlocked bios because of warranty issues...

 

and why do they ship an hp pavilion notebook with an RSA signed bios ..? because they don't want customers unlock their bioses ... ( RSA = BIOS Security )

Share this post


Link to post
Share on other sites

So..the tutorial :jerry: : :welcomeani:

 

1- Make sure your hardware is similar to mine:

AMD A6-4400M

Hp laptop pavilion g6 (Others might work or not, Im here doing a quick guide for my laptop with that cpu)

 

2- you need a legit copy of 10.8 or any other will do..lets go with 10.8.3..(they all work the same :D and for having that legit i assume you bought it on apple and so you have a working hackintosh or an actual mac.

 

3- Find a USB pen (SD Card may work..depends on YOUR BIOS..mine doesnt like them..so I recomend USB :wink2: ) then partition it with disk utility..so you have a partition for Clover and the installation on the same USB pen drive (8gb or 16gb..I use :graduated: 16gb) (Big space for Install and around 1 gb or less for Clover (FAT32).

 

4- Restore the image of mac install (first mount it to the system and then restore it!) to the right partition.

 

5- As long as that is going install Clover on the other partition choose the options wisely. (I use UEFI mode..but for some of you Clover might boot in legacy mode..in my laptop..it doesnt.)

 

5.1- In case you are whilling to try..Ill leave here my Full Clover installation..but ATTENTION! Might not work for you!! So dont be lazy and create your own Clover and put the necessary kexts your self that Ill be providing within the link:

 

https://mega.co.nz/#...B2YMcVrbY7mC-Zs

 

6- As soon as the image is on the partition..delete the file called: "mach_kernel" and go grab the AnV's kernel: (will put here the link after lunch, or use the forum :moil: ) and then rename it to mach_kernel and paste it on the install partition.

 

7- NOW (in mine it works this way) go to BIOS deactivate legacy boot, then leave the safe check on. Boot from USB Pen Drive and let it complain that it isnt safe. After that go to BIOS again and deactivate safe check ..otherwise Clover wont boot :wink2:

 

8- Install the mac OSX.

8.1- You'll have to put drivers for PS2 trackpad and keyboard..or use my example that has everything there already.

 

9- IF your using dual boot then after installation go on windows and change the vanilla kernel with the AnV's (with a program that allows you to write on HFS+) or:

 

9.1- Boot again into Installation partition.. go on Terminal and:

 

Then, when prompted, type this:

mount -uw / and hit enter.

Then type cp /mach_kernel /Volumes/name\ of\ your\ HDD and hit enter. or

I.e.: cp /mach_kernel /Volumes/Hackintosh

 

I.e.2: cp /mach_kernel /Volumes/My\ HDD

(you have to use "\ ", without the quotes, when the name has more than one word. You were a good boy and named your HDD with a single work, right? That makes things rather easy) (Will depend on the name you gave to the mountain Lion HD partition ;D )

 

10- Then reboot, still using the USB Clover, but this time select your HDD.

 

 

 

11- Congrats! If everything went right you are by now configuring your account ;D

 

11.1 - The rest of the kexts..is actually up to you..because the hardware probably is diferent ;D

12- Good luck :weight_lift::thumbsup_anim: !! ;D I was the first to make it work with an APU ..Join me in figuring out this unknow Land ;D :construction::moil:

 

If it works please post here so we can know..and if it doesnt post so we can try and help you! ;D

Credits to all the ones that helped :gathering: me making this true: theconnactic , clemj06 ,134 gils83 and many others that participated on this topic ;D

Share this post


Link to post
Share on other sites

Many thxs ! i'm still trying ... thxs for the terminal option ... hopefully after the terminal commands i can finally boot my hackintosh ! :star_sunglasses: :wink2:

Share this post


Link to post
Share on other sites

HELL YEAH !!! Finally i got it working with " pmmc '' files .... i don't know why but ... he got more files for clover.... i used his files to boot os x and FINALLY no more KP'S !!! THANK YOU !!!

Share this post


Link to post
Share on other sites

Ok, while I already have my beast of a rig running Mountain Lion 10.8.3 as shown here, I also have a HP Pavillion g6-1d98dx, w/ an AMD A6-3420M Quad-core processor, and AMD Radeon HD 6520G graphics. I've been trying like hell to get anything, from Leopard to Mountain Lion on this b*tch, and all I could get was a blank screen on a good day. And if I read this thread correctly, I just need to boot the installer with Clover instead of Chameleon (with AnV's amd kernel) right? Because this locked InsydeH20 BIOS is the worst thing thats ever been put on a PC. So, am I correct? Can I use the Clover v2_r1717 installer to install Clover on to my USB installer and boot from it, or do I need something specific? Thanks

Share this post


Link to post
Share on other sites

Yes.

 

Ok, trying this now. I'll report back with my results. Thank you for replying

 

EDIT: Keep getting a boot0 error. Pretty sure I screwed up something. I'll have to try again tomorrow.

Share this post


Link to post
Share on other sites

I got ML to install on HP G7-2111nr with AMD A6-4400M. However I can only boot in uefi mode and no matter what kexts I use, I cannot get sound. Anyone been able to get sound?

Share this post


Link to post
Share on other sites

I got ML to install on HP G7-2111nr with AMD A6-4400M. However I can only boot in uefi mode and no matter what kexts I use, I cannot get sound. Anyone been able to get sound?

 

yeah i got sound. but you installed? in the instalation you cant get sound.. just on the installed partition ;D

Share this post


Link to post
Share on other sites

yeah i got sound. but you installed? in the instalation you cant get sound.. just on the installed partition ;D

I meant the partition. Post install I've got everything but sound. I've got WiFi with a USB wireless adapter and graphics but no sound

Share this post


Link to post
Share on other sites

I meant the partition. Post install I've got everything but sound. I've got WiFi with a USB wireless adapter and graphics but no sound

 

you got graphics? well...your luckier than me ;) whats your graphics card?

Share this post


Link to post
Share on other sites

you got graphics? well...your luckier than me ;) whats your graphics card?

My graphics card is Radeon HD 7520G the hackintosh recognizes it as an HD display and I can change screen sizes and all. I'm curious as to why my sound wont work. ive tried various kexts and either get a kp or the sound just doesnt happen :/

Share this post


Link to post
Share on other sites

 

My graphics card is Radeon HD 7520G the hackintosh recognizes it as an HD display and I can change screen sizes and all. I'm curious as to why my sound wont work. ive tried various kexts and either get a kp or the sound just doesnt happen :/

Do you actually have QE/CI working?

Share this post


Link to post
Share on other sites

Do you actually have QE/CI working?

I did yes. But i can only boot in safe mode so none of my installed kexts seem to come up

Share this post


Link to post
Share on other sites

But QE/CI doesn't work in safe mode. Or do you mean you were able to boot without safe mode before and QE/CI worked then?

 

I'm curious because I somehow thought QE/CI doesn't work with APUs (But it would be awesome if it does!).

Share this post


Link to post
Share on other sites

But QE/CI doesn't work in safe mode. Or do you mean you were able to boot without safe mode before and QE/CI worked then?

 

I'm curious because I somehow thought QE/CI doesn't work with APUs (But it would be awesome if it does!).

I had QE/CI working without safemode. i think it had something to do with a post install program or something but im not certain. but then in my zeal for sound i tried various sound kexts (uninstallling one before trying the next, of course) and now i get kernel panics on either startup or after like 30 minutes whenever i try to install sound without being in safe mode.

Share this post


Link to post
Share on other sites

My graphics card is Radeon HD 7520G the hackintosh recognizes it as an HD display and I can change screen sizes and all. I'm curious as to why my sound wont work. ive tried various kexts and either get a kp or the sound just doesnt happen :/

 

But..dude..that is my graphics card..why didnt that happen to me??? :o

Share this post


Link to post
Share on other sites

But..dude..that is my graphics card..why didnt that happen to me??? :o

I know. i can not remember what i did to get it that way. i'll try back tracking to see what i did once i can get into the partition. Im still trying to figure out how you have sound but i dont. Both are altec lansing with dolby advanced audio but ive tried the audio kexts from your clover restore and none have worked :(. right now, i get a kp on boot dealing with voodoohda. i also misplaced my wireless usb adapter so i dont have internet on my hackintosh partition since my wifi card is not supported in hackintosh

Share this post


Link to post
Share on other sites

I got sound ... voodoo battery is working ... but no LAN and GPU .. so " mnugent93 '' what kext are you useing for the GPU ..? ( check system info )

Share this post


Link to post
Share on other sites

I got sound ... voodoo battery is working ... but no LAN and GPU .. so " mnugent93 '' what kext are you useing for the GPU ..? ( check system info )

Well i checked system info and it says no kext loaded for my graphics card. voodoo battery works, but no sound no matter what kext i use for that

Share this post


Link to post
Share on other sites

Does anyone think my laptop has a shot of running ML? I would like to dual boot ML with Windows 8, but if it won't work i always have my rig to fall back on. Here's my specs again:

 

HP Pavillion G6-1d98dx

AMD A6-3420M APU w/ Radeon HD 6520G graphics

I've tried just about everything. At first i tried a distro because i was desperate. It actually tried to boot, but I got the "Still waiting for root device" errors because I can't change the SATA mode to AHCI thanks to InsydeH20's crappy locked BIOS. When I tried to boot a retail copy from USB like i did my rig, all I get is a black screen, no reboots nor verbose messages, just a black screen. Then I installed the Clover bootloader to my USB, and my system wouldn't even acknowledge the USB stick. :mad: I'm not sure if this laptop uses UEFI or not, i know it boots 10x faster than a normal BIOS would.

So, if anyone thinks this laptop has a chance, plz let me know. Thanks.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×