Jump to content
TonyHailway

AMD APU mountain lion support

312 posts in this topic

Recommended Posts

Advertisement
:) Edited by theconnactic
Edited because the original topic was moved here by Fantomas. It was a duplicate of the first post. Deleted all other posts non-related to the subject to avoid confusion. Thanks =]

Share this post


Link to post
Share on other sites

Some help please, I really want to try hackintoshing :)

 

I suggest you start the project, and when i problem appears, you report here, for other APU users to see. You might as well be a pioneer. :)

 

As a starting point, i suggest:

 

1) Start with Lion, since it's easier to set up and is, by far, the most stable OSX release for AMD machines. When you have the perfect Lion machine, update to Mountain Lion. Go get the latest kernel for Lion here, and rename it to amd_kernel: http://www.mediafire...lnlecqnv20yvol6

 

2) Before you begin, make sure SATA mode is set as AHCI (or RAID if AHCI is not available) and C1E is disabled

 

3) Follow this method exactly as described, just adding the amd_kernel to the root of the USB installer (EDIT: the one i linked previously was for Mountain Lion) http://www.insanelymac.com/forum/topic/278181-amd-1073-guide-experimental-only/

 

4) Boot from your USB stick using the flags amd_kernel arch=i386 -v -f GraphicsEnabler=No (it's case sensitive, type exactly as written).

 

When you're done with these steps, post here. :)

 

All the best!

Share this post


Link to post
Share on other sites

Can this be done with iAtkos? Cause if I want to first see if my laptop is compatible/stable enough to be my daily driver than switch to vanilla, which is apparently better

Share this post


Link to post
Share on other sites

Hi, Akimoa!

 

Well, since he stated so assertively that them APUs are supported in Snow Leopard, i think he could try to be the first to successfuly run Lion/Mountain Lion with them. If it proves to be a failed project, at least he would have spent the $20 price tag of the OS - which is the price of two Big Mac combos, i must remind you - in something that effectively will add knowledge to his brains, not cholesterol to his veins.

 

All the best!

Share this post


Link to post
Share on other sites

Hi, can you guys sort things out for the APU's ? I've got an A6-4400M and all I get is instant reboots!! help!

Share this post


Link to post
Share on other sites

Hi, can you guys sort things out for the APU's ? I've got an A6-4400M and all I get is instant reboots!! help!

 

 

it can have various causes!

Once the try this:

 

boot with -s

 

then give:

/sbin/fsck -fy

then you give:

/sbin/mount -uw /

than give

exit or reboot

Share this post


Link to post
Share on other sites

it can have various causes!

Once the try this:

 

boot with -s

 

then give:

/sbin/fsck -fy

then you give:

/sbin/mount -uw /

than give

exit or reboot

 

didnt even get me to -s mode..once i finish typing the kernel and flags..what happens is that it shows the loading of the kexts but then it reboots..doesnt even show the verbose part.. get it ? :s so..i guess there is something missing on the kernel.. this CPU handles anything (sse3, ssse3, ...) as you can see here: https://www.dropbox.com/s/drmhm4c3r0pkno1/CPUZAPUAMDA6.png?m

Share this post


Link to post
Share on other sites

didnt even get me to -s mode..once i finish typing the kernel and flags..what happens is that it shows the loading of the kexts but then it reboots..doesnt even show the verbose part.. get it ? :s so..i guess there is something missing on the kernel.. this CPU handles anything (sse3, ssse3, ...) as you can see here: https://www.dropbox....ZAPUAMDA6.png?m

 

hello ,

 

Clover 1050 or 1208 ;)

Share this post


Link to post
Share on other sites

hello ,

 

Clover 1050 or 1208 ;)

 

humm thats interesting :P my BIOS has UEFI..I already tried here an EFI boot..it worked..but it rebooted.. question that pops out is do I turn off legacy boot so I can boot into Clover? and..what kernel should I use?

Share this post


Link to post
Share on other sites

:)

Clover 1208 fonctionne aussi pour AMD et les vieilles cartes mères S 939/940 .
Merci Slice et Mark...... :)
une fois fini , boot sur la clef usb , va très bien notamment sur les CPU FX , plus besoin de FakeSMC.kext et de NullCPUPowerManagement.kext

Clover also works for AMD in 1208 and the old motherboards S 939/940.
Slice and thank you Mark ...... :)
once finished, boot on USB key, goes very well especially on FX CPU, no need FakeSMC.kext and NullCPUPowerManagement.kext


 

Share this post


Link to post
Share on other sites

:)

 

Clover 1208 fonctionne aussi pour AMD et les vieilles cartes mères S 939/940 .

Merci Slice et Mark...... :)

une fois fini , boot sur la clef usb , va très bien notamment sur les CPU FX , plus besoin de FakeSMC.kext et de NullCPUPowerManagement.kext

 

Clover also works for AMD in 1208 and the old motherboards S 939/940.

Slice and thank you Mark ...... :)

once finished, boot on USB key, goes very well especially on FX CPU, no need FakeSMC.kext and NullCPUPowerManagement.kext

 

 

http://www.youtube.com/watch?feature=player_detailpage&v=YWum8sju69g

 

I couldnt boot into clover...tried all the ways..it used to actually work** any other method?

Share this post


Link to post
Share on other sites

814745Capturede769cran20130402a768111230.png

 

;)

 

 

I have been corrected... a6-4400m does have sse4.1/4.2 and ssse3

I am using an a6-3410mx and does not have sse4.1/4.2 or ssse3...

I was unable to run mountain lion on it, kept giving me a reboot, but worked fine on my phenom.

post-1122366-0-86313200-1364900105_thumb.gif

Share this post


Link to post
Share on other sites

:)

 

yes, as your CPU is the same architecture as the FX, normally, it works.

 

I havent understood one thing.. do i have to use any kernel? or i use the vanilla one that comes for intel and Clover will sort things out? :/

Share this post


Link to post
Share on other sites

If your CPU was made by AMD, you must use a patched kernel. There is a wiki page with patched kernels on it: http://wiki.osx86pro...Patched_Kernels.

 

Good luck!

 

EDIT: Oh yeah, I see you have an A6-4400M that, at least according to nobookcheck.net, doesn't support SSSE3. My first attempt would be with AnV's amd_kernel and then the "Fixed" one if you still get instant reboots. I can't speak for Clover as I've only used Chameleon.

 

I don't think we have any records of any of these APUs working with OS X, but please be the first! :thumbsup_anim:

Share this post


Link to post
Share on other sites

If your CPU was made by AMD, you must use a patched kernel. There is a wiki page with patched kernels on it: http://wiki.osx86pro...Patched_Kernels.

 

Good luck!

 

EDIT: Oh yeah, I see you have an A6-4400M that, at least according to nobookcheck.net, doesn't support SSSE3. My first attempt would be with AnV's amd_kernel and then the "Fixed" one if you still get instant reboots. I can't speak for Clover as I've only used Chameleon.

 

I don't think we have any records of any of these APUs working with OS X, but please be the first! :thumbsup_anim:

Yeah!!! :weight_lift::thumbsup_anim: wish you very good luck!, too

 

 

Joking aside,test one of the most diverse kernel of sinetek or the last amd_kernel of Andy :moil:

 

https://meklort.com/~sinet3k/

Edited by spakk

Share this post


Link to post
Share on other sites

If your CPU was made by AMD, you must use a patched kernel. There is a wiki page with patched kernels on it: http://wiki.osx86pro...Patched_Kernels.

 

Good luck!

 

EDIT: Oh yeah, I see you have an A6-4400M that, at least according to nobookcheck.net, doesn't support SSSE3. My first attempt would be with AnV's amd_kernel and then the "Fixed" one if you still get instant reboots. I can't speak for Clover as I've only used Chameleon.

 

I don't think we have any records of any of these APUs working with OS X, but please be the first! :thumbsup_anim:

 

yes !!

 

http://www.cpu-world.com/CPUs/Bulldozer/AMD-A6-Series%20A6-4400M.html

 

http://www.bit-tech.net/hardware/2012/11/06/amd-fx-8350-review/

 

it is the same architecture as the FX 8350 (piledriver) must be operated with Clover :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×