Jump to content
iMeee

OS X in my AMD PC

14 posts in this topic

Recommended Posts

Hi everybody !

 

 

I use OS X 10.8.3 since yesterday on my AMD PC through VMWare.

Everything works fine, but I would try to install OS X on my machine directly to take advantage of Quartz Extreme and my GPU.

 

Unfortunately I have an AMD CPU. Here is a summary of my setup:

- Asus M4A88TD-M

- AMD Phenom II X4 945

- ATI Radeon HD 5670

 

I use ethernet, maybe Wifi in the future (a D-Link DWA-547)

 

The 10.8.3 may work?

Or other not too old version.

 

Thank you !

Share this post


Link to post
Share on other sites
Advertisement

Yes, it works with a little bit of work. On the installation if you get black screen use PciRootUID=1 or PciRootUID=0. Qe/Ci is easy to get. Best try install it first then worry about that.

Share this post


Link to post
Share on other sites

Ok thanks ! I'll try that.

 

EDIT : What kexts should I choose during installation?

Share this post


Link to post
Share on other sites

I tried to install Niresh 10.8.2 but at the first boot the display not working correctly : http://www.image-heb...03181801723.jpg

I have Saphire ATI 5670 (512 Mb).

 

I will try with retail ISO.

What should I use after the restauration of the image on my key ? Chameleon, other ?

Share this post


Link to post
Share on other sites

chameleon

 

Can I integrate the kexts and install them at the same time of Mac OS X ?

And I must copy AMD kernel in root folder of my USB thumb ?

Share this post


Link to post
Share on other sites

Can I integrate the kexts and install them at the same time of Mac OS X ?

And I must copy AMD kernel in root folder of my USB thumb ?

 

Yes just copy it to the root. And you can integrate kexts yes

Share this post


Link to post
Share on other sites

Yes just copy it to the root. And you can integrate kexts yes

 

Ok thanks !

Where I need to copy kexts ? They will be in the list "Custom" in the installer (like Niresh) ?

 

EDIT : When I try to boot with AMD kernel I have "No {censored} support for AMD ..." ... ?

Share this post


Link to post
Share on other sites

What's the way you try to load the AMD kernel and what is the name of the kernel? Are you using the boot flags which you probably need for the kernel to work? The kext you can just Show All Files and copy them into System/Library/Extensions and boot with the -f flag.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×