Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  

Which kexts support ATi Chipset RV630? ATiRadeonx2000?

3 posts in this topic

Recommended Posts

New to Hackintosh but have got both my Dell Inspiron 530 (10.8.2) and Dell 435MT (10.8.0) working with ML. Both have Dell ATi Radeon HD 3600 PCI-E cards. The maximum res I can get is 1400x1050 (display cope with 1650x1080 on windows) and the DVI and DP ports both work but are not detected in SYstem Pref / Display and only display in as "mirrors". I have researched and found the DeviceID is 0x9598, Vendor 1002 and the Chipset used is RV630 but some places say RV635 so unsure.. This seems an OEM card for Dell.


I see in S/L/E there are multiple ATi kexts. kext Wizard tells me currently ATiRadeonx2000 (8.0.0) is loaded. I have tried in Chameleon Wizard the ATi Config of Megalodon and setting the ATi Ports to 2 and 3 (the HDMI does not seem to work). Not sure if there is another personaility/Framebuffer I should try or even if this will effect the dual output issue


I was hoping with this information I could adapt one of the other kexts to get both monitors working as extended display and preferably in 1650x1080 resolution. Can anybody direct me to a kext that supports this chipset and any other advice - I have read about adding my PNPID to the info list.


All steep learning curve fo me. Any help is appreciated.


Update: Evn more confused as to the DeviceID and which model and chipset I ahve. I definitly have Devcie ID 0x9598, Vendor 1002 (from Devcie manager within Windows).

The PCI Database shows both 0x9598 and 0x9599 Vendor 1002 as HD 3600 BUT in this link of contents of ATIRadeonx2000 (not looked at my own yet) shows

0x9598 1002 = RV630 [Radeon HD 4570]

0x9599 1002 = RV635 [Radeon HD 3600 Series]

Elsewhere I get 0x9598 as using chipset RV635


I have looked at info.list in ATiRadeonx2000 and there is reference to 0x9598 BUT there is no reference in any of the ATIxxxxController.kext, The nearest is ATI2600Controller.kext which references 9583 which is shown as HD 3600 but with RV630 chipset,


Should I add a 9598 reference to ATI2600Controller.kext ? Should the PCIID be found in both a Radeon and Controller kext as per this tutorial but is for SL?





Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.