Jump to content
InsanelyMac Forum
Sign in to follow this  
Sanjamal

Gigabyte H77M-D3H with Radeon 5870 Sleep and QI/CI Problems

Recommended Posts

Hello,

 

First, here's my build:

Gigabyte GA-H77M-D3H V1.0 (bios f9)

8 GB DDR3 RAM

Intel Core i3 2100 @ 3.09 GHz

XFX Radeon 5870

3 SATA hard drives (OS on 1, RAID 1 for the other 2)

 

Problem:

I installed 10.8.3 vanilla using myHack, and then installed kexts to get my network and sound working. myHack also installed Chameleon 2.1 for me. (I would have asked the fine folks at myHack, but I did my introduction and still I haven't been promoted to poster status after a week and a half.)

 

If the system goes to sleep it won't wake up. I disabled sleep and found that leaving the screen set to turn off worked, but it would only wake up if I press the power button, and if I leave it for an extended period that doesn't even work.

 

For graphics, the desktop looks great, I get that splash effect when I drop a new gadget on the dashboard, and I can play videos. I tried to run Uniengine Heaven 4.0 just to see how it may handle games, but I got a black screen with a little corruption on it. I looked in the System Profiler and this is what is says for Graphics/Displays:

 

 

Chipset Model: ATI Radeon HD 5870

Type: GPU

Bus: PCIe

PCIe Lane Width: x16

VRAM (Total): 1024 MB

Vendor: ATI (0x1002)

Device ID: 0x6898

Revision ID: 0x0000

 

I notice that there's no Quartz Extreme or anything like that listed and if I understand correctly, it should definitely be there if everything is functioning properly. I'm confused by this because I thought this was one of those cards for which Mac OS has native support.

 

Is there anyone out there brimming with awesomeness who could help me get these problems fixed?

 

Much appreciated!

Share this post


Link to post
Share on other sites
Advertisement

QE/CI is working. Test the following: put the computer to sleep, wake it and wait 10 minutes before checking it: if it wakes, your machine is suffering from the "long wake" issue (which will need a dsdt edit to fix).

 

Good luck!

Share this post


Link to post
Share on other sites

So I've been messing with it for two evenings now trying to figure out what the problem seems to be. I put it to sleep by using the Apple menu->Sleep function. I successfully woke it once by moving/clicking the mouse; it took between 30 - 60 seconds to wake, but this was after it had been sleeping for about 5 minutes. I put it to sleep a second time and left it for about 30 minutes before trying to wake it and I can't get it to turn back on without reset or hard shut down. I did wait at least 10 minutes every time I tried to wake it. Any ideas about what the fix for this may be?

 

Also, for the video card issue, if QE/CI is working then do you have any theories for why that Uniengine Heaven test failed so bad?

 

Thanks for the help! You are indeed brimming with awesomeness :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×