Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Dr. Hurt

Fixes for HFS+ partiton error

37 posts in this topic

Recommended Posts

fdisk -u /dev/rdisk0


There is a space after the "-u" and drop the "s2". You don't repair MBR on a partition. The MBR is maintained by the disk.


I have used norton partition magic and created a primary fat32 partition for OS X. but it is not listed in the disk utils. i tried allthe aboveusing the terminal and i am always getting the "permission denied" evev used the single user boot method there also i am getting the samr error.

my system is intel dual core with xp.


any help is appriciated

Share this post

Link to post
Share on other sites

It's not working for me...I have tried everything. Same error, but if i check...the partition with leopard is marked as active...so I don't know what to do. I can only boot with the OSX86 dvd. I have used the flag method too. My diskutil list is like this....if anyone has any other ideeas...please share...Thaks

Last login: Wed Jan 2 08:25:23 on console


alexs-mac-pro:~ AM$ sudo -s




bash-3.2# diskutil list


2008-01-02 08:27:27.756 diskutil[161:10b] _CFGetHostUUIDString: unable to determine UUID for host. Error: 35


2008-01-02 08:27:28.083 DiskManagementTool[162:10b] _CFGetHostUUIDString: unable to determine UUID for host. Error: 35






0: FDisk_partition_scheme *465.8 Gi disk0


1: Apple_HFS Leopard 14.3 Gi disk0s1


2: Apple_HFS Mac-Data 14.3 Gi disk0s2


3: Windows_NTFS DATA-2 437.1 Gi disk0s5






0: FDisk_partition_scheme *372.6 Gi disk1


1: Windows_NTFS SYSTEM 31.3 Gi disk1s1


2: Windows_NTFS DATA-1 330.8 Gi disk1s5


3: Windows_NTFS Recovery 10.5 Gi disk1s2






0: Apple_partition_scheme *4.4 Gi disk2


1: Apple_partition_map 31.5 Ki disk2s1


2: Apple_HFS Leopard_Install_Osx86 4.4 Gi disk2s2



Share this post

Link to post
Share on other sites

Joe Cargo...Thank You!!! Thank You!!! Thank You!!! Thank You!!! It works! I dnt know why I had to do it becuase it has been working everytime I used it till now but now it is :wallbash:

Share this post

Link to post
Share on other sites

That son of a {censored} actually created a multiboot for me :dev:, just ran if F8 then -s and Fdisk -e /dev/rdisk0s2 write a new record, reboot, than F8 -s Fdisk -u /dev/rdisk0 and now it seems to be booting ... or it's stuck again, but atleast I got a choice at startup :spam:

Share this post

Link to post
Share on other sites
just wanted to share how i got rid of my hfs+ problem...i tried everything in every fourm i came across. i was getting the permission denied when ever i tried to use the fdisk command in terminal, so i tried the sudo command and that got rid of the hfs problem but then it wouldnt boot at all....


to solve this, this is what i did


1. put the installation disk in the drive


2. when the darwin bootloader screen pops up press f8 and then type -s and enter to enter single user mode


3. single user mode is like booting from a windows floppy boot disk...you get just a command prompt


4 set the active partition and save the mbr

a. fdisk -e /dev/rdisk0 (the drive location that OSX was installed on 0 based)

b. flag 2 (the partition number OSX is on 1 based)

c. update

d. write

e. quit

f. reboot


5. take out your osx disk, you should now be able to boot into mac no problem.



EDIT::: if you dont plan to use vista stop reading here...you should now be working with OSX and if you have it installed xp as well


6. after i did this windows vista would refuse to boot for me so i had to fix the vista install, but vista wont see the install unless you make it the active partition, so reboot back to the OSX disk and go into single user mode again then type the following

a. fdisk -e /dev/rdisk0

b. flag 3 (in my case vista was on the 3rd partition this may be different for you)

c. quit

d. reboot


7. take out your osx disk and let windows vista try to start


8. vista should now give you an error while trying to boot along the lines of winload.exe is corrupted this is good


9. throw in your vista install disk and reboot


10. go through the first menu where you select your language and such and click repair on the bottom of the screen


11. vista should find the error and repair its self


12. now reboot and all your problems should be gone...i chose to use darwin as my boot loader so i used a partition manager to change mac back to active and make vista in active


hope this helps those of you still having problems



:::EDIT::: listed out my steps to get it working in stead of saying follow fdisk commands


I realize this relates to an earlier post (we are in Leopard) , but in searching, it applies to our dilemma. We have a Wind with Vista 32 over the shipping XP and a fully functional OSX build on dual boot. We lost the Darwin unexplicably , but the install is still there and didn't want to wipe the disk and do a fresh install.


In Disk Utility using the OSX install disk doing verify and repair, it returns:



Verify and Repair Volume "disk0s2'


** /dev/disk0s2 Invalid BS_jmpBootblock :fa31c0


ERROR: File System verify or repair failed.



We tried the above prior posted procedure by Xedek, but am unclear how it applies to Vista on the 1st partition and OSX on the 2nd partition as far as labels and flags go. We have tried different combos without success. Using FDisk variations and changing flags didn't work either.


Please help.



Share this post

Link to post
Share on other sites

I tried the fdisk -u /dev/rdisk0 command and it seems to have worked, I can now choose weather to start up in Vista or OS X. Though Vista works, OS X wont boot, it haults at Unknown SIGSEGV Code 0 and hangs there.

Share this post

Link to post
Share on other sites


I have been using os x for 1 year now and yesterday I broke my install but every-time I reinstall I get an HFS+ partition error. I have finally fixed it and thought I share my success.


Well, first you must know that this error occurs either because of a bad master boot record (MBR) or the partition id is not af.


To fix this, do the following:

1. Make sure that your partition id is af. You can check this by using spfdisk or diskpart.


If you partition id is af, then carry on to the rest of the steps.

2. Boot into your installation DVD (any version)

3. Open terminal from the utilities menu and type the following

fdisk -u /dev/rdisk0

NB. If OS X is on your second HD then use rdisk1 instead of rdisk0


An alternative way is to get make an MS-DOS start-up diskette and put fdisk on it, and boot from it.

In DOS, type

fdisk /MBR


I hope this helps the people who are having this problem. :)





i tried this, and tried to boot, the error became cannot login to the desired OS, files corrupted :/

i dunno what to do, i really need to try this OS and i got 3 different versions of Mac OS X and all of them give different errors, they install just fine, but they wouldn't boot and each with it's different error :o

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.