Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  

geforce 8500 gt - only dvi working

3 posts in this topic

Recommended Posts

hi there,

i am new to the forum but have been lurking for a while... i have a nvidia geforce 8500 gt (512mb) graphics card that i cannot seem to get working fully with mountain lion. ideally i would like to run two monitors, one from the vga port and one from the dvi port using a dvi-hdmi adapter. if i run a dvi cable directly to the monitor it works flawlessly (full resolution with qe/ci enabled) but i get nothing if i use the dvi-hdmi adapter and nothing from the vga port.

note: it does work from the vga port and dvi-hdmi adapter when booting, but the screen goes black and i get 'no input' as soon as osx starts.

graphicsenabler is set to yes

no other graphics kexts have been installed

it was a clean install of mountain lion

my dsdt is attached


system specs are as follows:

motherboard: ga-p35-ds3l

processor: intel q6600 core2 quad 2.4ghz

memory: 4gb ddr2 sdram

graphics card: nvidia geforce 8500 gt (512mb)

80gb ide hdd (osx 10.8)


any help would be greatly appreciated :-)


Share this post

Link to post
Share on other sites

As far as i remember, back in the days XD,when i had an 8800 gt the only way to make all output ports works was to use efi strings and graphic enabler, dunno if it works the same...

Share this post

Link to post
Share on other sites

so i have tried using efi strings and set graphicsenabler=yes but to no avail. i have also tried nvenabler.kext and official nvida drivers for mac as well but cant seem to get it working. i read somewhere that mountain lion does not support the 8500gt but it just seems strange that it works through the dvi port?

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By onlyJRevenge
      Buonasera ragazzi,
      grazie all'aiuto di questo forum, sono riuscito qualche mese fa a configurare il mio portatile e ne sono pienamente soddisfatto. Ora mi è sorto un dubbio, per poter utilizzare la porta HDMI esterna per collegare il portatile ad un monitor cosa dovrei fare? Ho letto che c'è la possibilità che questo non possa essere possibile, per via del fatto che ho disabilitato la GTX950M e di conseguenza essa portava il segnale "all'esterno". A voi cosa risulta? Riuscireste a darmi una mano?
      Grazie anticipatamente.
    • By MetalBreaker
      I noticed some weird behavior with macOS High Sierra. This system was working just fine on Sierra 10.12.5, until I decided to update to High Sierra (10.13.3). The upgrade process went mostly fine I guess, but it got stuck in an infinite spinning wheel which would just keep overlapping. I went into verbose mode, and sure enough, I found "IOConsoleUsers: gIOScreenLockState 3, hs 0, bs 0, now 0, sm 0x0" repeating over and over along with ACM errors... I'm really lost right now. I can boot in recovery mode and safe mode just fine, when the graphics drivers aren't loaded. Web drivers aren't installed. I installed NvidiaGraphicsFixup, but it didn't fix the issue. I tried deleting the native graphics drivers from macOS and installing web drivers, but it didn't help.
      SMBIOS: iMac13,1
      Graphics card: ASUS GT630-2GD3 (It's a Fermi card and it needs injection, so I modified my DSDT. Full graphics acceleration worked in Sierra. No Clover injection. I tried using Clover injection instead, I saw no difference.)
      CPU: Intel Core i3-3210, iGPU disabled in UEFI

      All kexts updated to their latest versions, along with Clover.

      For more info, you can refer to the GitHub issue where I posted it. https://github.com/lvs1974/NvidiaGraphicsFixup/issues/3
      Any help would be appreciated.
      Thank you for your time!
    • By yaoqb
      i have strange glitch problem on my fresh 10.13.2 install
      the glitch trigered randomly
      it may start from subtitle video from firefox or some transparent panel from a program like clover configurator
      then the whole desktop will have the graphic glitch every program will be affected
      the glitch may clear when toggle the program window zoom in and out but will be likely popup again until restart the system
      the glitch can even be captured by the system's own screenshot short cut
      the following method i try didnt work
      nvidia webdriver latest lilu with NvidiaGraphicsFixup different powermanagement setting