Jump to content
Dr. Hurt

[Guide] Intel HD2500 Full Resolution and QE/CI (10.8.3+)

74 posts in this topic

Recommended Posts

Hi, I'm pretty frustrated. Since 3 days I already try to get my Hackintosh up and running. :( I've got a Gigabyte GA-H77N-WIFI Motherboard with an Intel Core i3-3220T (with an Intel HD 2500). When I boot up Mac OS X 10.8.4 with the parameter "-x" then I can see the desktop. But as soon as I start without the "-x" parameter, my Hackintosh stops at "macx_swapon". Can someone help me in getting rid of this error? I already tried the things you mentioned here. :( I also read that I have to set the graphic memory to 32M!?

Well, unfortunately it doesn't work for everyone. I have yet to find out why.

 

Could you please upload your DSDT and I'll try patching it for you. 

Share this post


Link to post
Share on other sites
Advertisement

Here's your DSDT fully patched for your mobo, not just graphics. I also included an SSDT for your CPU.

 

Use Chameleon Wizard to disable Graphics Enabler and dropSSDT.

Set memory to 32MB in BIOS/UEFI.

Try with SMBIOS set to Macmini6,2 and iMac13,2

 

Try the DSDT.aml. If it doesn't work, try the other ones by renaming them to DSDT.

 

Please, if possible, upload an ioreg with every DSDT you try.

TEST.zip

Share this post


Link to post
Share on other sites

Hey all, I'm back, and this time I have DVI-D.

 

My situation is exactly the same as bennyn, although I almost reach the login screen, only to have the whole screen turn black except for a region in the top left where it's all checkered.

 

My HD 2500 was set to 64 MB and I tried both iMac13,2 and Macmini6,2.  I also injected your string in the first post through Chameleon and Clover, no luck.  Clover actually gave me a KP regarding AppleIntelCPUPowerManagement...

Share this post


Link to post
Share on other sites

@Lacedaemon,

 

I added a new platform-id in bennyn's DSDT. Lets see how how that works. 

Share this post


Link to post
Share on other sites

Thank you for the new DSDT file. I will try it now... To install it I will place the DSDT.aml file on my desktop and then select "UserDSDT or DSDT-Free Installation" in MutiBeast. Is that right? To save the IOReg information I need to install the "Apple Developer Tools" which come with Xcode, right?

Share this post


Link to post
Share on other sites

No. Just place the DSDT and SSDT in the /Extra folder on your OS X partition.

Download Chameleon wizard (google it), and use it to set SMBIOS (imac or macmini) and dropSSDT.

 

Forget about the ioreg for now.

Share this post


Link to post
Share on other sites

Hello Dr. Hurt,

 

I am following your guide to enable HD 2500 for me.

Here is definition of my system:

 

Mobo: Gigagyte GA-B75M-D3H

CPU: Intel Core i3 3220 with intel HD 2500 graphics

Ram: 4GB 1600 MHz

HDD: Seagate 1TB HDD

 

I have same problem as others have. I can only boot with -x(safe mode) flag. When boot without it, I can only see checkers screen as like others have and some GPU failed message displays and goes away. This is happening on both HDMI and DVI. I have not tested VGA as it is not working with Mountain Lion.

 

I am attaching my DSDT saved from Chameleon Wizard.

 

Please provide some solution to it.

 

Thanks,

Manish

DSDT.zip

Share this post


Link to post
Share on other sites

Thanks for the help again! I set SMBIOS to "Mac mini6,2" and I used the following Boot.plist:

 

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
    <key>DropSSDT</key>
    <string>Yes</string>
    <key>EthernetBuiltIn</key>
    <string>Yes</string>
    <key>GenerateCStates</key>
    <string>Yes</string>
    <key>GeneratePStates</key>
    <string>Yes</string>
    <key>GraphicsEnabler</key>
    <string>No</string>
    <key>Graphics Mode</key>
    <string>1920x1080x32</string>
    <key>Kernel</key>
    <string>mach_kernel</string>
    <key>Kernel Flags</key>
    <string>darkwake=0</string>
    <key>Legacy Logo</key>
    <string>Yes</string>
    <key>Timeout</key>
    <string>2</string>
    <key>UseKernelCache</key>
    <string>Yes</string>
</dict>
</plist>

 

 

After that I tried to boot with the three different DSDT.aml files but none of them worked.

Results:

DSDT.aml
DSDT2.aml
DSDT3.aml

 

Are there any other options? Or should I buy an Intel Core i3-3225 (with Intel HD 4000)? :D

Share this post


Link to post
Share on other sites

Thanks for the help again! I set SMBIOS to "Mac mini6,2" and I used the following Boot.plist:

 

 

After that I tried to boot with the three different DSDT.aml files but none of them worked.

 

Results:

 

DSDT.aml

DSDT2.aml

DSDT3.aml

 

Are there any other options? Or should I buy an Intel Core i3-3225 (with Intel HD 4000)? :D

 

Unfortunately, I don't think it'll work.

Before giving up, try deleting all AppleIntelHD3000* and AppleIntelSNB* kexts from /System/Library/Extensions/ and boot with -f.  Only try with the first DSDT this time.

 

If you have the option to get a CPU with an HD4000, do so. It works very well with OS X.

 

EDIT:

I think I found out why the frambuffer was failing to load. There was a missing id.

Give this last DSDT a try. 

DSDT.zip

Share this post


Link to post
Share on other sites

Hello Dr. Hurt,

 

I am following your guide to enable HD 2500 for me.

Here is definition of my system:

 

Mobo: Gigagyte GA-B75M-D3H

CPU: Intel Core i3 3220 with intel HD 2500 graphics

Ram: 4GB 1600 MHz

HDD: Seagate 1TB HDD

 

I have same problem as others have. I can only boot with -x(safe mode) flag. When boot without it, I can only see checkers screen as like others have and some GPU failed message displays and goes away. This is happening on both HDMI and DVI. I have not tested VGA as it is not working with Mountain Lion.

 

I am attaching my DSDT saved from Chameleon Wizard.

 

Please provide some solution to it.

 

Thanks,

Manish

 

Give those 2 DSDTs a try. They are fully patched for your mobo. 

With the first DSDT, set RAM to 32MB. With the second (after renaming), set RAM to 64MB.

 

Good Luck and please report back.

Test.zip

Share this post


Link to post
Share on other sites
EDIT:

I think I found out why the frambuffer was failing to load. There was a missing id.

Give this last DSDT a try. 

 

Okay. I'll try it once I'm home! I've been thinking about buying a new graphics card because it is cheaper than a new CPU. Or could I have then still problems with my CPU? The Geforce GT 610 & GT 620 series is quite cheap. I just have to find out if the Asus GT610-SL-1GD3-L or Asus GT620-DCSL-2GD3 is compatible...

Share this post


Link to post
Share on other sites

Okay. I'll try it once I'm home! I've been thinking about buying a new graphics card because it is cheaper than a new CPU. Or could I have then still problems with my CPU? The Geforce GT 610 & GT 620 series is quite cheap. I just have to find out if the Asus GT610-SL-1GD3-L or Asus GT620-DCSL-2GD3 is compatible...

 

You won't have problems with the CPU. AFAIK, both cards should work. 

Have a look here to see exactly what works and how.

http://wiki.osx86project.org/wiki/index.php/Main_Page

Share this post


Link to post
Share on other sites

Give those 2 DSDTs a try. They are fully patched for your mobo. 

With the first DSDT, set RAM to 32MB. With the second (after renaming), set RAM to 64MB.

 

Good Luck and please report back.

I am back Dr.Hurt.

 

I tried both DSDT with both RAM option. Neither worked for me.

Is there anything I need to do extra ?

 

Here is process I am following to.

 

Created boot USB from 10.8.4 Mac App store App.

Boot from it.

Created partition.

Installed on one partition.

Booted with USB and selected fresh partition on which we installed ML.

Installed Chameleon with Chameleon Wizard App. I Installed Boot0hfs, 2255 revision.

Made some change to boot.plist file. I am attaching this boot.plist file.

Set SMBios to Mac Min 6,2

Placed your DSDT to Extra folder and also put SMBios.plist and boot.plist in Extra folder.

 

Reboot. Nothing difference. It is same checkers screen as with device-properties way. I am attaching screenshot of that also.

 

Please let me know whether it is supported or not. Also I found that i3 3220 has device id 0152 but you set 0166 in DSDT. Is that ok ?

Archive.zip

post-336826-0-30521300-1376474335_thumb.jpg

Share this post


Link to post
Share on other sites

Dr.Hurt,

 

Here I have found 2 log files in System Diagnostic Reports.

One os WindowServer and another is SecurityAgent.

 

I think there is problem with AppleIntelHD4000GraphicsGLDriver.

 

I am attaching both file. Please check it and let me know if i can get it working or not.

 

Thanks for your kind help.


Also you may be interested in this install log:

 

 

 

14/08/13 3:30:51.000 PM bootlog[0]: BOOT_TIME 1376474451 0
14/08/13 3:30:58.000 PM kernel[0]: PMAP: PCID enabled
14/08/13 3:30:58.000 PM kernel[0]: PMAP: Supervisor Mode Execute Protection enabled
14/08/13 3:30:58.000 PM kernel[0]: Darwin Kernel Version 12.4.0: Wed May  1 17:57:12 PDT 2013; root:xnu-2050.24.15~1/RELEASE_X86_64
14/08/13 3:30:58.000 PM kernel[0]: vm_page_bootstrap: 988276 free pages and 52108 wired pages
14/08/13 3:30:58.000 PM kernel[0]: kext submap [0xffffff7f80737000 - 0xffffff8000000000], kernel text [0xffffff8000200000 - 0xffffff8000737000]
14/08/13 3:30:58.000 PM kernel[0]: zone leak detection enabled
14/08/13 3:30:58.000 PM kernel[0]: standard timeslicing quantum is 10000 us
14/08/13 3:30:58.000 PM kernel[0]: standard background quantum is 2500 us
14/08/13 3:30:58.000 PM kernel[0]: mig_table_max_displ = 74
14/08/13 3:30:58.000 PM kernel[0]: TSC Deadline Timer supported and enabled
14/08/13 3:30:58.000 PM kernel[0]: corecrypto kext started!
14/08/13 3:30:58.000 PM kernel[0]: Running kernel space in FIPS MODE
14/08/13 3:30:58.000 PM kernel[0]: Plist hmac value is    735d392b68241ef173d81097b1c8ce9ba283521626d1c973ac376838c466757d
14/08/13 3:30:58.000 PM kernel[0]: Computed hmac value is 735d392b68241ef173d81097b1c8ce9ba283521626d1c973ac376838c466757d
14/08/13 3:30:58.000 PM kernel[0]: corecrypto.kext FIPS integrity POST test passed!
14/08/13 3:30:58.000 PM kernel[0]: corecrypto.kext FIPS AES CBC POST test passed!
14/08/13 3:30:58.000 PM kernel[0]: corecrypto.kext FIPS TDES CBC POST test passed!
14/08/13 3:30:58.000 PM kernel[0]: corecrypto.kext FIPS SHA POST test passed!
14/08/13 3:30:58.000 PM kernel[0]: corecrypto.kext FIPS HMAC POST test passed!
14/08/13 3:30:58.000 PM kernel[0]: corecrypto.kext FIPS ECDSA POST test passed!
14/08/13 3:30:58.000 PM kernel[0]: corecrypto.kext FIPS DRBG POST test passed!
14/08/13 3:30:58.000 PM kernel[0]: corecrypto.kext FIPS POST passed!
14/08/13 3:30:58.000 PM kernel[0]: NullCPUPowerManagement::init: properties=0xffffff8009a3b500
14/08/13 3:30:58.000 PM kernel[0]: NullCPUPowerManagement::start
14/08/13 3:30:58.000 PM kernel[0]: AppleACPICPU: ProcessorId=1 LocalApicId=0 Enabled
14/08/13 3:30:58.000 PM kernel[0]: AppleACPICPU: ProcessorId=2 LocalApicId=2 Enabled
14/08/13 3:30:58.000 PM kernel[0]: AppleACPICPU: ProcessorId=3 LocalApicId=1 Enabled
14/08/13 3:30:58.000 PM kernel[0]: AppleACPICPU: ProcessorId=4 LocalApicId=3 Enabled
14/08/13 3:30:58.000 PM kernel[0]: calling mpo_policy_init for TMSafetyNet
14/08/13 3:30:58.000 PM kernel[0]: Security policy loaded: Safety net for Time Machine (TMSafetyNet)
14/08/13 3:30:58.000 PM kernel[0]: calling mpo_policy_init for Sandbox
14/08/13 3:30:58.000 PM kernel[0]: Security policy loaded: Seatbelt sandbox policy (Sandbox)
14/08/13 3:30:58.000 PM kernel[0]: calling mpo_policy_init for Quarantine
14/08/13 3:30:58.000 PM kernel[0]: Security policy loaded: Quarantine policy (Quarantine)
14/08/13 3:30:58.000 PM kernel[0]: Copyright (c) 1982, 1986, 1989, 1991, 1993
14/08/13 3:30:58.000 PM kernel[0]: The Regents of the University of California. All rights reserved.
14/08/13 3:30:58.000 PM kernel[0]: MAC Framework successfully initialized
14/08/13 3:30:58.000 PM kernel[0]: using 16384 buffer headers and 10240 cluster IO buffer headers
14/08/13 3:30:58.000 PM kernel[0]: IOAPIC: Version 0x20 Vectors 64:87
14/08/13 3:30:58.000 PM kernel[0]: ACPI: System State [S0 S3 S4 S5]
14/08/13 3:30:58.000 PM kernel[0]: PFM64 (36 cpu) 0xf80000000, 0x80000000
14/08/13 3:30:58.000 PM kernel[0]: HWSensors v5.2.725 Copyright 2013 netkas, slice, usr-sse2, kozlek, navi, THe KiNG, RehabMan. All rights reserved.
14/08/13 3:30:58.000 PM kernel[0]: waitForSystemMapper
14/08/13 3:30:58.000 PM kernel[0]: Backtrace 0xffffff800065204f 0xffffff8000651bc9 0xffffff8000651b30 0xffffff7f8102dcfc 0xffffff7f8102d45d 0xffffff80006311bc 0xffffff800062d400
14/08/13 3:30:58.000 PM kernel[0]: Kernel Extensions in backtrace:
14/08/13 3:30:58.000 PM kernel[0]: org.netkas.driver.FakeSMC(725.0)[E70D0EF3-2C11-3967-9EF3-99E275370C99]@0xffffff7f81028000->0xffffff7f8103cfff
14/08/13 3:30:58.000 PM kernel[0]: dependency: com.apple.iokit.IOACPIFamily(1.4)[A35915E8-C1B0-3C0F-81DF-5515BC9002FC]@0xffffff7f80cd4000
14/08/13 3:30:58.000 PM kernel[0]: [ PCI configuration begin ]
14/08/13 3:30:58.000 PM kernel[0]: FakeSMCDevice: 17 preconfigured keys added
14/08/13 3:30:58.000 PM kernel[0]: SMC: successfully initialized
14/08/13 3:30:58.000 PM kernel[0]: CPUSensors: CPU family 0x6, model 0x3a, stepping 0x9, cores 2, threads 4, TJmax 105
14/08/13 3:30:58.000 PM kernel[0]: CPUSensors: setting platform to d8
14/08/13 3:30:58.000 PM kernel[0]: mbinit: done [64 MB total pool size, (42/21) split]
14/08/13 3:30:58.000 PM kernel[0]: Pthread support ABORTS when sync kernel primitives misused
14/08/13 3:30:58.000 PM kernel[0]: rooting via boot-uuid from /chosen: 190EEC63-9CD0-3D28-B49F-784B141A8BA7
14/08/13 3:30:58.000 PM kernel[0]: Waiting on <dict ID="0"><key>IOProviderClass</key><string ID="1">IOResources</string><key>IOResourceMatch</key><string ID="2">boot-uuid-media</string></dict>
14/08/13 3:30:58.000 PM kernel[0]: com.apple.AppleFSCompressionTypeZlib kmod start
14/08/13 3:30:58.000 PM kernel[0]: com.apple.AppleFSCompressionTypeDataless kmod start
14/08/13 3:30:58.000 PM kernel[0]: com.apple.AppleFSCompressionTypeZlib load succeeded
14/08/13 3:30:58.000 PM kernel[0]: com.apple.AppleFSCompressionTypeDataless load succeeded
14/08/13 3:30:58.000 PM kernel[0]: console relocated to 0xf80000000
14/08/13 3:30:58.000 PM kernel[0]: PCI configuration changed (bridge=2 device=2 cardbus=0)
14/08/13 3:30:58.000 PM kernel[0]: [ PCI configuration end, bridges 4 devices 11 ]
14/08/13 3:30:58.000 PM kernel[0]: SuperIODevice: found ITE IT8728F on port=0x2e address=0xa30
14/08/13 3:30:58.000 PM kernel[0]: IT87xxSensors: started
14/08/13 3:30:58.000 PM kernel[0]: Got boot device = IOService:/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/SATA@1F,2/AppleIntelPchSeriesAHCI/PRT3@3/IOAHCIDevice@0/AppleAHCIDiskDriver/IOAHCIBlockStorageDevice/IOBlockStorageDriver/ST31000528AS Media/IOGUIDPartitionScheme/ML@2
14/08/13 3:30:58.000 PM kernel[0]: BSD root: disk0s2, major 1, minor 1
14/08/13 3:30:58.000 PM kernel[0]: Kernel is LP64
14/08/13 3:30:51.828 PM com.apple.launchd[1]: *** launchd[1] has started up. ***
14/08/13 3:30:51.840 PM com.apple.launchd[1]: *** Verbose boot, will log to /dev/console. ***
14/08/13 3:30:51.852 PM com.apple.launchd[1]: *** Shutdown logging is enabled. ***
14/08/13 3:30:58.007 PM com.apple.launchd[1]: (com.apple.automountd) Unknown key for boolean: NSSupportsSuddenTermination
14/08/13 3:30:59.000 PM kernel[0]: AppleRTL8169Ethernet: Ethernet address 94:de:80:61:19:d1
14/08/13 3:31:03.448 PM hidd[49]: Posting 'com.apple.iokit.hid.displayStatus' notifyState=1
14/08/13 3:31:03.516 PM hidd[49]: void __IOHIDLoadBundles(): Loaded 0 HID plugins
14/08/13 3:31:04.000 PM kernel[0]: macx_swapon SUCCESS
14/08/13 3:31:04.257 PM com.apple.SecurityServer[21]: Session 100000 created
14/08/13 3:31:04.258 PM appleeventsd[55]: main: Starting up
14/08/13 3:31:04.493 PM kdc[47]: label: default
14/08/13 3:31:04.493 PM kdc[47]:  dbname: od:/Local/Default
14/08/13 3:31:04.493 PM kdc[47]:  mkey_file: /var/db/krb5kdc/m-key
14/08/13 3:31:04.493 PM kdc[47]:  acl_file: /var/db/krb5kdc/kadmind.acl
14/08/13 3:31:04.661 PM mDNSResponder[41]: mDNSResponder mDNSResponder-379.38.1 (Apr 25 2013 19:19:56) starting OSXVers 12
14/08/13 3:31:04.000 PM kernel[0]: [IOBluetoothHCIController][start] -- completed
14/08/13 3:31:04.000 PM kernel[0]: Previous Shutdown Cause: 5
14/08/13 3:31:04.000 PM kernel[0]: DSMOS has arrived
14/08/13 3:31:04.949 PM com.apple.usbmuxd[29]: usbmuxd-296.4 on Dec 21 2012 at 16:11:14, running 64 bit
14/08/13 3:31:05.357 PM com.apple.SecurityServer[21]: Entering service
14/08/13 3:31:06.692 PM systemkeychain[73]: done file: /var/run/systemkeychaincheck.done
14/08/13 3:31:06.749 PM kdc[47]: WARNING Found KDC certificate (O=System Identity,CN=com.apple.kerberos.kdc)is missing the PK-INIT KDC EKU, this is bad for interoperability.
14/08/13 3:31:06.922 PM UserEventAgent[11]: Captive: [mySCCopyWiFiDevices:162] WiFi Device Name == NULL
14/08/13 3:31:06.953 PM apsd[61]: CGSLookupServerRootPort: Failed to look up the port for "com.apple.windowserver.active" (1102)
14/08/13 3:31:06.954 PM apsd[61]: CGSLookupServerRootPort: Failed to look up the port for "com.apple.windowserver.active" (1102)
14/08/13 3:31:07.110 PM mds[40]: (Normal) FMW: FMW 0 0
14/08/13 3:31:07.174 PM coreservicesd[62]: FindBestLSSession(), no match for inSessionID 0xfffffffffffffffc auditTokenInfo( uid=0 euid=0 auSessionID=100000 create=false
14/08/13 3:31:07.428 PM loginwindow[44]: Login Window Application Started
14/08/13 3:31:08.361 PM awacsd[59]: Starting awacsd connectivity-78.3 (Apr 25 2013 19:22:44)
14/08/13 3:31:08.387 PM awacsd[59]: InnerStore CopyAllZones: no info in Dynamic Store
14/08/13 3:31:10.502 PM mDNSResponder[41]: D2D_IPC: Loaded
14/08/13 3:31:10.502 PM mDNSResponder[41]: D2DInitialize succeeded
14/08/13 3:31:10.556 PM kdc[47]: KDC started
14/08/13 3:31:10.629 PM locationd[45]: NOTICE,Location icon should now be in state 0
14/08/13 3:31:11.932 PM WindowServer[87]: Server is starting up
14/08/13 3:31:11.000 PM kernel[0]: ACPI_SMC_PlatformPlugin::start - waitForService(resourceMatching(AppleIntelCPUPowerManagement) timed out
14/08/13 3:31:11.000 PM kernel[0]: WARNING: IOPlatformPluginUtil : getCPUIDInfo: this is an unknown CPU model 0x3a
14/08/13 3:31:11.000 PM kernel[0]: -- power management may be incomplete or unsupported
14/08/13 3:31:12.067 PM WindowServer[87]: Session 256 retained (2 references)
14/08/13 3:31:12.067 PM WindowServer[87]: Session 256 released (1 references)
14/08/13 3:31:12.205 PM WindowServer[87]: Session 256 retained (2 references)
14/08/13 3:31:12.209 PM WindowServer[87]: init_page_flip: page flip mode is on
14/08/13 3:31:12.367 PM UserEventAgent[11]: Captive: [mySCCopyWiFiDevices:162] WiFi Device Name == NULL
14/08/13 3:31:12.370 PM digest-service[95]: label: default
14/08/13 3:31:12.371 PM digest-service[95]:  dbname: od:/Local/Default
14/08/13 3:31:12.371 PM digest-service[95]:  mkey_file: /var/db/krb5kdc/m-key
14/08/13 3:31:12.371 PM digest-service[95]:  acl_file: /var/db/krb5kdc/kadmind.acl
14/08/13 3:31:12.373 PM digest-service[95]: digest-request: uid=0
14/08/13 3:31:12.398 PM configd[16]: network changed: DNS*
14/08/13 3:31:12.476 PM rpcsvchost[97]: sandbox_init: com.apple.msrpc.netlogon.sb succeeded
14/08/13 3:31:12.480 PM digest-service[95]: digest-request: init request
14/08/13 3:31:12.494 PM digest-service[95]: digest-request: init return domain: BUILTIN server: LOCALHOST
14/08/13 3:31:12.677 PM WindowServer[87]: mux_initialize: Couldn't find any matches
14/08/13 3:31:12.709 PM WindowServer[87]: GLCompositor enabled for tile size [256 x 256]
14/08/13 3:31:12.709 PM WindowServer[87]: CGXGLInitMipMap: mip map mode is on
14/08/13 3:31:12.741 PM WindowServer[87]: WSMachineUsesNewStyleMirroring: true
14/08/13 3:31:12.741 PM WindowServer[87]: Display 0x1a492840: GL mask 0x1; bounds (0, 0)[1920 x 1200], 27 modes available
Main, Active, on-line, enabled, built-in, boot, Vendor 469, Model 24a1, S/N 0, Unit 0, Rotation 0
UUID 0x00000469000024a1000000001a492840
14/08/13 3:31:12.741 PM WindowServer[87]: Display 0x003f003e: GL mask 0x4; bounds (0, 0)[0 x 0], 1 modes available
off-line, enabled, Vendor ffffffff, Model ffffffff, S/N ffffffff, Unit 2, Rotation 0
UUID 0xffffffffffffffffffffffff003f003e
14/08/13 3:31:12.741 PM WindowServer[87]: Display 0x003f003d: GL mask 0x2; bounds (0, 0)[0 x 0], 1 modes available
off-line, enabled, Vendor ffffffff, Model ffffffff, S/N ffffffff, Unit 1, Rotation 0
UUID 0xffffffffffffffffffffffff003f003d
14/08/13 3:31:12.745 PM WindowServer[87]: Created shield window 0x5 for display 0x1a492840
14/08/13 3:31:12.745 PM WindowServer[87]: Created shield window 0x6 for display 0x003f003e
14/08/13 3:31:12.745 PM WindowServer[87]: Created shield window 0x7 for display 0x003f003d
14/08/13 3:31:12.746 PM WindowServer[87]: Display 0x1a492840: GL mask 0x1; bounds (0, 0)[1920 x 1200], 27 modes available
Main, Active, on-line, enabled, built-in, boot, Vendor 469, Model 24a1, S/N 0, Unit 0, Rotation 0
UUID 0x00000469000024a1000000001a492840
14/08/13 3:31:12.746 PM WindowServer[87]: Display 0x003f003e: GL mask 0x4; bounds (2944, 0)[1 x 1], 1 modes available
off-line, enabled, Vendor ffffffff, Model ffffffff, S/N ffffffff, Unit 2, Rotation 0
UUID 0xffffffffffffffffffffffff003f003e
14/08/13 3:31:12.746 PM WindowServer[87]: Display 0x003f003d: GL mask 0x2; bounds (2945, 0)[1 x 1], 1 modes available
off-line, enabled, Vendor ffffffff, Model ffffffff, S/N ffffffff, Unit 1, Rotation 0
UUID 0xffffffffffffffffffffffff003f003d
14/08/13 3:31:12.747 PM WindowServer[87]: CGXPerformInitialDisplayConfiguration
14/08/13 3:31:12.747 PM WindowServer[87]:   Display 0x1a492840: MappedDisplay Unit 0; Vendor 0x469 Model 0x24a1 S/N 0 Dimensions 20.39 x 12.76; online enabled built-in, Bounds (0,0)[1920 x 1200], Rotation 0, Resolution 1
14/08/13 3:31:12.747 PM WindowServer[87]:   Display 0x003f003e: MappedDisplay Unit 2; Vendor 0xffffffff Model 0xffffffff S/N -1 Dimensions 0.00 x 0.00; offline enabled, Bounds (2944,0)[1 x 1], Rotation 0, Resolution 1
14/08/13 3:31:12.747 PM WindowServer[87]:   Display 0x003f003d: MappedDisplay Unit 1; Vendor 0xffffffff Model 0xffffffff S/N -1 Dimensions 0.00 x 0.00; offline enabled, Bounds (2945,0)[1 x 1], Rotation 0, Resolution 1
14/08/13 3:31:12.956 PM com.apple.launchd[1]: (com.apple.netbiosd[96]) Exited abnormally: Hangup: 1
14/08/13 3:31:12.956 PM com.apple.launchd[1]: (com.apple.netbiosd) Throttling respawn: Will start in 10 seconds
14/08/13 3:31:13.009 PM taskgated[13]: no signature for pid=96 (cannot make code: host has no guest with the requested attributes)
14/08/13 3:31:13.411 PM WindowServer[87]: GLCompositor: GL renderer id 0x01024400, GL mask 0x00000007, accelerator 0x00003143, unit 0, caps QEX|QGL|MIPMAP, vram 1124 MB
14/08/13 3:31:13.411 PM WindowServer[87]: GLCompositor: GL renderer id 0x01024400, GL mask 0x00000007, texture units 8, texture max 16384, viewport max {16384, 16384}, extensions FPRG|NPOT|GLSL|FLOAT
14/08/13 3:31:13.417 PM loginwindow[44]: **DMPROXY** Found `/System/Library/CoreServices/DMProxy'.
14/08/13 3:31:13.860 PM WindowServer[87]: Created shield window 0x8 for display 0x1a492840
14/08/13 3:31:13.860 PM WindowServer[87]: Display 0x1a492840: MappedDisplay Unit 0; ColorProfile { 2, "ASUS MK241"}; TransferFormula (1.000000, 1.000000, 1.000000)
14/08/13 3:31:13.880 PM launchctl[110]: com.apple.findmymacmessenger: Already loaded
14/08/13 3:31:13.969 PM com.apple.launchd[1]: (com.apple.netbiosd) Throttling respawn: Will start in 9 seconds
14/08/13 3:31:13.972 PM com.apple.SecurityServer[21]: Session 100004 created
14/08/13 3:31:14.276 PM locationd[116]: NOTICE,Location icon should now be in state 0
14/08/13 3:31:14.320 PM UserEventAgent[111]: cannot find useragent 1102
14/08/13 3:31:14.746 PM WindowServer[87]: **DMPROXY** (2) Found `/System/Library/CoreServices/DMProxy'.
14/08/13 3:31:14.778 PM loginwindow[44]: Login Window Started Security Agent
14/08/13 3:31:14.782 PM WindowServer[87]: Display 0x1a492840: MappedDisplay Unit 0; ColorProfile { 2, "ASUS MK241"}; TransferFormula (1.000000, 1.000000, 1.000000)
14/08/13 3:31:14.809 PM WindowServer[87]: Display 0x1a492840: MappedDisplay Unit 0; ColorProfile { 2, "ASUS MK241"}; TransferFormula (1.000000, 1.000000, 1.000000)
14/08/13 3:31:14.923 PM SecurityAgent[121]: This is the first run
14/08/13 3:31:14.923 PM SecurityAgent[121]: MacBuddy was run = 0
14/08/13 3:31:14.942 PM WindowServer[87]: MPAccessSurfaceForDisplayDevice: Set up page flip mode on display 0x1a492840 device: 0x10f9e1110  isBackBuffered: 1 numComp: 3 numDisp: 3
14/08/13 3:31:14.954 PM SecurityAgent[121]: User info context values set for manish
14/08/13 3:31:15.061 PM configd[16]: network changed: v4(en0+:192.168.0.159) DNS+ Proxy+ SMB
14/08/13 3:31:15.783 PM ntpd[93]: proto: precision = 1.000 usec
14/08/13 3:31:20.939 PM SecurityAgent[121]: The log in transition is taking too long, continuing log in.
14/08/13 3:31:21.000 PM kernel[0]: stampWait: Overflowed checking for stamp 0x32 on MAIN ring: called from sleepForTimeStamp
14/08/13 3:31:21.000 PM kernel[0]: timestamp = 0x0008
14/08/13 3:31:21.000 PM kernel[0]: GPU hang: 
14/08/13 3:31:21.000 PM kernel[0]: Trying restart GPU ...
14/08/13 3:31:21.000 PM kernel[0]: MAIN ring is NOT waiting on an event
14/08/13 3:31:23.687 PM awacsd[59]: Exiting
14/08/13 3:31:25.975 PM com.apple.launchd[1]: (com.apple.DumpGPURestart) Throttling respawn: Will start in 5 seconds
14/08/13 3:31:25.000 PM kernel[0]: stampWait: Overflowed checking for stamp 0x32 on MAIN ring: called from sleepForTimeStamp
14/08/13 3:31:25.000 PM kernel[0]: timestamp = 0x0031
14/08/13 3:31:25.000 PM kernel[0]: GPU hang: 
14/08/13 3:31:25.000 PM kernel[0]: Trying restart GPU ...
14/08/13 3:31:25.000 PM kernel[0]: MAIN ring is NOT waiting on an event
14/08/13 3:31:31.123 PM coresymbolicationd[130]: /System/Library/Caches/com.apple.coresymbolicationd/data did not validate, resetting cache
14/08/13 3:31:31.000 PM kernel[0]: stampWait: Overflowed checking for stamp 0x33 on MAIN ring: called from sleepForTimeStamp
14/08/13 3:31:31.000 PM kernel[0]: timestamp = 0x0032
14/08/13 3:31:31.000 PM kernel[0]: GPU hang: 
14/08/13 3:31:31.000 PM kernel[0]: Trying restart GPU ...
14/08/13 3:31:31.000 PM kernel[0]: MAIN ring is NOT waiting on an event
14/08/13 3:31:31.409 PM ReportCrash[129]: DebugSymbols was unable to start a spotlight query: spotlight is not responding or disabled.
14/08/13 3:31:32.457 PM ReportCrash[129]: failed looking up LS service ( scCreateSystemService returned MACH_PORT_NULL, called from SetupCoreApplicationServicesCommunicationPort, so using client-side NULL calls.
14/08/13 3:31:32.458 PM ReportCrash[129]: LaunchServices/5123589: Unable to lookup coreservices session port for session 0x186a0 uid=0 euid=0
14/08/13 3:31:32.458 PM ReportCrash[129]: failed looking up LS service ( scCreateSystemService returned MACH_PORT_NULL, called from SetupCoreApplicationServicesCommunicationPort, so using client-side NULL calls.
14/08/13 3:31:32.458 PM ReportCrash[129]: LaunchServices/5123589: Unable to lookup coreservices session port for session 0x186a0 uid=0 euid=0
14/08/13 3:31:32.458 PM ReportCrash[129]: failed looking up LS service ( scCreateSystemService returned MACH_PORT_NULL, called from SetupCoreApplicationServicesCommunicationPort, so using client-side NULL calls.
14/08/13 3:31:32.458 PM ReportCrash[129]: LaunchServices/5123589: Unable to lookup coreservices session port for session 0x186a0 uid=0 euid=0
14/08/13 3:31:32.458 PM ReportCrash[129]: failed looking up LS service ( scCreateSystemService returned MACH_PORT_NULL, called from SetupCoreApplicationServicesCommunicationPort, so using client-side NULL calls.
14/08/13 3:31:32.458 PM ReportCrash[129]: LaunchServices/5123589: Unable to lookup coreservices session port for session 0x186a0 uid=0 euid=0
14/08/13 3:31:32.458 PM ReportCrash[129]: failed looking up LS service ( scCreateSystemService returned MACH_PORT_NULL, called from SetupCoreApplicationServicesCommunicationPort, so using client-side NULL calls.
14/08/13 3:31:32.458 PM ReportCrash[129]: LaunchServices/5123589: Unable to lookup coreservices session port for session 0x186a0 uid=0 euid=0
14/08/13 3:31:32.479 PM loginwindow[44]: MIG: server died: CGSGetDisplayModeDescriptionOfLength
14/08/13 3:31:32.623 PM ReportCrash[129]: Saved crash report for WindowServer[87] version 332 to /Library/Logs/DiagnosticReports/WindowServer_2013-08-14-153132_localhost.crash
14/08/13 3:31:37.613 PM com.apple.launchd[1]: (com.apple.DumpGPURestart) Throttling respawn: Will start in 4 seconds
14/08/13 3:31:37.000 PM kernel[0]: stampWait: Overflowed checking for stamp 0x5c on MAIN ring: called from sleepForTimeStamp
14/08/13 3:31:37.000 PM kernel[0]: timestamp = 0x0034
14/08/13 3:31:37.000 PM kernel[0]: GPU hang: 
14/08/13 3:31:37.000 PM kernel[0]: Trying restart GPU ...
14/08/13 3:31:37.000 PM kernel[0]: MAIN ring is NOT waiting on an event
14/08/13 3:31:42.636 PM com.apple.launchd[1]: (com.apple.DumpGPURestart) Throttling respawn: Will start in 9 seconds
14/08/13 3:31:42.000 PM kernel[0]: stampWait: Overflowed checking for stamp 0x5c on MAIN ring: called from sleepForTimeStamp
14/08/13 3:31:42.000 PM kernel[0]: timestamp = 0x0035
14/08/13 3:31:42.000 PM kernel[0]: GPU hang: 
14/08/13 3:31:42.000 PM kernel[0]: Trying restart GPU ...
14/08/13 3:31:42.000 PM kernel[0]: MAIN ring is NOT waiting on an event
14/08/13 3:31:47.658 PM com.apple.launchd[1]: (com.apple.DumpGPURestart) Throttling respawn: Will start in 4 seconds
14/08/13 3:31:47.000 PM kernel[0]: stampWait: Overflowed checking for stamp 0x5c on MAIN ring: called from sleepForTimeStamp
14/08/13 3:31:47.000 PM kernel[0]: timestamp = 0x0036
14/08/13 3:31:47.000 PM kernel[0]: GPU hang: 
14/08/13 3:31:47.000 PM kernel[0]: Trying restart GPU ...
14/08/13 3:31:47.000 PM kernel[0]: MAIN ring is NOT waiting on an event
 

CrashLogs.zip

Share this post


Link to post
Share on other sites

I am back Dr.Hurt.

 

I tried both DSDT with both RAM option. Neither worked for me.

Is there anything I need to do extra ?

 

Here is process I am following to.

 

Created boot USB from 10.8.4 Mac App store App.

Boot from it.

Created partition.

Installed on one partition.

Booted with USB and selected fresh partition on which we installed ML.

Installed Chameleon with Chameleon Wizard App. I Installed Boot0hfs, 2255 revision.

Made some change to boot.plist file. I am attaching this boot.plist file.

Set SMBios to Mac Min 6,2

Placed your DSDT to Extra folder and also put SMBios.plist and boot.plist in Extra folder.

 

Reboot. Nothing difference. It is same checkers screen as with device-properties way. I am attaching screenshot of that also.

 

Please let me know whether it is supported or not. Also I found that i3 3220 has device id 0152 but you set 0166 in DSDT. Is that ok ?

Edit: First, delete AppleIntelGraphicsPowerManagement.kext and try again (boot with -f) with the same DSDTs from the previous post. If not, try with this DSDT attached below.

 

The id is normal. Its the HD4000 id which is also present in the kexts.

 

Give this last DSDT a test. I have set the id of the HD3000 IGPU as a last desperate attempt.

 

Tell me how it goes.

DSDT.aml.zip

Share this post


Link to post
Share on other sites

Edit: First, delete AppleIntelGraphicsPowerManagement.kext and try again (boot with -f) with the same DSDTs from the previous post. If not, try with this DSDT attached below.

 

The id is normal. Its the HD4000 id which is also present in the kexts.

 

Give this last DSDT a test. I have set the id of the HD3000 IGPU as a last desperate attempt.

 

Tell me how it goes.

There is no AppleIntelGraphicsPowerManagemnet.kext. But I found AppleGraphicsPowerManagement.kext. I have deleted that and tried with -f but same result. I am going to try your new DSDT now.

That time panic happen. Don't able to boot with that also.

 

is it possible that my App Store purchase is corrupt ?

Share this post


Link to post
Share on other sites

There is no AppleIntelGraphicsPowerManagemnet.kext. But I found AppleGraphicsPowerManagement.kext. I have deleted that and tried with -f but same result. I am going to try your new DSDT now.

That time panic happen. Don't able to boot with that also.

 

is it possible that my App Store purchase is corrupt ?

 

I guess its time for you to get a discreet graphics card then. I'm sorry.

Share this post


Link to post
Share on other sites

Hey! I just want to inform you that I bought a Sapphire Radeon HD 6670 Ultimate (1GB GDDR5and it works great! I have not changed my installation and simply plugged in the graphics card. It was immediately recognized and has worked out of the box. I can recommend my graphics card to all the HD2500 injured. The Sapphire Radeon HD 6670 Ultimate is worth its price, passively cooled and even has a display port!! :)

 

However, thank you Dr. Hurt for your help!! This has greatly encouraged and built up.

Share this post


Link to post
Share on other sites

Been following this thread, and I'm sorry you couldn't get it working, bro. :(

 

...but is it my turn now? ;D

Share this post


Link to post
Share on other sites

Been following this thread, and I'm sorry you couldn't get it working, bro. :(

 

...but is it my turn now? ;D

I'm not really optimistic about getting the HD2500 universally working with hackintoshs.

 

Anyway, upload your DSDT and tell me your mobo's model and I'll patch it once I get back home. 

Share this post


Link to post
Share on other sites

I'm not really optimistic about getting the HD2500 universally working with hackintoshs.

 

Anyway, upload your DSDT and tell me your mobo's model and I'll patch it once I get back home. 

You can grab the stock one with no errors here.

 

Thanks for your help!

Share this post


Link to post
Share on other sites

You can grab the stock one with no errors here.

 

Thanks for your help!

 

If you're using clover (which I strongly recommend), use dropoemssdt and generateivystates options to enable native power management.

Delete any SSDTs you're using. Don't use Clover's graphics enabler.

 

In your BIOS/UEFI, set DVMT to max and video ram to 32MB.

 

Tell me how it goes.

DSDT.aml.zip

Share this post


Link to post
Share on other sites

If you're using clover (which I strongly recommend), use dropoemssdt and generateivystates options to enable native power management.

Delete any SSDTs you're using. Don't use Clover's graphics enabler.

 

In your BIOS/UEFI, set DVMT to max and video ram to 32MB.

 

Tell me how it goes.

Same, checkered area in the top left.

 

I set the VRAM to 64MB to see if that would work, but it didn't... :(

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×