Jump to content
InsanelyMac Forum
Koekwous

BCM57781 10.8.3 network connection broken ASRock Z77E-ITX

Recommended Posts

hi,

 

I have a ASRock Z77E-ITX mainboard and last week updated to 10.8.3 without any issues (combo update). I only have to install the IONetworkingFamily.kext (which i also used in 10.8.2) and audio kext, but i have some strange behavior with downloading files and for example youtube movies. I can easily reproduce the error to do some speedtest @www.speedtest.netand do a test, the test wil abort after a while. also download a speedtest file of 1GB it says network connection broken. On some youtube movies i see that some movies are not fully downloaded and abrupt sometimes. i have tried to reinstall the kext (first deleted), but also same issue. i also cannot find a newer version of this kext: "IONetworkingFamily.kext BCM57781" i use (BuildVersion - 602).

 

someone any idea? tips?

Share this post


Link to post
Share on other sites
Advertisement

Just chiming in here since we have the same motherboard 'n stuff.  I've had the ethernet port working off and on, including 10.8.3 and 10.8.4.  Lately when I've been restarting the ethernet port stops working and in the Network preference pane it just lights up as red saying "Cable Unplugged."  Then when I delete the Ethernet interface and try adding it back again it's completely gone from the choices.  I've gotten it to work but for the life of me, I can't figure out what really is the "magic" setting.

 

I was using the IONetworkingFamily.kext file from this link (http://www.osx86.net/view/3089-broadcom_netlink_bcm57781.html) but that link goes nowhere now (apparently).

 

Basically, the ethernet port has worked great for me… when it works.

Share this post


Link to post
Share on other sites

Alex, I followed your link and was excited to see this note(!):

v2.3.5 solved reboot problem which had some users. Solved problem with unplugged cable where was incorrect status.

Now the Ethernet interface shows up (YAY!!!), but I'm still having problems connecting with it.  I'm getting an invalid 169.254.XXX.XXX IP address, and setting an IP manually doesn't work either.  Here are my exact steps I've done:

 

1)  Downloaded the ML_BCM5722D.kext.zip

2)  Copied original IONetworkingFamily.kext from System > Library > Extensions

3)  In this copy, placed BCM5722D.kext into Contents > Plugins, like you suggested

4)  Installed modified IONetworkingFamily.kext into Extra > Extensions with Kext Wizard

5)  Rebooted

6)  Went to System Preferences > Network and immediately was notified of a new interface (and added it successfully)

 

Here's what System Information reports:

ethernet:

  Type: Ethernet Controller

  Bus: PCI

  Vendor ID: 0x14e4

  Device ID: 0x16b1

  Subsystem Vendor ID: 0x1849

  Subsystem ID: 0x96b1

  Revision ID: 0x0010

  Link Width: x1

  BSD name: en1

  Kext name: BCM5722D.kext

  Location: /Volumes/Hackintosh SSD/Extra/Extensions/IONetworkingFamily.kext/Contents/PlugIns/BCM5722D.kext

  Version: 2.3.5

 

I've done some furtive searching elsewhere on the invalid 169.254.XXX.XXX IP address issue and the only advice seems to be to make sure to use the right .kext file.  Should I be concerned that the fix only seems to list BCM5722D, when my actual ethernet card is a BCM57781?

 

Thanks for the tip, and I hope to finally solve this annoying problem!!

Share this post


Link to post
Share on other sites

I have BCM57780 that should be close to your model. I have internet after sleep and my internet stopped not once since I'm using 2.3.4/5 version.

Would you install Debug version and give a feedback in the same place

http://www.insanelymac.com/forum/topic/247470-bcm5722-bcm5754m-bcm5755m-bcm5787m-and-bcm5906m-nic-driver-3264-bit/?p=1939708

Maybe either I or Mieze contrive something.

----

Forgot to say, show kernel.log(Console) afterwards.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.



  • Similar Content

    • By forumi0721
      Hi
      I use Z77.  I use ASRock Z77 Extermr4 board and BCM57781 LAN (Onboard).
       
      It was ok until High Sierra.
       
      But after install High Sierra, The onboard LAN keeps disappearing.
       
       
       
      It does not seem to have LAN at all.   On linux, lspci, on windows, device manager and on mac lspci/ioregistryexplorer....   There's no lan.     The only way to get it back is the CMOS reset. (Not a bios lload default menu, H/W jumper clear).       I wonder if others have this problem.      
    • By NOMAD8459
      Hi, HELP!! haha
       
       
      System Specs are as follows:
       
      ASUS M4N98TD EVO Motherboard with Nvidia MCP78 and NF200 chip - VIA 1708S sound
       
      AMD 1090T X6 at 3.9GHz
       
      MSI GTX 660 Gaming 10de 11c0
       
      8GB DDR3 1600mhz Ram
       
      I have successfully installed Snow Leopard but cant seem to update it past 10.6.3 without Kernel Panics, I also believe that support for the GTX 660 is not good.
       
      Using my snow leopard install, I created a Mountain Lion USB installer with the amd_kernel - using the boot flags:
       
      amd_kernel cpus=1 busratio=18 npci=0x2000 USBLegacyOff=Yes PCIRootUID=0 -v -f
       
      I managed to get the installer to run and install, it completed and said installation successful.
       
      I haven't been able to boot into the OS as yet however.
       
       
      All seems to be going well, with the kexts loading and SUCCESS coming up everywhere, then after macosx_swapon which is OK the loading seems to grind to a halt, it loads NVGK100Hal and also finds my Bluetooth dongle, assigns an internet address but just gets no further, it seems to be stuck just before it would normally say DSMOS has arrived....
       
      Any ideas would be most gratefully received....Many Thanks

    • By pazz0r
      Hallo liebe Community,
       
      ich bin hier wenn ich ehrlich bin so langsam wirklich am verzwifeln.
       
      Gleich vorne weg ich bin zwar kein ahnungsloser Anwender aber die Installation eines Bootloaders in mein System raubt mir den letzten Nerv!
       
      Zu meinen Spezifikationen:
       
      Asus K56CB
      Intel i5-3337U Ivy-Bridge
      750GB HDD Sata
      8GB Ram
      Nvidia 740M GPU
      Intel HD 4000 Graphics
      und so weiter...
       
      Um es direkt zu erwähen, ich habe alles so geregelt das mein Mountain Lion 10.8.3 auch trotz Optimus Technologie problemlos läuft.
       
      So nun zum eigentl. Problem... Ich habe ein UEFI System und schaffe es glaub auch mit 1000 weiteren Anleitungen nicht einen Bootloader so zu installieren das nach einem Neustart ohne BootCD nicht die Meldung "Insert proper boot device and restart" kommt.
       
      Ich weiß das viele sagen nutze keinen Chameleon Bootloader auf UEFI Systemen aber selbst diesen habe ich in den letzten Tagen ausprobiert.
       
      Nun an euch... was kann man denn bitte so enorm falsch machen das er einfach keinen Bootloader schluckt... Im Bios habe ich auch schon etliche Einstellungen ausprobiert doch es scheitert immer an der selben Stelle.
       
      Fast Boot ist aus, Launch CSM ist eingeschaltet und Launch PX oPRom oder wie das genau heißt ist ausgeschalten.( Hab alle Kombinationen schon druchprobiert )
      Kann man denn irgendwie seine UEFI Partition so zerschießen das sie nicht mehr funktioniert?! Ich weiß nicht mehr weiter.
       
       
      Ich hoffe ihr könnt mir helfen!
       
      Meine momentane BIOS Einstellungen und die Oberfläche allgemein könnt ihr euch im Anhang betrachten.
       
      Vielen lieben Dank, denn ansonsten rennt das Teil wie eine Eins!








    • By Regi Yassin
      patched kext for Ethernet Broadcom BCM57781
      Mavericks 10.9.2 (13C44, Beta 3)
       
      device id 14e4, 16b1
       
      patched by Regi Yassin
    • By DaSeeka
      Hey guys, new to InsanelyMac, seems like a great community.
       
      I recently got a EVGA GTX 780. I do a lot of gaming, which was my primary reason for that choice, but I also do some Adobe work on my OSX install. Understanding the known bugs with this card and 10.8.3, I determined that they would not affect my work that much (really just wanted that CUDA!).
       
      So I got it working on OSX, and obviously W7 fine, using the nVidia web drivers.  OSX recognized it by name a details in system info and I was getting excited!!
       
      Then reality set in...After trying to enable CUDA using terminal commands I found on several sites, I realized even though the computer knew it was a 780, it wasn't truly recognizing it. When I would use GPU Sniffer for enabling CUDA for AE, I wasn't getting the same info as many others. It wasn't giving me the dialogue "Name: GTX 7xx...." but rather something like "Engine: Nvidia GTX 780 OpenGL Engine....". So I was unable to get that working and could not find a real reason or anyone else experiencing the same issue.
       
      Then on Windows, thinking it might be a BIOS or GPU firmware incompatibility, I tried installing the latest firmware for the 780. In the prompt for installation, at the "finding devices..." it determined I had no compatible devices....even though I had the latest GPU drivers installed and could max out all my games and tweak the card using the nvidia control panel.
       
      Now, my question is...Is this in fact a motherboard/BIOS incompatibility? My current MOBO is the GA-Z68X-UD3H-B3 w/ UEFI U1h. They released an updated UEFI, U1l, in march '13, but I can't find any info if that is a GPU/7xx series compatibility update or something.
       
      Does anyone have any info on this matter? Really don't want to have to upgrade my MOBO and potentially my CPU if I don't have to.
       
      Thanks!
       
      P.S. This might also be a clue to the culprit....since upgrading my GPU, the MOBO splash screen hangs for about a minute or so on boot until finally going into the normal selection screen...I can't access BIOS either, if I try, my screen goes black once the spalsh screen moves on.
×