Jump to content
artur_pt

10.8.4 Betas Builds

195 posts in this topic

Recommended Posts

AGPM mostly didnt help with the wellknown "Nvidia OpenGL Channel timeout". Started in past with fermi gpus, but with an early 10.8.3 dev build even my 9600 GT got that problem - never had that (fermi) problem before.

AGPM was working before and after. And the only solution was one of the later 10.8.3 dev builds.

So it has to do with the Nvidia drivers and the AGPM (settings, working or not) may help to reduce the timeouts but will not avoid them completely.

 

I have been using build 12E30 for a week and none a single freeze by then. Try it and post back your results.

 

Good luck

Share this post


Link to post
Share on other sites
Advertisement

Mountain Lion 10.8.4 Beta (12E30)

12E30.png

Sweet...

 

Fabio

EDIT:

CUDA Feature gone... waiting until nvidia update it (w8 until Apple release the final 10.8.4).

Fabio

 

Ciao scusa, come fai a gestire due monitor con la scheda Nvidia Quadro?

Grazie

Ciao

This is related with you bootloader or with your DSDT injection or with your EFI string injection or with some custom kext...

In my case I use the simply GraphicsEnabler=Yes in o.c.B.p (org.chameloen.Boot.plist)

Share this post


Link to post
Share on other sites

I have been using build 12E30 for a week and none a single freeze by then. Try it and post back your results.

 

Good luck

 

Same here :)

Share this post


Link to post
Share on other sites

New update works fine. Only AppleHDA needed replacing.

Share this post


Link to post
Share on other sites

At the moment I'm testing the 10.8.4 nVidia kext + (my) patched AGPM.kext and the robertx openGL patch.

Hopefully this will reduce/remove the openGL timeouts..

 

One interesting thing, when browsing on the nVidia website I found this page, explaing that 305.53 driver gives OpenGL 4.3 Support for some Fermi/Kepler CPU's. The 'default' OS X 10.8.3 version has: 304.10.65f03. The 10.8.4 driver has 310.40.00.05b03. Could it mean that their simple was no (real) support for Fermi users in 10.8.3 and this has been added (due the new drivers) with 10.8.4?

 

Will keep you posted. :)

 

Thanks!

 

Update: Just got a freeze again! :(

Share this post


Link to post
Share on other sites

I am unsure, or better i think that your page link is an information for Windows OpenGL, which may implement different OpenGL Features than OS X.

At least tessellation OpenGL feature isnt available (even on 10.8.4). Which is normally an feature of 4.x, when gpu has that hw feature.

 

I dont think that Apple has the focus to implement fast "newer" OpenGL 4.x features into OS X. Less presure from users and devs on mac apps to implement that soon.

Looks different on the workstation (non Apple) market. Some 4.x features, beside tess, can speed up professional OpenGL Apps and / or make opengl dev more easier (less source code steps compared to 3.x for same functions).

Share this post


Link to post
Share on other sites

At the moment I'm testing the 10.8.4 nVidia kext + (my) patched AGPM.kext and the robertx openGL patch.

Hopefully this will reduce/remove the openGL timeouts..

 

One interesting thing, when browsing on the nVidia website I found this page, explaing that 305.53 driver gives OpenGL 4.3 Support for some Fermi/Kepler CPU's. The 'default' OS X 10.8.3 version has: 304.10.65f03. The 10.8.4 driver has 310.40.00.05b03. Could it mean that their simple was no (real) support for Fermi users in 10.8.3 and this has been added (due the new drivers) with 10.8.4?

 

Will keep you posted. :)

 

Thanks!

 

Update: Just got a freeze again! :(

 

Wich build are you using 12e33a or 12e30?? because I got 2 freeze in 12e33a but none on 12e30. I´ll continue using 12e30 to see if this drivers correct the freeze.

 

Good Luck

Share this post


Link to post
Share on other sites

Wich build are you using 12e33a or 12e30?? because I got 2 freeze in 12e33a but none on 12e30. I´ll continue using 12e30 to see if this drivers correct the freeze.

 

Good Luck

Thanks for reporting. I'm using the newest 12e33a. I'm going to try the 12e30 driver, maybe they work correctly. :)

 

Just one question: I only replaced the nVidia kexts. Is their need to replace other kexts/frameworks?

 

Thanks. :)

Share this post


Link to post
Share on other sites

Some inprovments in new nvidia drivers on e33a

yI1fArB.png

Jq7SHix.png

 

New nvidia drivers again,and new improvements on E36.

Vdb3jSt.png

 

Ua7gEEP.png

 

About cuda

 

before E36 update i did some changes to cuda.

I make s copy of libcuda_304.11.00.dylib and rename it to libcuda_310.40.00.dylib.

I make some changes to info.plist attached,now it dont show anymore that it needs update :D

Info.plist.zip

DJcmSn1.png

Share this post


Link to post
Share on other sites

With 12E33a, I had many freezes, on Fermi, like 10.8.3. Didn't try 12E30 but I'm not really hopeful...

Share this post


Link to post
Share on other sites

New nvidia drivers again,and new improvements on E36.

Vdb3jSt.png

 

Ua7gEEP.png

 

About cuda

 

before E36 update i did some changes to cuda.

I make s copy of libcuda_304.11.00.dylib and rename it to libcuda_310.40.00.dylib.

I make some changes to info.plist attached,now it dont show anymore that it needs update :D

Info.plist.zip

DJcmSn1.png

Pozdrav Ivica. :D

Share this post


Link to post
Share on other sites

Just installed the new NVIDIA driver that came on 10.8.4 to 10.8.3

 

During launch of Skype and iPhoto simultaneously

 

 

4/24/13 10:42:26.271 PM WindowServer[237]: CGXDisableUpdate: UI updates were forcibly disabled by application "iPhoto" for over 1.00 seconds. Server has re-enabled them.

4/24/13 10:42:48.000 PM kernel[0]: NVDA(OpenGL): Channel timeout!

4/24/13 10:43:09.000 PM kernel[0]: NVDA(OpenGL): Channel timeout!

4/24/13 10:43:29.000 PM kernel[0]: NVDA(OpenGL): Channel timeout!

 

:(

 

p5kpl-am

GTS-450

4G RAM

E8500

Share this post


Link to post
Share on other sites

@ncmontas : which build ? I'm trying 12E36 right now and for now it's stable. But I'll judge after a few days to be sure. 12E33 was freezing almost instantly though.

Share this post


Link to post
Share on other sites

With 12E33a, I had many freezes, on Fermi, like 10.8.3. Didn't try 12E30 but I'm not really hopeful...

Seems to be the same drivers (at least that what is reporting here) as on 12E33a.

 

Haven't tried the newest beta, but I got a feeling that I bought the wrong GPU for OS X. :worried_anim:

 

4/24/13 10:42:48.000 PM kernel[0]: NVDA(OpenGL): Channel timeout!

4/24/13 10:43:09.000 PM kernel[0]: NVDA(OpenGL): Channel timeout!

4/24/13 10:43:29.000 PM kernel[0]: NVDA(OpenGL): Channel timeout!

 

:(

 

p5kpl-am

GTS-450

4G RAM

E8500

Same card here.. maybe a card issue? :blink:

Share this post


Link to post
Share on other sites

@beta992 : No, 12E33a and 12E30 doesn't have the same drivers. With 12E33A I had freezes almost instantly for sure.

Try the newest beta, 12E36, for now it's been 24h I'm running it, including leaving my PC idling (which is causing the freezes almost every time with 10.8.3 kexts) and no problem. But, again, I prefer to wait a few days before I can tell that 12E36 is the key.

 

12E36 has newer drivers than 12E33A, version ends with XXXXXXXXXX.F01, F is usually used for FINAL nvidia kexts (earlier 10.8.4 builds before had a,b..., 10.8.3 GM had {censored}.f03).

Please try this build too and let me know how it goes.

 

EDIT : just had a freeze 25/04/13 14:11:16,000 kernel[0]: NVDA(OpenGL): Channel timeout!

25/04/13 14:11:37,000 kernel[0]: NVDA(OpenGL): Channel timeout!

25/04/13 14:11:44,000 kernel[0]: NVDA(OpenGL): Channel exception! exception type = 0x8 = Fifo: Watchdog Timeout Error

 

25/04/13 14:11:44,000 kernel[0]: IOVendorGLContext::ReportGPURestart

wit 12E36 :(

But, it unfroze by itself after waiting 30sec... Maybe got lucky

Share this post


Link to post
Share on other sites

@beta992 : No, 12E33a and 12E30 doesn't have the same drivers. With 12E33A I had freezes almost instantly for sure.

Try the newest beta, 12E36, for now it's been 24h I'm running it, including leaving my PC idling (which is causing the freezes almost every time with 10.8.3 kexts) and no problem. But, again, I prefer to wait a few days before I can tell that 12E36 is the key.

 

12E36 has newer drivers than 12E33A, version ends with XXXXXXXXXX.F01, F is usually used for FINAL nvidia kexts (earlier 10.8.4 builds before had a,b..., 10.8.3 GM had {censored}.f03).

Please try this build too and let me know how it goes.

 

Can I ask for the latest NVIDIA driver you have that came from the 12E36, don't have access to beta builds? I just downloaded the NVIDIA driver that is link to this thread (310.20.00a08)

Share this post


Link to post
Share on other sites

@beta992 : No, 12E33a and 12E30 doesn't have the same drivers. With 12E33A I had freezes almost instantly for sure.

Try the newest beta, 12E36, for now it's been 24h I'm running it, including leaving my PC idling (which is causing the freezes almost every time with 10.8.3 kexts) and no problem. But, again, I prefer to wait a few days before I can tell that 12E36 is the key.

 

12E36 has newer drivers than 12E33A, version ends with XXXXXXXXXX.F01, F is usually used for FINAL nvidia kexts (earlier 10.8.4 builds before had a,b..., 10.8.3 GM had {censored}.f03).

Please try this build too and let me know how it goes.

 

EDIT : just had a freeze 25/04/13 14:11:16,000 kernel[0]: NVDA(OpenGL): Channel timeout!

25/04/13 14:11:37,000 kernel[0]: NVDA(OpenGL): Channel timeout!

25/04/13 14:11:44,000 kernel[0]: NVDA(OpenGL): Channel exception! exception type = 0x8 = Fifo: Watchdog Timeout Error

 

25/04/13 14:11:44,000 kernel[0]: IOVendorGLContext::ReportGPURestart

wit 12E36 :(

But, it unfroze by itself after waiting 30sec... Maybe got lucky

Trying the new (final?) nVidia-drivers, hopefully this will change the timeouts.. :(

 

Question: what browser are you running? I know it sounds strange, but for some reason I have more openGL crashes since using Chrome instead of FireFox. :S

Share this post


Link to post
Share on other sites

Ok, I had 2 freezes tonight... And this time I had to hard reboot :( Both with 12E30 and 12E36... I think this is a dead end really.

 

Only drivers that are good for me are 10.8 DP3 ones, I never had any freeze with them. Only thing I noticed is that WebGL in Safari fails (try MapsGL with DP3 drivers, and it will spam your console with NVDA Opengl errors) which is quite funny considering it works perfectly fine with 10.8.3 kexts but sadly, I get the usual random freezes which are a pain.

 

So... I'm back to 10.8 DP3 kexts..... :(((((((

 

PS : I use Safari.

Share this post


Link to post
Share on other sites

Ok, I had 2 freezes tonight... And this time I had to hard reboot :( Both with 12E30 and 12E36... I think this is a dead end really.

 

Only drivers that are good for me are 10.8 DP3 ones, I never had any freeze with them. Only thing I noticed is that WebGL in Safari fails (try MapsGL with DP3 drivers, and it will spam your console with NVDA Opengl errors) which is quite funny considering it works perfectly fine with 10.8.3 kexts but sadly, I get the usual random freezes which are a pain.

 

So... I'm back to 10.8 DP3 kexts..... :(((((((

 

PS : I use Safari.

 

Which build in your sig and which GPU?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

×