Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

4 posts in this topic

Recommended Posts

Hi Guys.




Intel DX79TO firmware update to lastest version 2013

16 GB Ram Kignston

Video GT 440 (also used GT 220 with same results)

Kingston SSD SV300 series 120 GB (bootable)

WD 3TB (bootable)

Nexxt ION 150 WiFi card

USB Wireless Keyboard and Mouse

ML 10.8 upgraded to 10.8.2 then to 10.8.3

Chameleon latest version at the time Chameleon-2.1-r2069

Displays: 1 HP L1706 and Sony TV HDMI input 1080p


No DSDT available for this MO. :(




Built In LAN


Sound via VoodooHDA



Not Working:


USB3.0 (tried 3 versions of kexts)

Shutdown (tried all types of EvoReboots and OSXRestart etc)




SATA as usual to AHCI

Only needed to change the Front Panel Audio to DISABLE.


Actually its overclocked to 4.66G and RAM to 1410




First install was on the WD 3TB. In order to boot you must copy boot1h via dd since its a 4k hard drive. Google it for the solution "How to fix the boot0 error"


Second install on the SSD via Image Restore of the WD install.


Im not going to get into how to install a standard ML since there are tons of examples on how to get a USB or another HD to make an installation of the basic ML. I used the pinned one in this forum.


I always boot Verbose while Im installing to "see" whats going on. More on that later....













<key>Kernel Flags</key>

<string>arch=X86_64 npci=0x2000</string>

<key>Legacy Logo</key>












Once done the basic ML installation + OSUpd10.8.2 update you'll notice the mouse is very sluggish.

[solved] System>Legacy USB Support. Reboot. Ill try your patience to this this install as the mouse control is close to nada :thumbsup_anim:




The video GT440 or GT220 (did it with both) was perfect with GraphicsEnabler=Y in the org.chameleon.boot.plist. Careful where you put the VGA display since there are two vga ports but one is shared by the HDMI so if you have the HDMI and connect to the vga to the shared port you will get a black screen. Use the other vga/dvi+adapter port.




Sound did not work as usual so I tried to install many (at least 6) Realtek ALC892 versions from many sources. None worked for my combination so I used VoodooHDA_2.7.6d2 (also had to try many versions). Then in System Preferences>Sound chose the Line-Out (Green Rear) option. You might want to give it a shot with something else. Haven't tried the Mic. Apparently Video Cards with HDMI have another HDA controller and it causes "confusion".




The very economic wifi card Nexxt Ion 150 $12 is actually a Atheros 9285 code. It could work OOB if your IO80211Family.kext has the AirPortAtheros40.kext, otherwise need to install this kext.


I also tried the Tp-Link version {censored} which really is an Atheros 9485. There is no solution for this card. Did not work.


SSD Install:


After having tested the basic installation in the WD 3TB hard drive I made an image of the HD and restored it in the SSD. As usual you need to install the Chameleon bootloader. 10.8.2 was currently installed in the WD and hence the SSD.


Boot in verbose mode to see the process. VERY VERY fast, just great.


Then I went on to install al the apps I needed and migrate/setup data from the old HDs. Once I finished did a final verbose boot to check things, great. Men it does boot fast. :thumbsup_anim:


Now a standard boot and .... NO BOOT. Apple screen with the progress indicator frozen. Rebuilt kernelcache to no avail. It will only boot in Verbose Mode. What? :wallbash:


This for anybody having similar problems. [solved] Needed to install OSUpd10.8.3. Easier said than done since I fought for 2 days to stay at 10.8.2. Anyway, it worked and didnt need to reinstall a single kext when updated to 10.8.3


TA DA :trumpet:


Hope it helps.

Edited by Lejenk
Removed references.

Share this post

Link to post
Share on other sites

Hi, please take a note of this: http://www.insanelymac.com/forum/topic/279451-why-insanelymac-does-not-support-tonymacx86/


You can create your own DSDT, from Windows:



From Linux:



Use DSDT Editor to patch the DSDT. If you don't know how to, create a new topic in the DSDT section.


Use Pandaro's Box (http://www.insanelymac.com/forum/files/category/9-pandora/) instead of the software recommended previously by this "guide", not boot0 error.


About the sound, provide a codec.txt file, or at least a model.

Share this post

Link to post
Share on other sites



Thanks for the DSDT idea. Did that and solved some problems, shutdown/restart among the most important.


No luck with Audio via AppleHDA. Made at least 30 different configurations. Got the PinConfigs from Windows and put them in the AppleHDAHardwareConfigDriver plist. Showed the outputs channels but no sound at all on the Green-Rear, usually the standard output.


Played a lot with AppleHDA mod. It was being recognized since I erased many configs to see if it was being loaded and didnt show any channels which proved the modded AppleHDA was been loaded. Changed Layouts, etc to no avail.


Also compared PinConfigs from Windows to VoodooHDA dump (which works 2.8.2), and they are different. Changing them in AppledHDA didnt work. Used some combination of AppleHDA + HDAEnabler. No go.


Anyway I include the modded AppleHDA, the DSDT (with ALC892 fix) and the Pinconfigs from windows.


Great if you can help.




Share this post

Link to post
Share on other sites

Glad creating/editing the dsdt solved a few problems.


About the audio, i use this guide mostly: http://www.insanelymac.com/forum/topic/283754-patched-applehdakext-for-codecs-idt-92hd81b1x5-92hd91bxx-and-92hd87b24/

Extracting the codec from linux will provide more information, perhaps it's not the ALC892, will be shown in the first 5 lines of the codec.txt, of which i was speaking.


The guide provides Windows method too i think, but i only have used Linux for this, and only for my own sound chip.

So i don't know anything about the pinconfig from Windows, the Linux extraction is more sorted :)


Anyway, i can't help with the sound, hopefully the guide points something out you might have missed.

Best of luck :)


PS: Use Ubuntu, it provides a LIVE environment, no need to install it, just boot it from USB.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.