Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sign in to follow this  
3dadd

Nvidia Quadro 4000m (HP Z1 version)

2 posts in this topic

Recommended Posts

I've got my HP Z1 w/Q4000m card mostly working. The most nagging issue is getting the internal Display to work 100% of the time after I changed the Display card Device ID in the NVDAStartup.kext. When I do get it working, I appear to get full acceleration and external monitor support as well using the standard 10.8.2 or 10.8.3 drivers.

 

After several reboots the displays will go black as the driver fails to load. I can get back to the desktop by : -f PCIRootUID=0 GraphicsEnabler=Yes npci=0x3000 and then need to use an external display. The internal display only works if the boot flag GraphicsEnabler=No is set.

 

The version of the Quadro 4000m is special for the Z1. There are several different cards available and more coming. It's an excellent machine when it's running. Very fast and excellent speed on the graphics.

 

System:

HP Z1

10.8.3 (using App Store full installer)

Intel Xeon - (this is critical as many Z1's come with Corei5 or i7 and Intel HD graphics) WIth the Xeon model there is no support for the Intel HD 3000/4000 graphics.

32GB RAM

Boot from External USB 2.0 drive (switch it to USB 3.0 after Install drivers)

Audio - needs Voodoo 2.8.2

 

In order to get the internal display to work, I needed to use PlistEdit Pro to modify the Device ID of the Q4000m card (device id= 0x0e3b) . This will light up both displays , but after a reboot they both go black again. Not sure if it's writing a plist or cache file which is causing the issue.

 

Here's the change I made in the NVDAStartup.kext

 

original:

 

<key>IOPCIMatch</key>

<string>0x000010de&0x0000ffff</string>

 

change to Quadro4000m device ID

 

<key>IOPCIMatch</key>

<string>0x000010de&0x00000e3b</string>

 

Again, this will work until a reboots.

 

Questions:

Am I modifying the correct kext?

I've search for guides for hacking nvidia kext but most are out of date.

Are there other NVIDIA Kext that I need to modify.

 

 

any help would be appreciated.

 

thanks.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Posts

    •     Install from fresh again. This time without Tony Tools, follow some guide in this topic. Install IntelHD kexts as usual in S/L/E and thats it. Everything works again, except for backlight, I never could have this work, also got heating problem and when boots apple logo dissapears from like 5 seconds and then appear the login window... Any ideas on any of this????  
    • MAld0n, I can't post a new topic on post installation forum. is it on maintenance?
      Notebook Asus X550VX i7 - 7700hq
      GTX950MX - UHD630
      A1718086 - 025510ec ALC255 that works only on VoodooHDA 
      RTL8111 LAN Hwinfo
      https://drive.google.com/open?id=1n5rHIw-jDPCgocWJtZ0AoVlqIi6Xc7XL   Not work:
      1. White Screen Wake up
      EDID not a asolution
      IOREG output http://www.mediafire.com/file/u7odzbaxa7bbb6a/ioregSaved.txt and EDID
      http://www.mediafire.com/file/hqlapgf4luwchdf/DisplayProductID-69c.plist Image
      https://ibb.co/faL5wx 2. Battery info status bar sometimes goes on / off like battery has off
      3. Crackle Sound using   earphone using VoodooHDA
             Still investigation using patched iomatch voodooha info.plist
             The sound card can’t be using AppleALC, no sound came out using layout 3, 13, 17, 18, 27, 28, 99
      I have your (Mald0n) DSDT   http://www.mediafire.com/file/lmp5yy65rblx9ne/DSDTtitomaldon2.dsl   I have re-patched again for FnKeys and Brighness Key http://www.mediafire.com/file/5rs93ij0wco99s6/DSDTtitomaldon2editv2.aml

       
      codec dump linux
      https://drive.google.com/file/d/1pg2y76WvFYsO8vFY-2B_2OLyKMmkQ8Tg/view
       
       
      latest debug
      http://www.mediafire.com/file/2pjny4eq5r64ed8/debug_1383 (1).zip
       
      clover and kext
      https://drive.google.com/open?id=1n5rHIw-jDPCgocWJtZ0AoVlqIi6Xc7XL
       
    • somehow I can't post a topic using safari and Firefox on Mac. no box for inserting text, is this kind of maintenance?  
    • Hello Allan!   I do have ACPIBatteryManager.kext and if i use IntelBacklight then I get stuck on boot with an error along of the lines of "busy timeout, (60s), : 'PEG0'". I have tried to patch the DSDT but failed. If i understand right, ACPIBatteryManager.kext needs DSDT edits to work? same goes for IntelBacklight?   EDIT: I tried to edit my stock DSDT using MacIASL again and i applied the battery patch for Asus Q550LF from @RehabMan Repo! I also applied the AsusFNkey DSDT patch. Now the battery meter pops up when i unplug the laptop. If i plug the charger back in, then the battery meter stays but does not update to show that the charger has been plugged in. Ive attached the DSDT below.. DSDT.aml.zip
    • Unfortunately it still doesn't sleep. Monitor does but not computer


×