Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Peter Wrotniak

ASUS N56VZ - nVidia GT 650M or Intel HD4000 and Intel HD Audio - little help needed

7 posts in this topic

Recommended Posts

Hello there!


Yes I know there's google and I was using it much lately, though I'm really new to Hackintoshes and would be grateful for any help.


So after many hours spent and cried at my desk I have finally made my USB working(cause I couldn't boot with USB enabled in BIOS) and so I bought usbWifi card and got this thing working. I have removed some kext files and after few or more tries I'm able to boot normally without -x flag (it takes some time, if there's any way to boot with kernel cache use please let me know ;)


I'm running 10.8.2


1) Graphics

I heard that it is possible to make nVidia GT 650m work if Intel HD 4000 had been somehow disabled - can't do it in bios, there's no such option. Yes I have installed the latest bios before trying Hackintosh.


However here getting any video card fully working would be very appreciated - I'm having strong lags while using LaunchPad and can't watch any video some webpages same thing. System Info is telling me UKNOWN graphic card 64 mb shared system memory. I have tried many kext, bootflags and device-properties in chameleon, deleted all nvidia files. It just doesn't work.


Only one good thing here is I have set resolution to 1920x1080 (full hd screen) with "Graphics Mode" flag.


2) Audio

I got Intel HD Audio. I have tried VooDooHda many versions, can't get it working.


Thank you in advance for any help, I've made much effort and willing to try anything that could help.

I've exported DSDT as far as I have understood what it is it can help so I'm attaching it.

Share this post

Link to post
Share on other sites



About step 1, be happy if the Intel HD4000 works.


About step 2. Try patching the AppleHDA.


My information is useless right? So is yours.


I am really interested on what system you are trying to install OS X on.

Short summary, provide us with more system information, so we can actually help you.



Share this post

Link to post
Share on other sites

Thank You for your reply!



Intel Core i7-3610QM 2.3 GHz

Intel HM76

NVIDIA GeForce GT 650M - 2048 MB, Core: 835 MHz, Memory: 900 MHz, DDR3

Intel HD 4000

4 USB 3.0, 1 VGA, 1 HDMI, 1 Kensington Lock, Intel HD Audio

MAT{censored}A BLURAY,


BluRay drive is working so is USB (haven't checked the speed yet). Internal Touchpad is working though as mouse not touchpad (using usb mouse so it is not a problem).


Early Morning I have fixed sound problem - works like a charm (both internal speaker and mic). No problems with connecting mics and headphones (both minijack and usb).

VooDooHDA newest ver - 2.8.2 + I have restored kext I have accidently removed - IOAudioFamily.kext


I was trying to enable nvidia - ended up restoring my system now using time machine


I dont know if it's important but I'm booting to OSX using iAtkos installation DVD but all flags are on my hard drive (Chameleon v2).

Currently I'm kinda afraid to change the bootloader but I think I should use Clover 'cause of UEFI BIOS i got.



Another thing is I can read line about an error while verbose booting that my CPU is unknown and power management won't work or won't partly work, can't tell precisely it's only visible for few seconds.


About graphics: I was trying few <key>Device-properties</key> strings but none worked.


Is there any way to make my boot faster (using KernelCache) or it is just impossible on my system?


Thank You for any help.

Share this post

Link to post
Share on other sites

Intel HD4000 Graphics acceleration on Lenovo laptop - OSx86 10.8 (Mountain Lion) - InsanelyMac Forum


this are the possibles efi strings for hd 4000 lappy

ig-platform-id: 01660000, Stolen RAM for FB: 96MB, Pipes: 3, Ports: 4, FBMem: 3




ig-platform-id: 01660001, Stolen RAM for FB: 96MB, Pipes: 3, Ports: 4, FBMem: 3




ig-platform-id: 01660002, Stolen RAM for FB: 64MB, Pipes: 3, Ports: 1, FBMem: 1




ig-platform-id: 01660003, Stolen RAM for FB: 64MB, Pipes: 2, Ports: 2, FBMem: 2




ig-platform-id: 01660004, Stolen RAM for FB: 32MB, Pipes: 3, Ports: 1, FBMem: 1




ig-platform-id: 01660008, Stolen RAM for FB: 64MB, Pipes: 3, Ports: 3, FBMem: 3




ig-platform-id: 01660009, Stolen RAM for FB: 64MB, Pipes: 3, Ports: 3, FBMem: 3




ig-platform-id: 0166000A, Stolen RAM for FB: 32MB, Pipes: 2, Ports: 3, FBMem: 2




ig-platform-id: 0166000B, Stolen RAM for FB: 32MB, Pipes: 2, Ports: 3, FBMem: 2




try it

good hack

Share this post

Link to post
Share on other sites



u must test it all options for ig-platform-id


new guide..


Intel HD 4000


about power management u must have a proper dsdt to have native power management to use appleintelcpupowermanagement.kext


and u must read a lot about hack mac os x


mac os x is for mac and developed for mac


hack mac os x is 99% of reading, googling, persistency and 1% of luck u hardware be compatible..


if this is not u case.. forget it...


u must think in have a proper system, with graphics working, audio working, power management and then think in to boot fast...


good hack

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By MetalBreaker
      I noticed some weird behavior with macOS High Sierra. This system was working just fine on Sierra 10.12.5, until I decided to update to High Sierra (10.13.3). The upgrade process went mostly fine I guess, but it got stuck in an infinite spinning wheel which would just keep overlapping. I went into verbose mode, and sure enough, I found "IOConsoleUsers: gIOScreenLockState 3, hs 0, bs 0, now 0, sm 0x0" repeating over and over along with ACM errors... I'm really lost right now. I can boot in recovery mode and safe mode just fine, when the graphics drivers aren't loaded. Web drivers aren't installed. I installed NvidiaGraphicsFixup, but it didn't fix the issue. I tried deleting the native graphics drivers from macOS and installing web drivers, but it didn't help.
      SMBIOS: iMac13,1
      Graphics card: ASUS GT630-2GD3 (It's a Fermi card and it needs injection, so I modified my DSDT. Full graphics acceleration worked in Sierra. No Clover injection. I tried using Clover injection instead, I saw no difference.)
      CPU: Intel Core i3-3210, iGPU disabled in UEFI

      All kexts updated to their latest versions, along with Clover.

      For more info, you can refer to the GitHub issue where I posted it. https://github.com/lvs1974/NvidiaGraphicsFixup/issues/3
      Any help would be appreciated.
      Thank you for your time!
    • By yaoqb
      i have strange glitch problem on my fresh 10.13.2 install
      the glitch trigered randomly
      it may start from subtitle video from firefox or some transparent panel from a program like clover configurator
      then the whole desktop will have the graphic glitch every program will be affected
      the glitch may clear when toggle the program window zoom in and out but will be likely popup again until restart the system
      the glitch can even be captured by the system's own screenshot short cut
      the following method i try didnt work
      nvidia webdriver latest lilu with NvidiaGraphicsFixup different powermanagement setting

    • By LuCyr04
      Hi guys, I have a weird problem using an Xeon E5450(775 modded) with nvidia card(8600gt & Quadro 580 FX same problem).
      First I want to say that in windows I don't have any problem, so it's not something about compatibility.
      When I try to boot in macOS with this cpu and nvidia video card I get only a glitch displayed(see attachments), the computer isn't froze, I can access it with ssh or file sharing, only no image.
      If I boot with nv_disable=1 flag I get image(no acceleration of course) and everything's fine.
      I tried the cpu on 2 different boards and 2 different nvidia cards and the problem is the same.
      With amd video card I don't have this problem.
      What I tried and failed:
      Deleting injection from dsdt and injecting or not injecting with clover.
      Using nvidia web drivers.
      Changing CPU settings from bios, like virtualisation, speedstep etc.
      Different macos versions(10.11, 10.12, 10.13)
      The hack I want to use with this CPU is the Desktop from signature, I can provide dsdt or entire efi if it's needed but I don't think it matters since I have the same problem with 2 different boards and 2 different nvidia cards.

    • By Ron Lemmens
      Since I've installed a new GTX 1050ti I'm experiencing strange graphic glitches, e.g. some parts of application screens get scrambled (graphic noise), see attached example where the same page is loaded in both Firefox (scrambled on the left) and Safari (normal on the right).
      I had to upgrade to a newer graphics card because my old GTX 660 was no longer supported in MacOS 10.13 High Sierra.