Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
vol264

Kernel Panic on ASUS P5Q

4 posts in this topic

Recommended Posts

Hi,

 

I have a perfect working Snow Lepoard on my hack but would like to upgrade to Lion. I've tried a lot of options, but everytime when I boot i get kernel panic (see attached picture).

 

So what is the current situation:

 

1. Have a bootable USB stick with Lion and Chameleon 2.1 (checked on real MAC and is booting OK)

2. smbios.plist (Mac 3,1 optimized)

3. com.apple.Boot.plist

<key>Boot Banner</key>

<string>No</string>

<key>Kernel</key>

<string>mach_kernel</string>

<key>Kernel Flags</key>

<string></string>

<key>Timeout</key>

<string>3</string>

<key>RestartFix</key>

<string>Yes</string>

4. Have an optimized DSDT (only fakesmc.kext is needed on SL)

5. Exrta/Extensions (FakeSMC, tried also (IOAHCIBlockStorageInjector, AHCIPortInjector))

6. Tried with kernel flags (acpi=off, PCIRootID=0 and 1, no kernel cache, no graphics enabler)

7. Have unplugged CD/DVD and 1TB disk

8. Checked BIOS settings

 

I really have no more ideas what to try.

 

Any ideas what could be worng?

 

Thanks

post-515577-0-28204200-1362726166_thumb.jpg

Share this post


Link to post
Share on other sites

Restored Lion on the USB stick again and now it goes forward but now I'm stuck on the white screen after apple logo.

 

Tried PCIRootUID, npci, GraphicsEnabler.

 

When I do -f or -s I get then th same kernel panic as in first post.

 

Are there normally problems with USB stick when restoring images onto them? I suspect that this could be the same issue.

Share this post


Link to post
Share on other sites

-f -v -x PCIRootUID=1 UseKernelCache=No GraphicsEnabler=No npci=0x2000 cpus=1

 

Use only FakeSMC.kext and NULLCPUPowerManegemente.kext in S/L/E of your USBInstaller, in the root USBInstaller folder Extra with smbios.plist/org.chameleon.boot.plist/DSDT.aml, make a new USBInstaller with MAP/MBR Format/HFS+ , RESTORE with Disk Utility .dmg LION, InstallChameleon, make a Extra Folder, and try again, in your photo I see what the problem is Installer corrupt or you have made this wrong, serch for a guide how to mke a USBInstaller, take a look here.

 

The all-in-one guide to Vanilla OS X Mountain Lion + Chameleon + DSDT for beginners http://www.insanelymac.com/forum/index.php?showtopic=280756

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Posts

    • Hello Mald0n:

      Nice to meet you, I have created a post about my problem on High Sierra before and I was redirected to this guide by Allan.

      As mentioned in the post, I was not able to get pass the login screen at initial boot and the system could not shutdown occasionally.

      However I solve the high temperature problem when I replace the clover folder you provide on first post, currently the cpu temperature is around 5x-6x'c after 10 mins up time.

      Attached is the clover folder, ioreg as well as the send me app, thanks for your help!

      p.s. I notice that your clover boot efi is a old traditional grey apple boot logo, Is there a version of modern dark and white logo one that I could replace with? Thank you!

      https://www.insanelymac.com/forum/topic/333867-cant-get-pass-2nd-stage-boot-logo-on-initial-boot-and-high-temperature/    
    •   Still garbled sound in earphone. The speaker is loud as previous. louder than 2.9.1   
    • Up for https://sourceforge.net/p/cloverefiboot/wiki,
    • Has anyone had success/failure with using UPnP working with this Intel Network? I have a onboard Intel I219V2, that is working quite well, except I can't make UPnP work.  It works fine for other devices on my network, and my previous mac Mini.   In fact, I've not been able to get forwarded ports working even if I do them manually.   Any help or pointers towards where to look would be greatly appreciated.     (High Sierra, i7-8700K, ASUS ROG STRIX Z370-G)
    • Hi,  the resoldering complete socket would kill the board totally in couple month (as the guys from super-duper repair shop told me). It's all because of gygabite layered silicon grade. The layers are so thin, that they give 90% chance, that board would work correctly only a couple month until it would die. Even with IR equipment they have, gygabite silicon starting to get micro-bubbly 10-20 C before target desoldering temperature. So they not recommending to do it with this particular z97 lineup.   About pins - they are corrected with a microscope and skilled technician. As they broke right near the start, I won't be able to do it with looking glass I have). He did it quite good, visible that they were repaired, but esthetically looking super good.    As for build and Oz in it.  Current configuration is: Xeon e3 1245v3 CPU Z97hd3 Mobo Msi gtx 1050ti gaming X GF 1) Before pins problem, after I flash anything infused with Oz - it won't work with the graphics card installed. If I pull it out, flash, get bios setting right, boot and reset NVRAM (or clear CMOS, bios setting, NVRAM) than install graphics card - it freezes every boot.   2) If I press the CPU cooler a little bid, just give it a solid push - it kinda boots without a freeze, but not correctly. Bios go flickery.  3) After I pushed CPU couple times, I started to get random BSODS on windows, so I tested RAM. One dim would give me errors. I don't know, is this went after pushed a bid CPU cooler, or it was like that, but using totally different ram would give same freezes with OZ.  4) Tomorrow I would go again to this repair shop, they would try to perform another round of magic tricks. As this mobo work correctly (fully) with windows 10 - they not recommending it for full socket resolder. damaged pins were reserved. Maybe OZ uses them after all, but they were repaired. It's all looking magic, but there is no magic. If swapping not XEON CPU won't help it (but I saw builds with OZ and XEON), then I would search for another board or platform.       


×