Jump to content
verteks

AppleIntelHDGraphicsFB fixed (SL 10.6.8)

276 posts in this topic

Recommended Posts

Ok. Thanks! I try it.

You update your system to 10.8.3?

After updated in my system QE doesn't work. I changed kexts to old, but nothing changed.

Share this post


Link to post
Share on other sites
Advertisement

The first screenshot is telling me that the framebuffer did not load. I use to get that screen when only AppleIntelHDGraphics.kext was loading. The second, have you tried the alternative framebuffer in my zip file?

 

What I want to know is if the framebuffer detects your display. For example in mine, it does. If it does detect your display, something is weird.

 

Ok GhostRaider, thanks for your help. I did some more tests on a vanilla 10.8.2 OSX installation. I tried both your FB and I get the same screen with the spinning wheel never stopping. I add a pic to this post. I was able to get to the desktop without any Intel HD kext loaded.

In a previous post I posted a pic about a distorted screen. I used the FB (not the alternate) in your .zip file with the DualLink FB from Verteks "fixed" ML FB. You think the FB was loaded in that test?

 

How can I know if the FB detects my display?

 

I think the problem might be the fact that my laptop monitor's EDID is not picked up by osx. Not even in Windows 7 nor in Linux Mint I was able to get the EDID. Only in windows I was getting it from the registry and not from the monitor itself.

Below you can see the output of the get-edid from Linux:

 

sudo get-edid | parse-edid

parse-edid: parse-edid version 2.0.0

get-edid: get-edid version 2.0.0

 

Performing real mode VBE call

Interrupt 0x10 ax=0x4f00 bx=0x0 cx=0x0

Function supported

Call successful

 

VBE version 300

VBE string at 0x11100 "Intel®Ironlake Mobile Graphics Chipset Accelerated VGA BIOS"

 

VBE/DDC service about to be called

Report DDC capabilities

 

Performing real mode VBE call

Interrupt 0x10 ax=0x4f15 bx=0x0 cx=0x0

Function supported

Call successful

 

Monitor and video card combination does not support DDC1 transfers

Monitor and video card combination supports DDC2 transfers

0 seconds per 128 byte EDID block transfer

Screen is not blanked during DDC transfer

 

Reading next EDID block

 

VBE/DDC service about to be called

Read EDID

 

Performing real mode VBE call

Interrupt 0x10 ax=0x4f15 bx=0x1 cx=0x0

Function supported

Call failed

 

The EDID data should not be trusted as the VBE call failed

parse-edid: EDID checksum passed.

 

# EDID version 0 revision 0

Section "Monitor"

# Block type: 2:0 3:0

# Block type: 2:0 3:0

# Block type: 2:0 3:0

# Block type: 2:0 3:0

Identifier "@@@:0000"

VendorName "@@@"

ModelName "@@@:0000"

# Block type: 2:0 3:0

# Block type: 2:0 3:0

# Block type: 2:0 3:0

# Block type: 2:0 3:0

# DPMS capabilities: Active off:no Suspend:no Standby:no

 

# Block type: 2:0 3:0

# Block type: 2:0 3:0

# Block type: 2:0 3:0

# Block type: 2:0 3:0

EndSection

 

Could that be the reason why I cannot get the FB loaded?

post-774766-0-40035100-1363344451_thumb.jpg

Share this post


Link to post
Share on other sites

OK so I forgot to mention one thing :worried_anim: . In your IGPU, you need to go to Device DD02. Before the line " Method (_ADR, 0, Serialized)", you will need to add the line " Name (_HID, EisaId ("LCD1234"))".

 

Can you confirm you installed the latest Generic Brightness kext?

 

I also noticed you already have two PNLF devices in your DSDT. You will probably need to remove the old one, its in a different place. Also try putting my OperationRegions before your line " OperationRegion (PNVS, SystemMemory, 0xDB79BDA4, 0x0100)".. let me know how it worked!

I have exact the same problem. Cant find the entry you pointed. Appreciate your help.

ioreg.ioreg.zip

DSDT.aml.zip

Share this post


Link to post
Share on other sites

I have exact the same problem. Cant find the entry you pointed. Appreciate your help.

 

Hey calmesal. To find your graphics module, search for "Scope (_SB.PCI0.GFX0)". There you will find Device DD02. You need to name it LCD1234 as per my instructions. Put my OperationRegions before the first occurence of your "Scope (_SB)" and then find your Device (PNLF) {....}, delete it and replace with mine. Let me know if it worked. (If you can't compile, try replacing whenever my code says "PCI0.GFX0" try and change that to "_SB.PCI0.GFX0")

Share this post


Link to post
Share on other sites

Hi mnorthern

i have a g62 like you. I tried your patch with GenericBrightness.kext and it didn't work. I patched my dsdt correctly and the kexts seems to find the device DD02 with LCD1234 as name, but the brightness doesn't work (there's no slider too).

Little update: i can confirm that Natit is not mandatory to get to the desktop. I deleted it (it changes also some things on the ATi card!).

 

Last thing: my notebook is overheating on OS X! (not on Windows!). Any solution?

 

 

The real last thing: update 10.8.3 released, please verteks patch the new files (or release a patcher).

Edited by giofrida

Share this post


Link to post
Share on other sites

Hi mnorthern

i have a g62 like you. I tried your patch with GenericBrightness.kext and it didn't work. I patched my dsdt correctly and the kexts seems to find the device DD02 with LCD1234 as name, but the brightness doesn't work (there's no slider too).

Little update: i can confirm that Natit is not mandatory to get to the desktop. I deleted it (it changes also some things on the ATi card!).

 

Last thing: my notebook is overheating on OS X! (not on Windows!). Any solution?

 

Hi giofrida, can I have a look at your dsdt? Also, would you be able to download RW-Everything on Windows, then go into PCI window, select your Intel Graphics from the drop down, and send me a screenshot of what it shows? Also, when you go into Displays preference pane, what does it look like?

 

Also, I have edited my original instructions on the previous page for more clarity.

 

EDIT:

$h!t, I made a mistake :D Too many KEXTs loaded on my system and it looks like a mess. Do not install Generic Brightness, if you have it delete it. My DSDT patches will work if you install the following driver made by hotKoffy from our forum (http://www.insanelym...cklight-driver/) but I made slight changes to the plist, so download the one I attached and give it a go.

ACPIBacklight.kext.zip

Share this post


Link to post
Share on other sites

Hi giofrida, can I have a look at your dsdt? Also, would you be able to download RW-Everything on Windows, then go into PCI window, select your Intel Graphics from the drop down, and send me a screenshot of what it shows? Also, when you go into Displays preference pane, what does it look like?

 

Also, I have edited my original instructions on the previous page for more clarity.

 

EDIT:

$h!t, I made a mistake :D Too many KEXTs loaded on my system and it looks like a mess. Do not install Generic Brightness, if you have it delete it. My DSDT patches will work if you install the following driver made by hotKoffy from our forum (http://www.insanelym...cklight-driver/) but I made slight changes to the plist, so download the one I attached and give it a go.

 

I'll try it, thanks.

 

@verteks: this is the 10.8.3 framebuffer, please patch it.

AppleIntelHDGraphicsFB_10.8.3.zip

Share this post


Link to post
Share on other sites

I'll try it, thanks.

 

@verteks: this is the 10.8.3 framebuffer, please patch it.

 

Let me know how it works. Also, my hackbook overheats when watching a HD movie, I wonder how to solve this. Also wonder how to enable HDMI out

Share this post


Link to post
Share on other sites

Last thing: my notebook is overheating on OS X! (not on Windows!). Any solution?

Correct dsdt and maybe you can edit your smbios.plist to reduce max cpu-multiplier.

 

I have 43-46C on the low state and 56 on the max state.

aa85f299e29b45c6327c654afbb62d93.png

Share this post


Link to post
Share on other sites

Correct dsdt and maybe you can edit your smbios.plist to reduce max cpu-multiplier.

 

I have 43-46C on the low state and 56 on the max state.

aa85f299e29b45c6327c654afbb62d93.png

 

Could you elaborate on correct dsdt? I have applied all the standard patches to mine. Please post some links thanks

Share this post


Link to post
Share on other sites

Hey calmesal. To find your graphics module, search for "Scope (_SB.PCI0.GFX0)". There you will find Device DD02. You need to name it LCD1234 as per my instructions. Put my OperationRegions before the first occurence of your "Scope (_SB)" and then find your Device (PNLF) {....}, delete it and replace with mine. Let me know if it worked. (If you can't compile, try replacing whenever my code says "PCI0.GFX0" try and change that to "_SB.PCI0.GFX0")

Hi again!

The first and second part was no problem, but the PNLF part is no go. If I delete and copy your code I get compilation error. And I dont anderstand what you mean by(If you can't compile, try replacing whenever my code says "PCI0.GFX0" try and change that to "_SB.PCI0.GFX0")

I will be thankful if you could do this on my DSDT.

 

Thanks

post-21176-0-53077700-1363364861_thumb.png

post-21176-0-56875300-1363364894_thumb.png

post-21176-0-37961400-1363364925_thumb.png

Share this post


Link to post
Share on other sites

These are the differences between the original 10.8.2 kext and the patched one (Single Link) if you want to make a patcher.

I compared the 10.8.3 kext with this patched kext and the results attached are the same: there are only a lot of values changed (kext updated).

diff-original-singlelink.html

Share this post


Link to post
Share on other sites

Hello, now brightness control is enabled in my laptop, the only issue is "range" with 100% (slider) backlight is about 85-90% and 0% (slider) screen is too dark and F1(-)-F2(+) keys working for backlight but only once then don't change brightness.

 

Thanks mnorthern

Share this post


Link to post
Share on other sites

What happens if you use the 10.8.2 version of the kexts on 10.8.3?

 

it works as well.. i'm using 10.8.3 with 10.8.2 patched single link fb

Share this post


Link to post
Share on other sites

Hello, now brightness control is enabled in my laptop, the only issue is "range" with 100% (slider) backlight is about 85-90% and 0% (slider) screen is too dark and F1(-)-F2(+) keys working for backlight but only once then don't change brightness.

 

Thanks mnorthern

 

thanks for the report, i will try to fix the 100% to a higher setting, and fix the keys

 

when you set it to 0% do you get a completely black screen? i may need to fix this to a higher setting

Share this post


Link to post
Share on other sites

i'm using patched fb and ga/gldriver/vadriver from 10.8.3. i'm not using aihdg.kext cause for me (i5 450m - intel hd 1st + nvidia g310m) it didn't work neither with 10.8.2

Kexts.zip

Share this post


Link to post
Share on other sites

@mnorthern, can I get BAR0/BAR1 using DarwinDump?

 

I've never used DarwinDump unfortunately... but I edited my original post, and provided instructions how to use Windows and RW-everything.. its the easiest way!

 

Hi again!

The first and second part was no problem, but the PNLF part is no go. If I delete and copy your code I get compilation error. And I dont anderstand what you mean by(If you can't compile, try replacing whenever my code says "PCI0.GFX0" try and change that to "_SB.PCI0.GFX0")

I will be thankful if you could do this on my DSDT.

 

Thanks

 

I'll try to patch your DSDT tonight and send it to you for testing !

Share this post


Link to post
Share on other sites

thanks for the report, i will try to fix the 100% to a higher setting, and fix the keys

 

when you set it to 0% do you get a completely black screen? i may need to fix this to a higher setting

 

When I set it to 0% screen isn't completely black (is too dark, more dark than 0% when I use windows).

Share this post


Link to post
Share on other sites

i'm using patched fb and ga/gldriver/vadriver from 10.8.3. i'm not using aihdg.kext cause for me (i5 450m - intel hd 1st + nvidia g310m) it didn't work neither with 10.8.2

You mean that you dont use the AppleIntelHDGraphic.kext?

If yes, what version? Original or MLDP2.

Share this post


Link to post
Share on other sites

You mean that you dont use the AppleIntelHDGraphic.kext?

If yes, what version? Original or MLDP2.

 

no, i don't use that. if i try using that (event in 10.8.2), my computer freezes

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×