Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Zenith432

GenericUSBXHCI USB 3.0 driver for OS X with source

920 posts in this topic

Recommended Posts

Thanks, even if this is off topic here

 

Micky

 

Yeah i know..sorry but could find that post again.. Again Zenith great work on this, works for me with the flag..

Share this post


Link to post
Share on other sites

Hi Zenith432,

I did some testing and this is my feedback:

With or without DSDT edited for USB3 Intel and the kext GenericUSBXHCI the USB seem to work fine, but I have no USB3 devices to test the speed.

The generic kext in my case does not replace the CalDigit, without these the doors are not detected, with or without DSDT (tested on P8Z77-V LE),

The generic kext detects very well the USB3 NEC / Renesas (tested on P5P55D), you can eliminate PXHCD (which in some cases creates problems and instability).

In any case without DSDT edited the doors work, but the system does not go to sleep (my Mobo ASUS, I do not know the others).

I also tried out a new installation on my hard disk test, without DSDT and other kexts but the results are the same (perhaps because the doors are seen as PCI device)

Sorry for my bad english

Regards

Marco

Share this post


Link to post
Share on other sites

Fuxk tonymac!

 

They stole others work again:

http://www.tonymacx8...5-3-update.html

 

 

See "USB 3.0 - Universal which is RehabMan's branch of Zenith432's GenericUSBXHCI.kext"

 

They didn't steal anything. It's a fork and Zenith432 got credits.

I'm not a big fan of Tonymac tools, but RehabMan did a lot of great work for the HP notebook community.

Share this post


Link to post
Share on other sites

Fuxk tonymac!

 

They stole others work again:

http://www.tonymacx8...5-3-update.html

 

 

See "USB 3.0 - Universal which is RehabMan's branch of Zenith432's GenericUSBXHCI.kext"

 

This war between tmx and other sites is ridiculous. There is no stealing going on here.

 

First of all credit is given in MB and whenever I reply to a message where the OP is confused and trying to give me credit for Zenith432's work, I will always correct them to indicate that this is all Zenith432's work.

 

Second of all, this is open source. Perhaps you should read up on it: http://en.wikipedia.org/wiki/Open-source_software

Share this post


Link to post
Share on other sites

This war between tmx and other sites is ridiculous.

Obviously you are in the right :)... O.S. is always welcome, and take the work of others is allowed to develop it... when the creator has made available the source for this purpose. Is even better, because people can make improvements.

 

In Pandora will be available your AppleSmartBatteryManager.kext v1.32 (your source wil be cited).

 

But I remember well, when on tonymac, links to InsanelyMac were hidden (and this did not happen due to a bug) to prevent peoples coming on this forum.

So war is ridiculous, but the guilt we know who to give it.

I will never be there

 

EDIT

 

...and do not worry, you are a good person. 'm Just sorry that you have not opened any topic here on your works :whistle:.... would be nice :D

 

Micky

Share this post


Link to post
Share on other sites

Tried this on a Gigabyte Z68-UDH3, with an additional PCIe card as well.

 

Most things seem to work (Yay!), with the exception of sleep (Booo...).

 

Thanks very much for all your effort on this! Sleep works on this system without the driver in place; anything I can provide that would help debug the sleep issue?

 

Brent

Share this post


Link to post
Share on other sites

Confused:

I downloaded GenericUSBXHCI_1.1.4 by clicking on Zenith's original posting Binary link.

Later in the thread, I saw mention of a perhaps later version called "V1.1a4".

Did I get the most recent version of Zenith's USB 3.0 fix?

Are there some detail instructions on how to use the kext and when to use the kernal flags[in the #1 post in this thread].

FYI: GA-P55a-USB3 Rev2

i5 650, RAM =OCZ 1333speed 8GB

I suspect that there is an anwser to my question somewhere in this long thread. I did not find it because of my limited understanding of Hackintoshs.

OSX 10.8.2[ plan to update to 10.8.3]

Share this post


Link to post
Share on other sites

Tried this on a Gigabyte Z68-UDH3, with an additional PCIe card as well.

 

Most things seem to work (Yay!), with the exception of sleep (Booo...).

 

Update: Self powered devices (WD USB3 disks, specifically) work fine, but I'm having a problem with the only bus-powered disk that I have:

 

 

4/26/13 10:10:20.000 PM kernel[0]: USBF: 34330.941 The IOUSBFamily did not receive enough extra current for the SuperSpeed device (My Book 1130) at 0x1ca00000, asked for 400mA but got 0 mA

 

Any hints or things to try?

Share this post


Link to post
Share on other sites

Thank you Zenith432, it's working fine on my Z68AP-D3 with an Etron EJ168 controller. I use it only for USB2 devices and they all work except for my webcam, which was expected.

Share this post


Link to post
Share on other sites

It has been running great with my USB3 hub, Seagate backup plus USB 3 drives, and other harddrives... But when I plug in a LaCie Rugged Mini 500gig drive to my USB 3, the system freezes solid. It runs fine through firewire. My motherboard is the EVGA Classified II, and it has a NEC 3.0 chipset built in.

Share this post


Link to post
Share on other sites

Hey guys,

Can you clarify something? If this is installed on a 7 series chipset with intel native USB 3.0, does it work alongside the apple USB 3.0 drivers or does it supersede them? the reason is it seems for full compatibility it would be good if this driver were able to work on third party chipsets while allowing the apple driver to control the intel ones. Especially for those of us with USB sound cards and webcams, etc.

 

Thanks,

g\

Share this post


Link to post
Share on other sites

Hey guys,

Can you clarify something? If this is installed on a 7 series chipset with intel native USB 3.0, does it work alongside the apple USB 3.0 drivers or does it supersede them? the reason is it seems for full compatibility it would be good if this driver were able to work on third party chipsets while allowing the apple driver to control the intel ones. Especially for those of us with USB sound cards and webcams, etc.

 

Thanks,

g\

It supersede them. At least for me.

Want that too so

this driver were able to work on third party chipsets while allowing the apple driver to control the intel ones

Also after installing this universal kext I've lost extra-current feature (that worked well on CalDigit's kext and Intel) so I can't normally charge my iPad anymore. Is there a way to enable extra-current on this kext? Or at least on intel ports?

Share this post


Link to post
Share on other sites

I sometimes lose the extra current feature as well but a reboot without kextcache always solves it .

Tried clearing kext cache, same thing, extra-current not working

Share this post


Link to post
Share on other sites

This war between tmx and other sites is ridiculous. There is no stealing going on here.

 

First of all credit is given in MB and whenever I reply to a message where the OP is confused and trying to give me credit for Zenith432's work, I will always correct them to indicate that this is all Zenith432's work.

 

Second of all, this is open source. Perhaps you should read up on it: http://en.wikipedia....source_software

I'm so sorry to make you confused... I put on the quotation so that others could quickly find where I was talking about.

I was really not blaming you, but you know who ==

Thanks for your contribution too. :)

Share this post


Link to post
Share on other sites

It has been running great with my USB3 hub, Seagate backup plus USB 3 drives, and other harddrives... But when I plug in a LaCie Rugged Mini 500gig drive to my USB 3, the system freezes solid. It runs fine through firewire. My motherboard is the EVGA Classified II, and it has a NEC 3.0 chipset built in.

 

What USB 3.0 HUB are you using in your system ? And which driver are you using ?

Share this post


Link to post
Share on other sites

hello!

 

great work indeed. but on my system i experience some problems.

when i use the latest kext, only 2 ports of my 6 rear ports are working. at least my usb 3.0 corsair survivor recognized and mounted.

"that's fine" i thought. and as i read in first post there is kernel flag for this case ("-gux_defer_usb2"). although i could be wrong.

i tried to load with it and get kernel panic with some blah-blah usb reasons.

but now even when i not use this flag i also get kp. not always at boot screen but a few moments later on desktop.

i looked for "bios setting to route these ports to xhci" and found some "use legacy usb 3.0" stuff. three options: yes, no, auto.

on the right side of bios screen (info) i see some about "xhci" when this menu is selected. this is the only place in bios configuration, where i see something relevant. i'll post screenshots later if necessary.

changing this not affects behavior at all - kp anyway.

 

i wish i could post xhc dumps.. so i could not because of kp.

however i have a bunch of dumps from aida64. may be it will help.

+ attach my dsdt with fixes (native wlan, sata, removed unnecessary ps\2 things).

+ io registry explorer data

 

thank you!

dumps.zip

dsdt.aml.zip

ioregistry.zip

Share this post


Link to post
Share on other sites

hello!

 

great work indeed. but on my system i experience some problems.

when i use the latest kext, only 2 ports of my 6 rear ports are working. at least my usb 3.0 corsair survivor recognized and mounted.

"that's fine" i thought. and as i read in first post there is kernel flag for this case ("-gux_defer_usb2"). although i could be wrong.

i tried to load with it and get kernel panic with some blah-blah usb reasons.

but now even when i not use this flag i also get kp. not always at boot screen but a few moments later on desktop.

i looked for "bios setting to route these ports to xhci" and found some "use legacy usb 3.0" stuff. three options: yes, no, auto.

on the right side of bios screen (info) i see some about "xhci" when this menu is selected. this is the only place in bios configuration, where i see something relevant. i'll post screenshots later if necessary.

changing this not affects behavior at all - kp anyway.

 

i wish i could post xhc dumps.. so i could not because of kp.

however i have a bunch of dumps from aida64. may be it will help.

+ attach my dsdt with fixes (native wlan, sata, removed unnecessary ps\2 things).

+ io registry explorer data

 

thank you!

 

Is this kext working on x79 chipset motherboards? Maybe it works properly on Z77 chipset only. Perhaps that's the key, but I could easily be wrong. Zenith432?

Share this post


Link to post
Share on other sites

just as i told. it works. but for a while and for a couple of ports :)

x79 hosts its own ports, and they are working perfectly. so three asm1042's are able to work, but driver needs a fix.

 

small update: tested drivers from CalDigit, LaCie, Oyen Digital. i've had to inject their id's through dsdt to use latest versions from official sites.

by the way there's no asmedia devices in dsdt except hub-connected one and i've added them manually.

and with all drivers only two ports are working also. interesting thing is that works only one chip declared by myself in dsdt. not the second equal, not hub-connected, but exactly that one.

CalDigit - panic after a ~minute;

LaCie - no panic, but a logageddon happens :D no big deal. read speed 15-20 MBps, write speed almost the same (blackmagic disk speed test).

Oyen Digital - no panic.. yet, no log flood. read speed ~20, write speed ~50. i use it as a solution for the first time.

in earlier time i've tested driver from Highpoint (that was before dsdt fix, since kext has my id's). nothing works. only few empty strings in system profiler.

maybe I spent little time on tests of it. probably i'll return to them soon.

 

much smaller update: finally got working GenericUSBXHCI without kp. not known how long it will work like that.. likely a kind of mysterious coincidence.

although i've made dumps with corresponding tool. +screens. +new ioreg data.

post-213718-0-29181100-1368840485_thumb.png (here first six buses, 3 hi+3 super, are belong to this kext)

 

thanks for attention.

xhcdumps.zip

130518000428.BMP

130518000437.BMP

130518000442.BMP

130518000501.BMP

ioreg_18-05-2013.zip

Share this post


Link to post
Share on other sites

I've uploaded v1.1.6 with some bug fixes (See post #1).

 

One of the critical bugs fixed is a possible reason for freezes encountered with some superspeed drives mentioned in the thread.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×