Jump to content

[RESOLVED] Trouble Installing Win7 x64 on MBP 4,1 with SSD

2 posts in this topic

Recommended Posts

I need to get Windows 7 to run (however possible; with or without OS X, with or without rEFIt/rEFInd) on an Early 2008 Macbook Pro with an OCZ Vertex Plus R2 SSD installed in place of the original hard drive. I've asked around on the OCZ forums, but here seems to be a better place for a solution.


System: Macbook Pro 4, 1

EFI: 1.4

OS: 10.8.2


New hardware: OCZ Vertex Plus R2 with 1.2 firmware (latest) (uses an Indilinx controller)

Desired OS: Windows 7 x64, purchased from Digital River (I have confirmed that the DVD is working)



I previously had Windows XP 32-bit installed alongside OS X 10.6 on the original drive without issues.



I installed the 256GB OCZ Vertex Plus R2 to breathe some new life into the machine, and OS X runs beautifully. (I installed Mountain Lion from a USB drive.)



I want to install Windows 7 x64. The bootcamp assistant runs without a hitch, and I am able to boot to the installation CD immediately after restart. The Windows 7 installer runs, but upon reboot, the system locks up (still on the EFI screen, nothing's changed) as soon as I select a boot device. (If I do not select a boot device, I assume it is booting to the Windows 7 partition automatically, but it never gets out of the gray EFI screen.) All keys are nonresponsive, and you have to force a hard shutdown to get anywhere.


I've tried clearing everything that can be cleared (PRAM, SMC, fresh partitioning and writing a new GPT), but it doesn't seem to fix the issue. I suspect the issue is somewhere along the lines of Windows 7 forgets how to talk to the SSD, but this really isn't my forte; I'm entirely out of my depth.


If at all possible, I'd like to begin with a solution we know has worked for someone else and save experimental fixes for later. I've spent about a hundred hours on this over the past five days, and I really need to get this system off the ground. I can provide any additional information necessary.


I am cross-referencing the OCZ thread. Please read the entire thread if you peek over there, as this post is more up-to-date than the initial posts over there: http://www.ocztechno...VD&p=779862

Edited by serrath

Share this post

Link to post
Share on other sites


Incompatibility between EFI 1.4's BIOS emulation and the SSD's Indilinx controller. Firmware patch will never come for Macbook Pro 4,1 and is not expected for Vertex Plus R2. OCZ Summit drive is the only confirmed working drive for bootcamp Macbook Pro 4,1. If anyone finds another compatible drive, please post.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.