Jump to content
InsanelyMac Forum
  • Announcements

    • Allan

      Solution to create a topic or post.   04/24/2018

      Hello guys. The majority of you are having issues to create a topic or post here. This are a problem with our current theme InsanelyMac.  Now the theme will be the Default IPS. Sorry for any inconvenience.
Fez Vrasta

Reboot after Chameleon boot (AMD PC)

Recommended Posts

Hi all, I'm trying to install OS X on my assembled AMD PC.

I'm new and I've read forum rules so I hope my topic it's ok.

 

That's my hardware:

 

AMD FX-8120 8 Core 3,1Ghz
8GB RAM DDR3 2133Mhz
MoBo Asus M5A87
Radeon HD 6850 2GB ddr5
Unknow lighscribe DVD Reader/Writer SATA
SEGATE Hard disk 1tb 7200 RPM (with few linux partitions [ext4, swap] and a windows partition [ntfs] plus an unallocated space for OSx (about 80gb) 

 

I've tried this method:

 

 

Install Chameleon to DVD

Install iAtkos ML2 to an external USB 2.0 HDD

Boot Chameleon

start iAtkos with verbose mode

 

My pc suddenly reboots...

 

I'm not a geek of BIOS settings and I don't know if it can be the problem...

I've attached a screenshot of chameleon's error

https://www.dropbox.com/s/koct3tjh0lbgumf/2013-03-02%2016.23.47-1.jpg

 

Any help is appreciated, thanks!

Share this post


Link to post
Share on other sites
Advertisement

your problem is the distro what you use, not have a patched kernel for AMD , better method is USBInstaller Retail, with tis you can delete and add kexts and patched kernel for your hardware, change smbios etc..., the reboot problem can be graphics kexts, bad smbios, AppleIntelCPUPM kext, PCIRoot for your card etc..., make a USBInstaller Retail is more easy for install.

Share this post


Link to post
Share on other sites

Hi!

 

Check here: http://www.insanelym...md-development/. IFire already told you to do it, but i guess you didn't like you should, since you, quote, "can't find something useful for my problem".

 

For real-time help with AMD installations, add the chatroom #legacykernel in IRC, server chat.osx86.hu, many of the people who helped develop the current solutions for AMD usually are logged in.

 

Best regards!

Edited by theconnactic

Share this post


Link to post
Share on other sites

So I need to make a retail USB and manually add emm.. drivers.. (kexts?) right?

 

There isn't a method for get an error output for understand exactly what is the problem that make my pc rebooting?

I'll dig again into AMD section, maybe I missed something.

Share this post


Link to post
Share on other sites

I'll dig again into AMD section, maybe I missed something.

 

You really did ;)

 

Instant reboots are difficult to debug because they usually doesn't output anything. So we had to resort to other methods to learn what was going on. Fortunately, the work was already done for you. If you look at the kernel database topic in the link i sent you, you'll see that there's one specific for FX/Bulldozer CPUs. But you can really use any of the AMD kernels for Mountain Lion, if you just install Clover. Search, in the forum i linked to you, for the keyword "gils83" (without quotes), the user who found out this workaround.

 

Answer the second quiz, man: that way you'll not be limited to post in the New Users Lounge. :)

 

Best regards!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.



  • Posts

    • Here ya go... I do not see any lags on those web pages with a dual monitor setup 2560x1440. This was while playing a movie on vlc. EFI.zip   I did not see it before the nvidia fix.
    • @ivik AD1981 is an old codec.
      Ok, too few nodes for all devices, I had to reduce to Speaker, HP, IntMic and LineIn. try this: trial1_AD1981_layoutID11_(0B).zip Delete VoodooHDA and Disabler!
      AppleHDA must be original!
      AppleALC and Lilu in Clover / kexts / others and KextInject "Yes" in Clover
      Inject LayoutID 11 via Clover and FixHDA in Clover!
      or
      Inject in DSDT / HDEF with 0B without FixHDA in Clover!
      Good luck
    • Hi Sherlocks! test.zip Clover4446. Thanks, but I have not changed anything yet. If I use a clover 4439 then I do not have such nuances.
    • Navigate to this, click there, than do that, etc. That's one way to do it.   Or you navigate to https://www.insanelymac.com/forum/settings/signature/ and you bookmark / favorite that link
    • Hi,   after updating HS my WOL stopped working. It worked for sure in El Capitan, not sure in what version of HS stopped to work. I'm using Ozmosis as bootloader and IntelMausiEthernet (in S/L/E) for network. I created ssdt.aml with ssdtPRGen, and put it in EFI/Oz/Acpi/Load/. WOL is enabled in BIOS, wake for network access is checked pmset -g System-wide power settings: DestroyFVKeyOnStandby 0 Currently in use: standby 0 Sleep On Power Button 1 womp 1 hibernatefile /var/vm/sleepimage powernap 0 networkoversleep 1 disksleep 10 sleep 15 autopoweroffdelay 28800 hibernatemode 0 autopoweroff 0 ttyskeepawake 1 displaysleep 15 standbydelay 10800 If I put machine to sleep, WOL works for a short time, but not working if I let it sleep for a while.   I deleted Ethernet in Network, rebooted and recreated it, but still the same.   Hardware: MOBO:     Gigabyte Z97-D3H rev 1.1
      processor:    i5-4460 Haswell
      graphic:    Gigabyte GeForce GT 740 OC GDDR5 2GB (GV-N740D5OC-2GI)
      memory:    2 x 8GB Kingston
      disks:    Samsung SSD 850 EVO 120GB
              Seagate 2TB
              LG DVD±RW Sound:     VoodooHDA
      Network:    IntelMausiEthernet.kext   Any advice?   Best regards, Goran
×