Jump to content

[GUIDE] How to Install Mountain Lion on a P6X58D Premium

10 posts in this topic

Recommended Posts

Just got done with this (woohoo!) and put together a quick guide. I packaged it with every file I needed for the install.


Attaching the guide itself in case you wanted a preview. I couldn't get sleep to work, and didn't generate or use a DSDT. My boot time's > 2min since (spends a lot of time at "IOAPIC"). But I don't really mind any of these :)


Installation Files

Installation Guide


If you own this board and have had some luck with any of these issues, please update this thread.


Thank you everyone!

  • 2 weeks later...

You're welcome dude. Just trying to be useful around here :) I did try that sleep kext (and mentioned the link in my guide) but it didn't work for me reliably. I'm looking into DSDTs and will post anything I find on this thread.


Also wanted to put these two updates out there:

  • Upgraded my graphics card to a Gigabyte GTX 650. Then set "GraphicsEnabler=No". Works like a charm. Not a huge gamer; needed a decent card :) You can look at lists like these to find a better card if you want one.
  • Since this is a Kext-based install, the latest 10.8.3 update broke audio as expected. I simply reinstalled the "AppleHDA" and "HDAEnabler" kexts with "Kext Utility" and things were back to normal.
    Strangeness: During the upgrade to 10.8.3, I got an error dialog saying something like "Your Mac cannot be upgraded". Still, when I rebooted like it asked me to, the "About This Mac" dialog showed 10.8.3. There were no other updates in the App Store after reboot. I'm guessing this glitch isn't too serious (the update itself wasn't that spectacular anyway.)

I'll be trying to patch my DSDT and will keep updating this thread in the future. Please contribute any wisdom as you see fit. Thanks! :euro:



Turns out that the upgrade didn't go smoothly after all. I got the error I mentioned in the previous post due to kextcache failure.


sh-3.2# sudo kextcache -system-prelinked-kernel
Kernel file /mach_kernel does not contain requested arch: i386
2013-03-16 21:58:13.079 kextcache[15038:707] -[__NSCFData _fastCStringContents:]: unrecognized selector sent to instance 0x7fc2ab13cf40
2013-03-16 21:58:13.081 kextcache[15038:707] *** Terminating app due to uncaught exception 'NSInvalidArgumentException', reason: '-[__NSCFData _fastCStringContents:]: unrecognized selector sent to instance 0x7fc2ab13cf40'
*** First throw call stack:
0   CoreFoundation					  0x0000000109d79b06 __exceptionPreprocess + 198
1   libobjc.A.dylib					 0x000000010a3623f0 objc_exception_throw + 43
2   CoreFoundation					  0x0000000109e1040a -[NSObject(NSObject) doesNotRecognizeSelector:] + 186
3   CoreFoundation					  0x0000000109d6802e ___forwarding___ + 414
4   CoreFoundation					  0x0000000109d67e18 _CF_forwarding_prep_0 + 232
5   CoreFoundation					  0x0000000109cfe7cd CFStringFindWithOptionsAndLocale + 541
6   CoreFoundation					  0x0000000109d08092 CFStringFind + 178
7   kextcache						   0x00000001098b9c98 kextcache + 89240
8   kextcache						   0x00000001098b932b kextcache + 86827
9   kextcache						   0x00000001098a7cef kextcache + 15599
10  kextcache						   0x00000001098a841c kextcache + 17436
11  kextcache						   0x00000001098a6dfe kextcache + 11774
12  kextcache						   0x00000001098a548a kextcache + 5258
13  libdyld.dylib					   0x00007fff8d47a7e1 start + 0
libc++abi.dylib: terminate called throwing an exception


I'm not sure what's causing this. Everything seems to work except my DVD drive, which shows up fine in System Profiler and Disk Utility, but cannot mount anything! This is the only related topic I've found. I'll update this thread with any fixes.

  • Couldn't find a solution to the DVDs and CDs not mounting. Console says:
    /sbin/mount_udf: mount_udf: load_udf failed
    Similar to this issue.
  • The kextcache errors above are caused by this command:
    /usr/sbin/kextcache -system-prelinked-kernel
    I tried replacing the /usr/sbin/kextcache binary from before the 10.8.3 update. Worked without complaining. Didn't solve my DVD issues. Not sure if this stuff's related or not.

So I basically got frustrated, decided not to mess with things above my knowledge level, and reinstalled. The 10.8.3 update went smoothly. This will teach me to clone my boot drive before every system update <_<

  • 2 weeks later...

Quick solution to an annoying error:

App Store: Unknown error has occurred

  • Make sure that en0 is your primary ethernet device
  • Download and run EFI studio
  • Select Ethernet and click "Add Device"
  • Click "Copy Hex String to Clipboard"
  • Launch Chameleon Wizard, and choose the org.chameleon.Boot.plist tab
  • At the bottom of the panel, click "Paste"
  • Check "Device Properties"
  • Click "Save" at the top

Something like this was added to my org.chameleon.Boot.plist:



Reboot. Enjoy!

Hi, I also have this motherboard. I've been trying to have a solid bootup for a while. I have 24GB RAM Overclocked to 2000MHz. However I constantly have to reset BIOS and reapply settings and whatnot. I get mixed results. Like as of this reply, I have 16GB (recognizing 4 out of 6 DIMMS) Profiler sees the DIMM slot 5 and 6 as empty. During the RAM scan process during boot up, it scans and then stops after 16GB so I know it's a BIOS problem and not OSX


I will try to help where i can with this build. I'm interested in getting FIREPRO 3d V7800 to work but currently I'm using AMD HD 6670 2GB. I halso have a HD5450 but it never works----can't get acceleration.


I'll try your methods because I've been installing ML using other methods. I'm having a problem with Speedstep USB 3.0 currently.


I appreciate all of your efforts.


BTW I have the i7 980X 3.3GHz Overclocked to 3.43GHz however profiler lists it as unknown

Brandon's DSDT.zip

it's a BIOS problem and not OSX


I updated my BIOS to v1501 before doing anything. You can download it here. I have 16GB of RAM, so I didn't notice any problems :) As for AMD cards, I'm sorry, but I can't help there. I picked an nVidia card after looking through hardware compatibility lists. If you still can't make things work, and are not a huge gamer, it might be worth spending the $50 for a decent card you know won't cause you problems.

  • 4 weeks later...
  • 1 month later...
  • Create New...