Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
WhatTheTech

MSI Z77MA-G45 Worklog/Help Request

32 posts in this topic

Recommended Posts

MSI's standard one... I've received my motherboard one week ago and I'm not planning on making any changes to the BIOS...

Share this post


Link to post
Share on other sites

Hi, have an MSI Z77MA-G45 on order. Just checked msi website, latest bios version is 1.9 Can anyone confirm best of method of install for full functionality? Will be using with i5 2500k cpu for the moment and ati graphics so not bothered about intel hd graphics. I'd prefer a dsdt free install myself but would be very interested to hear your experiences with this board. Have previously used gigabyte boards with chimera / chameleon but again any opinions welcome.Thanks.

Share this post


Link to post
Share on other sites

Follow https://biosrepo.wordpress.com/2013/01/19/simple-way-to-patch-your-own-bios/ to patch the latest MSI BIOS.

 

For crafting a OS X install USB stick, Follow the instructions at http://www.osx86.net/guides-tutorials/19291-guide-clover-efi-bootloader-70.html#post131499

 

See http://clover-wiki.zetam.org/Home for more info

 

 

Good news, MSI Z77MA-G45 now supported in v. 5.2.678 HWMonitor / FakeSMC. Get it at
 
However I have not been able to get this board to boot via UEFI, I get a reboot a few lines into boot. I am successfully Clover booting via traditional BIOS only.

Share this post


Link to post
Share on other sites

Hi folks. I'm doing a fresh install on my MSI Z77MA-G45 with a new 500GB SSD. BIOS has been patched. I can successfully install with [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url], but I like using Clover much better and of course want the faster UEFI booting. I have created a USB boot drive using the instructions from http://cloverboot.weebly.com.

 

Clover starts up nicely, then after beginning to load the OS X installer, it gets stuck just after showing:

 

init

probe

start

 

Then some odd stuff about not finding the bluetooth ([iOBluetoothHCIController][start] -- completed)

 

If I wait awhile, a grey screen will come up and I get a spinning beach ball.

 

If I try safe boot, I get a reboot almost immediately.

 

No matter what I change in the config it does not seem to help; I have a monitor attached via DVI. And I suspect it's something with the display, but I could be wrong. Ideas?

Share this post


Link to post
Share on other sites

Did you ever get that sound cracking fix by any chance OP? I'm using Toleda's ALC892 kext with HDAEnabler but still get the same  issue.

 

Using the MSI Z77MA-G45 with latest 1.B Bios with UEFI Patch applied.

Share this post


Link to post
Share on other sites

Success with a full Clover UEFI setup. For running with the built-in Intel 4000 graphics, make sure you select Inject Intel in the Graphics section in Clover config.

 

I have sound successful via both analog and HDMI via a patched DSDT along with https://github.com/toleda/audio_cloverALC to get the Realtek ALC892 working. If you don't need HDMI audio, you can stop with just this, if you need HDMI audio, then 

 
Add in patches to Clover config according to https://github.com/toleda/audio_CloverHDMI
Make the direct kext frame buffer edits https://github.com/toleda/graphics_Intel_framebuffers
 
TO make HDMI Audio DSDT: 
MaciASL -> add http://pjalm.com/ sources
Boot no DSDT (or press F4 at the Clover boot screen, then grab the DSDT out of ACPI origin folder in Clover's EFI folder)
Patch MSI MSI-Z77A-G45, then Graphics Intel HD4000
MSI framebuffer is 0x6

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×