Jump to content
InsanelyMac Forum

Hd3000 artifacts on mountain lion

Recommended Posts

Hi to all!

I have an asus k53sc notebook,all work good,many out of the box.

The intel hd 3000 work good out of the box but sometimes i have artifatcs,sometimes the artifacts is all the screen.

In lion i have solved with fan control,but in mountain lion i don't know how to solve!


Share this post

Link to post
Share on other sites

Hi, i was searching several days for the artifacts solution (Intel HD3000 ML 10.8.2), and i want to share a solution for this.


Basically the problem is in AppleIntelSNBGraphicsFB.kext. when it is not load in kernel cache, (at first boot, usually you can see less artifacts, and increasing, after second boot, etc). To solve this, you need to use the keyword: UseKernelCache to Yes. in org.Chameleo.BootXXX...


Try it and let me know if this works for you.



If you cant boot with this Keyword, or system hangs. Then boot in verbose mode and check what is the problem. In my case i had trouble whit ACHI disk (still workin for root device), and i fix it with bcc9 patch. (look here in insanelymac)



P.S2: sorry about my english.

Share this post

Link to post
Share on other sites

Rob, today i was playing with the kext AppleIntelCpuPowerManagement (Trying to solve speedstep in my Laptop), and when i boot with new kext patched by me from vanilla one, OH NO!! the artifacts back, in others word, the problem is also related to this kext and good patch applyed over him. Here is it for mountain lion: http://www.tonymacx86.com/mountain-lion-desktop-support/60912-patched-appleintelcpupowermanagement-kext-10-8-a.html.


If you have NullPower (whatever) kext. Then do all to reeplace with AppleIntelCpuPowerManagement. (it's mind you need to put your SSDT.aml in /Extra, etc)





My english, some times look really bad! LOL sorry!

Share this post

Link to post
Share on other sites

I have an Acer S3 ultrabook and have these occasional but random artifacts.

Anyone tried any other suggestions to fix these artifacts ?

I already have UseKernelCache=Yes and that does not help.

I am already using the latest FakeSMC.kext and that does not solve the problem.

Share this post

Link to post
Share on other sites

I resolved this on the dell laptop to the point where it is as good, if not better than my probook. (probably the same to be fair)


I used fakesmc 4.2 I believe, it may have been a newer one, cant remember (the laptop is my friends, I dont have it here)


I moved all Kexts to SLE and usekernelcache=yes,


Some people have had success with third party apps, I forget the name of it, but its to do with the screen frequency i think.


for me, it was a simple case of repairing permissions and rebuilding the cache again.


I used kext wizard instead of kext utility.


Im not using nullpower management, I used a modded bios, but the applepowermanagement modified kext should work ok.


There are other factors that can cause the artifacts to be worse, like dual booting apparently.


There are fixes, but from what I have seen, it can be a different answer for every user depending on kexts used, DSDT etc...


I would suggest patching your own DSDT to start with if you are using another patched one, that made life much easier for me with multiple problems when working on my mates n5110.

Share this post

Link to post
Share on other sites

Rob, I'm glad to know that when you used "UseKernelCache = Yes" worked. All additional steps that you explain, I thought it was obvious, sorry for not explaining that FakeSMC also needed 4.2 or higher, and you had to have your kext in S / L / E.



Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.