Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


Disable NVidia GPU Dell 7720

13 posts in this topic

Recommended Posts



I've been working on disabling the Nvidia GPU by DSDT edit.

There is no actual guide for this, i used information from this topic to make the edits myself: http://www.projectosx.com/forum/index.php?showtopic=2315


Everything is in place, well, i think, but the GPU still shows up in the System Profiler.


The DSDT is a mess at the moment, sorry for that, but it works :P


Can someone have a look at it, and possibly correct the error, also provide the information on what went wrong, for future reference?


Thanks in advance.


Share this post

Link to post
Share on other sites

I know google as a friend, thank you.

First of all, please remove the link to tony...


The links you posted, thanks for looking them up, they are missing information. I provided the link to the topic i used to make the edits.

Somehow i screwed up, i just don't know where.


Also, i wish to skip kext injection :)

Share this post

Link to post
Share on other sites

Edited post.


Yeah, I'd also rather use DSDT than kexts. There are just two more issues other than this I need fixed: Audio (Realtek ALC269, using HDAEnabler.kext, would rather use DSDT), and battery detection(currently using modified AppleACPIPlatform.kext and VoodooBattery.kext, would rather use gsly's kext).


I'm currently attempting to read the ACPI specification to learn the ASL language, but I'm having a difficult time. Do you have any pointers on that, as a side note?

Share this post

Link to post
Share on other sites

For the audio, besides the DSDT edit, you will also need to patch the AppleHDA. For battery, i use the SmartBattery or something like that, don't know how to do this by DSDT.


I do not really have any pointers, i just look in the DSDT section(Forum), if someone needs a fix, i download the DSDT and try to fix it. Most of the time google is my friend, sometimes i have to figure it out myself, just trying random stuff i remembered from fixing other DSDT's, if i find the solution, i keep it in mind for the next one.

To better understand the DSDT, i extracted all my SSDT tables, and combined them into my DSDT, i moved everything to give it a nicer look, not without error, learned a lot from that, so that is something i can recommend to do.


Attached the DSDT which i am working on, not bootable, because the Scope_PR is not correct. I fixed this, but my wireless did not work anymore somehow, i had overwritten the changes i made, so i have to start over from the non working PR, ah well.


Share this post

Link to post
Share on other sites

Thanks for the tips. I'll work on it. I didn't understand when you said you extracted all your SSDTs and combined them into your DSDT. How do you go about doing that?

Share this post

Link to post
Share on other sites

Hmmmm. So if you see methods and devices in something like \_SB_PCI0_PEG0_PEGP, you just copy what is there to the scope in DSDT? But what if you get scope errors, like 'XXXX is not accessible/does not exist from Scope_YY'? Because that's what I tried to do when copying the _OFF method from the NVOptTbl SSDT to DSDT, and then I got this error.

Share this post

Link to post
Share on other sites

Then the fun starts :P Most of the time it's just an extra or missing bracket. If i see something like

\_SB_PCI0_PEG0_PEGP, i copy that to

\_SB_PCI0_PEG0_PEGP in the DSDT, provided an example, non working DSDT, but it should give you an idea. Also, in the SSDT, look at the top, you will see lines like:

External (\_PR_.CPU0._PSS, IntObj)
   External (\_SB_.PCI0.GFX0, DeviceObj)
   External (\_SB_.PCI0.PEG0.PEGP, DeviceObj)


Copy them also to the top of the DSDT, and remove them if when you add the objects.

Share this post

Link to post
Share on other sites

Aaahhh... I see. I'll start working on it, as soon as I finish my homework (I'm in 10th grade... Doing 'O' Levels in November)

Share this post

Link to post
Share on other sites

Dang. I can't get it to work.. I copied the code at the top of the SSDT to my DSDT, but nothing doing... I'm getting the same errors. I tried to copy the entire scope as you did, but something obviously went wrong...


Attached are my SSDT and DSDT with errors...


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By MetalBreaker
      I noticed some weird behavior with macOS High Sierra. This system was working just fine on Sierra 10.12.5, until I decided to update to High Sierra (10.13.3). The upgrade process went mostly fine I guess, but it got stuck in an infinite spinning wheel which would just keep overlapping. I went into verbose mode, and sure enough, I found "IOConsoleUsers: gIOScreenLockState 3, hs 0, bs 0, now 0, sm 0x0" repeating over and over along with ACM errors... I'm really lost right now. I can boot in recovery mode and safe mode just fine, when the graphics drivers aren't loaded. Web drivers aren't installed. I installed NvidiaGraphicsFixup, but it didn't fix the issue. I tried deleting the native graphics drivers from macOS and installing web drivers, but it didn't help.
      SMBIOS: iMac13,1
      Graphics card: ASUS GT630-2GD3 (It's a Fermi card and it needs injection, so I modified my DSDT. Full graphics acceleration worked in Sierra. No Clover injection. I tried using Clover injection instead, I saw no difference.)
      CPU: Intel Core i3-3210, iGPU disabled in UEFI

      All kexts updated to their latest versions, along with Clover.

      For more info, you can refer to the GitHub issue where I posted it. https://github.com/lvs1974/NvidiaGraphicsFixup/issues/3
      Any help would be appreciated.
      Thank you for your time!
    • By yaoqb
      i have strange glitch problem on my fresh 10.13.2 install
      the glitch trigered randomly
      it may start from subtitle video from firefox or some transparent panel from a program like clover configurator
      then the whole desktop will have the graphic glitch every program will be affected
      the glitch may clear when toggle the program window zoom in and out but will be likely popup again until restart the system
      the glitch can even be captured by the system's own screenshot short cut
      the following method i try didnt work
      nvidia webdriver latest lilu with NvidiaGraphicsFixup different powermanagement setting

    • By Pink Waters
      Hi guys, I have my dsdt.aml extracted from windows.
      I compiled just fine no errors, but when I try to add audio in it following this guide I get a lot of errors

      I am running High Sierra
      my audio is ALC889

      The errors are attached

    • By LuCyr04
      Hi guys, I have a weird problem using an Xeon E5450(775 modded) with nvidia card(8600gt & Quadro 580 FX same problem).
      First I want to say that in windows I don't have any problem, so it's not something about compatibility.
      When I try to boot in macOS with this cpu and nvidia video card I get only a glitch displayed(see attachments), the computer isn't froze, I can access it with ssh or file sharing, only no image.
      If I boot with nv_disable=1 flag I get image(no acceleration of course) and everything's fine.
      I tried the cpu on 2 different boards and 2 different nvidia cards and the problem is the same.
      With amd video card I don't have this problem.
      What I tried and failed:
      Deleting injection from dsdt and injecting or not injecting with clover.
      Using nvidia web drivers.
      Changing CPU settings from bios, like virtualisation, speedstep etc.
      Different macos versions(10.11, 10.12, 10.13)
      The hack I want to use with this CPU is the Desktop from signature, I can provide dsdt or entire efi if it's needed but I don't think it matters since I have the same problem with 2 different boards and 2 different nvidia cards.