Jump to content
geminidragonrx7

DSDT files of working systems

95 posts in this topic

Recommended Posts

Advertisement

ROM file: /Users/moasimac/Downloads/VGA Bios GTX550TI/vgabios.rom

Copyright 2008 Arti Itra version 1.4

If you find this program useful you

may consider a PayPal donation to:

arti.macelite@gmail.com

 

0400000000000300040000000000000700000000

Share this post


Link to post
Share on other sites

with Intel hackintosh NVCAP Maker works and can read my VGABios.rom file ,it's crazy

 

thx akimoa

Share this post


Link to post
Share on other sites

iFIRE, here is a topic to address problems with the DSDT or not? I'm still having problems with mine.

 

DSDT Issues can be discussed here. But general post installation steps, like kexts or addressing other issues with methods other than DSDT edits, will be moved to the help topic. Discussions about uni and [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] will be deleted, not moved.

 

Thank you.

Share this post


Link to post
Share on other sites

iFIRE, Repari where the arrow is pointing in ATY "Hamachi" is it that is causing graphical glitches? Since it is not carrying the Framebuffer "chutoro"?

capturadetela20130513s2.png

Share this post


Link to post
Share on other sites

can be, you have edit your boot.plist with chutoro? for now your system read only RadeonFramenbufer, for see that framenbufer your system read, put this code in terminal app, you need have installed lspci.kext

 

this is for my framenbufer of my card HD 5000 series

 

bash-3.2# ioreg | grep ATY

| | | | +-o ATY,Vervet@0 <class AtiFbStub, id 0x10000035e, registered, matched, active, busy 0 (90 ms), retain 8>

| | | | | +-o ATY_Vervet <class AMDFramebuffer, id 0x10000036b, registered, matched, active, busy 0 (16 ms), retain 18>

| | | | +-o ATY,Vervet@1 <class AtiFbStub, id 0x10000035f, registered, matched, active, busy 0 (0 ms), retain 8>

| | | | | +-o ATY_Vervet <class AMDFramebuffer, id 0x100000379, registered, matched, active, busy 0 (0 ms), retain 14>

| | | | +-o ATY,Vervet@2 <class AtiFbStub, id 0x100000360, registered, matched, active, busy 0 (0 ms), retain 8>

| | | | | +-o ATY_Vervet <class AMDFramebuffer, id 0x10000037f, registered, matched, active, busy 0 (0 ms), retain 14>

| | | | +-o ATY,Vervet@3 <class AtiFbStub, id 0x100000361, registered, matched, active, busy 0 (0 ms), retain 8>

| | | | | +-o ATY_Vervet <class AMDFramebuffer, id 0x100000385, registered, matched, active, busy 0 (0 ms), retain 14>

bash-3.2#

Share this post


Link to post
Share on other sites

It is to enter the "org.chameleon.boot.plist"? it is just my:

<dict>

<key>AtiConfig</key>

<string>Chutoro</string>

<key>AtiPorts</key>

<string>5</string>

<key>DSDT</key>

<string>/Extra/DSDT.aml</string>

<key>EHCIacquire</key>

<string>Yes</string>

<key>EthernetBuiltIn</key>

<string>Yes</string>

<key>GraphicsEnabler</key>

<string>No</string>

<key>Kernel</key>

<string>mach_kernel</string>

<key>Kernel Flags</key>

<string>arch=x86_64 npci=0x2000</string>

<key>Legacy Logo</key>

<string>Yes</string>

<key>RestartFix</key>

<string>YES</string>

<key>SMBIOS</key>

<string>/Extra/smbios.plist</string>

<key>SystemType</key>

<string>1</string>

<key>Theme</key>

<string>Choose_Your_OS</string>

<key>Timeout</key>

<string>5</string>

<key>UHCIreset</key>

<string>Yes</string>

<key>UseKernelCache</key>

<string>No</string>

</dict>

</plist>

 

Last login: Tue May 14 06:42:00 on console

iMac-de-Jorge:~ jorge$ ioreg | grep ATY

| | | | +-o ATY,AMD,RadeonFramebuffer@0 <class AtiFbStub, id 0x100000315, registered, matched, active, busy 0 (7127 ms), retain 8>

| | | | +-o ATY,AMD,RadeonFramebuffer@1 <class AtiFbStub, id 0x100000316, registered, matched, active, busy 0 (1 ms), retain 8>

| | | | +-o ATY,AMD,RadeonFramebuffer@2 <class AtiFbStub, id 0x100000317, registered, matched, active, busy 0 (0 ms), retain 8>

 

In the folder "extensions" is this kext: "lspcidrv.kext" this is the same if not I have it.

Share this post


Link to post
Share on other sites

OK, your system not read your framenbufer chutoro, only read

AMD,RadeonFramebuffer, this can be botloader problem, try Clover and see if this work for you.

Share this post


Link to post
Share on other sites

Has a new version of "Chameleon" to "Chameleon-2.2svn-r2225" and I have not installed this version, would solve this problem?

Share this post


Link to post
Share on other sites

Can you tell me how do I add the information of the video card in clover?And it seems to me that the clover is not compatible with my system.

Share this post


Link to post
Share on other sites

iFIRE Thanks for everything you are very good people, but I'll give up my system is AMD and I have put in my head that "Hackintosh" is only for INTEL system, I tried with all bootloaders! the only one that works on my system is the "chameleon" and I've tried this and lost the mood, does not load at all the "Framebuffer" my plate.

Sorry for the inconvenience. Thank you.

Share this post


Link to post
Share on other sites

i got this motherboard J&W-A61PM-D3

the chipset is nForce 6100-4xx MCP-61 / AMD K-10

question is how can you fix this annoying error :

_HID string must be exactly 7 or 8 characters (NVRAIDBUS)

this error was found under NVRBUS within the PCI0 section 

i can manage other error(s) and warnings but not this one 

 

can you guys help me giving the correct string value to the dsdt? or should i just delete the bugger from my dsdt?

 

(unpatched dsdt attached below) 

 

 

DSDT.aml.zip

Share this post


Link to post
Share on other sites

i got this motherboard J&W-A61PM-D3

the chipset is nForce 6100-4xx MCP-61 / AMD K-10

question is how can you fix this annoying error :

_HID string must be exactly 7 or 8 characters (NVRAIDBUS)

this error was found under NVRBUS within the PCI0 section 

i can manage other error(s) and warnings but not this one 

 

can you guys help me giving the correct string value to the dsdt? or should i just delete the bugger from my dsdt?

 

(unpatched dsdt attached below) 

I can't promise you anything but you may try

DSDT.zip

Share this post


Link to post
Share on other sites

Can anyone help me editing my dsdt? I don't have any clue how to make it fully functional. Thanks in advance!

 

my computer specs:

 

FX8320

Gigabyte 970A-D3P

16GB 1600mhz

MSI 7770 PowerEdition

 

GIGABYTE 970D3P.zip

Share this post


Link to post
Share on other sites

Can anyone help me editing my dsdt? I don't have any clue how to make it fully functional. Thanks in advance!

 

my computer specs:

 

FX8320

Gigabyte 970A-D3P

16GB 1600mhz

MSI 7770 PowerEdition

Hi zerking,

  • create a new dsdt.dsl from your system, your DSDT.aml you created and compilert did not fit
  • install all necessary patches from the DSDT editor.
  • after each patch install you should start, so at the end of the no fault remain, proceed step by step the compiler.
  • look here and follow the instructions by Rampage DEV , Rampage Dev has to make a youtube video,
  • look in your IOREG-file according to where your graphics card is recognized, in your case, see "PC02" use the search from the DSDT editor and add the patch as described,
  • at the end DSDT compilers as save DSDT.aml, then test the dsdt.aml

Good luck!

 

 

here is the patch for your graphics card:

                Device (GFX0)
                {
                    Name (_ADR, Zero)
                    Method (_DSM, 4, NotSerialized)
                    {
                        Store (Package (0x10)
                            {
                                "AAPL,slot-name", 
                                Buffer (0x07)
                                {
                                    "Slot-1"
                                }, 
                                "device-id", 
                                Buffer (0x04)
                                {
                                     0x3D, 0×68, 0×00, 0×00
                                }, 
                                "@0,name", 
                                Buffer (0x0D)
                                {
                                    "ATY,Aji"
                                }, 
                                "@1,name", 
                                Buffer (0x0D)
                                {
                                    "ATY,Aji"
                                }, 
                                "@2,name", 
                                Buffer (0x0D)
                                {
                                    "ATY,Aji"
                                }, 
                                "@3,name", 
                                Buffer (0x0D)
                                {
                                    "ATY,Aji"
                                }, 
                                "model", 
                                Buffer (0x13)
                                {
                                    "AMD Radeon HD 7770"
                                }, 
                                "hda-gfx", 
                                Buffer (0x0A)
                                {
                                    "onboard-1"
                                }
                            }, Local0)
                        DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
                        Return (Local0)
                    }
                }        
Edited by spakk

Share this post


Link to post
Share on other sites

with Aji FB my screen black-out completely... do you have any suggestion for the FB or if you could help editing my ATI Personality or some sort cuz these are complicated stuff for me to handle.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×