Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 

Install Mac OS X HP pavilion dv6

10 posts in this topic

Recommended Posts

Hey guys! I'm going right to the point...I have an HP laptop (shame on me!) and I think it's the most problematic laptop where install Mac OS. I have a HP Pavilion DV6 3104sl with Intel I5 460m, Ati 5650, 4gb Ram, atheros 9285 and some other stuff that I don't think really deserve to know(If i am wrong, say me and I will tell you.

THe point is I can install only Snow leopard 10.6.3...I want almost 10.6.8! When I try to update the version(I did it in 1000 ways: Using some "BEAST", copy and paste kext ecc...!) it stuck to "NTFS Volume Name....Version 3.1................It's frustrating!

Well, I try with Iatkos L2M, first it goes but at the next restar it stuck to ioplatform kernel panic...So I decide to reinstall it...And ladys and gentleman the DVD stuck on the fisrt screnn(yes, the first screen when it says "Press f8 to enter boot ecc...") and he don't go ahed! SO I try Iatkos ML2...the same! He install it the first time then it stuck on the first screen...Well, I supposed there is a bootloader problem so I download some stuff(R Boot LE) and try to start from then...It make me see some line in a fraction of second and return on the bootloaeder...The same on Iatkos l2m and Iatkos ML2...I try Lion Retail (my father has mac, I use his version) and he gave me "Local Apic Error"...I5 supposed to be native so I don't get what he want! I try with Mountail Lion (kindly offer by my father)...Same error!

Finally I try Niresh Lion and Mountain Lion! Lion don't start like Iatkos version...Mountain Lion start...Install it...And a few moment to complete the installation say me "installation failed!"...DOH!


So I think I try the possible and the impossible...The only think that remain to me is YOU!

Thanks for everty single replies I get!

Share this post

Link to post
Share on other sites

Install iATKOS ML2, I have a HP DV6 3194 and all is working perfectly.

I've choose this packages :


PS : U'll also need and EDID file, I found it on another thread here. If you haven't it boot with with "GraphicsEnbaler=No"

Share this post

Link to post
Share on other sites

Thank for the reply man! The problem with Iatkos is that It doesn't start! It stuck to screen where is the "countdown" and ask you to enter f8 to see the option...and if I enter f8 or any key or I wait the countdown end it frezzes!

I'm going to be crazy!

Share this post

Link to post
Share on other sites

I try the with another guide from Iatkos for Iatkos ML2 but same problem, my drive is not bootable! I install in each guide the boot loader in the drive like they ask me but also with other bootloader my pcdon't read my drive or it read only Niresh drive but during the installation it stucks to "Appleusbehci Uiminitialize...error occurred ecc." I also try with differents flags (USBBusix, EHCIacquire ecc.)

My laptop is

I5 460m 2,53ghz

4 gb ram

Intel hd graphics/AMD mobility radeon 5650 HD

Atheros 9285 Wireless

Toshiba 500gb sata


For the Extra folder now i retry your guide and post it but if someone can help me with the boot from drive i will very appreciate it!


P.S. Sorry for bad english!

Share this post

Link to post
Share on other sites

So I see a very strange thing...My drive is bootable only when is on MBR! But to install the boot packege on my drive, my drive have to be GUID...There is something that can I do?

Share this post

Link to post
Share on other sites

Hi CostardRouge, I've installed successfully ml2, but my ati 5650m still doesn't work. I have not a windows partition.

Where did u find your EDID file?


Sorry for my bad English

I have hp dv6 3011el

Share this post

Link to post
Share on other sites

I´ve the same Problem with my Dv6 6b06eg.. I cant boot. So i try the [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] Cd. Boot from it and want to start the Ml2 Dvd after that. But always i have to reset my Laptop. Nothing did work.


My Englisch is not the best :P I´m Sorry ;) 

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Posts

    •   Boot option name retrieval 1) Locate the booter image as explained blow. 2) Locate ".contentDetails" in the parent folder 2.1) if unsuccessful, locate ".disk_label.contentDetails" in the parent folder 2.2) if unsuccessful, retrieve the volume's name   HFS Boot 1) Retrieve blessed file via https://github.com/CupertinoNet/EfiPkg/blob/development/Include/Guid/AppleBless.h#L41 1.1) if unsuccessful, retrieve blessed folder via https://github.com/CupertinoNet/EfiPkg/blob/development/Include/Guid/AppleBless.h#L45, append "\\boot.efi". NOTE: This is broken in the latest binary I checked. 1.2) if unsuccessful, use the following hard-coded paths: "\System\Library\CoreServices\boot.efi", "\EFI\APPLE\{ARCH}\BOOT.EFI", <StandardEfiPath>, "\\boot.efi" in this order 2) FV2 Recovery does not follow the usual practice because it is not shown by BootPicker anyway. Determine it via https://github.com/CupertinoNet/EfiPkg/blob/development/Include/Guid/AppleBless.h#L49, verify it does not match 1).   APFS Boot 1) Determine the APFS Volume Info (and hencefor detect whether it is APFS in the first place) via https://github.com/CupertinoNet/EfiPkg/blob/development/Include/Guid/AppleApfsInfo.h#L54 1.1) Determine the APFS Container Info via https://github.com/CupertinoNet/EfiPkg/blob/development/Include/Guid/AppleApfsInfo.h#L36 1.2) Verify the Volume Role via https://github.com/CupertinoNet/EfiPkg/blob/development/Include/Guid/AppleApfsInfo.h#L51 1.3) Retrieve blessed file analoguous to HFS 1). NOTE: This step and 1.3.1) are broken in the binary I checked, hencefor it does not happen, but is probably supposed to. 1.3.1) if unsuccessful, retrieve blessed folder and append the booter name the same way as in HFS 1.2) 1.4) (if unsuccessful,) locate all Volumes that are part of the same container, check whether the current Preboot partition has folders named by the just located Volumes' GUIDs and append the hard-coded paths from HFS 1.2) if existant 2) Recovery detection works the same way as 1.4), just for a Recovery instead of a Preboot volume
    • Got garbled sound in earphone    Notebook Asus X550VX i7 - 7700hq with ALC255 not working with applealc  layout id  3, 13, 17, 18, 27, 28, 99 its is working with VoodooHDA but the new one 2.9.1 it much has low volume, but bad sound in earphone     codec dump linux https://drive.google.com/file/d/1pg2y76WvFYsO8vFY-2B_2OLyKMmkQ8Tg/view     latest debug http://www.mediafire.com/file/2pjny4eq5r64ed8/debug_1383 (1).zip  
    • For F6 Bios, which DSDT is the one i should use? I´m a little confused in the Mass of DSDT here ;-).   Great Thread by the Way.   Another Question: I have 2 960Pro inside my Rig (one with OS X, one with Windows 10). When i try to mount my EFI on OS X NVMe the system freezes... :-(   DWhen i unplug the Windows NVMe everything is fine an it mounts the EFI.   Anybody an idea?   Tried the upper Port on the Board (OS X) & the middle / lower Port, in the Middle it mounts the EFI in the lower it freezes.   But i need the middle Port for an SATA M.2 SSD :-D... Even when i plug the Windows NVMe into an PCIe Adapter Card it freezes at the point i mount the EFI.   I´m mounting with Clover Configurator.     Thank You guys.
    •   Just add "ngfxsubmit=0" to config.plist to disable the fix within nvidiafixup
    • @MegaCookie   ok, I have no solution for that Trial 7 good for the release?
      Is this codec good enough for you?