Jump to content
InsanelyMac Forum
Turaiel

[SOLVED] Unable to Install on Inspiron 1520

Recommended Posts

I posted about this a few months back, but after a few days I found I didn't have the time to continue messing with Mountain Lion on my Inspiron 1520.

 

I followed this guide: http://legacy.tonyma...p?f=170&t=26283

Only problem is, Chameleon won't continue after I select which partition I want to boot from.

 

I figured that the process for Mountain Lion would be about the same as it is for Lion (I don't have a copy of Lion).

 

I tried selecting Lion_USB from the menu, but then it just goes to a gray screen and reboots. I tried with the suggested flags ("arch=i386 -x -v"), and that spat out very little text and jumped back to the menu. I tried with just "-x -v", and then it loaded all the appropriate kexts, got a bit past "Restart fix applied" (that's as far as I was able to read) and rebooted.

 

I feel bad for letting my previous post die, especially since I was being helped (thanks eep357!), but I guess I just got swamped with work (yay college).

 

I'm currently trying this guide: http://www.insanelym...-mountain-lion/

I have my doubts as to whether it will work though, considering it's made for Gigabyte motherboards, and this Dell laptop is hardly that.

 

EDIT: SOLVED! DSDT patched by LatinMcG: http://www.insanelym...0/#entry1886726

Booted properly with a new copy of Lion (not ML) and the "-v" flag.

 

Specs:

Dell Inspiron 1520

Intel Core 2 Duo T7500 2.4 GHz

nVidia NB8P-GS (I think that's a GeForce 8600M)

2 GB RAM

 

Thanks in advance for any help!

Share this post


Link to post
Share on other sites
Advertisement

follow the dsdt guide for m1330 and also there is a guide for many dell laptops.. u should be ok following that

 

main thing for Lion on this 1520 is.. the DSDT Device (PCI0) is missing _UID under _ADR

without it lion wont work.

 

also almost all regulars here dont use tonyschmucX69 stuff

Share this post


Link to post
Share on other sites

I found the issue with Chameleon not starting. It was because the method in the guide was for Lion only. I got a copy of Lion from my roommate (who owns a Mac), and I was able to complete the first 17 steps. Now I'm stuck at a kernel panic saying "No HPETs available...CPU(s) configured incorrectly". I've attached a photo.

 

Here's what I've tried:

Used the DSDT with the guide, flags:

  • acpi=i386 -x -v
  • -x -v ForceHPET=Yes
  • acpi=i386 GraphicsEnabler=Yes ForceHPET=Yes -x -v

I also used the DSDT here: http://www.osx86.net...on_1520_a9.html with the same flags.

 

I tried to use the guide you posted to patch the DSDT, but it would have taken me hours to get all the code corrected. Also, I wasn't really sure if all of it would apply to my machine.

post-963367-0-94385100-1360127650_thumb.jpg

Share this post


Link to post
Share on other sites

Thanks! I added that DSDT, but now I'm having an issue with "Still waiting on root device"

Ideas?

 

EDIT: I applied modifications listed here: http://www.insanelym...y/#entry1862155 and booted with "-x -v". I was able to get into the installer, but then I got an error, and the installer was unable to continue. The install error log is attached.

Installer Log 7-Feb-2013.txt

Share this post


Link to post
Share on other sites

The BIOS is still how it was before, set to AHCI.

 

Also, I tried again without the modifications from the link I mentioned and got the same result.

Share this post


Link to post
Share on other sites

Fixed! Turns out, the copy of Lion was corrupted. I got a clean copy from my roommate and it's installing as we speak!

 

Thanks for the help and the DSDT!

 

[solved]

Share this post


Link to post
Share on other sites

Turaiel
Could you make a comprehensive post regarding how you actually suceeded, compiling all data, instruction and giving credit where it's due please.
I request this as I am still facing a CMOS reset or USBEHCI issues when attempting to install  Mavericks 10.9


Thanks in advance

Share this post


Link to post
Share on other sites

I was regrettably unable to get anything stable installed on this machine in part due to the AMD kernel I was using. I've given up on installing anything other than Snow Leopard on this machine and I'll be purchasing a new machine to hackintosh within the next couple months.

 

This link might be able to help, but I can't provide you with anything other than that.

 

Also, bumping posts is against forum rules, and this thread has been dead for close to a year. Please keep that in mind when posting on this site. Please give the rules a read.

 

Good luck!

Share this post


Link to post
Share on other sites

Sorry, I thought this was the thread for my Inspiron 531. My bad. The guide linked in the first post of this topic along with the DSDT linked in LatinMcG's post should get you going with Lion. Unfortunately, the modifications applied in the guide do not apply to Mountain LIon and Mavericks, so for that you're on your own.

Share this post


Link to post
Share on other sites

Sorry, I thought this was the thread for my Inspiron 531. My bad. The guide linked in the first post of this topic along with the DSDT linked in LatinMcG's post should get you going with Lion. Unfortunately, the modifications applied in the guide do not apply to Mountain LIon and Mavericks, so for that you're on your own.

That link you're referring to is dead.

Share this post


Link to post
Share on other sites

Looks like it moved here.

 

Also, if you want to continue discussing this, it's probably wise to start a new thread or PM me. This one's probably going to get locked for being bumped so many times.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.



×