Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


OS X on an IDE DELL?

20 posts in this topic

Recommended Posts

Hi, all

I have attempted a few hackintoshes before, mostly on clearly incompatible hardware (such as SONY latops), but now I got and old DELL Optiplex GX270, which has been proven compatible by many people inside and outside this forum (like here:

). Unfortunately, this computer has a 40 GB IDE Drive. This makes stuff a little more complicated. I have attempted to install both Tiger and Leopard, but both without success and with the same error.

I've tried many variations of OS X, but none boots me further than 'still waiting for root device'


Here is what I did:

  • I used a USB installer with Flashboot, because the DELL won't read DVDs
  • I tried different USB ports
  • I tried some boot flags that were listed as solutions to this problem (although without IDE)

Can someone reccomend me either what "distro" to try out, or what boot flags or troubleshooting options could help me? (Please don't tell me stuff like "get a new hard drive/optical drive" or "don't install OS X on something that old")


Here are the Specs of the PC:

Intel Pentium 4 @ 2.8 GHz

Intel Integrated Graphics chip

40 GB IDE Hard Drive

1280 MB of RAM (2x512mb + 2x128mb)

Share this post

Link to post
Share on other sites

That's because 865 is paired with ICH5 which apparently has no AHCI support.

Anyway It's a non-issue, AHCI mode is not required for OS X to work, it's just more convenient. All you need is the right driver, the right combination of drives (don't try to mix PATA and SATA drives connected to the same controller) and BIOS settings.


Use AppleIntelPIIXATA.kext:



If you want to try a distro I recommend JaS 10.5.4 Client/Server or iPC 10.5.6 Final, if you can still find them. My first Hackintosh was ICH5/i865 as well.


Jumper and cable all PATA drives as Master and place one drive on each channel, at the end of the cable. Don't use cable select. Try not to use any SATA ports, disable them in the BIOS if you can.

Share this post

Link to post
Share on other sites

Thanks for the reply, I will try those, although iPC can't fit on a USB,because I use flashboot (which formats the flash drive as FAT32, which can't fit an entire iso, since it copies the iso to the flash drive and tries to boot from it) If you have any other way os USB-Installing (Transmac did not work, possibly because of a linux bootloader being present(?)). I guess I coul also use the existing ISO and add the kext, but I would have to know how to add a kext to an iso. Is that, too possible?

Thanks a lot!

Share this post

Link to post
Share on other sites

No idea about your Dell, not familiar with the hardware. Yes, master/slave/cable select is set via jumper on the hard drive. Read more on Wikipedia.


Don't use flashboot, burn iPC or JaS to a DVD. You don't need flashboot (whatever that is), all distro DVDs have their own boot loader. /EDIT oh I just saw, you can't boot from DVDs. Don't know what to tell you then, I never installed OS X from USB on my ICH5/i865 Hackintosh.

Share this post

Link to post
Share on other sites

Okay, did the cables. Still the same error,at a different position. I get an error about a kext, which is very close to the one you sent me.But this one is pata. I would add the one you gave me into the iso if i knew how. Still using the USB installer, i might get a dvd drive, but not anytime soon. Here is the error:

AppleIntelPIIXPATA:80-Conductor cable not detected on primary channel
Still waiting for root device......

Share this post

Link to post
Share on other sites

PUT all this kexts in Extra/Extensions of your USBInstaller, if this not detect your disk try put device id of your controller in infoplist the kexts.





Share this post

Link to post
Share on other sites

Are you using a 80 conductor cable and is the drive properly jumpered as master and installed at the end of the cable? Make sure there is only one device on each cable and both are jumpered as master. Disconnect any slave devices.


Check the BIOS settings for the ICH5. You have combined, enhanced and compatible mode or something like that. It can be set to one of three different modes, only one of them will work when using only PATA drives, and I can no longer remember which one it is. Try them all and make sure that jumpering and cabling is correct.

Share this post

Link to post
Share on other sites

The jumper is on master, in fact, that id's what got me to this error, before it was set to something like CS. Still same error, but earlier, message about iTunes, not what I wrote in my previous post. I'll try the bios settings.

Share this post

Link to post
Share on other sites

Dell's BIOS is practically option-less. But I sorted out the 80 pin connector problem. After setting the jumper to 'master', my HDD was not recognized! Now, as I have set the drive back to 'cs', the drive is being extremely slow and my current OS 'ElementaryOS' (Based on ubuntu) does not boot as it shows tons of errors (it would probably eventually boot, as I predict it is also being slow). And yes, setting the jumper back brings me back to "Still waiting for root device" Now booting os x I get still waiting for root device all over the place as the boot is super slow, but eventually freezes on the lines below:

Still waiting for root device
AppleIHCxSATA: Primary PCI IDE Channel Disabled
AppleIHCxSATA: Secondary PCI IDE Channel Disabled
Still waiting for root device
IOUSBMassStorageClass has no kernel dependency
Still waiting for root device
Still waiting for root device
Still waiting for root device
and then it just keeps on still waiting for root device.

There is (little) distinguishable HDD activity.

Share this post

Link to post
Share on other sites

Well it does state very clearly that both channels are disabled.


Still waiting for root device means that the OS can't see your hard drive (your drive is the root device) which is normal when there's no driver loaded for the controller it's attached to.

AppleICHxSATA is the wrong driver. As I said earlier, you should be using AppleIntelPIIXATA.kext for Intel ICH5.

Share this post

Link to post
Share on other sites

No idea, I've never had to do that. I'm sure there's a tutorial here somewhere, problem is it'll probably require access to a Mac or working Hackintosh. I don't think you'll be able to rebuild the installation packages on Windows.


I can't help you any further with this, we're going in circles here.


I know that both JaS 10.5.4 and iPC 10.5.5 Universal PPF5 final have the driver you need. JaS 10.5.4 had solid support for i865/ICH5. I also remember vaguely installing Kalyway 10.5.2.



There's really no way you can get a hold of a DVD drive?


That DVD drive of yours won't read DVDs at all, or are you saying that it just won't boot from them?


I'll say this once more:

Each drive must be on its own IDE channel, each jumpered as master, plugged in at the end of the cable, both cables must be 80 conductor.

Do not plug both drives into the same IDE channel/the same cable, it will not work.

Share this post

Link to post
Share on other sites

The DVD drive can't read dvds. Under linux (and previously windows) clikcing on the cd drive did nothing. CDs are perfectly bootable. I will try to get a hang of a drive, because the distros are all bigger than 4GB (FAT32 limit for booting)

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Discount_Mac
      I have done a semi-successful install of macOS Sierra 10.12.6 on my Dell OptiPlex 3010. When I mean semi-successful, I mean I have some issues left, one of them is Networking.
      Networking, meaning Ethernet, does not seem to work on this machine after installing Mac OS. I've tried installing kext files, reinstalling Sierra, and so on but nothing seems to work, I have an Ethernet cable plugged and it's lights flashing and whatever but the connection does not show up in Sierra.
      My PC Specs are:
      Dell OptiPlex 3010 MT
      Intel Core i3-3240 @ 3.40GHz
      AMD Radeon HD 7470
      4GB of RAM
      Realtek RTL8111E
      So, Any Help?
    • By Trung_Nguyen
      Hello everyone, 
      I'm getting these error at verbose boot, It waits at this line a little bit long. I think it's a DSDT error:

      Here is my DSDT:DSDT.zip
      Could someone help me fix this? Thank you all!.
    • By Trung_Nguyen
      Hello everyone,
      I am trying make the fix keyboard backlight on Dell Latitude E6230. It currently works but the macOS not recognized it. There is a keyboard shortcut which had 6 states of bright. I'm using IOWMIFamily to use the display brightness shortcut(Fn Up/Down) Is there a way to make the Ultimate keyboard backlight slider like in Debian?

      P/s: By the way, what is the ADB codes for VidMirror? I want to remap it because it controlled by PS2 and currently map to cmd+P(print) Thanks again
    • By Zsparrow0
      NOT WORKING   SD Card Reader (Use USB adapter ) Hibernation Nvidia Graphic Cards Fingerprint Reader Thunderbolt HotPlug REQUIREMENTS   Fresh installation One working OSX environment Whole disk available (No partitions) Knowledge in PLIST edition Backup Made (EVERYTHING WILL BE ERASED) Latest BIOS version 4k sector patch NVME WIFI CARD DW1560 (EFI FOLDER CONTAIN PATCH FOR THIS CARD ONLY)     1 - CREATE USB     Download High Sierra from AppStore Plug in your USB Key (16GB or More) Format it with Disk Utility and name it « MyVolume » Launch Terminal and type : sudo /Applications/Install\ macOS\ High\ Sierra.app/Contents/Resources/createinstallmedia --volume /Volumes/MyVolume Mount the EFI partition /MyVolume/EFI/ with Clover Configurator (See in the EFI Folder) Copy the entire EFI folder linked to the post to /MyVolume/ 2 - BIOS SETTINGS   MAKE SURE EVERYTHING IS CORRECT BEFORE CONTINUE OR IT WILL FAIL ON BOOT !     System Information          Check that Video Memory is already 64MB       Advanced Boot Options (all off)        System Configuration      SATA Operation (AHCI)      Drives (all on)      SMART Reporting (on)      USB Configuration (all on)      Dell Type-C Dock Configuration (on)      Thunderbolt Adapter Configuration (all on, no security)      USB PowerShare (on)      Audio (all on)      Touchscreen (on)      Miscellaneous Devices (all on except SD Card Reader)      CPU XD (on)      Secure Boot        Secure Boot Enable (disabled)      Intel Software Guard Extensions        Intel SGX Enable (Software-Controlled)      Performance        (Everything on/enabled)        Power Management        (USB Wake Support = off)      (Wake on Dell USB-C Dock = on)       Wake on WLAN (off)      Block Sleep (off)        Virtualization Support        (Everything on)    3 - BOOT PROCESS
        Start your computer and press F12 to open the boot menu Boot from your USB Key Select the "Installer from (Your usb key)" (Verbose mode is enable by default to see what's going on if it fail)   -----------------------------------------------------------------------------------------------------------------------------------------     WAIT ! EVEN IF YOU THINK THAT THE LOADING BAR IS STUCKED IT COULD TAKE 5MIN TO LOAD ENTIRELY     IF IT FAIL SEE THE REHABMAN GUIDE BEFORE ASKING QUESTION     IF YOU CAN'T BOOT YOU CAN TRY TO USE A FAKE IG-PLATFORM GO TO THE CLOVER OPTION IN THE GRAPHIC PARTS AND USE A FAKE IG-PLATFORM SUCH AS 34567898764   ----------------------------------------------------------------------------------------------------------     4 - INSTALLATION   - Once arrived on the installation screen - Open Disk Utility and Erase your Main Hard Drive and format to : MacOS AFPS (not encrypted) - Go back to the installer continue and choose your Formated Hard Drive to install MacOS. - The computer will reboot after about 2 min - Press F12 to choose your usb key and hit ENTER   (YOU COULD HAVE 2 CHOICE DURING THE REBOOT : INSTALLER ON "YOUR DRIVE NAME" OR PRELOADER "YOUR DRIVE NAME". You have to use "Installer on your "drive name" in case it FAIL select the OTHER OPTION. You will have to do this twice if I remember correctly.   BE CAREFUL YOU HAVE TO ALWAYS BOOT ON YOUR USB KEY BECAUSE CLOVER IS NOT YET INSTALLED ON THE SYSTEM, SO PRESS F12 ON EVERY REBOOT AND CHOOSE YOUR USB KEY UNTIL CLOVER PROPERLY INSTALLED     5 - POST INSTALLATION   - Open Kext Wizard in My EFI folder - Click on installation tabs browse kext and select ALL THE KEXT IN USB/EFI/CLOVER/KEXT/OTHER - Make sure that the destination drive is your MAIN HARD DRIVE and press INSTALL - Once done go to MAINTENANCE TAB and select the radio button for System/Library/Extensions and press EXECUTE.   6 - RESTART WITHOUT USB   - Disconnect your usb and reboot normally, everything should work properly now.     !!! CONGRATULATION YOU DID IT !!!               if not...       Give us enough clear information in the comments section so we can help you to have this laptop working.   A BIG         TO     Dell for making this laptop Apple for Mac OS RehabMan for so many detailed posts, enormous collection of SSDT files, kext development, and being overall incredibly helpful throughout this whole process KNNSpeed for this amazing guide Pike R. Alpha for his in-depth blog and the 0xE2 patch (among being the source of many other developments and patches) The Clover team for the Clover bootloader netkas, kozlek, and Slice for FakeSMC wmchris for his initial XPS 9550 write-up Jonny4911 for posting his 9560 setup and his version of the AudioFix folder syscl for a lot of work into the XPS 9360 and his build of VoodooPS2Controller darkhandz for his XPS 9550 repo toleda and goodwin_c for audio, ALCPlugFix goodwin_c for HWP dpassmor for the Thunderbolt/USB-C ExpressCard trick vit9696 for Lilu and AppleALC PMHeart for CoreDisplayFixup lvs1974 for NvidiaGraphicsFixup darkvoid for Wi-Fi patches filequit for the 5GHz global channel bonding patch denskop for the "Boot Graphics Glitch" patch netkas, kid2010, and syscl for the Thunderbolt 3 blacklist bypass patch Blazinsmokey for all his good advice and knowledge   AND ALL THE OTHER THAT I DIDN'T QUOTE BUT WHO CONTRIBUTED TO MAKE THIS DREAM HAPPENED !     MORE CUSTOMIZATION   Improve battery life and CPU temperature :   Check the @abn6x Guide : http://www.insanelymac.com/forum/topic/331775-guide-how-to-undervolt-your-haswell-and-above-cpu/     EFI.7z
    • By Rocketval
      Hi everyone! My pc specs are these:
      Dell Optiplex 3010 SFF
      mobo: Dell 042P49
      cpu: i3-3240
      gpu: hd2500 (will be added a new gt710 next week)
      USB created with HackintoshZone restoreSierra from my macbook pro.
      So, I've installed from usb after setting up (I hope correctly) the bios (legacy, uefi doesn't work properly I think) and, even if I've restarted after waiting so long when it said "less than a minute remaining", I can boot just fine into Sierra in my SSD ("Hackintosh") selecting, when I start/restart the pc, boot from Hackintosh.

      Everything works fine except graphics (I know hd2500 is not supported so I just bought an used gt710 that will arrive next week), audio (it worked 2 times after setting with clover configurator, then it stopped) and ethernet (I think it's faulty, anyway I've a wifi dongle that works fine).
      BUT if the usb created with restoreSierra.pkg is not connected I can see Clover bootloader but I can't see my SSD "Hackintosh" which is the drive Sierra is installed in.

      I'm pretty sure something in post installation (Clover configurator -> Boot secton) is missing, these are the steps I made after the automatic initial setup:
      Mount EFI partition of SSD (since is not mounted by default)
      Install Clover EFI in order to install Clover Legacy.
      Copy EFI folder from HZ usb
      Delete EFI folder from EFI partition of SSD
      Paste EFI folder from HZ to EFI partition of SSD

      When I restart the pc w/o usb plugged I can't see the SSD, the space over the rounded icons is empty except from BOOT from EFI (and if select it it reload the same thing).

      I hope someone could help me, this is my first step in hackintosh world
      Have a nice day