Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


ATI 4650m and the 1600x900 LVDS via eDP

8 posts in this topic

Recommended Posts

There is a big problem well known for the ATI mobility users: 1600x900 screen in LVDS is very difficult to attain. I think I have found the real motive for this. ATI uses, in some cases, the eDP output for connect with the internal lcd probably because of the high resolution of the panel. In my case the output is the following:



Connector Object Id [14] which is [LVDS]

encoder obj id [0x21] which is [iNTERNAL_UNIPHY2 (osx txmit 0x12 [duallink 0x2] enc 0x4)] linkb: false

Connector Object Id [5] which is [VGA]

encoder obj id [0x15] which is [iNTERNAL_KLDSCP_DAC1 (osx txmit 0x00 enc 0x10?)] linkb: false

Connector Object Id [12] which is [HDMI_TYPE_A]

encoder obj id [0x1e] which is [iNTERNAL_UNIPHY (osx txmit 0x20 [duallink 0x0] enc 0x1)] linkb: true


But the transmitter 12/04 or 12/01 give me a black screen or half resolution (even with the dual link patch that can be made with chameleon, DSDT or via ATY_init plist).

The root of the problem, then, I think is the connector type. Reading the Linux driver info ( http://cgit.freedesk...ecac298b8d441d0) in the section Connector Object ID Definition has it:


As you can see, the connector that is identified as LVDS with the redsox bios decoder is really the eDP decoder. Kizwan has noted that some Imacs uses that port: http://www.insanelymac.com/forum/topic/249642-editing-custom-personalities-for-ati-radeon-hd45xxx/page__st__260#entry1662530.

The problem is that with the Shrike framebuffer Mountain Lion simply not load the GUI in my HP. How to solve that? I mean how to patch a framebuffer with this info i.e eDP output to enable LVDS connected via eDP. What are the connector type and control flags?

Share this post

Link to post
Share on other sites

maybe it's the same problem found on any vaio with that card.. In my case with Lion, 4650m and 1920x1080 internal lcd I can only use safemode with 1400x1050 as max resolution and no QE/CI, in normal mode I've always had a gray screen with artifacts at login prompt..

Share this post

Link to post
Share on other sites

@volram, 14 in this output is not hex. 14=0xe.

@aunor, I Think that there is something in this direction. Take a look of a similar problem with the installation of Windows 7: http://support.microsoft.com/kb/978226. Note the reference to the Imac (4670m) in the description of the problem. However, some people with the connector object id [14] has been successful in getting the LVDS output. The problem should be in DSDT (sleep or lcd section). I noted that there is a interference between the lvds and hdmi output even though there is no conflict in the edited framebuff. When I plug the hdmi cable the lvds turn black (white line to backlight). More: when I plug a usb the lvds change the color (when it is not black). The problem is the conflict. Or the dual link pathc or the dsdt (sleep, usb, lcd). A big trouble.

Share this post

Link to post
Share on other sites

@volram, There is a another strange thing. LVDS with senseID = 7 mostly work without troubles. My Samsung R720 with 4650m have LVDS with sid=2 - black screen with any combinations.

VGA work

perfectly on any FB. But I don't try HDMI.

Share this post

Link to post
Share on other sites

My early theory is confirmed. In some cases 4650 mobility (and perhaps a lot of others AMD mobility GPUs) uses the LVDS/eDP connector. The log of softMCCS confirmed that:

Skipping over LVDS/eDP on ATI Mobility Radeon HD 4650

We need help of some guru to solve the problem. I believe that I found the root of it.

You can find my softMCCS log here: https://mega.co.nz/#...wgUgNbG2iVxuuk.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By tomh117
      When I turn on my PC it will show Clover on the 1080p monitor and the other two DP monitors will go into standby, if I boot OSX like this then all monitors will black screen instead of showing the login screen. The DP monitors will go into an endless loop of trying to get a signal and saying "Display Port" like they do when looking for a singal and the 1080p DVI one will just display a black screen. The system is not hung, I can still ssh into it.
      The only way for me to successfully boot and have all 3 monitors work is either to:
      fully turn off both DP monitors, boot only with DVI until log in screen, then turn on both DP monitors
      manually turn on both DP monitors while booting but before it comes to the login screen, so they are not in standby
      But if I just let it start normally it without doing either it black screens.
      The same thing also happens when I'm already logged in and have it running successfully and turn off all monitors and come back later. Usually (8 out of 10 times) when I turn them all on it works again, but the other 2 times all of them start to black screen the same way. It seems the most consistent way to avoid that is to turn both DP monitors on at the same time.
      What I've tried so far:
      SMBIOS 14.2, 15.1, and MacPro 6.1 (the current one), none of that helped.
      Lilu.kext + NvidiaGraphicsFixup
      Patching AppleGraphicsDevicePolicy.kext/Contents/Info.plist and setting everything to none
      Switching the 1080p monitor to HDMI but that was the same, can't switch the DP monitors really since they are 4k and need DP.
      Nothing had any effect.
      My setup:
      i7 4790k, GA-Z97X-UD3H, 32gb
      980Ti (reference card) driver 378. (should be the latest one)
      2x Samsung 4k monitor (Display Port)
      1x 1080p via DVI
    • By TommyV6
      Hi, on my gear (i7-3770 16GB GA-Z77X-UD3H GTX 760 2GB) Web Driver works only 1-3 reboots after instalation. After this I`m geting black screen in middle of loading. I can login remotly to my machine when screen is black. After rebuilding cache manualy or with kext Utility screen work again!   I have MacOS Sierra 10.12.6 with all updates nVidia Web Driver 378.05.05.25f04 installad Lilu.kext and NvidiaGraphicsFixup.kext On macos default driver I`m getting same results.   Latest Clovers is my boot loader.   How I can fix this up permanently ?  
    • By obov
      Hello everyone!  This is a new user to InsanelyMac, although I've built my Hackintosh long ago with the information on this forum
      But it seems like the problem I encountered has no solution posted here, I would like to share my solution to that. 
      I have an i7 6700k, a GIGABYTE Z170 motherboard (though these two are not important at all in this problem), and a GTX970. I recently updated my Hackintosh from 10.11 to 10.13.1 (I think it should also work for 10.13) through App Store. The system was successfully installed, but I found that it was impossible to log in the system with my GTX970 plugged in -- it always led to black screen (no signal) before the login screen was shown. 
      There are some discussion on InsanelyMac, but none of the solutions proposed worked for me. Here are my experiments:
      Since I am using iMac 15, 1 SMBIOS, I manually modified the AppleGraphicsDevicePolicy.kext so that it would not use the "Config2," or I can't even boot into the system with my IGFX (as we all know, it causes black screen / no signal before login).  AppleGraphicsDevicePolicy.kext is NOT the cause of the problem in my case, although they have the same symptom; before using this solution, check your SMBIOS and AppleGraphicsDevicePolicy.kext. I also put Lilu.kext and NvidiaGraphicsFixup.kext in my Clover, but since they do the same thing as manually modifying Info.plist, I don't think it really matters here. In case of installing a broken Web Driver to my Hackintosh, I enabled SIP before the installation of Nvidia driver. It seemed like it worked: the first time I installed the Web Driver with SIP disabled, as well as after I accidentally removed a kext from /S/L/E and broke the driver, it produced a "gIOScreenLockState 3" problem. One of my guesses: the "gIOScreenLockState 3" is due to a broken or disabled (i.e. forgot to add NvidiaWeb in Clover config) web driver. NVwebDriverLibValFix.kext has no effect. It changed nothing but caused reboot before login when I was using IGFX.  At last, I tried injecting a fake ID for Nvidia (0x00000000) and it WORKS! Go to "Devices" section in Clover Configurator (if you use it) and put 0x00000000 to "NVidia" in the "Fake ID" section, or modify the text of Config.plist like this:
      ... <key>Devices</key> <dict> ... <key>FakeID</key> <dict> <key>NVidia</key> <string>0x00000000</string> </dict> ... </dict> ... Then save, reboot. It should work if you have the same problem with me. 
      Hope this help. If you have any question, leave a reply. I would be glad if I can help someone solve the problem. 
    • By Mac-on-PC
      After upgrade from Sierra to High Sierra I just get a black screen after boot. Lilu.kext and WhateverGreen.kext in EFI/Clover/kexts/Other. I have a AMD Radeon HD5670 graphic card native supported by macOS out-of-the-box until now. What could be wrong? Can someone help. Thanks.
      Mobo:        Gigabyte GA-EG45M-DS2H (rev. 1.0) Intel®G45 + ICH10R Chipset Socket 755
      CPU:          Intel® Core™2 Quad Processor Q9550 (12M Cache, 2.83 GHz, 1333 MHz FSB)
      Graphics:  ASUS AMD ATI Radeon HD 5670 1024 MB
      SMBIOS:   Mac (27-inch, Late 2013)
      Clover:      4220
    • By syscl
      EnableLidWake.kext provides fix for Intel integrate graphics lid wake issue(enable internal display after sleep). This a Lilu plugin that provides users an alternative way to enable their lid wake after resuming from sleep. 
      Support platform: Haswell, Skylake and later on Kabylake...
      Usage: Install Lilu.kext + EnableLidWake.kext(and yes, you can inject it through bootloader)
      Here's the source code: https://github.com/syscl/EnableLidWake
      Here's the pre-built version of EnableLidWake.kext
      Credit: @vit9696 and his Lilu.kext
      Credit syscl for the lid wake patches
      Good luck!