Jump to content
GhostRaider

[GUIDE] 1st Generation Intel HD Graphics QE/CI

2,011 posts in this topic

Recommended Posts

Advertisement

Good news, the problems from 10.14.4 are solved.
1st generation Intel HD Graphics - the way is not over!!!
normal graphics patch of the Intel Kext's and:

Rollback from 10.14.3:

GPUSupport.framework to /System/Library/PrivateFrameworks
OpenGL.framework to /System/Library/Frameworks

DP5 10.14.4 works well again with transparency and acceleration.

Share this post


Link to post
Share on other sites
On 3/13/2019 at 2:32 PM, MacPeet said:

Good news, the problems from 10.14.4 are solved.
1st generation Intel HD Graphics - the way is not over!!!
normal graphics patch of the Intel Kext's and:

Rollback from 10.14.3:

GPUSupport.framework to /System/Library/PrivateFrameworks
OpenGL.framework to /System/Library/Frameworks

DP5 10.14.4 works well again with transparency and acceleration.

Good day my friend. Im using the high Sierra on 1st gen. From what you said I can go to Mojave 14.4 ? where can I find this frameworks ? Ty

Share this post


Link to post
Share on other sites
4 hours ago, Rikchell said:

Good day my friend. Im using the high Sierra on 1st gen. From what you said I can go to Mojave 14.4 ? where can I find this frameworks ? Ty

 

https://forums.macrumors.com/threads/macos-10-14-mojave-on-unsupported-macs-thread.2121473/page-497#post-27152791

Share this post


Link to post
Share on other sites
Posted (edited)

Good evening sorry for my English but come on, I own a Sony Vaio VPCEB laptop, i3 330m Arrandale LVDS Graphics and I can not activate the qe / ci acceleration with the framebuffers of this post, I tried to patch the FB kext but I did not get results I tested several methods shared by users in this same thread, but still no result, I get hackintosh mojave 10.14 but with only 4mb of VRAM when injecting the kexts I have white screen, VBIOS patch in Clover also does not work I usually use SMBIOS MacBookPro10,1 but also tried to use MacBookPro6, 2 and 6.1 also unsuccessfully tried to use IntelHdGraphicsPatcher by giofrida, please help I am already several days trying to solve this problem without any success I own a hackintosh Mojave 10.14 active on an asus laptop with i3 2330m intel hd graphics 3000 e did not give me as much work as this D: 

 

THAKS FOR HELP GUYS, REALLY HELPED ME ASF :sick:

 

Edited by bobzil

Share this post


Link to post
Share on other sites
Posted (edited)

Hi all,

 

I've found this forum recently, I plan to do a setup USB for an old Lenovo T410 (with i5 m540 CPU/ no dedicated GPU)

But I've stucked.

 

1. The linked clover version can't downloadable.

2. If I try to use a clover with same version (not special edition), even if the El Capitan install app on the Application folder, when I want to install clover to the pendrive, the install app not in the selectable items like in the picture.

 

I've tryed it under a virtual Mohave, and under a snow leopard, and mountain lion Hackintosh, but install app not seen.

 

What did i do wrong? Or how can I download the right Clover?

 

Edited by sirkope
misstype

Share this post


Link to post
Share on other sites

Help..

i working on i3 370M

Mac os sierra 10.12.6

smbios MBP6,2

 

but it says kextd waiting for IGPU

i use intel hd graphics kext mac os sierra Alternate

Share this post


Link to post
Share on other sites
On 6 de febrero de 2019 at 10:36 PM, Badruzeus said:

This method was still working long time ago under Snow Leopard (10.6.8) on my laptop with IntelHD 1st Gen graphics.

I attached my worked FB kext if you wanna give a try (also provided on above link, actually. Not sure if mine will give diff. result).

 

It was "2nd Stage Boot Glitch" WhateverGreen already solved this issue, tested upto 10.14.3 (18D43) and it works. Another method is using KextToPatch via Clover. Below is for 10.13.x - 10.14.x:

 

  Reveal hidden contents

 


<key>KextsToPatch</key>
        <array>
            <dict>
                <key>Comment</key>
                <string>Fix Second Stage Boot Glitch</string>
                <key>Disabled</key>
                <false/>
                <key>Find</key>
                <data>
                AQAAdSI=
                </data>
                <key>InfoPlistPatch</key>
                <false/>
                <key>MatchOS</key>
                <string>10.13.x,10.14.x</string>
                <key>Name</key>
                <string>com.apple.iokit.IOGraphicsFamily</string>
                <key>Replace</key>
                <data>
                AQAA6yI=
                </data>
            </dict>
        </array>
 

 

Choose only one, between WEG or KextToPatch and don't use altogether.

AppleIntelHDGraphicsFB.kext_10.6.8.zip

 

 

Then I can install 10.6.2 and the kext attached? Sorry for answering so late: 3

Share this post


Link to post
Share on other sites

Cant seem to get my laptop to boot with any of the kexts on HS 10.13.6. Some of them just reboot at the boot attempt, some just load up to 100% and just stay there.

 

I5-580M

8GB RAM

Toshiba Satellite L655 /H55 Express Chipset

Share this post


Link to post
Share on other sites
Posted (edited)
20 hours ago, koolp said:

Cant seem to get my laptop to boot with any of the kexts on HS 10.13.6. Some of them just reboot at the boot attempt, some just load up to 100% and just stay there.

 

I5-580M

8GB RAM

Toshiba Satellite L655 /H55 Express Chipset

Nvm was able to resolve this... Had to use the natit.kext which allows it to work properly, but I guess patching the DSDT is a better method that I will have to check out. Laptop is a Toshiba Satellite L655-S5069 if anyone else is ever interested in getting to work on that old of a laptop the Patch I used for HS was (macOS Sierra FB, SingleLink, Normal...., LW1 + natit)

Edited by koolp

Share this post


Link to post
Share on other sites

Thanks to all, this community is really great, I knew more about OS X in many aspects, I could see the implementations and changes from 10.6.8 to 10.14, the first system I wanted to try was Snow Leopard and curiously go through all the versions and This is the last one, I am very happy, if I can help someone with the same laptop as me (toshiba satellite l500-sp6018m) It would be great, even if you do not have the same laptop I want to learn more, Thanks again :)
Greetings from Mexico!!!!! , Enjoy the holidays. :fishing:

Captura de pantalla 2019-04-19 a las 02.28.07.png

Captura de pantalla 2019-04-19 a las 02.31.51.png

Captura de pantalla 2019-04-19 a las 02.32.26.png

Captura de pantalla 2019-04-19 a las 02.35.41.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By GhostRaider
      This download is only for users who have a laptop with a 2010 Intel® Arrandale Processor with Intel® HD Graphics:
       
      1st Generation Intel® Core™ Processor with Intel HD Graphics (Arrandale only)
      Intel® Celeron® Processor with Intel® HD Graphics (Arrandale only)
      Intel® Pentium® Processor with Intel® HD Graphics (Arrandale only)
       
      Make sure the Device ID and Vendor ID match with the following:
       
      Device ID: 0042 or 0046
      Vendor ID: 8086
       
      In here you will find my QE/CI and CI only packages for your 1st Generation Intel HD Graphics IGPU for OS X Mountain Lion, OS X Mavericks, OS X Yosemite, OS X El Capitan, macOS Sierra, and macOS High Sierra.
       
      Choose your package:
       
      Download the Intel® HD Graphics QE/CI package if your laptop is using the LVDS connector. This package has the necessary kexts to enable Quartz Extreme with Core Image (QE/CI). This enables full hardware/graphics acceleration.
       
      or
       
      Download the Intel® HD Graphics CI package if your laptop is using the eDP connector. This package enables Core Image (CI) only. This enables partial acceleration.
       
      Note: CI only (CI) is only available on OS X Mavericks 10.9.5 and below. Future releases of macOS requires full graphics acceleration (QE/CI) for optimal performance and stability.
       
      For more information about 1st Generation Intel® HD Graphics, everything is explained in my guide:
       
      http://www.insanelymac.com/forum/topic/286092-guide-1st-generation-intel-hd-graphics-qeci/
    • By jack-69
      DISM is your friend!
       
      Part 1: (For all the computers that don't have UEFI)
       
      Prepare two USB keys, one with El Capitan & one with Windows 10.
      First put the Windows USB, during the installation (when it asked the Windows code) press shift + f10 and will open the command prompt:
      diskpart list disk (list of your hdd) select disk 0 (0 is number of your hdd) clean (ATTENTION clean all your hard disk selected) convert gpt create partition efi size=200 (creates EFI partition) format fs=fat32 label=EFI We made a EFI partition.
      In my Hdd I have 3 partitions ( 1 for Mac, 1 for Windows=Ntfs & 1 in exFat for sharing files between the two systems).
      create partition primary size=100000 (1 partition for Mac OS X 100GB) format fs=fat32 quick label=Mac (after we will format in HFS+ with disk utility) create partition msr size=128 (creates Microsoft Reserved) create partition primary size=100000 (1 partition for Windows 10 100GB) format fs=ntfs quick label=Windows (format in Ntfs) create partition primary (creates a partition with the remaining space) format fs=exfat quick label=Hdd (format in exFat) Now the fun part.
      We should insert the letters for the partitions. Check
      select disk 0 list volume (check the assigned letters, REMINDS the letter assigned to the USB "example d") list partition (check the number of partition EFI "example partition 1") select partition 1 assign letter=h list partition (check the number of partition Windows "example partition 3") select partition 3 assign letter=g exit Then we have the letter "D:\" for the USB, "H:\" for the EFI partition & "G:\" for the Windows partition.
      Now we need to copy the installation files from the USB to the Windows partition.
      cd\windows\system32\ dism /apply-image /imagefile:d:\sources\install.wim /index:1 /applydir:g:\ Break....
      Now we need the Windows EFI boot files.
      cd\ g: bcdboot (check the command line) bcdboot g:\windows /1 en-us /s h: /f UEFI (in my case "/1 It-it") Restart the computer with the Mac USB "Clover bootloader", then select Microsoft EFI and start the installation of Windows 10 in FULL GPT. 
      If you don't see the exFat partition in Windows don't worry.
      (Take a program like Partition Wizard, format the partition in NTFS  and assigns the letter D:\. Now open the command prompt administrator and write:
      diskpart select disk 0 list partition (check the partition before-exFat = after-NTFS "example partition 4") select partition 4 format fs=exfat quick label=Hdd Now you must have the partition exfat visible and writable)
       
       
      Part 2:
       
      Important!  
      Don't format or delete the EFI partition.   
      From the Mac USB we need delete AppleIntelHDGraphicsFB.kext. 
       
      Now we go in to the installation of El Capitan, with disk utility format the partition "Mac" in HFS+ mac journaled, then install Mac OS X.
      While starting El Capitan from your hard drive, we must block AppleIntelHDGraphicsFB.kext and AppleIntelHDGraphics.kext. (& add cpus=1 or patch with clover)
      When El Capitan is started:
      Patch AICPM with Clover Configurator Install Clover like this  (of course without installation El Capitan) "Legacy mode" Replace the config.plist in EFI partition and add SMBIOS with clover configurator - macbook pro 6.1 Put the DSDT Put HFSPlus.efi, NTFS.efi in drivers64 folder Insert and replace all kext PS:During the first system start we must go in the system preferences, keyboard, shortcuts and change the key combination of brightness (f2- f3+).
       
       
      Work:  
       
      Intel Core i5 460M
      Intel HD Graphics                                      (Clean graphics without artifacts)
      Wifi & Ethernet                                          (Atheros AR9285 & Realtek 8111)
      Stereo speakers & Microphone                    (IDT92HD81B1X5)
      Keyboard & multi-touch touchpad
      Memory Card Reader
      Camera
      All USB
      Battery
      Sleep & Wake
      Brightness Values
      App Store
       
      Don't work: 
       
      ATI Mobility Radeon HD 5470                      (Blocked by BIOS)
      FaceTime                                                   (With Rom,SN,MLB valid work)
      iMessage                                                   (With Rom,SN,MLB valid work)
      Maps            
       
       
      Thanks : GhostRider - pokenguyen - Mirone & Micky1979 - RehabMan
       
       
      HP El Cpitan.zip
    • By newbie2379
      Good day,

      I'm trying to install OSX El Capitan on my laptop all the time.
      I have a laptop with a Intel CORE i5 430M Arrandale CPU and first generation Intel HD Graphics.
      The problem is the graphics card.
      I have deleted the kext for the graphics card to install El Capitan.
      After installing it boots also without error messages, but then comes a graphic error. The graphics error was already before I had deleted the Kext before installing.
      The graphics error should not come, however, if I had deleted the kext?

      I can install OSX successfully, but when booting comes a graphic error.

      I have also searched the Internet for solutions. The solutions I had found only work after a successful boot.

      I have tried it with other graphics kext, but without success.

      I also have no other computer with OSX.

      Best regards
×