Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
GhostRaider

[GUIDE] 1st Generation Intel HD Graphics QE/CI

1,869 posts in this topic

Recommended Posts

Sure i have. I told with only cI kexts + LW1 FB i can get pretty clean screen but it waves with 1024x768@60Hz, but screen isnt cut.

If I understand correctly, you get a clear display with QE/CI using the kexts from the Core Image archive and then adding the Intel HD Graphics framebuffer wth LW1? The kexts inside the Core Image archive aren't that different from the QE/CI archive. Not sure what's happening there.

Here is results, all steps done. This is first time when I've got loaded QE/CI AppleIntelHDGraphics.kext. Will try with others FB with those kexts. LW2 (mine by linux dump) still gray screen (crashed not normal).

 

@edit i noticed QE/CI is working, problem is with FB, I've got FB working alone without others HD kexts but never get clean display

 

So if you set 1280x1024, your screen is cut but you see that qe/ci is working right? If this is true I already know what is happening.

Share this post


Link to post
Share on other sites

If I understand correctly, you get a clear display with QE/CI using the kexts from the Core Image archive and then adding the Intel HD Graphics framebuffer wth LW1? The kexts inside the Core Image archive aren't that different from the QE/CI archive. Not sure what's happening there.

Not true, w/o framebuffer i can boot with kexts from only CI zip, but QE/CI kexts won't boot w/o FB. Otherwise AppleIntelHDGraphics.kext from QE/CI size is 981 kB, from "only ci" pack is 977 kB.. I've tried every FB from pack, on LW2 and 3 got grey screen with black margin at left, LW4 seems like LW1 picture, but with colours.

Share this post


Link to post
Share on other sites

Not true, w/o framebuffer i can boot with kexts from only CI zip, but QE/CI kexts won't boot w/o FB. Otherwise AppleIntelHDGraphics.kext from QE/CI size is 981 kB, from "only ci" pack is 977 kB.. I've tried every FB from pack, on LW2 and 3 got grey screen with black margin at left, LW4 seems like LW1 picture, but with colours.

 

Okay. From the scenarios that I have experimented:

 

1. If you boot with only Core Image kexts, you will have core image working.

2. If you boot with AppleIntelHDGraphics.kext, AppleIntelHDGraphicsVA, AppleIntelHDGraphicsGA and AppleIntelHDGraphicsGLDriver (no framebuffer), you will have a distorted screen that makes the screen it unusable.

3. If you boot with only the patched framebuffer, you will have a clear desktop with native resolution, display detected, but no acceleration.

 

So if you only boot with the frambuffer (only framebuffer with no other intel kexts) (LCD+VGA LW1) what happens? Does the screen look cut or is it distorted?

Share this post


Link to post
Share on other sites

To be clear:

 

1. I get clean screen with CI support with kexts from "only CI" pack, no FB.

2. I never get clean screen with FB loaded (no metter is other kexts loaded or no)

3. Resolution and display is always detected properly

4. I can get QE/CI support with "only CI" kexts + all variation of patched FB with LW1 (results on #543) 

5. I can get QE/CI support with kexts from "QE/CI" pack but won't boot with normal patched FB, only alternate (no metter which one) LW1 & LW4 (results @ #545)

6. I can load same FB w/o other kexts, but screen still crashed (#541)

7. VGA works only with DSDT 0x04/0x02 injection

8. I have to inject my string into info.plist to get kext loaded

Share this post


Link to post
Share on other sites

Number 4 is the important one. You can get qe/ci working using the kexts from the qe/ci package with an alternative framebuffer right? You can see the display with a resolution of 1024x768 but looks bad in 1280x1024 right?

Share this post


Link to post
Share on other sites

Number 4 is the important one. You can get qe/ci working using the kexts from the qe/ci package with an alternative framebuffer right? You can see the display with a resolution of 1024x768 but looks bad in 1280x1024 right?

Not exacly. 1024x768 looks good with "only CI" kext with normal patch method FB LCD+VGA LW1 (QE/CI supported then), but default it loads with native resolution (#541 view), i must change it in preferences. But by good i mean only that, screen isnt scratched and cuted. It still waves and i can see noise on it.

 

If u have any suggestion to try, just tell. I am out of ideas.

Share this post


Link to post
Share on other sites

Not exacly. 1024x768 looks good with "only CI" kext with normal patch method FB LCD+VGA LW1 (QE/CI supported then), but default it loads with native resolution (#541 view), i must change it in preferences. But by good i mean only that, screen isnt scratched and cuted. It still waves and i can see noise on it.

 

If u have any suggestion to try, just tell. I am out of ideas.

What if you try connecting the monitor through DVI?

What if you install SwitchresX?

Share this post


Link to post
Share on other sites

What if you try connecting the monitor through DVI?

What if you install SwitchresX?

 

Have only VGA out on my mobo.

I am sure Switchresx wont help, I have used it with x3100 graphic. I can switch resolution freely in prefernces

Share this post


Link to post
Share on other sites

Have only VGA out on my mobo.

I am sure Switchresx wont help, I have used it with x3100 graphic. I can switch resolution freely in prefernces

The only thing that SwitchResX has is the ability to choose higher refresh rates. I'm not sure if this can solve your screen issue. It's worth a try. As far as I know, there doesn't seem much for you to do now since your telling me no combinations make a difference.

Share this post


Link to post
Share on other sites

The only thing that SwitchResX has is the ability to choose higher refresh rates. I'm not sure if this can solve your screen issue. It's worth a try. As far as I know, there doesn't seem much for you to do now since your telling me no combinations make a difference.

SwitchresX seems able to make my monitor stable. I tried various values in custom resolution but I don't know what those mean. Do you know how to set and what is important? Now i can see display, isnt cut in vertical, but it is moved in horizontal some about 200 poixels, and waves...

Share this post


Link to post
Share on other sites

@biLLy0o,

You have to mess with the Front Porch, Sync Width and Back Porch for Horizontal.

Try reducing Front and Back Porch these affect the position where screen starts and ends.

 

Can you post a screenshot ( mobile phone ) so I can see exactly what your getting?

 

I've been using Switch.. to set up my external monitor for VGA because every mode above

1280x1024 always looks distorted at default values.

 

@Ghost..,

 

Regarding using the AAPL,OS.. yes you are right people with only CI can use this to

get VGA with full QE/CI using the FB with VGA+LCD. ( This is with Mountain Lion up to 10.8.5 )

 

The only problem is changing from laptop mode ( internal display ) with only CI to external mode ( with only VGA ) with QE/CI.

 

The only way I found to get this working is using two different Extensions and Kext Caches folders and running scripts to move these

and rebooting and then pressing your laptop keys to change to only outputing on VGA.

 

Best regards,

voidRunner 

Share this post


Link to post
Share on other sites

Hi,

I tried to enable full CI/QE on my laptop in signature after installing 10.9 GM. Every Framebuffer kext I install (also patching) I have Quartz exterme but not Core Image! In 10.8.5 nothing worked, in 10.8.4 I had the contrary, CI enabled with right resolution 1366x768x32, but not QE, I didn't see any video. Now I see the videos and I have transparent finder bar, but resolution is still 1280x720. Furthermore if I open finder i see correct windows, but if I move them they interlace and I can't see anything inside.

Some help?

Share this post


Link to post
Share on other sites

Stil no luck in my case. SwitchresX makes even worse mess.. 

 

Hi,

I tried to enable full CI/QE on my laptop in signature after installing 10.9 GM. Every Framebuffer kext I install (also patching) I have Quartz exterme but not Core Image! In 10.8.5 nothing worked, in 10.8.4 I had the contrary, CI enabled with right resolution 1366x768x32, but not QE, I didn't see any video. Now I see the videos and I have transparent finder bar, but resolution is still 1280x720. Furthermore if I open finder i see correct windows, but if I move them they interlace and I can't see anything inside.

Some help?

 

Which kexts did u load?

Share this post


Link to post
Share on other sites

The kext taken from the first page of this guide,

 

the "Intel HD Graphics QE/CI 10.9", here

https://mega.co.nz/#!BsUVWQwY!InfWaHBPvUq-ulVu0PZpLB17dJZyn8johAHPucvG_og

 

I tried to patch the framebuffer unmodified kext with giofrida's patcher, but it was useless with all the patcher's options

Share this post


Link to post
Share on other sites

Why are you adding strings to the ExcludeList? You don't need to do that. Also delete Natit and try to patch your DSDT. You have to abandon Natit someday. If you want, you can look for your patch frame buffer in my 10.9 QE/CI zip archive.

Ok I reinstall Mavericks GM, take frame buffer from your zip archive in first page, patch my DSDT, and i don't have QE/CI. With Mountail Lion and Mavericks DP works always, but now not. Why???

 

Edit: After install all kexts in 10.9 zip, and not only framebuffer, QE/CI works

Share this post


Link to post
Share on other sites

Ok I reinstall Mavericks GM, take frame buffer from your zip archive in first page, patch my DSDT, and i don't have QE/CI. With Mountail Lion and Mavericks DP works always, but now not. Why???

 

Edit: After install all kexts in 10.9 zip, and not only framebuffer, QE/CI works

Yeah your suppose to install all the kexts and 1 framebuffer from my 10.9 QE/CI zip. I thought people knew that  :P  I highly recommend using Kext Utility to install these kexts. It should avoid errors.

Share this post


Link to post
Share on other sites

Where are the kexts for CI only for 10.9?  There is still only 10.8.5 as an option while the kexts for QE/CI are available for 10.8.5 and 10.9.

In OS X 10.9 Mavericks, CI only is natively supported. All you have to do is delete "AppleIntelHDGraphicsFB" and "AppleIntelHDGraphicsGA" kexts. I'll provide the kexts as a download but you don't really need them.

Share this post


Link to post
Share on other sites

In OS X 10.9 Mavericks, CI only is natively supported. All you have to do is delete "AppleIntelHDGraphicsFB" and "AppleIntelHDGraphicsGA" kexts. I'll provide the kexts as a download but you don't really need them.

Thanks.  I kind of need them now since I deleted them.  Thank you very much again for everything.

Share this post


Link to post
Share on other sites

So it turns out that the Mavericks GM that people were asking me to patch wasn't the final build. -_- Great now I have to reinstall everything. I'm deleting the links for Intel HD Graphics 10.9 kexts. They're useless now. You'll see the links again when I know Apple has offically released the final build of OS X Mavericks.

Share this post


Link to post
Share on other sites

I'll upload the new Intel HD Graphics patched kexts over the weekend. OS X Mavericks is offically released so I always recommend getting the latest verison of OS X on your PC. There should be no excuse since the OS is free now lol. Sure it can be a scary thing to update because you may have kernel panics and stuff, but if you remember what kexts to patch, what DSDT to use, then upgrading should not be a problem. Eventually you'll develop a strategy on how to update your PC with the latest updates and releases of OS X and it won't be scary anymore! :)

 

OS X is a great operating system when you have everything stable and working. In terms of innovation on the desktop, Apple is leading the way. I'm not saying Windows is terrible, but Micro$oft is abandoning the desktop experience and made a complete mess. That's what made me mad about them and why I joined the Hackintosh world.

Share this post


Link to post
Share on other sites

Ghost...I review the files from previews 598 GM and the official Release...and didn't saw any differences....please confirm..

Share this post


Link to post
Share on other sites

Ghost...I review the files from previews 598 GM and the official Release...and didn't saw any differences....please confirm..

 

You cannot have OS X Mavericks GM Build 13A598. This build will not recieve any OS updates other than software updates like iLife. Whether they change some things in the kexts are unknown but again to be on the safe side use the 2nd GM or download the officially released build from the App Store. No other choice.

Share this post


Link to post
Share on other sites

You cannot have OS X Mavericks GM Build 13A598. This build will not recieve any OS updates other than software updates like iLife. Whether they change some things in the kexts are unknown but again to be on the safe side use the 2nd GM or download the officially released build from the App Store. No other choice.

I downloaded already. The questions was about versioning the 603 has the same build number of 598 for appleintelhd.kext an FB. I will make a new installation using those kext and report back.

Share this post


Link to post
Share on other sites

I downloaded already. The questions was about versioning the 603 has the same build number of 598 for appleintelhd.kext an FB. I will make a new installation using those kext and report back.

Why not just patch the original kexts? I don't see what the problem is...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×