Jump to content
InsanelyMac Forum
Sign in to follow this  
eurisko

HD 2000 working full-resolution

Recommended Posts

hi

 

I managed to get the HD 2000 to work full resolution (No acceleration), without any extra .kext.

 

Installed on a Asrock H61M-S IGP VM set to Auto on UEFI, Processor is a Pentium G860 (Sandy Bridge).

 

During install i noticed that the native resolution of the screen was correctly detected, upon first boot the system hang just before the login screen, with a grey screen and the spinning ball.Check logs

 

 

Jan 31 12:24:27 Joaos-iMac.local WindowServer[83]: Created shield window 0x8 for display 0x1a493e80

Jan 31 12:24:27 Joaos-iMac.local WindowServer[83]: Display 0x1a493e80: MappedDisplay Unit 0; ColorProfile { 2, "ASUS VH242"}; TransferFormula (1.000000, 1.000000, 1.000000)

 

 

Jan 31 12:24:27 Joaos-iMac.local UserEventAgent[106]: cannot find useragent 1102

Jan 31 12:24:28 Joaos-iMac.local loginwindow[42]: Login Window Started Security Agent

Jan 31 12:24:28 Joaos-iMac.local SecurityAgent[116]: This is the first run

Jan 31 12:24:28 Joaos-iMac.local SecurityAgent[116]: MacBuddy was run = 0

Jan 31 12:24:34 Joaos-iMac kernel[0]: stampWait: Overflowed checking for stamp 0x63 on MAIN ring: called from

Jan 31 12:24:34 Joaos-iMac kernel[0]: timestamp = 0x0012

Jan 31 12:24:34 Joaos-iMac kernel[0]: **** Debug info for *possible* hang in MAIN graphics engine ****

Jan 31 12:24:34 Joaos-iMac kernel[0]: ring head = 0x000006a0, wrap count = 0

Jan 31 12:24:34 Joaos-iMac kernel[0]: ring tail = 0x00002618

Jan 31 12:24:34 Joaos-iMac kernel[0]: ring control = 0x0000f001 enabled, auto report disabled, not waiting, semaphore not waiting, length = 0x010 4KB pages

Jan 31 12:24:34 Joaos-iMac kernel[0]: timestamps = 0x0012

Jan 31 12:24:34 Joaos-iMac kernel[0]: Semaphore register values:

Jan 31 12:24:34 Joaos-iMac kernel[0]: VRSYNC: (0x12044) = 0x12

Jan 31 12:24:34 Joaos-iMac kernel[0]: BRSYNC: (0x22040) = 0x0

Jan 31 12:24:34 Joaos-iMac kernel[0]: RVSYNC: (0x 2040) = 0x0

Jan 31 12:24:34 Joaos-iMac kernel[0]: BVSYNC: (0x22044) = 0x0

Jan 31 12:24:34 Joaos-iMac kernel[0]: RBSYNC: (0x 2044) = 0x0

Jan 31 12:24:34 Joaos-iMac kernel[0]: VBSYNC: (0x12040) = 0x0

 

 

If i boot safe mode i would get the native resolution, and the graphics model would be correctly identified.

 

I check also that during safe mode

 

 

Jan 31 12:26:11 Joaos-iMac.local com.apple.kextd[11]: Can't load AppleIntelHD3000Graphics.kext - ineligible during safe boot.

Jan 31 12:26:11 Joaos-iMac.local com.apple.kextd[11]: Load com.apple.driver.AppleIntelHD3000Graphics failed; removing personalities from kernel.

 

 

So my guess was that AppleIntelHD3000Graphics.kext didn't like the HD 2000.

Moved the AppleIntelHD3000Graphics.kext /Extra/RemovedExtensions/

 

Reboot and is working.

 

List of Extensions on /Extra/Extensions

 

ALC662.kext

AppleACPIPS2Nub.kext

AppleHDA.kext

ApplePS2Controller.kext

AtherosL1cEthernet.kext

FakeSMC.kext

HDAEnabler.kext

NullCPUPowerManagement.kext

Patched_10.7_AppleRTC.kext

lspcidrv.kext

 

My Chamaleon boot.plist file

 

 

<dict>

<key>Graphics Mode</key>

<string>1920x1080x32</string>

<key>GraphicsEnabler</key>

<string>yes</string>

<key>Kernel</key>

<string>mach_kernel</string>

<key>Kernel Flags</key>

<string></string>

<key>PciRoot</key>

<string>0</string>

<key>Timeout</key>

<string>5</string>

<key>UseKernelCache</key>

<string>Yes</string>

</dict>

 

Don't forget to generate kernel caches. Hope this helps.

 

I also changed the computer id to a Mac mini.

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.



×