Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
WaldMeister

DSDT Dell 7720/Help injecting Ethernet

6 posts in this topic

Recommended Posts

Hi,

 

I need some help injecting my ethernet card into my DSDT. Found some solutions scattered around the web, but none of them seem to inject specific hardware information, which is needed.

 

Attached my current DSDT and ioreg file. The "airport" device is located under RP01, i think the information needs to be injected somewhere near that location.

 

Thanks for the help in advance.

ioreg.txt

DSDT.aml.zip

Share this post


Link to post
Share on other sites

Use DSDT Editor and inject the patch.

 

 

 

Atheros 9285.txt

 

Wifi works, it's about the Realtek ethernet, should have been more specific, sorry.

The realtek ethernet (lan) works now, by installing a kext from the realtek page, but i would like to inject it using dsdt.

 

Thanks for the reply.

Share this post


Link to post
Share on other sites

Device was RP05.

 


           Device (LAN0)
           {
               Name (_ADR, Zero)
               Name (_SUN, 0x03)
               Name (_PRW, Package (0x02)
               {
                   0x0B, 
                   0x04
               })
               Method (_DSM, 4, NotSerialized)
               {
                   Store (Package (0x0C)
                       {
                           "built-in", 
                           Buffer (One)
                           {
                                0x00
                           }, 
                           "location", 
                           Buffer (0x02)
                           {
                               "1"
                           }, 
                           "network-type", 
                           Buffer (0x09)
                           {
                               "ethernet"
                           }, 
                           "revision-id", 
                           Buffer (0x04)
                           {
                                0x05, 0x00, 0x00, 0x00
                           }, 
                           "model", 
                           Buffer (0x22)
                           {
                               "Realtek RTL810SE Gigabit Ethernet"
                           }, 
                           "name", 
                           Buffer (0x09)
                           {
                               "ethernet"
                           }
                       }, Local0)
                   DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
                   Return (Local0)
               }
           }

 

Adding the above should work.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×