Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
wormyrocks

Native Adapter Woes - AR5BXB112

6 posts in this topic

Recommended Posts

Hi all,

 

I'm currently running a Hackintosh with an AR5BXB112 wi-fi adapter (this model) and I am pulling my hair out trying to get it to work on a PCIe adapter.

 

I can't figure out whether it's a hardware problem or a software problem. Initially I had thought that the issue was that the wireless card was not appropriately seated in the adapter and that it needed to be screwed into the PCB to be properly grounded. After acquiring some screws I found that they made no difference in my reception.

 

Basically what will happen is I will turn on wi-fi, the computer will recognize and connect to the wireless network (giving me a few moments of connectivity) and then immediately disconnect. The same thing happens regardless of whether or not my screws are attached to the PCB. I experienced similar symptoms with another card, the ARBC94321.

 

So, in a moment of desperation, I removed the little metal shield on the card. That made a difference.. but an odd one. Now, when I connect to wi-fi, I get a full strength signal, and it says I'm connected to the Internet... but when I unplug my Ethernet cable, I stay fully connected to the wi-fi network, but it says that I've lost my Internet connection.

 

I'm sort of at my wit's end. I've been through a TP-Link adapter and two wi-fi cards. Is there some software configuration thing that I can try, or is my PCI adapter likely faulty? Should I put the shield back on? Should I just up and buy a WDN4800? Gah.

Share this post


Link to post
Share on other sites

smells like IRQ issue in dsdt.. remove them with dsdt editor patch

 

arbc94321 is actually BCM94321

if both give u problems. its the dsdt or install source issues.

Share this post


Link to post
Share on other sites

I'm running a DSDT-free installation - do I need to create a DSDT in order to get this working?

 

Also, I get an identical problem on Windows, which is leading me to think that it's a hardware issue.

Share this post


Link to post
Share on other sites

check bios version from board and manufacturer, read changes.

 

any other pci-e slots.. it dont have to be x1 sized. the 4 or 8 works.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Posts

    • Did you tried use ACPIBatteryManager.kext for the Battery? And for brightness you can use IntelBacklight  Both created by @RehabMan 
    • I have put it into clover drivers 64uefi folder on Yosemite thru High Sierra which allows me to edit my High Sierra disk if needed in Yosemite system.   There is no functionality of apfs in other versions but it does allow other clover bootloaders and systems to recognize the HS apfs drive or open it for inspection.   If you don’t have it you can’t see your HS drive or access it in another macOS version.
    • Hi! Is it possible to get codec AD1981 running with AppleHDA on HP Compaq 8710w? It works nicely with VoodooHDA. Speakers and HP are switching automatically.  Internal and HP mic also work - no switching in SysPref but it works when mic is plugged in and internal mic works when hp mic is unplugged.   It has same weird pathmap - connected directly:  Playback: nid=5 [pin: Speaker (Analog)] | + <- nid=3 [audio output] [src: pcm] bindSeq=00008001 nid=6 [pin: Headphones (Grey Left)] | + <- nid=3 [audio output] [src: pcm] bindSeq=00008001   But inputs are really weird. There are 5 nodes from input to HP mic/Internal mic nid=4 [audio input] | + <- nid=21 [audio selector] [src: mix] bindSeq=00000003 | + <- nid=12 [audio mixer] [src: mix] bindSeq=00000003 | + <- nid=30 [audio selector] [src: mic] bindSeq=00000001 | + <- nid=8 [pin: Microphone (Grey Left)] [src: mic] bindSeq=00000001 + <- nid=31 [audio selector] [src: monitor] bindSeq=00000002 | + <- nid=24 [pin: Microphone (Analog)] [src: monitor] bindSeq=00000002 Can pathmap like that even work with AppleHDA? What codec should I patch? I tried patches from AD1984 but no luck.    These are manually patched verbs: 00571c10 00571d01 00571e17 00571f90 00570C02 00671c20 00671d10 00671e21 00671f03 00771cf0 00771d00 00771e00 00771f40 00871c30 00871d10 00871e81 00871f03 00971cf0 00971d00 00971e00 00971f40 00a71cf0 00a71d00 00a71e00 00a71f40 01671cf0 01671d00 01671e00 01671f40 01771cf0 01771d00 01771e00 01771f40 01871c40 01871d01 01871ea0 01871f90 01971cf0 01971d00 01971e00 01971f40   Codecgraph and linux codecdump attached. Thx for any help or suggestions.              codec.txt 2.svg codec.txt
    •   Yes, 'cause APFS log is coming before clover boot screen.
    • and you suspect apfs on before clover issues  


×